Getting Daily call to work over network

Discussion in 'TiVo Series 1 - UK' started by tdenson, Jan 19, 2006.

  1. tdenson

    tdenson New Member

    296
    0
    Oct 3, 2002
    Leeds
    I have had Tivoweb for several years now but never managed to get my daily call working over the network. I though it was about time I cracked this, so can anyone give me a clue where to look. I have set my gateway (with route.tivo) to 192.168.1.1 and I can ping the outside world by ip address. However if I tell my Tivo to use ,#401 as the dialup I get "cannot connect" or somesuch.
     
  2. mike0151

    mike0151 A Friend of Dot

    752
    0
    Dec 13, 2001
    Liverpool,...
    ,#401 is NOT needed for a UK TiVo.

    you need to run nic_config_tivo and set it to connect over the network rather than dial-up, making sure all other details are correct and then reboot the TiVo.

    HTH
    Mike
     
  3. tdenson

    tdenson New Member

    296
    0
    Oct 3, 2002
    Leeds
    Although I've used it in the past I can't seem to find nic_config_tivo - where should it be (I've looked in /sbin and /var/hack)
     
  4. cwaring

    cwaring VM Tivo User

    9,015
    0
    Feb 11, 2002
    Knaresboroug...
    I think it should be in the 'path'; ie you should be able to type it from anywhere. I know that it works for me without me changing directories :)
     
  5. Glesgie

    Glesgie New Member

    194
    0
    Feb 3, 2003
    London
    nic_config_tivo is in /sbin.

    I suggest that you download the latest .iso from silicondust, burn it to CD,
    use it to boot a PC with the TiVo drive(s) attached and run nic_install_tivo.

    PS if you are using an old (TiVonet) card instead of a turbonet card the process is different.

    Posting the contents of /etc/rc.d/rc.net (config for network card) could help.
     
  6. tdenson

    tdenson New Member

    296
    0
    Oct 3, 2002
    Leeds
    rc.d/rc.net contains -



    if /sbin/insmod -f /lib/modules/ax88796.o devicename=eth1 macaddr=69C667 timing= 3 ; then
    /sbin/ifconfig eth1 192.168.1.200 netmask 255.255.255.0 up
    fi
     
  7. Rob Nespor Bellis

    Rob Nespor Bellis Grumpy Sod

    674
    0
    Feb 17, 2001
    ~, Brighton, UK
    For the daily call to work the ethernet interface must be named eth0.

    Rgds,

    R.
     
  8. tdenson

    tdenson New Member

    296
    0
    Oct 3, 2002
    Leeds
    Restored nic_config_tivo from a backup and now all working thanks.
     
  9. tdenson

    tdenson New Member

    296
    0
    Oct 3, 2002
    Leeds
    I don't think so - see my other post (and I didn't change the eth1 to eth0).
     
  10. Rob Nespor Bellis

    Rob Nespor Bellis Grumpy Sod

    674
    0
    Feb 17, 2001
    ~, Brighton, UK
    If you used nic_config_tivo to change the daily call type I *suspect* that it would have renamed the interface to eth0 as naming the interface eth1 is one way of having a network connection but using the phone line for daily calls.

    Rgds,

    R.
     
  11. tdenson

    tdenson New Member

    296
    0
    Oct 3, 2002
    Leeds
    My apologies, you are right - nic_config_tivo changed it.
     
  12. Fastdax

    Fastdax New Member

    4
    0
    Apr 26, 2005
    Sheffield
    I'm also having trouble getting my daily call to work over the network.
    I have set the daily call option to "network" in nic_config_tivo but still it uses the phone!

    I can ping the outside world from my Tivo just fine. I even see it trying to access the Tivo website IP address in my router's log (but, bizarrely, only when the phone line is connected!)

    /etc/rc.d/rc.nett (anti-spam filter compliant naming!) file is as follows:

    if /sbin/insmod -f /lib/modules/turbonet2.o macaddr=00:0B:AD:5C:3C:B3 ; then
    export DYNAMIC_NET_DEV=eth0
    /sbin/ifconfig eth0 192.168.0.200 netmask 255.255.255.0 up
    /sbin/route.tivo add default gw 192.168.0.1 netmask 0.0.0.0
    fi

    Any help very gratefully received.
     
  13. mike0151

    mike0151 A Friend of Dot

    752
    0
    Dec 13, 2001
    Liverpool,...
    Did you remember to reboot the TiVo after making the changes?

    Mike
     
  14. Fastdax

    Fastdax New Member

    4
    0
    Apr 26, 2005
    Sheffield
    Yup.
     
  15. Glesgie

    Glesgie New Member

    194
    0
    Feb 3, 2003
    London
  16. Fastdax

    Fastdax New Member

    4
    0
    Apr 26, 2005
    Sheffield
    Thanks Glesgie. I read that thread with growing anticipation and made the suggested changes (and rebooted) but I'm sorry to report that my Tivo still uses the d@mn phone. Every time!

    Any other suggestions would be most welcome as I'm at the point of tearing my hair out and reprogramming my Tivo with an axe. I can provide logs etc. as required to help diagnose this one.
     
  17. threadkiller

    threadkiller Dark side Nrth Devon

    523
    0
    Dec 12, 2002
    I had similar problems when I first installed my airnet, although the gateway was correctly entered in Nic_Config it wasn't being correctly saved in the right file. I had to manually change it. Hoiwever the newer versions of the drivers fixed this. So I updated them & the problem disapeared
     
  18. my02awe

    my02awe New Member

    4
    0
    Jun 19, 2005
    I'm having similar problems
    thompson 2x200Gb + 512Mb cachecard running v2.5.5-01-1-023 + TCL - v1.9.4 (no subscription)

    when I checked, the daily call hasn't run since june
    however the test call ran when I triggered it - so I decided to run setup to update chanels etc. Of course the "real" call failed ...
    After a little thought I rememberd the nic setup .. switched to the phoneline ... and everything worked ok .... but still no network connection.
    the only mod I've made I've made this year (jan/feb) is to update the manrec.itcl module to version v0.2.5 - if it 'aint broke)

    Can complete call using phoneline .... but not with network (can ping (both ways), transfer files locally (b/w), use tivoweb interface & schedule recordings).

    I've followed the suggestions here and backgrounded everything ... no joy

    I've not tried a full restore (and I don't want to - I don't like being beat - but I can live with this small irritation)

    I'd appreciate any suggestions

    andy


    Oct 31 10:22:24 (none) tcphonehome[129]: setting call in progress to 1 (second successCount)
    Oct 31 10:22:25 (none) tcphonehome[129]: End of transaction, err is 0 0x00000000
    Oct 31 10:22:25 (none) tcphonehome[129]: Setting callActive to 1
    Oct 31 10:22:25 (none) tcphonehome[129]: Running command: /bin/getprom -gateway
    Oct 31 10:22:25 (none) tcphonehome[129]: Command output: 0.0.0.0
    Oct 31 10:22:25 (none) tcphonehome[129]: Command finished status: 0, errno = 2
    Oct 31 10:22:25 (none) tcphonehome[129]: Running command: /sbin/route add default gw 0.0.0.0 netmask 0.0.0.0
    Oct 31 10:22:25 (none) tcphonehome[129]: Command finished status: 0, errno = 2
    Oct 31 10:22:25 (none) tcphonehome[129]: setting call attempt
    Oct 31 10:22:26 (none) tcphonehome[129]: Running TClient
    Oct 31 10:22:26 (none) tcphonehome[129]: Running command: $TIVO_ROOT/tvbin/tivosh $TIVO_ROOT/tvbin/TClient >> /var/log/tclient
    Oct 31 10:22:26 (none) tcl[170]: Tcl created pool of 3145728 bytes
    Oct 31 10:22:42 (none) EvtSwitcher[77]: Tmk client 12 (pid=170) has attached
    Oct 31 10:22:42 (none) EvtSwitcher[77]: Client 12 (Phone Home, pid=170) is service Phone Home
    Oct 31 10:22:42 (none) EvtSwitcher[77]: Client 12 (Phone Home, pid=170), thread 170 has activated MFS
    Oct 31 10:22:43 (none) TClient[170]: activated
    Oct 31 10:22:43 (none) EvtSwitcher[77]: Client 12 (Phone Home, pid=170) has asked for 30 events
    Oct 31 10:23:06 (none) EvtSwitcher[77]: Client 12 (Phone Home, pid=170) has asked for 26 events
    Oct 31 10:23:33 (none) Recorder[154]: AllocateFiles for live cache
    Oct 31 10:23:33 (none) Recorder[154]: Live cache size 1462272
    Oct 31 10:23:33 (none) Recorder[154]: User recording 378198400 free 449920
    Oct 31 10:23:33 (none) Recorder[154]: TivoClip total 10000000 free 9686656
    Oct 31 10:23:33 (none) Recorder[154]: Allocated stream Id 1009296, size 208896
    Oct 31 10:23:33 (none) mediamgr[154]: AddLiveFile input#0
    Oct 31 10:23:34 (none) Recorder[154]: Adding check schedule task
    Oct 31 10:24:12 (none) TClient[170]: connect 204.176.49.3:80
    Oct 31 10:24:20 (none) EvtSwitcher[77]: Client 12 (Phone Home, pid=170) says he has finished
    Oct 31 10:24:20 (none) EvtSwitcher[77]: Client 12 (Phone Home, pid=170) being removed
    Oct 31 10:24:21 (none) tcphonehome[129]: Command finished status: 0, errno = 2
     

Share This Page