Galleon randomly quits

Discussion in 'TiVo Home Media Features & TiVoToGo' started by mitch2k2, Sep 16, 2007.

  1. s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005

    Advertisements

    Well, after thinking about it for a while, the out of memory on the tivo could be that the hme apps are loading too many resources. There is a max size, but I've never hit it before. I know galleon is a memory hog/whore. Are you running a lot of apps in galleon? try saving off your configuration.xml and start with a new one that only has the music app in it. Does it behave better?

    As for the "missed flush" exceptions...you can pretty much ignore that as an end user. It's some lame hacky debugging thing the tivo guys put in to print out a stack trace if the software changes something that sends info to the server, but doesn't flush within a 1/2 second. What it means for the developer is they caused something to write out an HME command, but never forced it to get sent to the server. It will eventually flush, but just not within the 1/2 second. In lamens, the hme view elements might misbehave. That won't affect the music playing though because tivo is pulling the music rather than the hme pushing it to the tivo.
     
  2. windracer

    windracer joined the 10k club

    12,321
    241
    Jan 3, 2003
    St. Pete, FL
    I was just guessing ... :)
     
  3. s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    Hey, it's a valid guess. A well behaved app shouldn't see any exceptions. But that particular exeception is a poorly designed "feature" that doesn't really work or report properly for multithreaded apps. But that's in the core HME apis so there isn't much I can do about that one.
     
  4. mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006
    I'm only running the music app now, and without the grouping menu. so that's the only galleon app in play.
     
  5. mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006

    Advertisements

    I should probably add that the same computer is also running Tivo.Net. DO you think there could be some sort of conflict between that and Galleon?
     
  6. windracer

    windracer joined the 10k club

    12,321
    241
    Jan 3, 2003
    St. Pete, FL
    Try the new version Dave just posted. :)
     
  7. mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006
    Was planning on it (though not hoping for much, since it doesn't seem like any of the changes as noted in the announcement would seem to affect my issue). It'll be a little later on before I can, though, but when I do I'll come back and post my results.
     
  8. mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006
    Well, so far, the new version is running and without interruption. There's a few kinks here and there (mostly having to do with the screen saver, art, and lyrics), but the most important thing - the music - is functioning much better than with the prior install.

    Though there is a several second gap between one song and another. That's new.
     
  9. jtkohl

    jtkohl Member

    170
    0
    Feb 6, 2004
    Arlington,...
    Odd, we didn't do anything particular on the music app playback code. Glad it works, though!
     
  10. mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006
    Well, "works" for me right now just means I can hear music. But there's still issues with all of the whizzbang gee whiz stuff that makes it so cool. I already posted the issues in the 2.5 thread. Maybe you can take a look at that log and see if you see anything?
     
  11. s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    Glad to see you can hear the music now. One of the things that I did change that might affect the out of memory errors was I changed the way some of the skin resources get loaded. Hopefully the new version fixed your music playing problems and we can move on to other bugs....

    David
     
  12. mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006
    I can hear the music, yes, but only up to a point, when Galleon (only happens when Galleon is running an app on the TiVo, anyway) causes a reboot of the TiVo. Happened three times yesterday, and I've held off on using Galleon since then. Everything else TiVo seems to be working okay, which makes me think this has something to do with Galleon and my setup.
     

Share This Page

spam firewall

Advertisements