Galleon development restarting

Discussion in 'Developers Corner' started by jtkohl, Jun 3, 2007.

  1. Aug 8, 2007 #81 of 137
    PaulS

    PaulS Active Member

    779
    38
    Sep 16, 2002
    Southern NH
    My ZoneAlarm installation recently wigged out, so I had to uninstall/reinstall, and ended up in the same boat with Galleon once again. After a fresh reinstall of ZA, I simply could not connect to Galleon. All of the TiVo entries in the ZA program control section were missing. Nothing I did in ZA managed to correct the problem. A uninstall/reinstall of Galleon also did not fix the problem.

    You know what fixed it ? I installed TiVo Desktop 2.5 tonight, which properly populates all of the firewall entries in the ZA program control table, and voila! Galleon is connecting with no problems. Give it a shot...
     
  2. Aug 10, 2007 #82 of 137
    rigger29

    rigger29 New Member

    106
    0
    Jun 1, 2007
    i asked this question before but got no reply. whenever i put galleon in a group Blockbuster online the blue color dissapears its all black. it works perfectely just the color is missing
     
  3. Aug 11, 2007 #83 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    By putting it in a group do you mean File/Properties and then checking the "Menu" checkbox? Also when you say "the blue color dissapears its all black" are you saying that the background is solid black, but the app works just fine?

    There seems to be plenty of other issues with that menu mode. Mine doesn't seem to be consistently displaying all the apps in the menu.
     
  4. Aug 11, 2007 #84 of 137
    rigger29

    rigger29 New Member

    106
    0
    Jun 1, 2007
    yep thats what it does
     
  5. Aug 23, 2007 #85 of 137
    morac

    morac Cat God TCF Club

    12,762
    1,407
    Mar 14, 2003
    NJ
    Okay I figured I'd try this version and I'm having nothing but problems. I tried the windows version and it won't run, it dies with the following exception:

    The Linux version runs under Windows XP SP2 fine, except that I get errors when trying to access photos:
    Also while the ToDo module works fine on the TiVo (it lists the shows I have), running it in the GUI gives an error saying that the GUI can't connect to the Galleon server.

    I never had problems with 2.3.1

    Edit
    Okay I got things working by copying the following files from the linux distribution's lib directory to the windows distribution's lib directory and then modifying the run.cmd file to include them:
    asm-1.5.3.jar, jl1.0.jar, jta-1.1.jar, odmg.jar

    After that everything worked. So the Windows install file is missing those 4 files and the linux install file doesn't contain the 3 .dll files needed in Windows (which is why I got the shortcut error) which is why neither worked for me.
     
  6. Aug 29, 2007 #86 of 137
    shredhead

    shredhead Guest

    98
    0
    Oct 14, 2003
    Is there any possibility of making Galleon run on DirecTivo units?

    I can't code but I'm willing to be the guinea pig to test things to see if they work..
     
  7. Aug 29, 2007 #87 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    It's not possible because the HME apis aren't implemented on those tivos.
     
  8. Aug 29, 2007 #88 of 137
    JamieP

    JamieP Member

    991
    0
    Aug 2, 2004
    Actually, hacked dtivos running 6.3x can support HME. The price you pay is that you lose the ability to enable MRV, since they removed code from the 6.3 releases, while it was still in 6.2x.
     
  9. Aug 30, 2007 #89 of 137
    shredhead

    shredhead Guest

    98
    0
    Oct 14, 2003
    Bummer for 6.3 folks I guess.

    One could go with Movieloader but than means you need to keep mfs_ftp running and that requires you to leave it rw. Plus mfs_ftp transfers tend to be slow.

    I'll stay at 6.2a for now.
     
  10. Aug 31, 2007 #90 of 137
    pfunky

    pfunky New Member

    38
    0
    Sep 14, 2006
    You still planning to cut a 2.4.2 tarball soon? I see notes of "prepare for 2.4.2", but they're 7 weeks old ;-)

    That version fixes the mis-sized backgrounds and progress bar on the "music" app doesn't it?

    Many thanks!
     
  11. Aug 31, 2007 #91 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    I was going to let john do it. I don't think he gave me admin access anyway, just developer access. I think he's busy until after labor day weekend and hasn't had a chance to work on galleon in the past month. I've mostly been fixing the music app and yes it fixes just about all display issues with the music app in hd like layout, font size, screensaver, playbar and it also fixes the lyrics downloading. The only thing that I might want to do later is make the layout of the playback screen fill up the space more with other information since that screen is a little bare and has more real estate to work with. I've also added a new app to plug in the tivo hd photos and it shouldn't be slow with a large photo set like tivo desktop is from what I hear. I decided to do that since that app looks really polished compared to the galleon one. Lately I've been trying to fix the netflix app in movie rentals since it's all broken.

    So that 7 week old number (wherever you saw that) doesn't reflect the actual work since I did most of that in the last month or so. My guess is the "prepare for 2.4.2" note you saw was right after he made 2.4.1 since the version in the source tree already says 2.4.2.

    David
     
  12. Sep 6, 2007 #92 of 137
    pfunky

    pfunky New Member

    38
    0
    Sep 14, 2006
    Ahh. Well, thanks for you work on Galleon too. I've sorta stopped using it, since the display was so bad, and I was afraid of burn-in on my HD-CRT. Plus, since I've a S3, I still haven't gotten to ever play with the whole Tivo2ComeBack or Tivo2Go stuff. Hopefully someday :-(
     
  13. Sep 6, 2007 #93 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    I agree, galleon looks pretty bad right now with the layout all screwed up. That's why I've been working on it. I've already gotten music and a new hdphotos wrapper app so at least those look nice. Another thing is that it's a beast. My movie rentals app starts quickly and is pretty compact, galleon does not and requires a ton of resources that it probably shouldn't.

    About the burn in, I was thinking of the same issues since I have a plasma. There is a screen saver in the music app, but that only dims it. I was thinking about making a global screensaver for all apps and making a new one that either has a black screen ( be able to adjust the transparency on the music screen saver) or a bouncing tivo image that moves across the screen.

    I'm in the same boat waiting for TivoToGo since I have an S3 too. I also have an S2, but I don't really use it much. I'm just hoping that the enable MRV soon so I can at least use it a little bit before I ditch my S2 when the free year sub is up.

    David
     
  14. Sep 6, 2007 #94 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
  15. Sep 6, 2007 #95 of 137
    pfunky

    pfunky New Member

    38
    0
    Sep 14, 2006
    That sounds nice. The dimming works ok for me...enough that I don't worry much when I'm listening to music, but something more "active" would be nice. Heck, the song/title/thumbnail of the current track bouncing around would be really cool.
    Wheew. I'm glad to hear you have an S3 ;-) That means if they do get T2G running, you'll be motivated to fix any problems :p

    I'd be happy to help by doing beta and filing bugs, but once I've grabbed all the latest code from CVS, I'm not sure what's needed to compile a working system. Is there documentation that would help me run the latest (pre-release) cvs code?
     
  16. Sep 7, 2007 #96 of 137
    fred2

    fred2 Member

    514
    0
    Jan 20, 2006
    I believe that I've got the most recent version. I notice when looking at Photos, the Folder Icon and Folder names are displaced from each other.

    I now forget what the application is - something like coming events??? You can use the virtual keyboard to enter data... the keyboard is messed up. Using the right arrow, it went from A to C skipping the letter B. When I went down a row, I actually got the letters from the above row.

    When scrolling down through Internet images, there is NO highlight so I cannot tell which image I am on when selecting.
     
  17. Sep 7, 2007 #97 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    Yes the photos app is pretty messed up in 2.4.1. The selection is a static size because it's an image graphic so it usually draws behind the photo. I added a wrapper for the tivo hd photos app in 2.4.2 (not out yet). I figure that one looks better anyway so I made a new wrapper app for it rather than fix the photos one for now.
     
  18. Sep 7, 2007 #98 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    Yes, they just announced TTG for S3 in Nov. Woohoo! I'll definitely fix that one when the time comes. Yeah, I'm more motivated to fix my own problems with the apps I use before fixing other people's problems in apps I don't use. Call me selfish I guess. :)

    As for developer docs, here is the doc that leon wrote:
    http://galleon.cvs.sourceforge.net/galleon/galleon/Developers.txt?view=markup

    Basically just install java, ant, and eclipse (if you want to change code). Then run ant with no params under the galleon directory. That generates some hibernate files. Then you can use eclipse after that for compiling if you actually make any changes.

    To build a copy of the installed app for the platform of your choice, run:

    ant -Dplatform=win32 package

    That will build it under the build directory and you can run it from there using the bin/run.cmd script. The other platforms are unix or osx.

    David
     
  19. Sep 16, 2007 #99 of 137
    mitch2k2

    mitch2k2 New Member

    110
    0
    Aug 2, 2006
    For some reason Galleon keeps quitting music playback; sometimes after as little as s minute or two, sometimes after as much as 45 minutes to an hour. In any case, the music just stops and the TiVo switches back to the Galleon menu.

    This is the most recent version, running over a wireless network, and in the past I'd (finally) gotten Galleon to work almost all the time without a hitch. Lately though, it craps out like this so frequently it's frustrating all over again.

    ANy ideas?
     
  20. s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    I tried using it today and it kind of did the opposite. It gave an internal tivo error saying can't run application, but the music was still playing in the background and it went out of the app into the tivo music, photos and more menu. I had to go back into galleon and start a new song to get it to stop.

    Not sure what's up with it. I might look into the playback logic a little to see if I can find any obvious problems in the code.
     

Share This Page