Galleon development restarting

Discussion in 'Developers Corner' started by jtkohl, Jun 3, 2007.

  1. Jul 2, 2007 #41 of 137
    rigger29

    rigger29 New Member

    106
    0
    Jun 1, 2007

    Advertisements

    I think i might discovered a bug. when ever I group galleon into a group for some reason the colors disappear and its all black with white writing. all the different apps. work but the color is gone.
     
  2. Jul 4, 2007 #42 of 137
    pfunky

    pfunky New Member

    38
    0
    Sep 14, 2006
    jtkohl, I've seen some writes to the CVS tree, but no real releases lately...is there any progress towards a new version?
     
  3. Jul 4, 2007 #43 of 137
    jtkohl

    jtkohl Member

    170
    0
    Feb 6, 2004
    Arlington,...
    I want to get some of the egregious HD layout stuff fixed before another release.
    What's in there so far is:

    * Turned off HD for applications that don't need it (e.g. top level menu,
    Weather since its maps are small)
    * Updated Mac OS X install to put applications in subdirectory:
    /Applications/Galleon/
    * Fixed Mac OS launch scripts to enable quit function
    * Fixed Movies application (needed an update to parse HTML output change from data source)
    * Fixed Windows installer JRE detection (accepts Java 6)
    * Fixed MusicOrganizer MP3 count (1746310)

    Worth a release yet?
     
  4. Jul 4, 2007 #44 of 137
    pfunky

    pfunky New Member

    38
    0
    Sep 14, 2006
    Mostly I'm looking forward to the layout fixes. I'm running on Linux, so on a selfish level, I'm not needing the OSX/Windows stuff ;-)

    I'm not a java developer...but out of curiosity poked around at the source in CVS. I'm fairly good at figuring out languages, by example, but I don't think I'd be any help to you on it unfortunately. I wish I could help.

    Anyway...I'll take this opportunity to thank you for your work...I'd hate to see Galleon die.
     
  5. Jul 4, 2007 #45 of 137
    ACraigL

    ACraigL Member

    716
    1
    Feb 12, 2003

    Advertisements

    Sure! These are sorely needed. What else is on the roadmap?
     
  6. Jul 4, 2007 #46 of 137
    rigger29

    rigger29 New Member

    106
    0
    Jun 1, 2007
    change the default color of music organizer the bright orange is aweful to look at
     
  7. Jul 5, 2007 #47 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    Can you also upgrade htmlparser to use 1.6 instead of 1.5? That way I won't have to override it for my movie rentals plugin.
     
  8. Jul 9, 2007 #48 of 137
    DVila

    DVila New Member

    5
    0
    Oct 19, 2005
    I also have Galleon and java is using about 350MB of my 1GB memory. It is making my Win XP-sp2 PC really slow. Any way to make it use less memory?
     
  9. Jul 9, 2007 #49 of 137
    ACraigL

    ACraigL Member

    716
    1
    Feb 12, 2003
    If possible, a feature I would like to see added would be a "true" screen saver. I have a plasma screen and even with the intesity-fade offered now, I still tend to turn off the TV when listening for fear of burn-in. I'd love to have a moving screen saver that still lets me see the music info, even if foregoes the timebar (like TD music uses now, except to include album art as well :))

    Thanks, and 2.4 seems to be working well so far!!!
     
  10. Jul 10, 2007 #50 of 137
    PaulS

    PaulS Active Member

    793
    39
    Sep 16, 2002
    Southern NH
    I ran 2.4.0 fine against my S3. I just downloaded 2.4.1, and all of a sudden things are not working. The install appears to have went well, but the GUI can not connect to the server. Install is on a WinXP machine as Administrator. Java is up to date. Any ideas ?

    I might not know my Java (I'm a C hacker), but perusing the log files shows a bazillion instances of this :

    22:23:08,562 ERROR [ListenThread] ListenThread - java.lang.NullPointerException

    Looks like a problem...
     
  11. Jul 10, 2007 #51 of 137
    ACraigL

    ACraigL Member

    716
    1
    Feb 12, 2003

    Double-check all the required ports are still open... maybe it removed some along the way?
     
  12. Jul 13, 2007 #52 of 137
    whitepelican

    whitepelican Member

    684
    3
    Feb 14, 2005
    Just curious, but should the HD version of Galleon work with an HR10-250 DirecTivo? I downloaded and have it running, but I'm not sure that anything is really shown in HD. The "Photos" application certainly doesn't look like it. I'm also having the same problem that Fred2 mentioned above, with all of my photos being stretched to fill the screen, even though my TV is not set to do this, and the HR10-250 is set to "Panel" so it shows sidebars on SD content. Any ideas?
     
  13. Jul 13, 2007 #53 of 137
    jtkohl

    jtkohl Member

    170
    0
    Feb 6, 2004
    Arlington,...
    What does your TV do with 480p input?
    HME SD apps are 480p on the S3. Would the HR10-250 generate 480p?

    If you have the TV set to stretch 480p to fill 16:9 (e.g. if you have a DVD player with progressive scan output), that might apply to the TiVo in 480p as well.
     
  14. Jul 16, 2007 #54 of 137
    whitepelican

    whitepelican Member

    684
    3
    Feb 14, 2005
    Hmmm... that's interesting. I have my HR10-250 set to always output 720p, but I guess that might not pertain to the menus and HME apps. I guess it could be possible that I have 480p set to stretch, but then I thought this new version of Galleon (v2.4) was supposed to be in HD. Which applications are actually in HD, and what HD resolution do those apps use?
     
  15. Jul 16, 2007 #55 of 137
    jtkohl

    jtkohl Member

    170
    0
    Feb 6, 2004
    Arlington,...
    HD includes photos, music, and a bunch others, but not weather nor the top menu.
    It's only HD if the TiVo sends the HD resolution stuff in the same way the S3 does.
    s2kdave figured that stuff out, perhaps he can comment on what's needed and/or whether the HR10-250 does a similar resolution negotiation for HME.
     
  16. Jul 18, 2007 #56 of 137
    PaulS

    PaulS Active Member

    793
    39
    Sep 16, 2002
    Southern NH
    A follow up...

    I uninstalled 2.4.1, and re-installed it as Admin (as I had before). Still no dice. The GUI could not talk to the Galleon service. I poked around in my firewall (ZoneAlarm) to see if I could make sure that the appropriate ports were open, but didn't see anything there. For giggles, I tweaked the application permissions for all of the listed TiVo services. After that, things seemed to work just fine. All of the apps that I set up seemed to work just fine.
     
  17. Jul 19, 2007 #57 of 137
    rgura

    rgura RobGTX

    69
    1
    Feb 20, 2005
    Austin, TX
    How about adding some new built-in apps for Galleon?

    There has been some interesting ones over the years but many are difficult to configure for the average user. Some that I would be interested in seeing on the Galleon roadmap would be: Streaming stocks, Streaming sports news, eBay browser/bid agent and some decent games ... my wife is getting bored with SameGame.
     
  18. Jul 20, 2007 #58 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    I just added the Movie Rentals app that I make as a core 2.4.1 galleon app... :rolleyes:
     
  19. Jul 20, 2007 #59 of 137
    s2kdave

    s2kdave New Member

    515
    0
    Jan 27, 2005
    As far as I know, the Series3 is the only one that does the resolution handshake. But you can find out by turning up the logging level in the log4j.xml file.

    <category name="com.almilli.tivo.bananas.hd">
    <priority value="debug"/>
    </category>


    Then start up an HD supported app that uses the hme-hd library such as movie rentals. Look for this:

    handleChunk: ResolutionInfo

    If you see that in the logs, then it's trying to do the handshake by sending the resolutions it supports. If you don't see that in the log, then it acts just like a Series 2 which only does 480i therefore won't do HD until TiVo supports their own HD photos (via TiVo Desktop) on that model TiVo.
     
  20. Jul 21, 2007 #60 of 137
    TBoyd

    TBoyd Less Cable, More Cloud

    371
    18
    Apr 9, 2000
    SF Bay...
    on my S3 (Windows XP PC) after two bad installs, a removal and a "new" install.

    Thanks for re-starting development on Galleon.
    Tim
     

Share This Page

spam firewall

Advertisements