FreeBSD HMO runtime issues

Discussion in 'TiVo Home Media Features & TiVoToGo' started by cshuttle, Jan 10, 2006.

  1. cshuttle

    cshuttle New Member

    14
    0
    Dec 19, 2003
    Let me be the first to say that this is probably something incredibly obvious, as I hate classpath errors and they're especially annoying when you see how simple the solution is. That said, I'm seeing the following after running my ant compile script on FreeBSD:

    [Loaded sun.misc.URLClassPath$FileLoader from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    Exception in thread "main" java.lang.NoClassDefFoundError: org/lnicholls/javahmo/server/Server
    [Loaded java.lang.StackTraceElement from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded java.lang.Shutdown from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded java.lang.Shutdown$Lock from /usr/local/jdk1.4.2/jre/lib/rt.jar]


    Obviously, this is no good. An excerpt from my /etc/profile reads as follows:

    JAVA_HOME=/usr/local/jdk1.4.2
    export JAVA_HOME

    CLASSPATH=.:${JAVA_HOME}/jre/lib:/usr/share/javaHMO/build/lib
    export CLASSPATH


    So, I guess I'm pointing to the right place, but since java is sooo good at telling me exactly which JAR it's looking for, I have no idea what it's missing out on.

    Any help with this would be just ducky.
     
  2. javahmo

    javahmo New Member

    1,538
    0
    Aug 11, 2003
    If your TiVo has version 7.2.1 software, rather install Galleon: http://galleon.tv

    Otherwise, you need to ensure that all of the .jar files in the JavaHMO lib directory are added to the CLASSPATH environment variable:
    CLASSPATH=.:${JAVA_HOME}/jre/lib:/usr/share/javaHMO/conf
    for j in /usr/share/javaHMO/lib/*.jar
    do
    CLASSPATH=$CLASSPATH:$j
    done
    export CLASSPATH
     
  3. cshuttle

    cshuttle New Member

    14
    0
    Dec 19, 2003
    Yea, I'd sure like to be able to use Galleon, but this is a directivo setup. I'll let you know how your suggestion turns out...
     
  4. cshuttle

    cshuttle New Member

    14
    0
    Dec 19, 2003
    Much better! Still getting the following:

    [Loaded java.awt.font.TransformAttribute from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded java.awt.geom.AffineTransform from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded java.awt.font.TextAttribute from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded sun.java2d.FontSupport from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded sun.java2d.SunGraphicsEnvironment from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded sun.awt.X11GraphicsEnvironment from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded sun.awt.font.NativeFontWrapper from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    [Loaded java.lang.InternalError from /usr/local/jdk1.4.2/jre/lib/rt.jar]
    Exception in thread "main"
     

Share This Page