Free movie filter

Discussion in 'TiVo Roamio DVRs' started by Wm. Schmidt, Jun 21, 2017.

  1. Wm. Schmidt

    Wm. Schmidt New Member

    3
    0
    Jun 19, 2017
    I'm new to Tivo and was wondering if there is a way to filter just the free movies on Amazon Prime? I know that Prime offers this feature on their webpage.
     
  2. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,198
    3,466
    Dec 7, 2012
    Ashland, PA...
    That's a little confusing. Prime implies only free movies. From the TiVo, you can access the Amazon app. In the upper right corner there is a filter pull down ("D" key). You can select Prime only.

    At one time you could use TiVo's Search and the TiVo would filter free also. I don't know if that still works.
     
  3. Wm. Schmidt

    Wm. Schmidt New Member

    3
    0
    Jun 19, 2017
    It's possible I set something up wrong in Tivo, but when I select Amazon Video there is a rent or buy option and an associated charge of usually $3.99.
     
  4. JoeKustra

    JoeKustra in the other Alabama TCF Club

    19,198
    3,466
    Dec 7, 2012
    Ashland, PA...
    In Settings, Recording, OnePass and Recording Options, change Rent or Buy: to "Don't Include". That only applies to TiVo's Search. Going straight to Amazon as a Video Provider is where you need to set the manual filter (which doesn't stick).

    Using TiVo's Search, I looked for "Kong Skull Island" and it wasn't found. The Search filter seems to work, but don't trust it.
     
  5. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,338
    5,797
    Apr 17, 2000
    Nevada
    If you go to the apps list there are two options for Amazon. One is for paid content and the other for Prime. If you uncheck the paid option and leave the other one checked then you'll never get the Rent option in the TiVo menus.
     
    PSU_Sudzi likes this.
  6. Wm. Schmidt

    Wm. Schmidt New Member

    3
    0
    Jun 19, 2017
    Thanks for the help. I hadn't noticed the pull down menu when I set Tivo up. I got it configured and its working fine now.
     

Share This Page