Forum sluggishness happening more frequently

Discussion in 'Forum Operations Center' started by astrohip, Jul 28, 2020.

  1. astrohip

    astrohip Well-Known Raconteur TCF Club

    15,966
    5,839
    Jan 6, 2003
    Houston/Bren...

    Advertisements

    I've been having forum issues over the last few weeks, and lately (last few days), they're getting more regular. It's not an Internet issue, as I regularly access this site from two places, with two totally unrelated ISPs.

    Long delays in loading, new posts sitting with those gray blinking things for 10-20-30 seconds at a time. Marking a forum READ sometimes is quick, at other times takes 5-10 seconds.

    The forum became incredibly snappy when you made that huge upgrade a few years back. I'm starting to feel like it's becoming pre-upgrade feeling.

    Is it just me?
     
  2. Mike Lang

    Mike Lang Administrator Staff Member Administrator TCF Club

    8,850
    1,742
    Nov 17, 1999
    Seems quick as usual for me.
     
    astrohip likes this.
  3. JandS

    JandS Well-Known Member TCF Club

    3,154
    1,044
    Oct 1, 2010
    East of Seattle
    I have noticed a slowdown too, about 2-4 weeks maybe. I put it down to opening multiple tabs in Firefox 78.0.2 (oops, I see there's a 79 out now, will confirm one way or the other tonight or tomorrow.

    Win10, 1909

    My SOP is to open a specific forum, then right-click to open multiple threads of interest in a new tab, sometimes 8, 10, 12.

    Lately each new tab is slow to open, the tab header eventually shows the thread title but there's a little back-and-forth blue icon to the left while the tab finishes opening. During this time the vertical scrolling display gets choppy, like the tabs opening is eating all the cpu. When each tab finally opens the choppy display resolves itself.

    I use NoScript and AdBlock Plus. I have Facebook.net and .com "Untrusted" in NoScript.

    I've noticed that Twitter embeds often take more time than usual to show up.
     
    astrohip likes this.
  4. JandS

    JandS Well-Known Member TCF Club

    3,154
    1,044
    Oct 1, 2010
    East of Seattle
    I just timed opening original forum tab plus 5 additional tabs and the blue ball "waiting" icon in the tab title space is actually doing a metronome, one second for each transition left to right and back. So it was 5 seconds to open 5 tabs.
     
  5. Jun 6, 2021 #5 of 19
    NorthAlabama

    NorthAlabama tabasco rules

    13,907
    4,684
    Apr 19, 2012
    sweet home, al

    Advertisements

    mike, were you aware the forum has been sluggish all day, even throwing 502 sever down messages a few times?

    it's hit or miss, but has mostly been an unpleasant experience today, and appears to be getting worse, in case you weren't aware.
     
    Random User 7 likes this.
  6. Jun 6, 2021 #6 of 19
    Mike Lang

    Mike Lang Administrator Staff Member Administrator TCF Club

    8,850
    1,742
    Nov 17, 1999
    No, I’ve been on & off all day without issue and there haven’t been any other reports.
     
  7. Jun 6, 2021 #7 of 19
    NorthAlabama

    NorthAlabama tabasco rules

    13,907
    4,684
    Apr 19, 2012
    sweet home, al
    terpfan1980 and pdhenry like this
     
    Random User 7 likes this.
  8. Jun 6, 2021 #8 of 19
    kaszeta

    kaszeta $nullstring TCF Club

    33,988
    7,777
    Jun 11, 2004
    Grantham, NH
    Yeah, it's been almost unusable for me today, with the occasional page fetch taking minutes.
     
    NorthAlabama likes this.
  9. Jun 6, 2021 #9 of 19
    Mike Lang

    Mike Lang Administrator Staff Member Administrator TCF Club

    8,850
    1,742
    Nov 17, 1999
    Weird, I just checked again and not a single email. When we have a widespread outage or slowdown there are usually a bunch of emails.
     
  10. Hank

    Hank AC•FTW TCF Club

    26,354
    2,846
    May 31, 2000
    Boston, MA
    I’ve has bouts of many slow loading pages and images all day, but no server errors.
     
  11. NorthAlabama

    NorthAlabama tabasco rules

    13,907
    4,684
    Apr 19, 2012
    sweet home, al
    things seem to be flying now.
     
  12. stevel

    stevel Dumb Blond TCF Club

    43,397
    16,257
    Aug 23, 2000
    Nashua, NH
    When TCF is slow or unresponsive, as it was yesterday, I don’t think to email, as it is a frequent occurrence. I just chalk it up to Suckuri (my spelling) and go find something else to do. If the site owners aren’t being notified of frequent 402 errors by Suckuri, then perhaps it’s not the right choice.
     
  13. kaszeta

    kaszeta $nullstring TCF Club

    33,988
    7,777
    Jun 11, 2004
    Grantham, NH
    Yeah, I got quite a few Sucuri notices yesterday.

    sucuri.png

    Things seem to be working fine now, however.
     
    NorthAlabama and HerronScott like this.
  14. hummingbird_206

    hummingbird_206 Retired

    12,768
    2,940
    Aug 22, 2007
    Valley of...
    I'm getting lots of the Sucuri notices today
    upload_2021-6-8_12-46-6.png
     
  15. dcheesi

    dcheesi ...I'm not.

    18,657
    1,469
    Apr 6, 2001
    MD, USA
    Not sure if this is the same issue, but this morning TCF has been making my whole PC sluggish. Any time I load the forum, my CPU usage goes from ~25% to ~80% with nothing else running, engaging all cores simultaneously.

    Engaging an ad-blocker (which I normally don't for this site) fixes the issue. Perhaps a shady ad is doing something in the background (mining crypto, etc.)?
     
  16. rcoates777

    rcoates777 Member

    177
    6
    Jun 28, 2005
    I have not been on this forum for a while but I now notice that it takes over the CPU when it is running.
     
  17. Mike Lang

    Mike Lang Administrator Staff Member Administrator TCF Club

    8,850
    1,742
    Nov 17, 1999
    My guess would be a rogue targeted ad (based on your browsing history) that only you see. I'm not able to replicate it and the particular ad should quickly get replaced with a different one.
     
  18. rcoates777

    rcoates777 Member

    177
    6
    Jun 28, 2005
    Thanks, I do notice that after a few minutes things get back to normal for a while.
     
  19. NorthAlabama

    NorthAlabama tabasco rules

    13,907
    4,684
    Apr 19, 2012
    sweet home, al
    i hit the sucuri firewall error once last night, and it's caused the forum to hang a few other times, but a page refresh generally fixes things quickly.
     

Share This Page

spam firewall

Advertisements