1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixes for MFSTools 2.0 swap problems

Discussion in 'TiVo Upgrade Center' started by Robert S, Jul 31, 2002.

  1. slaponte

    slaponte The Iron Monkey

    Apr 6, 2005
    Miami, FL
    I don't think you can use FSCK. The file system check for Tivo is custom. This goes back to the swap thing, if it doesn't have enough swap, it will never end. Is a particularity of the Tivo fsck... Just an opinion. Sorry, don't have hard data on this.
  2. renatom

    renatom New Member

    May 5, 2002
    I am having the same problem. My tivo reboots after the "just a few minutes more.." message. I am upgrading a tivo from 80gb to seagate 400gb.

    It seems a common problem and somehow others got it fixed.

    Sergio, did you change the -s parameter to create your 340hrs?

    this is what I used to create the new disk.
    mfsbackup -Tao - /dev/hda | mfsrestore -s 127 -r 4 -xzpi - /dev/hdb

    another question from a Newbie: When I run again the same command does it erases my target HD or I have to clean it first?

    Thanks in advance
  3. renatom

    renatom New Member

    May 5, 2002
    I forgot to mention: I have 7.3 version...
  4. luan773

    luan773 New Member

    Jul 27, 2006
    I DL the free MFS Tool 2.0 from Hinsdale, and burned it to CD. All good. But the very 1st command mkdir /mnt/dos gives me an error "could not find kernel image mkdir" . Why? Someone can explain, pls. Thanks. Btw, my Tivo is Series 2 TCD540040. Reason for me to upgrade harddrive is sometimes my TIVO produce bad sound, it's like when you have scratches on CD or tape, very terrible sound. I suspect HD bad and need to replace it, and I would replace it with a Maxtor 250GB. The old Tivo HD is also Maxtor.

    2nd, what if I get a new TCD540080 Tivo and swap the HD, does it keep all the config. from new Tivo to my old Tivo? Is it possible? And what if I wanna put the new 250GB HD on top of the pre-config Tivo HD, to expand space, what I have to do? I'm not Linux geek, so someone can give me a good instruction pls. Thanks very much.
  5. Aug 7, 2006 #605 of 609

    Soloist64 New Member

    Aug 3, 2006
    I have a Series 2 Tivo TCD24004a The hard drive is completely dead. I have a brand new 250 GIG HD Never Used. What are the steps that I need to follow to install the operating system for tivo on this new drive. I don't think I can access the old drive and frankly, I don't want to. Any help would be appreciated.
  6. Oct 1, 2006 #606 of 609

    kewashi New Member

    Mar 11, 2006
    Since your old HD is dead you'll have to get a new image. Your best bet is to grab a fresh image from PTV at:


    For $20 you can download a fresh image and burn it to your new hard disk.
  7. Oct 1, 2006 #607 of 609

    wmldwilly New Member

    Mar 5, 2006
    Wow. This is way more difficult than I thought it would be. I'm stuck in the reboot-loop phase of upping the stock drive in an HR10-250 to a 500gb drive. I've used the hindsale guide and mfstools and all it's companions to get as far as:

    1) prepare bootable cd.
    2) pull drive, add to pc in ide positions reccomened.
    3) create small backup on fat32 disk
    4) restore small backup to new 500g drive
    5) forget to run/not know I needed to do the tpip thing (like 98% of upgraders it seems...)
    6) put the drive back in the HR10-250 w/ jumpers back to master,
    7) observe reboot loop.
    8) put drive back in PC, leaving it set for master after removing fat32 disk used earlier
    9) run tpip.

    Here's where I'm totally crapped out:

    I do:
    #tpip -1 -s /dev/hda

    and it replies:
    #initializing swap partition (version 0) @ <very long number>, Size = 127 MiB

    Put it back in the tivo, still boot-loops.

    I'm a little confused at why the -1 option still yields the (version 0) message. Looking closer at tpip's useage it mentions --mkswap and --swaptype={0,1}. Upon trying:

    #tpip --mkswap --swaptype=1 /dev/hda

    I get:
    the same message as before, but with (Version 1) in there.

    Put it back in the tivo, and still boot-looping.

    So my triplet of questions follows - and PLEASE take pity on me - I've been gearing up for this and reading up on it for a week, and have been working on this from 8pm tonite to 5:45AM now when i'm writing this...it's kicking my arse.

    q1) what command do I use to once and for all confirm or deny that the swap partition is there at all? I'm getting the impression that tpip is writing these headers to something mythical.

    q2) If the swap partition isn't actually present on the drive at all, how do I actually MAKE one? I'm guessing that's going to be ugly and dangerous, and searches have led me thru threads about copying a swap partition from the CD, but it never quite sounds like what will work for me and an HR10-250.

    a3) being that this is an hr10-250 running 3.1.5f, do I have to think about "byteswapping" in this whole procedure? I read in one thread that byteswapping is a series 1 thing, not a series 2 thing. I admit freely I don't completly understand what byteswapping is anyway.

    Oh dear gawd please somebody...

    Off to pass out,


    Here's where it gets weird
  8. sync23976

    sync23976 New Member

    Apr 9, 2005
    Long Beach, CA
    Just a thought, though it may not matter, have you tried booting the drive in the Tivo with the jumper set to Cable Select (cs)? That is the way mine came from the factory. I am anxious for you to succeed because I am most of the way through to upgrading my HR10-250 to a 500 gig drive and I created a 400 meg swap during the copying. The new drive boots but I have not tried to tpip the swap yet so I'm sure it is functioning with no working swap file, I'm not sure if the stock kernel will recognize such a large swap. I would like to have the larger swap in case it needs to do a mfscheck but maybe it's not worth the hassle.
  9. ciper

    ciper New Member

    Nov 4, 2004
    Even though this thread is ancient I wanted to post something relevant.

    My Tivo had two 200gb drives and 127mb of working swap. I stupidly did an "mfsassert -please" not knowing my swap file wasnt large enough. I got stuck in a continuous reboot cycle as fsfix / fsck crashed on every boot.

    The interesting thing is that I was able to create an 80mb swapfile on my var partition using only DD for a total of 207mb of swap!
    I copied from swap partition 8 and specified to only copy 80 to the file. I then modified rc.sysinit with a "swapon /var/swap" command right after var is mounted (near the beginning). My Tivo accepted this additional swap just fine and the file system check was able to continue.

    If I remember right the command I used was
    dd if=/dev/hdc8 of=/9/swap bs=1024k count=80
    hdc8 being the swap partition of my Tivo's A drive and /9/ being the temporary mount point I used for the var partition (partition 9).

    Edit: Although definitely better my Tivo did reboot after staying on the GSOD for 5 hours. Im hoping this is normal and not that I ran out of swap again :(

Share This Page