firewall issues

Discussion in 'TiVo Home Media Features & TiVoToGo' started by tgrim1, Jun 19, 2011.

  1. tgrim1

    tgrim1 New Member

    199
    0
    Sep 11, 2006
    Iowa
    I just switched to using windows firewall from the AVG one. Now I'm stuck on "please wait" for streambaby and pytivo wont find my shares. Where/what program to allow an exception for so that these go through?

    I can still push using the 'config' for pytivo from the pc.

    Is a firewall even necessary when behind a router?
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,689
    922
    Apr 6, 2000
    SF Bay Area
    You need to add TCP and UDP ports in the firewall settings.

    TCP: 37, 80, 443, 5005, 5222, 5223, 7287, 7288, 8000, 8080-8089
    UDP: 37, 123
     
  3. orangeboy

    orangeboy yes, I AM orangeboy!

    4,089
    0
    Apr 19, 2004
    East Moline, IL
    I don't think those ports have anything to do with pyTivo or Streambaby. I believe Windows Firewall allows setting exceptions for application names, so setting an exception for both java.exe and python.exe may be needed.
     
  4. tgrim1

    tgrim1 New Member

    199
    0
    Sep 11, 2006
    Iowa
    I added exceptions for java and python, still no go. I added a rule for tcp and udp 7290 and all is good so far.:up:
     
  5. wmcbrine

    wmcbrine Well-Known Mumbler

    11,653
    786
    Aug 2, 2003
    pyTivo wants 9032, 5353 and 2190. I have no idea what 7290 is.

    And no, a firewall is not necessary behind a NAT router. Unless you expect to be attacked from a system on your own LAN.
     
  6. matt@thehickmans

    matt@thehickmans Hemo_jr

    537
    0
    Jan 8, 2008
    You could try re installing streambaby and pytivo. During the install process windows firewall usually picks up on what ports need to be opened. It then requests that you confirm.
     

Share This Page