Edge Reboot Loop - Software Failure

Discussion in 'TiVo Edge' started by Sloanstar, Nov 18, 2020.

  1. Sloanstar

    Sloanstar New Member

    5
    2
    Nov 16, 2020

    Advertisements

    Problem Description:
    Edge device reboots after making it through starting up sequence and displaying the main menu screen. The wait wheel spins several times (most of the time) then the device reboots. The rebooting only appears to happen when the device has internet access. If I remove the Coax (MoCa) the issue goes away and I can navigate the menu on the TiVo.

    The Troubleshooting
    In my infinite wisdom I decided to change the connectivity from MoCa to WiFi to rule out a MoCa driver/software issue. Well, it wasn't MoCa related because the unit kept rebooting on WiFi as well only now I couldn't pull the cable.

    So I called tech support back up with this new bit of information further proving my case that this was a software issue not a failed hard drive like they were trying to dump my previous call for. I got Jorge and while he's a nice enough guy I could immediately tell he was less technical than my grandmother SO we went around in a circle for a bit and I was asking him how to factory reset the tivo from the boot sequence, he insisted there's no way to do that and wanted me to pay $99 to swap out a bot that is less than a year old for a software error obviously caused by TiVo. At this point I was done talking to Jorge and demanded an escalation. I forget the next guy's name so we'll call him Wilbur, it was something with a W. Anyway, we chat for a few minutes he agrees this sounds like a software issue and starts talking about a kickstart code. Pleased that I found someone with a couple brain cells to rub together, we tried a few times to get the code entered (Pause 57) but didn't have any luck. I think he might have had old documentation that didn't cover the Edge because he was trying to chat with someone at product development. We ultimately weren't successful in getting the kickstart code entered but I was offered a 2 day air $49 replacement instead of a snail mail $99. Ok... most people would accept that and move on. I just couldn't let this go. I just knew if I could reset this device it would be fine. There was only one thing left to do. I have to kill the network.

    The Fix
    I have a pretty elaborate wireless mesh network with about 50-60 IoT devices connected some of which are better than others at coming back online after an outage. So reluctantly I went around pulling the power for my wifi satellites and the main device... Once the SSID was no more the next reboot left the TiVo in a usable state. Navigating through the menu I factory reset the box. Once reset and re-enrolled to the account the device was functioning perfectly. I checked the TiVo Minis - all good there too. I checked the clock, TiVo support closed 30 mins ago - it figures.

    I'll get some videos posted of the reboot loop and the fix is just a factory reset, but I did video that as well.

    TLDR:
    - TiVo tier 1 support is the worst. Escalate immediately.
    - Don't take their word for it. They want you off the phone and would like to generate some revenue while doing it.
    - Think critically about how to rule things out.
    - This would be a lot easier to solve if Kickstart worked for Edge.
    - Remove the device from the network ( or the network from the device )
    - Factory Reset
     
    Last edited: Nov 18, 2020
    tommage1 and Dan Cour like this.
  2. tommage1

    tommage1 Well-Known Member

    1,702
    406
    Nov 5, 2008
    I have some Tivos that are/were rebooting only when connected to the internet. Otherwise different from yours, mine are Roamios on TE3 with large (8TB and up) drives. I decided to try some of your process with one of the 8TB. Disconnected everything from the network/router including nothing hooked up to Wifi. Reset the router (well just unplugged, waited a couple mins then plugged back in). I then reconnected one ethernet cable to the router and ran it direct to the 8TB Tivo. Let the Tivo reset the IP. And for now it works, no rebooting. Hooked all my other devices back up, still working. Tested for 1/2 day or so, forced connections to Tivo, did long recordings etc. I did NOT do a factory reset as I'd lose everything on my nearly full 8TB drive. I hope it keeps working. Not sure what actually solved the problem (assuming it is solved, only time will tell) but your post got me to try something a bit different and for now seems to have worked. Oh Kickstart 58 did not work in my situation, just went to a screen that says "installing an update" but it never progressed, had to unplug eventually. Did not try KS57 as some people have reported a KS57 on a TE3 Roamio can brick the drive.

    Oh, about your Kickstart tries with the Edge. Were you able to run and just did not work? Or just not able to run? I believe when running KS you have to use a remote in IR mode, can't do it with RF mode. So maybe you could have run the KS if you tried a remote in IR mode?
     
    Last edited: Nov 20, 2020
    Dan Cour likes this.
  3. multiple

    multiple Member

    74
    32
    Aug 26, 2007
    On my new Edge, I swapped out the original drive for the 2.5" 5TB drive I had available and it went into the reboot loop. I tried Sloanstar's process but it wouldn't recover. I put the original drive back in and the issue went away. I hope Tivo is not trying a new mechanism to invalidate drives. I think it is trying to phone home early in the boot process when a non-standard drive is installed.

    I'll try tommage1's process, then I'll remove the wireless setting with the original drive and then try a wired connection under the 5TB drive.
     
  4. multiple

    multiple Member

    74
    32
    Aug 26, 2007
    Same thing happened even after reseting the Edge back to factory default state using the original drive. Once I switched over to the 5TB drive it would format, startup and give the fatal error on the second reboot and then reboot over and over. I tried 3 different 5TB drives and each had the exact same issue.

    Let me see if plugging in a wired connection changes anything.
     
  5. multiple

    multiple Member

    74
    32
    Aug 26, 2007

    Advertisements

    My issue was caused by not fully erasing the 5TB drive before installing it. My Mac indicated the drive was not formatted, but there must have been some residual data.
     

Share This Page

spam firewall

Advertisements