Easier to use pyTivo - pyTivo Desktop

Discussion in 'TiVo Coffee House - TiVo Discussion' started by Dan203, Jan 23, 2017.

  1. holysin

    holysin New Member

    22
    2
    Mar 15, 2002

    Advertisements

    Odd problem with the current version of the desktop on windows 10: After installing, running as service, manually allowing both the service (pyTivoService) and the main executable (pytivo) through the windows firewall, and then launching the desktop I am able to see all of the files on my tivo (woot!), the tivo can't see my share (boo!), and transfers hang at 0% (boo!) I've rebooted both my pc and the tivo with no difference. I do also have the original pytivo command line python in a different folder and am not running it at the same time. When I do manually run the old version, it works fine fetching files from the tivo, and the tivo can see my share (the same share) and download any of the files there (x264, x265, etc). But I figured it was worth trying the latest and greatest. Is there anything obvious I'm missing?

    (edit: as it didn't help, removed conf files)
     
    Last edited: Oct 17, 2017
  2. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    Reinstall without the service option. Or you need to go into the service and set it to run as the same user as you used to install it. Without user permissions the service can't access to ffmpeg.exe in the install folder, which is why the downloads stall.
     
    holysin likes this.
  3. holysin

    holysin New Member

    22
    2
    Mar 15, 2002
    Beautiful, (I swear I tried without a service first, but apparently that was a fever dream) had to uninstall, manually remove a few leftovers (which were hidden in fun locations... flipping windows), rebooted then reinstalled as admin before I got it to fully work but it's now running and talking both ways :) In fact downloading is now working so well that I'm currently getting 90Mb/s from a tivo OTA so I'm a happy camper (and a little surprised as I thought it's 100Mb pipe was throttled to wireless-g speeds of 55ish). Odd question though, the old PT would sort with groups (folders) first (Capitals first because it's more of a PITA), however the new version sorts the groups just like the files (e.g. I'll see files starting with an A before I see groups that start with a B.) Is there a way to change that behavior in the conf file, or is it just part of the new system? Heck, for that matter, is it possible to convince one end or the other to ignore caps vs lowercase? As a *major* plus for your current version over the OG, the video share list is now populated *oh so much* faster (annoyingly I share an obscene amount of media to the tivo to the point where plex isn't an option as at least last time I tried, it just stalls, most users might not even notice the change?) Aside from the install issues (which are completely user/windows issues) you've created an awesome piece of software here, I reiterate the call for a tip jar that someone made in the first 10 pages for those who don't want / need editing software to be able to express their appreciation for your work on this project... It might be worth on the 1st post perhaps under the spoiler saying for windows users run the install file as admin and do NOT SELECT SERVICE as I suspect that'll drastically cut down on the posts since apparently we can't read the repeated instructions in 65+ pages of posts ;) Thanks again, it rocks and continues to do something that plex wouldn't do for me, now at what seems to be a higher speed in every possible way.
     
  4. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    I'm going to remove the service option. Too many people select it just because and then don't understand why it doesn't work. I'll leave the scripts that will allow them to enable the service option manually if they want, but I'm going to remove it from the installer.

    As for the tip jar... I'm good. I make good money at my day job. This is just a hobby. If people start paying for it then it'll start feeling like work.
     
    krkaufman, V7Goose, Mikeguy and 3 others like this.
  5. cpubradley

    cpubradley New Member

    7
    0
    Oct 19, 2017

    Advertisements

    Thanks for creating this great software. One question, is it a know bug/issue with some shows up as duplicates in "My Shows" for downloading recordings? Sorry if it has been discussed before I haven't read through all 66 pages. If I download either listing, it downloads the same file. When downloading it shows 2 (or more) copies downloading even though it only really downloads one. Thoughts?
     
  6. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    That's a feature. It has a retry feature where it retries X number of times and always keeps the one with the least number of errors. If it gets a completely clean copy it stops. Otherwise it retries all X times and keeps the one with the least number of errors. At the end it should clean up after itself and you should end up with just one file.

    If you want to turn that off you can in the download section of the settings.
     
  7. cpubradley

    cpubradley New Member

    7
    0
    Oct 19, 2017
    I didn't explain myself well :) --- the listing in the app shows the same show multiple times -- attached a screenshot.
     

    Attached Files:

  8. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    13,014
    1,245
    Apr 6, 2000
    SF Bay Area
    The other shows (above and below) don't show dupes, so you may have parts of the show in 2 parts.
     
  9. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    That's weird. Do you have duplicates like that on the TiVo itself?
     
  10. cpubradley

    cpubradley New Member

    7
    0
    Oct 19, 2017
    Nope no duplicates on Tivo -- Attached is from the Tivo Now Playing togo webpage showing just one file per episode.
     

    Attached Files:

  11. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    What you're seeing is not normal. There are either duplicates in the XML I get from the TiVo or there is a parsing bug. Are you willing to run some tests for me to figure out which it is?
     
  12. cpubradley

    cpubradley New Member

    7
    0
    Oct 19, 2017
    Sure just let me know what you want me to do.... note that sometimes it is more then one duplicate too, also it seems to happen more frequently with older recordings - with the oldest showing up 6 times and it is just a single episode (not part of a group).
     
  13. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    I'll need to create a special build for you with extra logging. I'll do that tomorrow and contact you via private message with a link and instructions.

    Are you Windows or Mac?
     
  14. cpubradley

    cpubradley New Member

    7
    0
    Oct 19, 2017
    Windows.
     
  15. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,552
    8,100
    Apr 17, 2000
    Nevada
    Sorry I had an emergency today at work that took all day so I didn’t get a chance to do this. I’ll try to get to it tomorrow
     
  16. cpubradley

    cpubradley New Member

    7
    0
    Oct 19, 2017
    No problem, no rush.
     
  17. Skold

    Skold New Member

    2
    0
    May 16, 2008
    Dan203!

    Long time lurker, first time poster here...

    i've used the @wmcbrine fork of pyTiVo for years, and it was one of the reasons i stayed w/ TiVo for so long. Then Plex happened, and i didn't need it anymore. (TY wmcbrine for all of your hard work!).

    Just did the $99 Bolt transfer thing, and i was dismayed to learn that TiVo Desktop does not work with Bolt. At all.

    So, Dan203, this thing works great, and no need to install Python libraries and all that. Thanks!

    Also, many thanks to wmcbrine for updating this in the first place! He's obviously the Batman to Dan203's Robin. :p
     
  18. HerronScott

    HerronScott Well-Known Member

    7,631
    1,141
    Jan 1, 2002
    Staunton, VA
    TiVo Desktop does work with the Bolt?

    Scott
     
  19. atmuscarella

    atmuscarella Well-Known Member

    6,955
    617
    Oct 11, 2005
    Rochester NY
    TiVo Desktop works just fine with my Bolt
     
  20. V7Goose

    V7Goose OTA ONLY and Loving It!

    1,721
    582
    May 28, 2005
    New Mexico...
    Well, it "kinda" worked with my Bolts - when the Bolts could see the computer, it worked just like with any other TiVo, but my Bolts were were constantly having the computers disappear, especially after a Bolt restart. Each time that happened, the only way I found to get it back was to restart the Desktop on each computer. Just for comparison, the three computers running TiVo Desktop never disappeared from the two S3 boxes I was running at the same time, just the Bolts.
     

Share This Page

spam firewall

Advertisements