Easier to use pyTivo - pyTivo Desktop

Discussion in 'TiVo Coffee House - TiVo Discussion' started by Dan203, Jan 23, 2017.

  1. May 7, 2017 #581 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada

    Advertisements

    Must of been a cache issue.

    I'll look at adding some no-cache tags to my download pages to prevent that in the future.
     
  2. May 7, 2017 #582 of 2492
    Mikeguy

    Mikeguy Well-Known Member

    27,636
    9,207
    Jul 28, 2005
    Downloaded without issue, looking forward to checking out the enhancements. Thanks, as always! :)
     
  3. May 7, 2017 #583 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada
    Crap, just found a bug! There was a typo in one of the functions and it makes it so the PS download doesn't work if you have the "let me choose" option enabled. Not sure if it's worth releasing a new build for. But if any of you want to get an update for it let me know and I'll send you a link.
     
  4. May 7, 2017 #584 of 2492
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,107
    172
    Jul 9, 2001
    Central Jersey
    Unless you have a new build scheduled to come out in a day or so, I think it best that you do up the build minor number and release a version without the typo.

    You can't count on everyone interested in 'the latest and greatest' pyTiVo Desktop finding this one post...
     
  5. May 7, 2017 #585 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada

    Advertisements

    OK new build posted for both PC and Mac. I also found an issue with the Mac build that prevented tivolibre from working, which is critical since it's now used for the come back feature. There was some weird conflict between the jar2exe program I use to convert it to an executable and code signing, so for now that's the one executable in the package that is not signed. Hopefully that doesn't cause issues for users. But it's better then not working at all.
     
    aaronwt likes this.
  6. May 8, 2017 #586 of 2492
    Sparky1234

    Sparky1234 Well-Known Member

    2,327
    348
    May 8, 2006
    Great improvements!

    Is there a way to download shows/movies from PC to TiVo into one folder on TiVo?
     
  7. May 8, 2017 #587 of 2492
    Steve

    Steve TiVowner since 1999

    1,273
    281
    Apr 23, 2003
    White...
    Hi Dan. I've got a Bolt+ and 3 MoCa-connected minis. 1.5.xx was working fine for me. After I installed 1.6.1, however, pyTiVo Desktop can see the Bolt+ playlist, and the minis can see the shared PC folder, but the Bolt+ can't. I've tried soft and hard restarts of pyTiVo, with the same results. Any suggestions? I'm trying to avoid rebooting the Bolt+, if possible.
     
  8. May 8, 2017 #588 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada
    I had a similar problem with my Bolt. Unfortunately rebooting it was the only thing that fixed it. On the plus side the Bolts boot up relatively fast.
     
  9. May 8, 2017 #589 of 2492
    Steve

    Steve TiVowner since 1999

    1,273
    281
    Apr 23, 2003
    White...
    Thanks. That means I'll have to run KMTTG to re-enable "quick clear" of the progress bar. Not a big deal, except I have to re-install Java first to run that. LOL!
     
  10. May 8, 2017 #590 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada
    I think you can if you use the pyTivo metadata format. I believe you just assign a series ID of TS00000000 where the 0s are whatever you want, but the same for all shows, and they will group in My Shows.
     
  11. May 8, 2017 #591 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada
    FYI I got the service working last night. I'm going to include it as an option with my next update and allow th tray app to detect it and start/stop it rather then launching a hidden version of pyTivo like it does now.
     
    krkaufman and Mikeguy like this.
  12. May 8, 2017 #592 of 2492
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,107
    172
    Jul 9, 2001
    Central Jersey
    S-P-S-P-S *STILL* works from a TiVo Remote, so you could enable it 'Caveman Style'. ;)
     
  13. May 8, 2017 #593 of 2492
    Steve

    Steve TiVowner since 1999

    1,273
    281
    Apr 23, 2003
    White...
    It used to, but now S-P-S toggles 'quick play' on my Bolt +.
     
  14. May 8, 2017 #594 of 2492
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,107
    172
    Jul 9, 2001
    Central Jersey
    Yeah, it's a PITA like that on my Roamios too - you just have to get the timing right. Play a recorded show, count aloud "One Mississippi, Two Mississippi, ..." - you need to find YOUR TiVo's 'rhythm'.

    Keep trying - it DOES work. :)
     
  15. May 8, 2017 #595 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada
    I've got it down to a tee. My wife is always turning on that clock in the upper right corner and I hate it so I'm always turning it off. I've got the timing perfect to where it works every time.
     
  16. May 8, 2017 #596 of 2492
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,752
    7,129
    Apr 17, 2000
    Nevada
    There is a little bit of a hiccup with the service. I've discovered that for an app to interact with a service it has to be run as admin. Not sure if that's acceptable or not to people. TiVo Desktop calls it's server a "service" but in reality it's starting a background process just like I'm doing, which is why it doesn't require admin rights.
     
  17. May 8, 2017 #597 of 2492
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,107
    172
    Jul 9, 2001
    Central Jersey
    I wanted to reply to this statement while the breadcrumbs were still visible (i.e. Tabs still open in Chrome). I had the time to troubleshoot, and fix, this problem yesterday, but not the time to post.

    With over 2TB now of .TIVO PS / 'Slow' Format transferred files on my Canvio 3TB External HDD, I wanted to TEST to see if I actually had VIEWABLE programs. I went through the 'growing pains' of figuring out the installation of both kmttg and pyTiVo back in February 2016, both still reside on my half-dead laptop, so I already used a Linux Boot CD to get kmttg over my LAN, why not grab pyTiVo too. Well, Python couldn't just be copied, it needs to be installed to make entries in the Windows Registry, so I figured, why not grab the latest 2.7 version, 2.7.13 x86. D/l'd it, right-CLICKd, and nothing! :confused: Check the byte count - matched; too lazy to check hashes and / or checksums, so I just grabbed the copy of 2.7.11 x86 from the half-dead laptop. It installed almost 100% (according to the progress bar) and then flashed an error and ROLLED BACK OUT!?! :eek: WTH! This is the same file that installed PERFECTLY on my laptop back in February 2016. So, I called up my good friend GOOGLE:

    So, whatever 'Pip' does in Python, I'm currently running @wmcbrine pyTiVo 20170427 successfully without it.

    Since I thought that this was an unusual problem with a unique solution, I thought that I'd post it here on TCF for others to possibly benefit from during future SEARCHes. :cool:
     
    Last edited: May 8, 2017
  18. May 8, 2017 #598 of 2492
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,107
    172
    Jul 9, 2001
    Central Jersey
    @JoeKustra,

    Did you ever check your CPU Utilization during TiVo-to-PC and PC-to-TiVo PS / 'Slow' Format file transfers?

    Is your 'Black Cloud of Gloom & Doom' gone for good? ;)
     
  19. May 8, 2017 #599 of 2492
    JoeKustra

    JoeKustra in the other Alabama TCF Club

    20,328
    3,777
    Dec 7, 2012
    Ashland, PA...
    Nope. Only network speed. But, while it may not matter, I have nothing active in the background. My idle process is always 99% unless something is working. My CPU speed frequently varies, but not without my noticing. I even have Flash disabled, Adobe updates disabled and Windows Updates disabled. I use Taskmgr a lot. :)
     
  20. May 8, 2017 #600 of 2492
    ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    1,107
    172
    Jul 9, 2001
    Central Jersey
    How about that 'Black Cloud' - gone?
     

Share This Page

spam firewall

Advertisements