Downloads have blank picture when AVC and HDR

Discussion in 'TiVo Bolt DVR/Streamer' started by quah, Apr 29, 2021.

  1. quah

    quah New Member

    5
    0
    Apr 14, 2009

    Advertisements

    This is a Tivo Bolt+ with CableCard.
    I am downloading with KMTTG in TS mode.
    Never had a problem until last few months.
    Some downloads result in a blank picture.
    Using MediaInfo I can see that this seems to happen every time the recording is HDR.

    MPEG2 and AVC downloads usually work and playback just fine with VLC, Plex, etc.
    This is not a decryption problem. I've tried TivoLibre and DirectShow Dump. I have Tivo Desktop and VideoRedo. installed.
    All software is current.
    QuickStream Fix does not help and sometimes just fails.
    Recordings play back just fine on the Tivo or with the Tivo App.
    I don't need HDR, and would be happy to get working downloads in SDR.

    Has anyone had similar problems or know how to solve this?
     
  2. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,198
    7,902
    Apr 17, 2000
    Nevada
    Are you the same poster from the VideoReDo forum?

    If not I have another customer over on the VRD forum complaining about a TiVo download that us blank for the first 30 minutes. They didn’t specifically mention that the video was 4K HDR but it might be.

    When you download the recording are you decrypting it or leaving it as a .tivo?
     
  3. quah

    quah New Member

    5
    0
    Apr 14, 2009
    Thanks for your reply.

    I am not the same poster. This is my first post on this subject anywhere.

    I have not tried this with 4K. This is happening with 720p, specifically from ABC and NBC, received over Cable.

    I have tried it both ways: Letting kmttg decrypt (using various methods available) and also working with just the .tivo file, decrypting with TivoLibre. I have also tried opening the files in VideoReDu (which can normally decrypt) and it just hangs.
     
  4. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,198
    7,902
    Apr 17, 2000
    Nevada
    Can you try pyTivo Desktop?

    After you install it set the transfer format to "allow me to choose per recording". Now find the show and download both the TS and PS versions. Do either of them work?
     
  5. quah

    quah New Member

    5
    0
    Apr 14, 2009

    Advertisements

    OK, thanks for the suggestion.

    I installed pyTivo Desktop. I selected "Install DirectShow Filters" option during install.

    Working with shows recorded from local ABC affiliate over cable...

    I downloaded a show using initial defaults (TS, no decrypt). pyTivo reports "TS errors detected" during the download, but it completes. The .tivo file hangs VideoReDo, as before.

    I next downloaded a show using TS, and with "Decrypt with TivoLibre" enabled. pyTivo reports "TS errors detected" during the download, but it completes and decrypts. As before, this results in blank video in VLC.

    I tried setting pyTivo to decrease download speed automatically and keep retrying in the case of errors. On the 7th attempt, it successfully downloaded the TS without errors - the final speed was about 20Mb/s. I had high hopes when I tried to play this file, but, as before, there is still blank video in VLC and it reports 0 video blocks decoded. VideoReDo reports "Unable to determine initial clock" when I try to open the file. VideoReDo Quickstream Fix says it is "Unable to open file". The log says "no clock offset at initial seek".

    I tried a different PC, but had the same result. I tried playing the file with Plex and had the same result.

    I next downloaded the same show using PS, also with decrypt enabled. The resulting .mpg file is about 5% of correct size. (This is equivalent to previous results with kmttg.) As before, this results in blank video in VLC. MediaInfo does not show details about the video format other than bit-rate. From other reading, it seems that PS does not support AVC.

    I also tried downloading another AVC show from Comedy Central, using TS. It works perfectly. This show did not have HDR.

    So the current situation is that some AVC shows download with TS errors and are unplayable. Some other AVC shows download and play ok. All shows that won't play happen to be HDR and all shows that do play are not HDR, but I have not done a massive comparison. In all cases, the audio stream is ok. It does not seem related to download errors.

    I'm led to conclude that there is a problem with the Tivo. Any assistance will be greatly appreciated.
     
  6. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    55,198
    7,902
    Apr 17, 2000
    Nevada
    Can you do me a favor? Open VideoReDo. Select Tools->Trim & Copy Source. Select the file with no TS errors, set from beginning, and output 1000 MB. Then upload the resulting file here…

    Upload Files to VideoReDo

    I'll take a look and see if there is anything we can do in VideoReDo to fix.
     
  7. quah

    quah New Member

    5
    0
    Apr 14, 2009
    Thanks very much! The file output.ts is in folder "582930".
     
  8. quah

    quah New Member

    5
    0
    Apr 14, 2009
    I forgot to mention that I am using VideoReDo 6.62.4.827. Let me know if you need me to update to the beta. Thanks!
     

Share This Page

spam firewall

Advertisements