1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Download from Tivo

Discussion in 'TiVo Underground' started by Soapm, Aug 27, 2018.

  1. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO
    I've been away for a while but I've been trying all day to download a series from my Tivo HD. I tried pyTivo web and KMTTG and all I get is the audio and no video.

    What gives? What could I be doing wrong?
     
  2. Wil

    Wil Senile Member

    4,333
    91
    Sep 26, 2002
    You are trying to download mpeg4s as program streams. Use transport streams.
     
  3. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO
    Thanks, i checked that box in kmttg and waiting the results...
     
  4. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO
    That didn't work, all I'm betting is 163 megs which is just the audio. No video.

    What did you mean by "use transport stream"? Can I do it with pyTivo on a Series 3 HD.
     
  5. Wil

    Wil Senile Member

    4,333
    91
    Sep 26, 2002
    How are you tivodecoding?
     
  6. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO
    To my knowledge, I'm not. I'm just looking at the size of the .tivo file at this point and they're coming out around 163 megs which is just the audio. The entire show is 1.6 gigs.

    If I can get the file off the tivo then I plan to use Video Redo on the computer upstairs, it's the only one licensed. I can't use it to get the files off the Tivo because pyTivo isn't working and I can't get kmttg to run on that PC because I can't get java to update to a later version because it's running xp64.
     
    Last edited: Aug 27, 2018
  7. Wil

    Wil Senile Member

    4,333
    91
    Sep 26, 2002
    To recap: You're definitely downloading transport streams, not program streams, as .tivo files, and getting audio-only?

    If so, could you confirm that it's an mpeg4 channel? Maybe I'm wrong about that too.

    I'm having trouble getting my head around this. There are other ways that could happen, and even with mpeg2's I suppose, but everybody I know who had that problem had it with mpeg4s and program streams.

    EDIT: There is a current thread, "Downloading to computer, files corrupted" which mostly deals with transitory disruptions, but I see now one recent post mentions all the video being gone. Maybe something new is going on.
     
    Last edited: Aug 28, 2018
  8. HerronScott

    HerronScott Well-Known Member

    6,078
    665
    Jan 1, 2002
    Staunton, VA
    Are you on Comcast? If so they've switched to MPEG4 for the cable channels, leaving only the broadcast channels as MPEG2. MPEG4 shows have to be downloaded in Transport Stream but even though TiVo released on update to allow HD's to record MPEG4, they did not update the HD to allow Transport Stream downloads.

    The only way to get MPEG4 shows off of an HD is to transfer them to a newer model TiVo (Premiere or higher) that will allow you to download them in Transport Stream mode.

    Scott
     
  9. HerronScott

    HerronScott Well-Known Member

    6,078
    665
    Jan 1, 2002
    Staunton, VA
    He mentioned that he has an HD which was never updated to allow Transport Stream downloads.

    Scott
     
  10. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO

    Yes, I'm on Comcast/Xfinity... I tried pulling the show to my Premier but I'm getting an error doing that also. I rebooted the TivoHD since I've been working on this most of the day but I will post the exact error if it still does it.

    Thanks for the education, I guess most of this came with 11n???

    PS to add... I do see the TS setting in pyTivo for my Premier, but not my HD so this makes sense... I used to have an ftp program running on the HD since it's hacked but it's been so long I don't know where to begin to see if it's still running and how I used to bet to my shows... I know TivoWebPlus quit working a while back and I never could get it started again...
     
  11. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO
    The error when trying to pull the show to my Premier says...

    Then on the next screen it says..

    The show is there, the Tivo is on and connected to the network because I can browse she shows from my Premier but for some reason the shows won't transfer over.

    Edited to add: The show is Pacific War in Color so I just set a season pass on the Premier and moved it to the top so will have to wait until it shows again so I can get the 7 or 8 shows in the series...
     
  12. Wil

    Wil Senile Member

    4,333
    91
    Sep 26, 2002
    I use it occasionally and it works fine. Maybe your var directory got system-cleaned-out?

    I had forgotten that you have to transfer the mpeg4s to a more recent Tivo to get the transport stream to work so you'll have to persevere on getting past that error message.

    With all of the problems being reported on that other thread I mentioned, I too am wondering about going back to that old "ftp" system. I've tested it out and it still works fine.
     
  13. Soapm

    Soapm Active Member

    1,643
    5
    May 9, 2007
    Aurora, CO
    I lost my instructions on how my Tivo was hacked, I used a script called Sapper that loaded all that stuff for me so I never knew how really to make it work. I imagine I could download and start it fresh but even then I'd need detailed instructions because I can hardly use windows, CLI stuff be over my head.

    The other thread did have a similar problem but it started with a Romio. I think the HD problem is unique to it in that it encodes in mp4 but you can't transfer it. In my case, not even to another Tivo.
     

Share This Page