Do the cable cards ever actually work without any issues?

Discussion in 'TiVo Series3 HDTV DVRs' started by NCTRNL, Sep 28, 2007.

  1. NCTRNL

    NCTRNL New Member

    20
    0
    Sep 24, 2007
    Kansas City

    Advertisements

    I'm new to the forum but have been a Tivo user for quite a while. I hate the TWC Navigator as much as anyone so that's why I bought a S3. Cable guy is coming this afternoon to do the cable cards but does anyone ever have a seamless transition with this?

    Has anyone bought a S3 or THD and had the cable guy install the cable cards, activate them, and then have no problems after that? It seems this process would have to work better than reported here to have been successful at all.
     
  2. jakerock

    jakerock Hey ho howdy!

    4,583
    865
    Dec 9, 2002
    Lee, NH
    I had an install and had no problems. I have a TiVo HD with Comcast service in New England.
     
  3. mrdazzo7

    mrdazzo7 Well-Known Member

    5,611
    236
    Jan 8, 2006
    I was wondering the exact same thing! I'm sure we only read so much about the negative stuff because that's usually what people discuss, but there seems to be an overwhelming majority of people who have problems vs. those who have success. I'm getting mine installed tomorrow, very anxious to see how it goes.

    Post back when you're install is done, let us know how it went.
     
  4. dianebrat

    dianebrat wait.. I did what? TCF Club

    13,222
    2,320
    Jul 6, 2002
    boston'ish
    yes,

    Malden, MA, got my 2 cards installed last September, never had a single issue, in install or operation.

    Diane
     
  5. DancnDude

    DancnDude Thrice as nice TCF Club

    10,396
    1,213
    Feb 7, 2001
    Madison, WI

    Advertisements

    Mine went in just fine. I was also worried with all the nightmare talk here.
     
  6. PSUMattDE

    PSUMattDE New Member

    26
    0
    Aug 16, 2007
    Wilmington, DE
    My FIOS CC installation went off w/o a hitch as well.

    Luckily, the pixellation fix firmware was already out and I had it installed.

    From start to finish - took about 30 minutes.
     
  7. NCTRNL

    NCTRNL New Member

    20
    0
    Sep 24, 2007
    Kansas City
    Wow...I feel much better. I know that message boards are generally just the things that go wrong...but it's good to hear that there are positive reports out there. I figured there had to be some positive because Tivo would have gone under by now...
     
  8. montivette

    montivette Member

    147
    1
    Sep 7, 2006
    Minnesota
    Forums are generally filled with posts of people who have problems. Reading a forum on any product prior to purchase will make you think twice about buying the product as it seems everyone has problems with it. The other popular posts are those which state the shortcomings of the product or inadequacies of design.

    The most boring threads and the ones with the fewest comments are those which state the person loves the product and have had no issues with it. There will be about 10,000 threads stating problems or dissatisfaction to every 1 thread about how wonderful the product is.

    I have never had any serious functionality issues with the Series 3 and the cable card install was effortless, done in a short period of time and in one visit.
     
  9. Reinman

    Reinman New and improved!

    74
    0
    Nov 28, 2001
    My install was flawless using two Motorola cablecards in about 45 minutes. I left the system alone for a couple of weeks then successfully performed a hard drive upgrade to 1TB. Shortly thereafter I received the Fall update. I've only witnessed pixelization a couple of times and it vanished in the blink of an eye.

    I'm very happy with my TiVo HD and FWIW, my cable service is provided by Charter.
     
  10. mathewbeall

    mathewbeall New Member

    53
    0
    Mar 4, 2002
    I have 6 cablecards (3 Tivo HD's) and it all works good.... never had a problem.

    Matt
     
  11. acvthree

    acvthree Active Member

    2,484
    2
    Jan 17, 2004
    Carrollton,...
    My Fios/cablecard/Tivo install went faster and smoother than just about any instal I've ever had.

    Al
     
  12. jpreston

    jpreston New Member

    1
    0
    Aug 11, 2007
    I first purchased my S3 when I was a Comcast customer. The "installer" tried 5 or 6 cards and none worked. The installer didn't have a clue and neither did "technical assistance." I was not a big fan of Comcast anyway, so I switched to Verizon Fios. The cards worked perfectly from the get-go. I continue to be impressed with Verizon. Their technical assistance folks actually know what they are talking about.
     
  13. bananaman

    bananaman Member

    116
    0
    Jul 18, 2005
    I've used 5 CableCards from two different providers (Comcast and RCN), no install or use issues :).
     
  14. mrdazzo7

    mrdazzo7 Well-Known Member

    5,611
    236
    Jan 8, 2006
    This thread is extremely encouraging, lol. Sounds like a lot of people are having good success with Verizon. They came to my area but my landlord didn't want to switch, probably because they don't understand the differences/didn't want to deal with the hassle.

    Anyone have this kind of success with Cablevision? I know there's a CV-specific thread, but it seems to be focused on the (many) problems people have faced. Would feel better if there were some success stories, haha
     
  15. Sapphire

    Sapphire Xtal substance

    44,092
    804
    Sep 9, 2002
    USA
    I have two CableCARDs from SE Cable in Northwest NJ.

    They work fine. No issues setting them up either.
     
  16. ThePennyDropped

    ThePennyDropped Now I get it.

    4,391
    648
    Jul 5, 2006
    Northeast US
    Another quick, smooth and easy install from Comcast in New England here, too, done a few months ago.

    --Debbie
     
  17. Kablemodem

    Kablemodem Get the ketchup.

    19,354
    42
    May 26, 2001
    Sherman...
    Most cable card problems are caused by incompetent installers who refuse to follow the directions that come with the TiVo.
     
  18. Revolutionary

    Revolutionary Too sleepy for TV...

    575
    0
    Dec 1, 2004
    Virginia
    My install was smooth and service with Cox Fairfax has been just fine. The installer had done "many, many" S3s before, which gave me only a little comfort when he proceeded to disregard the install procedure that Tivo provides in the box!

    But it worked out and both cards were activated with no issues. He was there maybe 15 minutes total. :)
     
  19. pkscout

    pkscout Well-Known Member

    4,010
    44
    Jan 10, 2003
    Honolulu, HI
    When I was in Las Vegas Cox installed 2 cards in my TiVo S3 and I didn't have any problems. Well, until a couple of months later when the guys at the head end changed the copy flags on every channel to copy never, but I don't count that as an "install" problem.
     
  20. WizarDru

    WizarDru New Member

    147
    0
    Jan 18, 2005
    Malvern, PA
    Smooth sailing with FIOS in suburban Philadelphia with 2 TiVo HDs and a total of 4 cable cards.
     

Share This Page

spam firewall

Advertisements