DIY 10TB Roamio

Discussion in 'TiVo Upgrade Center' started by jmbach, Nov 17, 2018.

Tags:
  1. jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    Sure you were not trying to play a streaming version of the video or one found on another TiVo in your house? I am not sure what connecting error would be other than a network error.

    If it is a recorded video, then the issue probably happened at the copy. Try the copy again and try KS 58 on boot up followed by several connections to the TiVo servers and then play several recorded programs.


    Sent from my iPad using Tapatalk
     
  2. dave_d

    dave_d Member

    62
    0
    Oct 16, 2003
    It was actually a couple epsiodes of the same program that the particular TiVo I'm upgrading recorded. (one worked then the next ones didn't.) Anyway sure, I can try the copy again and then try KS 58 on the first boot up before I do anything else. Oh for anybody that's doing 3tb to 10tb like me it took 18 hours to do the mfscopy but the adds were quick, not even a minute. Also I can try what you're suggesting with the way the drive is now and see what happens. I'll try to keep better notes on exactly what I'm seeing though. Thanks again.
     
  3. angra

    angra Old Fogey

    192
    5
    Apr 12, 2002
    I am definitely interested, and will follow up with PM. Unfortunately, my physical skills are pretty bad now, so I won't be able to do anything that involves soldering, etc. or any fine detail work.
     
  4. digpower

    digpower New Member

    21
    0
    Feb 12, 2019
    I successfully upgraded my Roamio Pro to an 8 TB hard drive about a year ago. Overall things seem to work well with the exception of the mobile app. The issue I have is that while using the mobile app (iOS or Android) the Roamio will reboot itself. Needless to say, it has made the app unusable as it will constantly reboot the TiVo box. Has anyone else experienced this issue after upgrading to an 8 TB drive?
     
  5. Scott9mm

    Scott9mm Member

    101
    21
    Apr 4, 2015
    Rural NC
    Just successfully upgraded my Roamio Plus to 10T (from 3T). Upgrade worked exactly as described in jmbach's post #2. At first online update failed to completely load but kickstart 58 fixed it like jmbach suggested. MANY thanks.
     
    Mikeguy likes this.
  6. May 2, 2020 #306 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    Hey guys! I just copied my 1TB to an 8TB with the instructions at the beginning of the thread. The copy went great, tried it in my Roamio Plus and booted just fine. All my recordings and settings came over. It shows 699 HD hours and I should be closer to 1200. So I tried the mfsadd -xcm 2040 /dev/sdY (Mine is c) and get an invalid argument reading volume header. Any ideas?
     
  7. May 2, 2020 #307 of 333
    jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    Post a mfsinfo -d output of the drive

    Sent from my SM-G988U using Tapatalk
     
  8. May 2, 2020 #308 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    I finally got it to run. Its having me do a guided setup. Waiting to see the results now. But here is the mfsinfo:
     

    Attached Files:

  9. May 3, 2020 #309 of 333
    jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    So at the point you ran mfsinfo and your screen shot, you added a partition pair but you did not run mfsaddfix to move the added partitions. If you put it in the Roamio at that time, it will reformat the drive.

    Sent from my SM-G988U using Tapatalk
     
  10. May 3, 2020 #310 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    I see that now. Thank you. I've restarted the copy. It has about an hour left. We'll see what happens this time doing it correctly!
     
  11. May 4, 2020 #311 of 333
    dave_d

    dave_d Member

    62
    0
    Oct 16, 2003

    Thanks for all the help. The advice about KS 58 was spot on. I didn't need to copy again, I just had to run KS 58 and now I can play all the old videos as well. I did that about a week ago and I've been trying it ever since and it's working like a champ now. So if anybody else does a copy with your tools and then gets an error when trying to play any old videos just run kickstart 58. Thanks a ton.
     
  12. May 8, 2020 #312 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    So I've been trying different way to get this 8TB to upgrade my Roamio(TCD848000). I've tried the procedure in the forum with no luck. My second to last attempt, I bought a cloning dock, which worked fine. It booted, connected to TiVo and when I tried to expand it said it was at its Max. But the drive showed as 1.3TB and not 8TB. My last attempt, I wiped the drive, got it to see the full 8TB and then when I plugged it in to the TiVo(as a new drive) it looked okW and connectedIconnected to Tivo. When I went to expand the size, the attached picture shows the error 'zone map checksum error'. I tried to run an mfsinfo and get the same error. Any ideas?
     

    Attached Files:

  13. May 8, 2020 #313 of 333
    jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    So are you trying to save the recordings on your initial Roamio drive?

    If you are not, run MFSR on the drive and then put it back in your Roamio.
    Sent from my SM-G988U using Tapatalk
     
  14. May 9, 2020 #314 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    Preferably yes, but I'm not apposed to creating the 8TB with out and transferring everything later. It seems, so far trying to set it up with my recordings, is not working. Do you have an image for the Roamio Plus(20.7.4b)? Or another solution to get the 8TB working with full capacity?
     
  15. May 9, 2020 #315 of 333
    jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    First let's copy the 1 TB to the 8 TB with the command mfscopy -am 2040 /dev/source /dev/target. Then put the 8 TB into the Roamio and let it boot. Make sure you have the correct recording space for 4 TB. Then reboot the drive and run a Kickstart 58 as it boots up. Once it is booted ,check to make sure it will download and load the data correctly from the TiVo servers. Once that is done, let us know here for the next step.

    If you run into issues, the more details you can give us about your set up and screenshots of the errors will help troubleshoot.

    Sent from my SM-G988U using Tapatalk
     
    Last edited: May 9, 2020
  16. May 9, 2020 #316 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    Thank you for this. I just got out of work and tried the mfscopy -am 2040 /dev/sdc /dev/add I'm getting a Copy source: input/output. Any tricks/ideas?
     

    Attached Files:

  17. May 9, 2020 #317 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    Also, both drives are connected via USB adapters. Not sure if that makes a difference.
     
  18. May 9, 2020 #318 of 333
    jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    If this is a dual dock, swap the drives. If it is two individual adapters, switch the adapters on the drive.

    Sent from my SM-G988U using Tapatalk
     
  19. May 9, 2020 #319 of 333
    JJC4545

    JJC4545 New Member

    18
    1
    Mar 1, 2019
    I have a Western Digital external drive bay, an IDE/SATA to USB adapter and a dual cloning dock. I've tried all three with the same Copy Source Input/output error. Before I tried this I used the cloning dock to do an offline copy and the copy went good. The TiVo saw it, but when I went to expand the volume with mfsadd -xcm 2040, it said it was at its max.
     
  20. May 9, 2020 #320 of 333
    jmbach

    jmbach der Neuerer

    2,959
    406
    Jan 1, 2009
    Post a screenshot of mfsinfo -d on the 1 TB drive.

    I would recommend to copy the 1 TB with your cloner to another 1 TB or larger drive. Boot that drive in the Roamio and run a Kickstart 58 on boot up. Then see if mfscopy can copy that drive to the 8TB.

    Sent from my SM-G988U using Tapatalk
     

Share This Page