Disappearing Hacks

Discussion in 'TiVo Underground' started by mike, Jan 21, 2006.

  1. mike

    mike Cohiba Man

    46
    0
    Mar 26, 2002
    WI (USA)

    Advertisements

    I’m trying to hack a Sony Series 2 with 300GB WD drive. I ran through steps 1 & 2 of the Jenkins hack procedure to gain Telnet access, but it didn’t work (I couldn’t access the TiVo thru Telnet). I popped the drive back into my PC and noticed that all the new files and /hack directory were missing.

    I thought initrd might be the culprit, so I ran ./kill_initrd info. That returned the error:

    Error – No TiVo drive detected.

    I re-ran all the Jenkins steps again and just for kicks, I re-booted with the Jenkins disk again to look for the files and the /hack directory. They were all gone again! And this time, the drive never even made it to the TiVo.

    What’s going on? :confused:

    Mike
     
  2. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    Right at the top of the page of the jenkins guide, it says for Series 1 tivos... hacking a Series 2 generally involves a different process... Check out gunnyman's unguide and the zipper thread
     
  3. mike

    mike Cohiba Man

    46
    0
    Mar 26, 2002
    WI (USA)
    From what I can read, the SVR-3000 is not listed fuw unguide and zipper. What should I use to Telnet?
     
  4. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    Didn't realize you were running a standalone. The hacking process for a standalone is ALMOST identical (but I'm not positive exactly what is different, as I don't own one).
    More info on hacking an SA can be found on DDB.
     
  5. mike

    mike Cohiba Man

    46
    0
    Mar 26, 2002
    WI (USA)

    Advertisements

    Thanks.

    I’m still really confused though - why did the hacks disappear after simply re-booting the PC?
     
  6. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    newer tivo s/w versions (v3+) checksum the files in the system. If any of them aren't recognized, they get deleted. This is probably what happened to your hack directory.
     
  7. mike

    mike Cohiba Man

    46
    0
    Mar 26, 2002
    WI (USA)
    Thanks BTUx9.

    I don’t quite understand how a checksum is initiated on the drive while it’s in my PC.

    TWP requires a new directory, but it'll be blown away before I even get to fire it up in the TiVo. So how do I load the necessary hacks w/o losing them immediately?
     
  8. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    re: the info that disappeared when you didn't even boot the drive in the tivo, I haven't got a clue... are you sure you put it where you think you did?

    re: twp, that's why the box needs to be hacked... it disables that "feature", so the tivo s/w doesn't checksum itself and doesn't blow away whatever hacks you've installed. For S2 tivos (not the newer "s2.5" w/ the nightlight) the most common hack is called killhdinitrd... you may want to look around for info on that.
     
  9. rowdan

    rowdan New Member

    21
    0
    Feb 26, 2005
    San Diego
    im trying to gain telnet access for my series 2 nightlight tivo

    can any one direct me to the correct how to page?
     
  10. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    at this point, the only publicly available hack for nightlights is a physical prom mod (not for the faint of heart)
     
  11. rowdan

    rowdan New Member

    21
    0
    Feb 26, 2005
    San Diego
    oooooo more soldering the unsolderable, to fix the unfixable..... :D

    ok but seriously..... so there is a hardware mod to fix the "nightlight" so i can install telnet, ftp, ect... ect...

    is there a reference name i can look for or a link you can send for information on it?

    or should i just be searching for "prom fix" "prom hack"
     

Share This Page

spam firewall

Advertisements