DirecTV HD DVR HR10-250 Upgrade Thread

Discussion in 'TiVo Upgrade Center' started by weaknees, Apr 22, 2004.

  1. HDVRFAN

    HDVRFAN New Member

    6
    0
    Sep 21, 2006
    Monmouth...

    Advertisements

    I tried running the mfsadd again with the new "-r 4" switch and it didn't fix the problem. I then did a restore to a blank 300gb drive and Tivo booted up fine. Tried restore to original drive which restored fine but got a message expanding the swap failed. Tried the mfsadd again with original 250 gb drive (A) and 300 gb (B) using all the command switches advised. The results said that I had increased my hours the appropiate amount but when when I put everything back in the tivo and booted up the system info screen still only shows the 30hours HD 300hours SD?!?

    I've been at this for several days and I'm close to giving up. Not to mention that the weakness bracket I bough includes this fan that makes the tivo hum and vibrate at a level that I don't think I can live with. A single 500gb drive upgrade is probably a smarter choice. The double drive setup has not gone as smoothly as advertised. Anyone...anyone...Buhler? :confused:

    Why is the mfsadd not working?
     
  2. dwynne

    dwynne New Member

    481
    0
    Mar 11, 2002
    I am confused as to what you did. I have used the twin breeze brackets w/o a problem in a couple of HD Tivos as well.

    What I did in both cases:

    1) Pulled the OEM drive
    2) Set my PC up with the OEM drive and a pair of new drives (2x250gb in one case and 2x400 in the other)
    3) I followed the how-to instructions on going from a single new drive to dual drives in one step
    4) I went and watched TV while the copy did its thing
    5) I put the new drives in the HD Tivo and it booted up and worked
    6) I stored the OEM drive away in case I need it for something down the road.

    The how-to can be found many places on the web and in this thread. I usually use the ones here .

    Going through the selections for an HDTivo replacing one drive with two new ones and saving all the settings and recordings the command line is:

    mfsbackup -Tao - /dev/hdX | mfsrestore -s 127 -r 4 -xzpi - /dev/hdZ /dev/hdZZ

    You have to look in the instructions to figure out which drive is which depending on how you connect them - but hdX is the OEM drive and hdZ is the master new drive and hdZZ is the slave new drive.

    Dennis
     
  3. HDVRFAN

    HDVRFAN New Member

    6
    0
    Sep 21, 2006
    Monmouth...
    Thanks for the response Dennis.

    I didn't even care about the recordings so I did the basic image only backup. That worked fine.

    I just wanted to add a 300gb B drive ran the mfsadd command it seemed to work fine but upon boot-up got GSOD reboot loop.

    Then I read the threads and realized Hinsdale instructions which I used left out the -r 4 swith which is needed for larger drives. Put the drives back into the PC tried to re-run the mfsadd with -r 4, got a succesful message upgrade time.

    Put drives back into tivo. GSOD!!!

    I read somewhere GSOD could be bad drive or power supply wanted to eliminate that possibilitly. Took 300gb orginally planned as B drive and ran restore of image onto it as a solo A drive. Tivo booted fine.

    Decided to do a restore of image onto original 250 gb A drive and then try the mfsadd with 300gb B drive. All messages succesful. Put drives back into Tivo everything booted fine. Went to system info screen only reporting 30 hrs HD 300 SD?!? Gave up for the night at 1:00 am.

    Just decided today to go to a larger (750 gb) single drive since restore is the only thing that seems to work reliably. Two drives is too much hassle. Also weakness bracket fan is too noisy and vibrating. I have to get rid of it. Not to mention the pins in the power splitter in the weakness kit are loose and easily push out when inserting tivo factory power clip.

    FYI if anyone reads this thread today 9/22 CompUSA has a deal that expires today on the new Seagate 750gb drive. $329 plus tax (order online, for in store pick-up only) minus $50 rebate. My total after rebate will be about $300. Most other offers on the web are around $450.

    Also if anyone wants a weakness backet kit with fan and accesories you can have mine for half of whatever they want for it. Send me a message and it yours.
     
  4. Oct 1, 2006 #1884 of 1979
    wmldwilly

    wmldwilly New Member

    33
    0
    Mar 5, 2006
    I feel like sharing my experience with this process also. I embarked upon the task of copying my existing HR10-250 drive to a new 500gb drive. Fry's had the Deskstar 500g / 7200 / 16mb buffer on serious sale (129.00 after rebates) so I dove in. I've been gearing up to do this for a few weeks now, reading up and searching, assembling how-tos and of course the 75939375 posts that give corrections to the howtos :).

    I have a post out there that details my first problem, but at the moment it seems to have gone away and the tivo is booting fine with my expanded capacity. Whew! Anyway, I did the following:


    1) prepare bootable cd.
    2) pull drive, add to pc in ide positions reccomened.
    3) create small backup on fat32 disk
    4) restore small backup to new 500g drive
    5) forget to run/not know I needed to do the tpip thing (like 98% of upgraders it seems...)
    6) put the drive back in the HR10-250 w/ jumpers back to master,
    7) observe reboot loop.
    8) put drive back in PC, leaving it set for master after removing fat32 disk used earlier
    9) run tpip.

    Here's where I'm totally crapped out:

    I do:
    #tpip -1 -s /dev/hda

    and it replies:
    #initializing swap partition (version 0) @ <very long number>, Size = 127 MiB

    Put it back in the tivo, still boot-loops.

    I'm a little confused at why the -1 option still yields the (version 0) message. Looking closer at tpip's useage it mentions --mkswap and --swaptype={0,1}. Upon trying:

    #tpip --mkswap --swaptype=1 /dev/hda

    I get:
    the same message as before, but with (Version 1) in there.

    Put it back in the tivo, and still boot-looping.

    I have basic linux experience (did a LOT of installing/tinkering with LinuxPPC on G3s way back when...) but admit I was a bit stumped at how to get a thorough look at what partitions were actually on the device, and what they were used for. I say that because it sort of acted like there wasn't any swap partition at all. The basic 'mfsinfo' command turned up a few partitions, none of which clearly detailed which was which. At least I didn't see a partition that was around the 127mb size that it seems the mfsrestore should be creating....or NOT creating, as many long convoluted threads talk about. :p

    Since there's LOTS of talk for years now about how mfstools 2.0 is brain damaged with respect to swap partitions, I did my best with tpip with my limited knowledge (read: just enough to be dangerous) but never got an actual "restored from small backup with no expansion and no shows" image that did anything other than boot-loop. I began wondering if the dd copy route was the right way to go but decided against it because of the numerous reccomendations to stick to mfstools and expand the swap partition.

    Finally, I blew all that off and decided to proceed to the full copy/expansion from the old 250g drive to the new 500g drive. I was doing it under the impression that I would end up in the same place - an error free restore with a wonked swap partition that would boot-loop the tivo. The command I issued (from the apparently outdated hindsale guide)was:

    # mfsbackup -Tao - dev/hdc | mfsrestore -r 4 -s 250 -xzpi - /dev/hda

    ...and off it went. Whirring away copying/restoring for about 6 hours (we had quite a few HD shows and an HD movie or two stored on the drive).

    When it was all over (the next morning) I was again following up on various "what's wrong with the swap partition" threads and noticed a bit of talk about how "-r 4" should actually be "-r4" and I figured I was hosed again. There it was right there in the command line from last nite - I had used -r <space> 4. At this point I am still mystified about the swap partition thing, but decided to try it in the tivo anyway. I fully expected it to boot-loop or do some other nasty unpleasant thing, but LO AND BEHOLD...it booted, aquired info from the sat, and came to life. Shows intact, new recording capacity listed, and seemingly back to normal. For what it's worth, the hindsale guide of course doesn't mention the -r switch at all, and the Weaknees "interactive" guide spells it out with the space, or "-r 4".

    So here I am - a new fat HD tivo drive, and I'm moving on to the zipper. :)

    I do have a comment or two though:

    I have searched my ever lovin' arse off on this issue. One thing I notice is that there seems to be a consensus that the Hindsale guide is out of date, MFStools 2.0 is slightly broken, tpip for some reason has multiple commands that may or may not do the same thing but do or don't work for various people (i.e. -s versus -mkswap, and using a dash versus using a double dash...). This info isn't very new - this has all been going on for years if I'm to judge by the age of the posts and threads my search after search after search turns up, some going back to 2002. Is there SOMEWHERE, a new improved updated for 2006 guide, along with new improved bug-fixed versions of mfsrestore and tpip and all that? It seems like the apparently uuber frustrating to some basic questions like "I did what the guide said but it didn't work..." would be really well served by being pointed to a thoroughly modern upgrade-and-expand-your-drive guide. Just a thought. If there is one, please point ME at it because I never found one in a search and I've read hundreds of posts on these issues.

    On to the zipper!

    WM
     
  5. Oct 2, 2006 #1885 of 1979
    wmldwilly

    wmldwilly New Member

    33
    0
    Mar 5, 2006

    Advertisements

    Following up on my own post...and asking a question:

    I've successfully zippered the drive I talked about above. I have 63 HD hours or 470 SD hours now, and all my shows survived, I can telnet in, I get lots of new stuff in the system information screen, and it all seems to be working fine. However, I'm getting nervous about the swap partition thing. As detailed in my other posts I had the same roadbumps many before me have had with the whole larger swap space/use tpip thing, but I have to say that on my final attempt I did nothing more than follow the "copy and expand" instructions in the Hindsale guide (with the addition of the -r 4 switch), and it did exactly that - it copied the drive, expanded the partitions so I have the full new recording capacity of the 500gb drive, and it boots and plays shows and is generally happy. Note *I did nothing special with tpip or any other tool* after the process.

    So...this leaves me asking: What if I dont' have a swap partition at all??? May I please have a quick specific instruction from someone to check to see if I do? Running "bootpage -p /dev/hda" on the tivo yields: "root=/dev/hda4 dsscon=true console=2,115200 upgradesoftware=false.

    Seems all fine, but it doesn't tell me about partitions. Would someone please take pity on my brain cramp and hit me with what command to run and what to look for to verify I have a real, actual swap partition?

    Thank you in advance,

    WM
     
  6. Oct 3, 2006 #1886 of 1979
    slocko

    slocko New Member

    690
    0
    Mar 4, 2004
    Old Bridge, NJ
    soon you will find that 63 hours of HD is not enough :)

    I thought I was set at 80 hours of HD and yet it's still not enough!!!!!
     
  7. Oct 3, 2006 #1887 of 1979
    Freightdog

    Freightdog New Member

    36
    0
    Aug 24, 2005
    Atlanta
    wmldwilly, my understanding is:

    -r4 is for a large cluster size, needed on larger drives.
    Since you had a space between the r and the 4, you would not have the proper cluster size. Could cause a problem later?

    -s250 won't properly prepare the swap partition. Anything larger than -s127 will require the tpip thing.

    One thing I know from reading the threads is that the swap is needed for tivo to repair any file system issues it encounters. Some folks say 127 is plenty, other say larger.

    I'm not up on linux (old VMS guy), so can't help on other commands yet.
     
  8. Oct 7, 2006 #1888 of 1979
    wmldwilly

    wmldwilly New Member

    33
    0
    Mar 5, 2006
    Thanks for the info. Unfortunately this leaves me wondering if my drive has a) the wrong cluster size, and b) a swap partition of unknown size with unknown useability.

    May I please appeal to the gods of tivo-ana around here for a suggestion or two?

    #1) I'm fairly convinced there's a swap partition there that's not properly formatted, even though tpip sure didn't cure the problem on the first "small install" test that hindsale sends you thru. Should I pull the drive and do this all over again?

    #2) Aside from the cluster size which I'd imagine can only be fixed when the drive is formatted/prepped for use in the early part of the process, is there any way to verify or fix the partition thing while the drive is IN the tivo from the bash command line?

    All suggestions are much appreciated.

    WM
     
  9. Oct 7, 2006 #1889 of 1979
    wmldwilly

    wmldwilly New Member

    33
    0
    Mar 5, 2006
    Aha! there it is again - "-r <space> 4" and not "-r4" The confusion over this is adding to my nervousness that I've got a working tivo drive that's a ticking time bomb waiting to fail because of a) too small a cluster size and b) a swap partition that's a friggin' mystery after the vagueries of tpip.

    Grrrr.
     
  10. Oct 7, 2006 #1890 of 1979
    wmldwilly

    wmldwilly New Member

    33
    0
    Mar 5, 2006
    Okay, cat /var/log/kernel | grep swap gives me:

    Oct 7 03:53:51 (none) kernel: Starting kswapd
    Oct 7 03:53:51 (none) kernel: Activating swap partitions
    Oct 7 03:53:51 (none) kernel: Unable to find swap-space signature
    Oct 7 03:53:51 (none) kernel: swapon: /dev/hda8: Invalid argument

    So, I have a swap problem. Any suggestions that can be done from the command line, or do I have to pull the drive again and try tpip?

    The big question about trying tpip is that the drive is already in service after zippering and is working well. But if it ever needs to recover...i'm hozed.

    Help! :eek:
     
  11. Oct 8, 2006 #1891 of 1979
    wmldwilly

    wmldwilly New Member

    33
    0
    Mar 5, 2006
    I feel like I'm talking to myself. Well, I kinda am, aren't I? :)

    I searched. Oh did I search. What I found was instructions to try this simple bit of commands:

    mkswap /dev/hda8
    swapon -a

    And WooT!!!! Now in the kernel boot log I get:

    Jan 2 00:00:16 (none) kernel: Activating swap partitions
    Jan 2 00:00:16 (none) kernel: Adding Swap: 255992k swap-space (priority -1)

    Whew! Somebody who knows more than most of us would please comment, I'd feel better and resist the urge to go to Fry's and buy *another* 500gb drive and do this all over again (except for the cluster size problem).

    Also, tell me what this means: In my tribulations of bouncing the stock drive with the shows to the new drive, I came up against the MFS-tools 2.0 bugs with respect to swap partitions. Lots of the documentation says that if you try for a swap space larger than 127 you'll get nothing. In true "open source style" nobody really elaborates on what "nothing" means (open source rule #1: if you don't already know, I can't explain it to you...) - No hda8 at all? an hda8 of the size you requested but with no format? It seems to me that you get a swap partition of the size you requested, but no format so it can't be brought up as swap at boot. Otherwise I wouldn't have been able to simply give it a the right header for swap (mkswap) at the command line while the tivo was already running.

    I'm continuing to talk to myself to enlighten others who might feel as lost as I did, but took little comfort in the wide array of partial explanations out there - most of them dated almost 2 years ago.

    </rant>

    wm

    two side notes:

    1) I only see "Starting kswapd" after a full power cycle. does it stay running across soft reboots?

    2) the kernel log entries are dated "Jan 2 00:00:xx" for the first bit of booting. Then suddenly it knows what time it is again. :)
     
  12. ethan

    ethan Lurker

    41
    0
    May 9, 2002
    i'm planning on upgrading my HR10-250 this weekend with a single, larger A drive. it's been 4 or 5 years since my last TiVo upgrade, so i thought i'd take the "easy" route and use the weaKnees instructions.

    i had planned to use the following command, as directed by the guide:
    Code:
    mfsbackup -Tao - /dev/hdX | mfsrestore -s 127 -r 4 -xzpi - /dev/hdZ
    however, previous posts here have mentioned there should be no space between the "-r" and the "4". should i use the following instead?
    Code:
    mfsbackup -Tao - /dev/hdX | mfsrestore -s 127 -r4 -xzpi - /dev/hdZ
     
  13. smu1997

    smu1997 New Member

    22
    0
    Oct 22, 2003
    I tried using the download Boot CD image of MFSTool 2.0 here with WeaKnees Large Kernel Support:. I was unable to boot the CD and kept getting an "Trying to mount the CD-ROM, try 1". I read that this has to do with some kind of IDE controller setting my drives to /dev/hde & /dev/hdf instead of /dev/hda & /dev/hdb.
    So I attempted to use the "LBA48 Boot CD iso from PTVupgrade" to booted my PC from the CD. I issued the command mfsadd -r 4 -x /dev/hde /dev/hdf. It did something for a couple of minutes and then a moment later it showed an approximation of the amount of recording hours resulting from the upgrade.
    I inserted the drives back into my Tivo but my hours have not changed. What am I doing wrong?

    Thanks
     
  14. dennya

    dennya Member

    82
    0
    Mar 28, 2003
    WA
    Okay, I have a Weaknees bracket and a 400GB drive to add as a second drive. I was all set to do this, but now the discussions here have me worried. Lots of folks with problems, and they're unanswered.

    So the quick question is:
    Do the current Weaknees instructions for adding a second drive to the HR10-250 work properly? No changes needed to the command lines, etc? Would love to hear from someone who did this successfully.

    And is it -r 4 or -r4 on mfstools? I'm seeing both here.
     
  15. boiler_man

    boiler_man New Member

    2
    0
    Jan 27, 2006
    I just upgraded mine yesterday and used the interactive gude exactly as it is written and it worked without a problem. I wanted to keep my recordings and it took 7 hrs to copy. I went fromt the oringinal 250 gb to a 320gb and a 120 gb. Everything seems fine and all my recordings are there. It did seem like it took a little longer to boot up than it has before.

    Good Luck
     
  16. dwynne

    dwynne New Member

    481
    0
    Mar 11, 2002
    I used the interactive instructions when I did my two upgrades and both are working fine.

    I would STRONGLY recommend purchasing a 2nd drive of some size and replacing the OEM 250gb with a pair of drives. If something goes wrong, being able to fix it by re-installing the OEM drive is worth it. And you can use it to re-do the upgrade if you need to. A 250gb drive is cheap these days, or get a 2nd 400gb drive for a lot of space.

    Dennis
     
  17. btwyx

    btwyx Substantive Member

    11,343
    6
    Jan 16, 2003
    Mountain...
    I totally agree. You can put the drive back and see if any problems go away, then you know your upgrade has a problem (or not). Also when one of my drives gave up earlier this year, I could swap in the old drive and be up and running again inside of a day. Getting the drives fixed took a few days, and I could be watching some really important stuff in the meantime. (Like several games in the World Cup.)
     
  18. Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    Well, I finally was able to stop my old man's and upgrade his HR10-250. I still have telnet access, so it looks like his connection is OK (he's using an FA120). However, the 30-second skip no longer works by default. I entered in the command to enable it, but I KNOW that when the unit reboots every Sunday and Wednesday night, he'll be calling me the next day screaming about the 30-second skip not working. So, to avoid his blaming ME for his troubles, I tried to look for a way to enable it permanently so that when the unit reboots, it'll always be activate.

    I couldn't find the answer to this. Can someone point me in the right direction?

    Edited to add: Thanks to you-know-who. All's well that ends well.
     
  19. dennya

    dennya Member

    82
    0
    Mar 28, 2003
    WA
    Thanks, Boiler_man. That makes me feel more confident.

    I realized I have a 300GB drive I pulled from my main system when I upgraded (had to swap to a SATA drive), so I'll copy the 250 to that and keep the original as a backup. Much safer.

    Now I just have to figure out how to manage the instructions when my PC has only one IDE connector, which means I can't connect both drives and the CD-ROM simultaneously. Wonder if the boot disc will work with my old Maxtor IDE card.
     
  20. kimbray

    kimbray New Member

    5
    0
    Nov 28, 2004
    All, Here is my situation. I have a 10-250 that has a 300GB second drive. This drive has CRASHED and is making a lot of noise. I removed power from it and now I want to be able to test if it boots up correctly with just the original drive in the unit. Will I be able to power up the unit and get it going just by removing power to the second hard drive? Second question, I had the connection on the unit connected to my TV HDMI but my test TV to see if the 10-250 works after making changes is a composite connection. I cannot get video to show on the screen.. Suggestions? THANKS!
     

Share This Page

spam firewall

Advertisements