daily call needs network and phone

Discussion in 'TiVo Series 1 - UK' started by dchsimpson, Apr 26, 2011.

  1. dchsimpson

    dchsimpson New Member

    16
    0
    Jan 23, 2004
    Stafford
    My dialy call via dial up has started to fail. I have had a turbonet card installed for several years but have always used dial-up for the daily call as I do not have a permanent internet connection available.


    I can only succesfully make the daily call if I have both the phone line connected and a live internet connection. The daily call option is set to dial up (see below).

    If I switch off the local net work the daily call fails with number unavaiable after being stuck in connect for several minutes. If I remove the phone line it fails with failed to connect.

    Re-setting the call option to dial up (which it was already set at) saving and re booting the box does not fix the problem.

    Thanks for any help.

    bash-2.02# cat /etc/rc.d/rc.net
    #
    #!/bin/sh
    #

    if /sbin/insmod -f /lib/modules/turbonet.o devicename=eth1 macaddr=00:0B:AD:C6:0
    2:BD timing=3 ; then
    /sbin/ifconfig eth1 192.168.1.200 netmask 255.255.255.0 up
    /sbin/route.tivo add default gw 192.168.1.1 netmask 0.0.0.0
    fi
    bash-2.02#
    bash-2.02# ifconfig -n
    eth1 Link encap:Ethernet HWaddr 00:0B:AD:C6:02:BD
    inet addr:192.168.1.200 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:705 errors:0 dropped:0 overruns:0 frame:0
    TX packets:599 errors:0 dropped:0 overruns:0 carrier:0 coll:0
    Interrupt:29

    bash-2.02#
    bash-2.02# nic_config_tivo

    TiVo TurboNet/AirNet/CacheCard on Tivo Configure - 20041201

    Copyright 2002-2004 Silicondust Engineering Ltd. All rights reserved.

    Detecting TiVo hard drive...

    Detecting TiVo partitions...
    Active kernel partition = /dev/hda6.
    Inactive kernel partition = /dev/hda3.
    Active root partition = /dev/hda7.
    Inactive root partition = /dev/hda4.
    Var partition = /dev/hda9.

    Determining software version...
    Thomson UK Stand Alone TiVo running 2.5.5-01-1-023

    Remounting root partition...
    Root successfully remounted as writable.

    Checking installation type...
    Configuring TurboNet installation.

    Checking script...
    Complete.

    Current/New Configuration:
    timing setting = optimal
    mac address = 00:0B:AD:C6:02:BD
    ip address = 192.168.1.200
    ip subnet mask = 255.255.255.0
    ip gateway = 192.168.1.1
    debug level = off
    daily call = dialup

    Options
    1: Change timing setting
    2: Change MAC address
    3: Change IP address/gateway
    4: Change debug logging option
    5: Change daily call option
    6: Dump log file
    0: Apply and exit
    !: Exit without saving

    [0..6]?
     
  2. mikerr

    mikerr TiVoCentral.co.uk

    2,599
    0
    Jun 2, 2005
    Lancashire, UK
    That file is wrong, nic_config_tivo should set it up as:

    Dialup daily call: ethernet set to eth1 and no route.tivo line
    Network daily call: ethernet set to eth0 and the route.tivo line

    Yours is a mixture of both, so it needs both to dial ;)

    Re-run nic_config_tivo until it fixes it as above (recommended)
    or edit /etc/rc.d//rc/net directly - but be careful if going that route - its safer to use nic_config_tivo.
     
  3. dchsimpson

    dchsimpson New Member

    16
    0
    Jan 23, 2004
    Stafford
    Thank you. I set the daily call to Dialup and that changed the ehernet setting back to eth1. I then set the ip gateway to 0.0.0.0. I am not sure if that is what you meant but the call went through OK just using the phone line! I still have a route.tivo line, as follows

    bash-2.02# cat /etc/rc.d/rc.net
    #
    #!/bin/sh
    #

    if /sbin/insmod -f /lib/modules/turbonet.o devicename=eth1 macaddr=00:0B:AD:C6:0
    2:BD timing=3 ; then
    /sbin/ifconfig eth1 192.168.1.200 netmask 255.255.255.0 up
    /sbin/route.tivo add default gw 0.0.0.0 netmask 0.0.0.0
    fi
    bash-2.02#
    bash-2.02#
     
  4. spitfires

    spitfires wassock

    724
    0
    Dec 19, 2006
    South Coast, UK
    Providing both the 'insmod' and the 'ifconfig' lines say "eth1" (rather than "eth0") - which yours do - then your TiVo will use dial-up (and will ignore any 'route.tivo' line).

    So you're ok now, yes?

    .
     
  5. dchsimpson

    dchsimpson New Member

    16
    0
    Jan 23, 2004
    Stafford
    Yes thanks, the dialup is working fine now.

    However I had to edit rc.net and remove the line
    /sbin/route.tivo add default gw 192.168.1.1 netmask 0.0.0.0
    before it would use dial up without a net work connection as suggested by Mikerr above. He also suggested using nic_config_tivo as a safer method to remove the line than editing but I could not find out a way to get nic_config_tivo to remove the line. Certainly changing back to dialup from network does not remove the line
     

Share This Page