Credit card issue on my tivo account

Discussion in 'TiVo Coffee House - TiVo Discussion' started by Evilmumrah, May 5, 2019.

  1. Evilmumrah

    Evilmumrah Member

    86
    0
    Dec 15, 2002

    Advertisements

    Just curious about this. Has this happened to anyone else? My credit card number was stolen in January of this year so we were issued new cards. One of the first things I did was change the card info on my Tivo account. Well, long story short, I got an email today that my automatic payment was late. When I went to see what happened I found that my number had reverted to the stolen and now closed card. They fixed it, of course, but they couldn't explain how that happened.
     
  2. JACKASTOR

    JACKASTOR Active Member

    777
    135
    May 26, 2011
    ONTARIO,...
    Probably a glitch in the system. And it didn't save correctly happens from time to time.
     
  3. achalupa

    achalupa Member

    88
    3
    Oct 27, 2008
    How many TiVo’s do you have that you have to make payments for? I think the last time I went through this the payment method is set on each device not at the account level. You had to update all of the devices using the payment method.


    Sent from my iPhone using Tapatalk
     
  4. ajwees41

    ajwees41 Well-Known Member

    3,083
    164
    May 7, 2006
    Omaha,NE
    correct each tivo device on a subscription listed separately


     
  5. Evilmumrah

    Evilmumrah Member

    86
    0
    Dec 15, 2002

    Advertisements

    I have one. The other is on Lifetime. And I did try to change the credit card on both units even though I didn't have to. The strange part was that I had changed the card back in January and it stuck until time for the latest payment, which tried to go to the old card. I got it fixed with help from customer support but just wondered if this had happened to anyone else.
     
  6. jcondon

    jcondon Well-Known Member

    33,949
    1,997
    Jul 9, 2003
    Mikeguy likes this.
  7. sharkster

    sharkster Well-Known Member TCF Club

    14,043
    5,014
    Jul 3, 2004
    NV
    I haven't had cc info stolen (lately), but I did have a situation in the last several months where I got an email from Tivo that the credit card info on one of my Tivos was not good. I went there and looked at the cc info on my account and it was perfectly fine. I just re-entered all the exact same info and it's been fine since.

    I think I agree with a post up-thread that it could just be a glitch. That's what I figured mine was.
     
  8. Evilmumrah

    Evilmumrah Member

    86
    0
    Dec 15, 2002
    As long as it got fixed ...
     
  9. Crystaliyah27

    Crystaliyah27 New Member

    6
    1
    Nov 29, 2010
    I had the same problem back in February. I got an email that there was a problem with my card (which it wasn’t) and that I was late. I entered a different CC. Exactly one week later I received the same exact email. Highly annoyed, I changed to a different credit card. Nothing was wrong with any of my cards. I paid twice for the month of February and again in March. In the month of March my account was randomly deactivated and my TiVo box was frozen. CS could not explain why my account was deactivated despite clearly seeing my payment history. I was offered 3 free months for being I inconvenienced but those free months are not reflective on my account per the chat associate so I have to call CS AGAIN!!
     

Share This Page

spam firewall

Advertisements