Comcast CC Activation Troubles: What I've learned...

Discussion in 'TiVo Series3 HDTV DVRs' started by SLCMike, Sep 18, 2006.

  1. SLCMike

    SLCMike New Member

    31
    0
    Nov 18, 2003

    Advertisements

    Hopefully this will be of some help to those Comcast customers struggling to get the CC's activated. I *finally* got my cards activated thanks to swapping cards and talking with a very helpful CSR. This post relates to Motorola cards FWIW.

    First off, if you are having trouble activating, DO NOT ASSUME THAT YOUR CARDS ARE OK. If you check your "Conditional Access" on a card and it does not have "Encryption: DES" -- you probably have a poorly configured card. I noted that one of my two cards did not have this bit of information. I suggest comparing your 2 cards under their respective "Conditional Access" menus and make sure that they generally look the same. (numbers and such may differ, but again, they should both have "Encryption DES" listed. Between a weekend of no luck with activation after 5 or 6 separate calls to Comcast and noticing eventually that my 2 cards were definitely different under the "Conditional Access" menu, I finally went back to my local Comcast office and told them that a CSR suggested I get two new CC's. They seemed dubious of my request, but I walked out with two new CC's.

    When I got home I rebooted the TiVo and inserted the my first card into CC slot 1, checking to make sure that the "CableCARD Pairing" information had registered. I next did the same for CC slot 2. I then proceeded to call Comcast and request activation of my 2 CC's. Before starting anything, I had the CSR confirm the CC equipment serial numbers to make sure we were both talking about the same cards.

    After confirming we were talking about the right cards, she sent the signal to activate my cards. Normally, based on 2 days of experience anyway, this is about the time CSR's seem to want to get off the phone. I simply asked that she stay on the line with me until I could confirm that everything was working. She was incredibly nice and said "no problem." I started flipping between the cards to "Test Channels." It look about 90 seconds for the 2nd card to start working and about another 30 seconds for the 1st card to start working. Sweet! A small victory.

    Of course the next thing to test was "do I have access to the content that I'm paying for?" A quick test revealed I had none of the digital channels, no HBO, etc. working on either card, just the basic cable. FWIW, at this point under the "Conditional Access" menu I had the following (among the other stuff) for Auth showing:

    Auth: MISSING_PROGRAM_REKEY

    The CSR then went to work to send *another* signal to both cards to tell them what content I was allowed to view. Within 2 minutes I had received the "161-4" "error" message for both cards. This is actually a *good* sign as far as I can tell. After this, under the "Conditional Access" menu I had the following (among the other stuff) for Auth showing on both cards:

    Auth: SUBSCRIBED

    Within another 2 minutes (the CSR was again nice enough to stay on the line with me) all of the channels I'd expect to be getting appeared to be working.

    I am now happily recording 2 streams of HD on the S3!

    Hopefully this post will help some other S3 Comcast people out. If enough people post their experiences, I suspect we'll soon be able to diagnose other TCF member's activation problems, hopefully saving some frustration!
     
  2. sharding

    sharding Member

    250
    0
    Feb 11, 2001
    Seattle/East...
    Yeah, it certainly seems that way.

    Are these error codes standard to the CableCard spec, or are they something TiVo-specific? If the former, what is 161-4 supposed to mean?
     
  3. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    They are specific to CableCard - I posted the actual message earlier tonight in another thread.

    The only thing specific to Tivo is the error message text they pop up - the condition is the same for all hosts, including TVs and other CableCard devices.
     
  4. jfh3

    jfh3 Active Member

    4,471
    2
    Apr 15, 2004
    Denver area
    To the OP -

    Do you happen to remember the manufacturer and firmware levels of your original cards?
     
  5. prbyers

    prbyers New Member

    9
    0
    Dec 29, 2003
    Chicago, IL

    Advertisements

    My problem was exactly the one described above:

    AUTH: MISSING_PROGRAM_REKEY

    No HBO, ESPN (non-HD) had no sound, no ESPN HD, no Comcast Sports Net, etc.

    I called and FINALLY got a competent CSR in Chicago (Natalie was her name). She was able to send signals to my cable cards and get them working.

    Before she got off the phone with me I asked her to tell me what others should tell the CSRs so they can get it right:

    She said to tell them to do an "initialize" on each card.

    Oh yeah - my card make is Motorola. Firmware 4.21.

    Hope this helps!
     
  6. maharg18

    maharg18 Active Member

    3,644
    13
    Dec 3, 2002
    Chattanooga, TN
    Hey guys, still having the dang missing_program_rekey problem here on both cards.

    I have one question, did you have to supply a host ID or anything to the CSR on the phone? When I called to set mine up, all I supplied where the serial #'s on the cards.
     
  7. SLCMike

    SLCMike New Member

    31
    0
    Nov 18, 2003
    I didn't have to supply anything over the phone. I do know when I picked up the cards, the CSR there keyed the card numbers into their system however. (Just 1 number for each card.)
     
  8. speedy2

    speedy2 TivoAddict

    98
    0
    Aug 19, 2002
    Preston, CT
    "I have one question, did you have to supply a host ID or anything to the CSR on the phone? When I called to set mine up, all I supplied where the serial #'s on the cards."

    As far as I know you need to provide the host ID from the tivo to your cable provider in order for them to pair it to the cc.The host id and the serial # of your cc have to be tied together in the system.This has to be done for each cc you put into your tivo.Atleast this is what has to be done in a SA system using SA cable cards.

    :)
     
  9. beergeek2

    beergeek2 New Member

    4
    0
    Jan 30, 2002
    Thanks! I pointed the Comcast analyst to this thread and they were finally (after 8 attempts) able to get things working.
     
  10. rickeame

    rickeame New Member

    86
    0
    Jan 3, 2002
    YES! After screwing around with 3 different techs, I read your exact word "initialize" and everything worked!

    you the man!
     
  11. maharg18

    maharg18 Active Member

    3,644
    13
    Dec 3, 2002
    Chattanooga, TN
    Well, I just pointed rep # 3 to this thread, she supposedly read it, yet still was unable to do anything. She said the signals were unable to go through.

    I mentioned the word initialize, and it didn't seem to mean anything to her. She told me there is only 1 kind of activation signal.

    This whole ordeal would be funny if it wasn't such a PITA.
     
  12. RentMusic

    RentMusic New Member

    4
    0
    Sep 22, 2006
    Where, when, and how is this error displayed? When I try to get help from Comcast online Chat, they "send the reset signal" and nothing ever happens that I can see.

    The technicians they have sent out to our house have been, well, less than helpful.

    My two cards were in the states UNSUBSCRIBED and MISSING_PROGRAM_REKEY states.

    I sent an e-mail to Comcast support through their online form this evening, checked back an hour or so later and my cards were now in the SUBSCRIBED and MISSING_PROGRAM_REKEY states. (Progress?)

    I tried Comcast Online Chat tonight and got the standard "Comcast does not support the TiVo CYA". They attempted the RESET but nothing happened that I could see. The suggested that they schedule sending out a technician (after the way they've handled the situation and refused to even look at the TiVo, I consider this a very bad exerience and intend on sending a formal complaint to Comcast regarding this).

    Online Chat said my other option was to contact 1-888-COMCAST. Which I intend to do.

    But I want to avoid the "did the reset do anything?" run-around.

    What specific things should I be asking for and what things should I be looking for? Pictures of the screens would be helpful.
     
  13. Gregor

    Gregor Wear Your Mask! TCF Club

    58,397
    5,136
    Feb 18, 2002
    I've found that going down to your local Comcast office and talking to them has had a much better result than the 800 number, which pretty much spouts the "Comcast does not support cable cards with Tivo" line.

    After going 2 or 3 rounds on the phone with Comcast regarding that, I found a local manager who was willing to schedule the install. which is Monday.

    I'll report back with the results.
     
  14. dbattaglia001

    dbattaglia001 Member

    118
    6
    Feb 9, 2003
    Chicago, IL
    My situation seems bizarre.

    cc1 works without a problem, i get all analog, digital, and HD channels. "Conditional Access" menu shows "Auth: SUBSCRIBED".

    cc2 has similar problems as other posters in this thread (1 to 99 work, but no digital or hd channels). cc2 "Conditional Access" menu shows "Auth: MISSING_PROGRAM_REKEY". In addition, in "CableCARD Pairing" menu, I get this message showing which doesn't show for CC1: "The cablecard considers the Host to have only one-way RF capability".

    Calling support many times to try to rinitialize the cc2 has not worked. But what I recently noticed, and this is where it gets weird...if cc1 is recording something on a digital or hd channel, then when I switch tuners, i can watch/record a second digital/hd channel simultaneously. If I am recording nothing at all, cc2 will not let me view hd/digital channels (just a blank black screen appears). Before I schedule someone to come out to fix this, anybody have any suggestions or ideas? Is this still probably a faulty cablecard setup that comcast should be able to fix remotely (and i just keep on talking to idiots on support)? Or is this perhaps a problem with my TiVo. Thanks so much to anyone who can offer some advice.
     
  15. JennyP

    JennyP New Member

    53
    0
    Jul 11, 2006
    It sounds like that second CC just hasn't been initialized properly. Just get on the phone and don't let them off until it states subscribed. I went round in circles with the CSR I spoke with and finally just told him "just validate the card, I don't care that your boss tells you your not supposed to need to... just go ahead an reinitialize or Cold initiate the card as you're not gonna break it any worse than it is." Finally he did whatever he wasn't supposed to do, and after going in and out of the Status menu I finally got it to display Subscribed and all was well. I'm pretty sure his suggestion of rebooting everything would have worked as well but you know I'd rather be bitchy. :p

    I found all the information I needed from this link, it was provided in another post somewhere... I tried searching for it to give credit where its due, but I had no luck in finding it.
    http://techdigs.net/content/view/46/42/#ccconfig
     
  16. WJB21

    WJB21 New Member

    6
    0
    Oct 4, 2006
    I have the same issue -- cablecard 1 is ok -- cablecard 2 is missing program rekey -- i had three tech visits and three phone calls and no one can seem to activate this card. The tech today told me that there is nothing they can do but try a differnet card --- when they can get one as they are out now.

    I really think i am close to getting this working - and after reading the posts it seems possible ...

    For those that had the rekey message fixed -- was it necesssary to unplug and reinsert the card? or was it as easy as saying the magic word to the CSR for them to send the right signal to get it working? I asked one of them to cold initiate and i got this response as if she didnt know what I was talking about but then said she sent the signal -- so maybe they are only sending the restart signal and not the one i need - i checked the status menu too after i asked for that and i did not see any segments downloading ...

    On other thing i learned is that comcast (in sunnyvale ca anyway) does not keep track of your host id numbers -- they only keep track of the card serial number so they know what you have and where to send activations signals to. I heard some other areas keep track of the slot your card is in so that way if someone removes it and puts it in another device it won't work.
     
  17. eDbolson

    eDbolson Member

    55
    0
    Oct 25, 2001
    Redmond, WA
    I just completed my installation and was very happy to have this thread available. An installer arrived on time, with no concerns about the 2 CableCards or the TiVo. The first card appeared to install. The second one gave various errors, so he gave up and put a third one in. This one was recognizced by the Tivo and showed the pairing screen. However, after he told the support person the various numbers, he was told that the host was assigned to another account! They could not work it out, and he had no more cards. They sent someone to my house with another card while we waited. I was impatient and and for grins started the guided setup (which I'd done before without any cable cards). Didn't realize that it would redownload everything, but it managed to finish before the new card came.

    The 4th card (in slot 2) initialized properly (with the appropriate error code, which appears to indicate some success!), and after a few minutes had all my channels including the premium ones. The service guys left.

    THEN I found out the first card was not showing any of the enhanced or premium channels (only the clear QAM, I guess). I called support, they had me do things like remove the card and reinsert it, and, using the notes in this forum, told them to do an initialize. I got the error code, and channel information again, but it was clear something was different than CC2. The CableCard menu was different, and the initial screen didn't have the text about "one way RF capability". Nor was there an "IP Service" menu item, and the Conditional Access screen was completely different from CC2. Certainly nothing about Encryption:DES.

    So I asked if I could just go to the local "comcast store" (which is quite convenient to me) and get another card. She told me to go ahead, no problem.

    Next day (today), I went in and exchanged CC1 for a new card. Interestingly the beginning of the serial number was the same as the working CC2. For the record this was NG3630. The failing card was NG3344. In any case, I called support, got the callback after 30 minutes, and upon initialization and a little patients, everything was good.

    So my experience was not terrible, though time-consuming, and helped immeasureably by this thread.
    Thanks
    Ed
     
  18. atl Tivo

    atl Tivo New Member

    17
    0
    Apr 14, 2003
    The...
    So I have been having a horrible experiance with the install and then I read this thread. I found a great tech. He re-initialized both of my Cards and I get all channels. The weird thing is that in the AUTH: section is reads, "unknown" instead of "Subscribed". If everything works fine, should I be concerned that I may have problems later on?
     
  19. Goines

    Goines New Member

    4
    0
    Sep 30, 2004
    Thanks.

    I had to make 3 sets of call to comcast (in seattle) today to get a new hd tivo up and running.

    First call didn't seem to do anything (at least got my cc info into their system correctly).

    Second call got channels working (MISSING_PROGRAM_REKEY), and I let the guy go once channels were on the screen (don't do this, wait for Subscribed).

    Third call got the right "initialize" signal to get SUBSCRIBED into the Auth, and get hbo, etc, up and running.

    Thanks for this information, definitely not a card problem, and a problem getting comcast to correctly send the right signal. The last rep i talked to did have some sort of information on setting up tivo's as she knew the menu's, etc.
     
  20. pkorona

    pkorona New Member

    1
    0
    Aug 4, 2007
    More information in Seattle, although it may apply elsewhere as well.

    Like others, the original subcontracted guy came out and got one card working but the other did not receive all channels. From the forums I learned to check the "Conditional Access" screen and sure enough, the second card showed MISSING_PROGRAM_REKEY. I contacted Comcast and had them hit the card again, went through the guided setup, but no luck. The Comcast rep said the card was bad and I needed to have another tech visit.

    This time I was lucky and got a very knowledgeable guy from Comcast (not subcontractor). He looked at the Conditional Access screen and noticed the line

    Connected: yes, enabledByCP: no

    Both should be yes he said, and this was indicative of being in the wrong zone. (Seattle has north and south zones.) He called that info in, got it changed and a new hit out, and we got both yes and Auth: SUBSCRIBED. Soon after we were getting all the channels.

    Note it did NOT require a new card. So the "zone" may be another critical setting that not all the Comcast reps know about.

    Hope this helps someone else!
     

Share This Page

spam firewall

Advertisements