Change from static to DHCP, and broken joe editor help please

Discussion in 'TiVo Underground' started by shoei600, Sep 22, 2007.

  1. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Hi all,
    Is there an easy way to chage from static to dhcp without removing the hard and running the setup again? I have run the nic_install_tivo and nic_config-tivo files via telnet but this just seems to allow me to change the static ip itself.
    The installed is a turbonet card purchased some years ago, I believe from 9th tee. I originally installed everything based on Steve Jenkins' superb guide, especially as I have limited Linux expertise.
    I also have a problem with joe editor that I noe cannot use. I have tried to re-install this but I have directories I can't move, write to, or delete which just about scuppers it really.
    Step by step command help would be greatly appreciated.
    Kind regards,
    James.
     
  2. lew

    lew Well-Known Member

    4,234
    78
    Mar 12, 2002
    One of the screens lets you type a d which will select DHCP. Just run nic_install.

    I have a Sony T-60 (DTV). I see you're from the UK. I don't know if that changes anything.


     
  3. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Hi Lew,
    I had tried running nic_install_tivo turbonet and I don't get an option for going to dhcp. I am able to change the static IP, Subnet and Gateway, but not change the IP setup.
    I think I shoul be able to set DHCP in the rcnet file, but because my joe editor is not working I can't do that either.
    James
     
  4. lew

    lew Well-Known Member

    4,234
    78
    Mar 12, 2002
    I don't remember if it was a "silent" option. Try entering a "d" instead of listing a real IP address.

    edited to add I know I used nic_install_tivo turbonet to change from static to dhcp a couple of months ago. I don't think it asked if I wanted dhcp, my memory is answering one of the question with d made the change.
     
  5. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    It will only allow me to enter numbers a that point.
    Do you know how I can delete everything to do with joe editor and re-install? I'm getting the feeling that I'm only going to be able to change this by either removing the drives and using the install boot disk, or edit the rcnet using joe.
    I'd like to get the editor functioning again for future use anyway. It originally stopped working after I tried upgrading it to a later version unsuccessfully.
    Thanks.
     
  6. lew

    lew Well-Known Member

    4,234
    78
    Mar 12, 2002
    Try Jenkins site, re-install Joe.
     
  7. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Hi Lew,
    I can't seem to extract the joe archive bacuse I already have a directory called joe, apparently with files in although I can't see them. I am also unable to delete the directory or invisible files. I've tried the chmod 755 command too.
    The last try I had of doing this, I was also getting an invalid header checksum reporting on the archive, but I think that is because the archives come in as tar.tar and the commands all say enter tar.gz.
    It's in a bit of a mess.
    Everything works perfectly on the tivo including tivoweb, I'm just unable to change anything.
    Thanks.
     
  8. lew

    lew Well-Known Member

    4,234
    78
    Mar 12, 2002
    The most recent "native" install version of nic_install (20050218) let's you type d (lower case) under IP address and will select dhcp for you.

    http://www.silicondust.com/forum/viewtopic.php?t=990

    I don't know anything about the UK unit.

    winzip will corrupt tar files. try to untar/unzip on the tivo
     
  9. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Hi Lew,
    I have now been through the process of the upgrade only to find I was actually running the latest version all along.
    I still cannot enter a 'd' as the IP address. I don't receive any echo response back unless I enter a numeric at that point.
    I'm guessing that this can only be done using the pc install and not the native telnet install.
    Does anyone know if a wildcard 0.0.0.0 would qualify tivo to know it must be a dhcp?
    Thanks.
     
  10. lew

    lew Well-Known Member

    4,234
    78
    Mar 12, 2002
    When I posted I typed a d to get DHCP.

    Must be something different with the UK tivo. Sorry I can't help you.



     
  11. GlennL

    GlennL Finding My Way

    26
    0
    Mar 1, 2005
    Sunny...
    I can't help you with the DHCP change but maybe with the Joe editor it is a simple return to the basics. (Not to be insulting but I often forget the basics only to discover the solution was simple after several hours of trying to solve a simple problem with a complex solution.)

    If you followed Steve's directions from beginning to end you probably need to set your system to read/write using the command: rw [ENTER]. If not Steve tells you how to make the system read/write using the command: mount -o remount,rw / [ENTER]

    Do you have FTP access, and if so, can you upload a file?

    If so, you can download the joe.tar from here. Use the command

    cpio -idu -H tar < joe.tar

    From Steve Jenkins' site to decompress the tar file. Follow Steve's directions from that point.

    Don't forget to reset the system back to read/only using the command: mount -o remount,ro / [ENTER]
     
  12. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Hi Glenn,
    I'm with you on forgetting the basics, but I had been using the rw/ro comments.
    When I run the "cpio -idu -H tar < joe.tar" command I get the response "cpio: cannot remove current joe: Directory not empty."
    While in "/var/hack" I have tried "rm joe", "rmdir joe" (which is not recongnised), and setting CHMOD 755 permissions in the hope of removing it. I have also tried doing this through the ftp client that reports the same "not empty" after having sent a "RMD joe" command.
    I have ftp access and cannot see any files in the joe directory either.
    I am a newbie with Linux and only really use it for the TiVo, so I am unable to get any further with this.
    Many thanks.
     
  13. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    could be hidden files... try rm -rf joe
     
  14. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Great, thanks BTUx9, easy when you know the commands. OK, that's cleared the directory and I have re-installed joe. this works for the test file but does not work for the rc.net. I wanted to continue the procedure and instal tivobin too but was having some problems with tgz and tar and invalid checksums. It seems you download a file called tivobin.tar which I then ftp to TiVo but all the commands are based on tgz, after renaming it reports checksum invalid. Oh well, I 'll revist that.
    I have finished by remounting ro, sync and reboot. Once done I go to /etc/rc.d and type "joe rc.net" and get "joe: command not found" this is wha the guide says I should do so I can only think that the system does not yet know that joe is installed, which is what I thought sync had done.
    Nearly there, more help please.
     
  15. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    check that joe is in the path, and that it is marked executable (ls -l gives a dir listing... left column should have some x's in it)
     
  16. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    is is not a recognised command unitl the tivobin issue is sorted. I'll keep trying.

    I have downloaded from stevejenkins/downloads/tivobin.tgz to my XPPro desktop where it becomes .tar (Winrar?). I then ftp this directly to the tivo. I have tried renamed the extension to tgz and put in "cpio -idu -H tar < tivobin.tgz" which creates "cpio: invali header: checksum error" or I have left the file as a tar which gives the same result.

    I have also tried the http_get to download the file directly but the tivo cannot find this even though it makes its daily call over the internet. "http_get -T 0 -C 0 -D /var/hack -U http://216.168.47.137:80/downloads/tivobin.tgz".

    Any clues?
     
  17. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    Oops, although I had renamed the file back to tgz, I hadn't tried the previous command for gzip, which worked without the checksum error.
    I have now been through the rest of the guide and have everything working including the rw and ro profiles, joe, etc, and I'm ready to edit the IP.
    Here's where the guide differs from my settings and I'm a little nervous about changing it as I will no longer have network if it's wrong.
    I'll post the actual settings shortly.
     
  18. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    My file says:

    #
    #!/bin/sh
    #

    if /sbin/insmod -f /lib/modules/ax88796.o macaddr=69C667 timing=3 ; then
    /sbin/ifconfig eth0 192.168.0.150 netmask 255.255.255.0 up
    /sbin/route.tivo add default gw 192.168.0.1
    fi

    Which is quite different from that on Steve Jenkins instructions. Should I be able to use his standard that seems to show a dhcp setup succesfully, or would somebody be able to advise exactly what I should have in this file?

    I have put the file here http://www.widgetsandgadgets.co.uk/rc.zip

    Many thanks, almost there.
     
  19. shoei600

    shoei600 New Member

    33
    0
    Feb 17, 2007
    London, England
    I've now tried several versions of rc.net file and each time the TiVo failed to join the network. I have had to hook up to the serial port and terminal in to delete the faulty rc.net and rename the backup.

    I have a dhcp server running supporting other devices fine. My rc.net is:

    #
    #!/bin/sh
    #

    if /sbin/insmod -f /lib/modules/ax88796.o macaddr=69C627 timing=3 ; then
    export DYNAMIC_NET_DEV=eth0
    mkdir -p /var/state/dhcp
    /sbin/dhclient -q eth0 2>/dev/null &
    fi

    Any pointers why this won't work please?

    Thanks.
     

Share This Page