Can't switch to HD Menus on "new" premiereXL setup

Discussion in 'TiVo Premiere DVRs' started by dougtv, Oct 4, 2019.

  1. dougtv

    dougtv Member

    39
    17
    May 20, 2015
    Bought a lifetime tivo premiere xl4 from a friend. Transferred lifetime membership to a brand new TiVo account.

    Cannot seem to switch to HD Menus in video/display settings on this XL4. The option *was* there until one of the reset/reboots or when lifetime service was transferred...

    Tried with different HDMI cables, different monitors/TVs for testing
    Monitor(s) displays 720p and 1080i just fine from the TiVo.
    TiVo directly to a monitor (no HDMI switches, etc)

    Tested manually setting TiVo to 1080i as well as AUTO detect, both options still give no "HD vs SD menu" options.

    Some System Info:
    Series4
    Software Version: 20.7.4.RC42-758-2-758
    TiVo Service Account Status: 5 Product Lifetime
    TiVo Service Level: C:
    TiVoToGo: i,a,i,a
    HDMI Status: HDCP 1.x enabled
    Service Map Version: 25 TIVOPVR SpigotMap

    HDUI Available: Yes
    Active UI Mode: Classic
    HDUI Support: Capable
    Active Video Output format: 720p
    Service Connection Type: Network

    Flash Player Version: (my note: nothing is displayed here on my tivo)
    HD Menu Software Version: (my note: nothing is displayed here on my tivo)

    What is interesting is I can force the HD Menu of TiVo Central if I access a dead channel I do not get and press Select to use the " get more information" screen from TiVo. The more information error is part of the HD menus and when I press TiVo button from there it will take me to the HD version of TiVo Central with full on top right video display and everything. If I switch to a recording or Live TV and press TiVo again, it defaults back to SD menus with again, no options anywhere to choose HD menus.

    I have even tried full reset/erase on this box and still no options to change menus.
     
  2. kpeters59

    kpeters59 Well-Known Member

    2,865
    582
    Jun 19, 2007
    Houston, Texas
    I fixed an HD Menus issue on a Premiere by running a KickStart 57...

    -KP
     
  3. ggieseke

    ggieseke Well-Known Member

    5,680
    701
    May 30, 2008
    I would recommend KS58 instead of KS57. There are several reports of KS57 causing a boot loop.
     
    ClearToLand likes this.
  4. Wigohwt

    Wigohwt Member

    125
    30
    Jun 9, 2019
    I have no idea why this would work for your issue, but it's something you should want to do anyway.

    Log into your TiVo account and under "Device Preferences" check the boxes for video sharing and enable video downloads (even if VidDL is not a thing right now, why not?).

    According to TiVo, this takes up to 24Hrs to take effect.
     
  5. Wigohwt

    Wigohwt Member

    125
    30
    Jun 9, 2019
    I Have:
    HDUI Available: Yes
    Active UI Mode: HD
    HDUI Support: Capable

    Weird, since it says it's capable, and it worked before.
    Are you saying that under Settings->Display there is no "Choose TiVo Menus" item? or no HD Choice?
    Double-check under "TV Aspect Ratio" under "Video Settings" and make sure it's set to 16:9 Widescreen.

    If the KS58 and video sharing settings on your account don't work, you could always try the new HDD route.
    If the HDD has never been replaced, for a box this old, it would probably be a good idea to reimage a new one anyway.
     
  6. dougtv

    dougtv Member

    39
    17
    May 20, 2015
    Thanks everyone!

    i tried kickstart 57, got the proper green screen but still no luck. (did not get to try ks 58 because I got it working below...

    Wigohwt, your tip helped. I was “opt-out” and had to set the setting to opt in / default in order to enable those two tivo sharing and download option. It appears after that and a reconnect to tivo network (couple hours later) and now the “Choose your menu” menu options appear! Yay!

    Probably had something to do with the allow sharing / download option. Strange but glad it works. Was not sure how well HD menus would run on my Premiere XL4 but so far so good. Just like the consistent look between my Roamio Pro and now PremiereXL4 in the office. No plans on upgrading to TE4 so no worries there ;)

    Thanks again everyone.
     
    cw1675, kpeters59 and Wigohwt like this.
  7. cw1675

    cw1675 New Member

    1
    0
    Dec 5, 2011
    Your suggestion worked like a charm. Thanks!
     

Share This Page