Can't open kmttg.jar

Discussion in 'TiVo Home Media Features & TiVoToGo' started by pyrrhicvictory, Aug 9, 2019.

  1. justen_m

    justen_m Cheesehead

    9,999
    637
    Jan 14, 2004
    Boise, ID
    ClearToLand likes this.
  2. pyrrhicvictory

    pyrrhicvictory New Member

    8
    0
    Aug 9, 2019
    ej42137, please reread pyrrhicvictory (me) and minimeh's post, carefully, I am still not recreating any scripts. Never have and never will.
    I acknowledge openly that I am a Linux noob. However, noob does not translate to useless. I can navigate a file system via terminal reasonally well.
    Given there is a second page others are having issues.
    In order I am;
    1. Uninstalling Java 8 on my box.
    2. Uninstalling kmttg
    3. Reinstall Java 8 on my box
    4. Check hashs
    5. Check version in terminal
    6. Reinstalling kmttg
    7. Check hashs
    8. Check version in terminal
    9. Run kmttg.jar in /user/bin/kmttg or maybe /home/bin/kmttg?
     
  3. ej42137

    ej42137 Well-Known Member

    3,686
    549
    Feb 15, 2014
    Los Angeles
    This post led me to think you were recreating the script, and that you didn't understand where it came from. Because you referred to the script after talking about entering it into the terminal, I presumed you were talking about entering it in the terminal under an editor rather than trying to execute it under the command line. My mistake.

    If I had correctly interpreted your description, I would have told you that what you were trying to do was not going to work at all because what the lines of the script are doing depend upon executing within the script environment; for example, "$0" is the name of the currently executing script, it won't have the correct value when executed directly from the command line. But to execute kmttg from the command line you just have to invoke Java against the kmttg JAR file while in the install directory: "java -jar kmttg.jar"

    I don't see the word "Oracle" in front of Java 8. I have only ever been able to get kmttg to work under Oracle Java 8. If you have trouble with that post here for more information. It would help if you noted your Linux distribution.

    Usually one checks the hash of an install package before you install it. If you have already installed the package, checking the hash is pointless.

    Don't install kmttg into a bin directory; that's not what bin is for. Create its own directory like /home/pyrrhicvictory/kmttg and unzip the install file there. Then change into that directory and execute "./kmttg" to start the kmttg GUI.

    Linux directories explained.
    Oracle Java 8 downloads.
    Helpful link.

    By the way, I don't know if you realize it or not, but the way you are complaining about kmttg is grating. It is a free program, after all. It does require some sophistication to get it running, and as you have admitted more than once, you are a Linux noobe.
     
    Last edited: Aug 18, 2019
    minimeh and kpeters59 like this.
  4. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    I have followed the directions on the Kmttg wiki for Windows. I have Java 1.8.0_221. I have done the following:

    First determine full path to your Java installation javaw.exe file. Then start a cmd window as administrator and type:
    assoc .jar=jarfile
    ftype jarfile="C:\Program Files (x86)\Java\jre1.8.0_45\bin\javaw.exe" -jar "%1" %*
    (Of course replace path to javaw.exe above with your java installation path.)

    And the Jarfile won't open with Java. Just a blank black box. Any help would be greatly appreciated.
     
  5. ej42137

    ej42137 Well-Known Member

    3,686
    549
    Feb 15, 2014
    Los Angeles
    Your ftype specifies 45 and you say you have installed 221. Did you double-check that is actually where your javaw.exe file exists?

    Have you tried just entering "java -jar kmttg.jar" from the command line in the kmttg directory? Do you get any messages from that?
     
  6. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    Yes, I used the 221 and that is where the file is specified. When I type the command as you requested, I get Error: Unable to access jarfile kmttg.jar
     
  7. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    I know what the problem is. Thank you ej42137.

    I am on C:\Windows\System and don't know how to open a command window in the Program Files (x86) folder since now it's Powershell Window is the option.
     
  8. mtepper27

    mtepper27 New Member

    28
    2
    Jul 8, 2019
    So I figured out how to get to the Program Files (x86) folder and this is my updated command.

    C:\Program Files (x86)>Java\jre1.8.0_221\bin\javaw.exe -jar "%1" %*

    and it still responds with unable to access jarfile
     
  9. justen_m

    justen_m Cheesehead

    9,999
    637
    Jan 14, 2004
    Boise, ID
    Stop using substitutions and use complete path names. For example, from anywhere my command prompt is, the following will work. e.g.

    c:
    cd c:\"Program Files (x86)"
    Java\jre1.8.0_221\bin\java.exe -jar d:\kmttg\kmttg.jar

    [I installed kmttg on my HDD (D: ) instead of my SSD (C: ) where Windows and most programs reside. The intial c: will switch the command prompt back to my C: drive it I happened to be on the D: drive. Obviously unnecessary if your system only has one drive mounted.]
     
  10. ej42137

    ej42137 Well-Known Member

    3,686
    549
    Feb 15, 2014
    Los Angeles
    1. To open a command window in Windows, hold down the Windows key and press the R key, then type "cmd" (without the quotation marks) and hit enter. A command window should open.
    2. Try the command
      Code:
      java -version
      the Java installer should have set up the registry such that the default version of Java will execute in any directory. If that works and displays the desired version of Java, you don't need to worry about using the full path to the Java program. Otherwise, you will have to enter the full path to java.exe. That path will probably include blanks, so it will need to include quotation marks:
      Code:
      D:
      cd D:\Whatever directory you unzipped kmttg into
      "C:\Program Files(86)\Java\jre1.8.0_221\bin\java.exe" -jar kmttg.jar
    3. If that doesn't work (that is, Java still says it can't find kmttg.jar) then issue this command:
      Code:
      dir
      and examine the output, which should look something similar to this:
      Code:
      03/06/2016  02:22    <DIR>          .
      03/06/2016  02:22    <DIR>          ..
      03/06/2016  02:25    <DIR>          AtomicParsley
      03/06/2016  02:25    <DIR>          ccextractor
      03/06/2016  02:25    <DIR>          comskip
      03/06/2016  02:23    <DIR>          css
      03/06/2016  02:25    <DIR>          dsd
      03/06/2016  02:23    <DIR>          encode
      03/06/2016  02:25    <DIR>          ffmpeg
      03/06/2016  02:32    <DIR>          Files
      03/06/2016  02:25    <DIR>          handbrake
      03/06/2016  02:25    <DIR>          mediaInfo_cli
      03/06/2016  02:25    <DIR>          mencoder
      03/06/2016  02:23    <DIR>          rc_images
      03/06/2016  02:23    <DIR>          service
      03/06/2016  02:23    <DIR>          slingbox
      03/06/2016  02:25    <DIR>          tivodecode
      03/06/2016  02:23    <DIR>          VRDscripts
      03/06/2016  02:23    <DIR>          web
      08/01/2016  02:18             8,028 auto.history
      08/01/2016  02:10                 0 auto.ini
      11/15/2016  17:16         6,346,428 auto.log.0
      11/15/2016  17:16        10,485,787 auto.log.1
      03/06/2016  03:00           259,978 AutoSkip.ini
      03/06/2016  02:25             4,864 config.ini
      10/14/2018  20:34             4,858 config.ini0
      03/06/2016  02:23             1,536 index.html
      05/08/2019  13:41                99 kmttg
      02/04/2019  04:48                51 kmttg.bat
      03/06/2016  02:23         2,774,761 kmttg.jar
      02/04/2019  04:54               417 kmttg-debug.bat
      02/08/2019  01:54                25 kmttg-debug.dat
      02/08/2019  02:59        19,803,839 kmttg-debug.log
      02/08/2019  01:44                14 kmttg-debug.pat
      02/08/2019  01:44                12 kmttg-debug.pat1
      02/08/2019  03:00                24 kmttg-debug.pat2
      02/14/2019  01:08               634 kmttg-debug.patdel
      05/02/2016  00:12            35,142 LICENSE
      03/06/2016  02:23               980 README.html
      05/21/2016  20:13            22,486 TtGo_blue.ico
                    21 File(s)     39,749,963 bytes
                    19 Dir(s)  133,567,180,800 bytes free
      
      If you don't find kmttg.jar in that output, figure out where it is and start over.
    4. If you get kmttg to work from that, then try to set up the associations with ftype and assoc.
     
    Last edited: Sep 7, 2019
  11. ej42137

    ej42137 Well-Known Member

    3,686
    549
    Feb 15, 2014
    Los Angeles
    I presume the ">" is a typo.

    Is this the command you execute?
    Code:
    kmttg.jar
    
    Are you in the same directory as kmttg.jar when you issue "kmttg.jar"?
     
  12. bertp

    bertp New Member

    16
    3
    Sep 24, 2018
  13. MPSAN

    MPSAN Well-Known Member

    1,480
    27
    Jun 20, 2009
    Portland,...
    Funny, on Windows 10 where I have JAVA installed I can RIGHT click on kmttg.jar and select OPEN WITH and a list comes down and JAVA is on it. I then just clicked it and KMTTG finally did open! I only want to use this to save my One Passes, etc so I believe it will not take much to configure KMTTG to just save as a .csv.
     

Share This Page