Can't copy hacked 200g -> 300g new drive

Discussion in 'TiVo Underground' started by landie, Jan 2, 2006.

  1. landie

    landie New Member

    14
    0
    Sep 16, 2005
    I've been unable to copy a 200g hacked drive to 300g for a backup.
    My eyes are bleeding from trying to find a solution : (
    Don't care if settings are saved just want a duplicate of the hacked drive.

    Tried larger swap with hacked tivo drive primary master set to master
    new drive secondary set to slave with:
    mfsbackup -Tao - /dev/hda | mfsrestore -s 150 -r -xzpi - /dev/hdb
    stalled after two hours

    Tried 127 swap with hacked tivo drive primary master set to master
    new drive secondary set to slave with:
    mfsbackup -Tao - /dev/hda | mfsrestore -s 127 -r -xzpi - /dev/hdb
    also stalled

    Started knoppix terminal
    dd bs=64k conv=sync,noerror if=/dev/hda of=/dev/hdb

    Not sure if anything happened, there wasn't a progress report.

    Can someone please point me in the right direction to get this drive copied?

    Thanks!
     
  2. Diana Collins

    Diana Collins Well-Known Member TCF Club

    3,328
    794
    Aug 21, 2002
    New York...
    Sounds like you are using an older boot disk. To work with drives over 137GB you need a LBA48 boot disk. Another possibility is that the PC you are using is not recognizing one or the other drive's geometry.
     
  3. landie

    landie New Member

    14
    0
    Sep 16, 2005
    Used PTVupgrade LBA48 4.01 with Enhancements.

    Running mfsbackup w/127 swap again, it's at 30% which is the best thus far.

    Hopefully one of these attempts will finish successfully.

    Thanks!
     
  4. Rob00GT

    Rob00GT This space for rent.

    78
    0
    Mar 10, 2003
    D/FW...
    From the command you typed it looks like you are trying to "expand" your recording capacity while transferring everything to the new drive. Don't think you can do that. Try using the same command but with -bzpi instead. This will copy everything to the 300GB drive, but you'll still only have the recording capacity of 200GB.

    Another helpful hint, the transfer may go a bit faster if both drives are not connected to the same IDE cable. Try using hda and hdc or hdd to speed things up a bit. You might also enable DMA for faster transfers between the drives (will save hours) using this command for the hda drive:
    hdparm -d1 /dev/hda
    Repeat this command for hdb, hdc, etc. for whatever your other drive is and the transfer will speed up.
     
  5. landie

    landie New Member

    14
    0
    Sep 16, 2005
    Copy did complete, said new hours 342 the 200g said 222 hours...but the power got yanked at this point.

    Ah, okay. It was a matter of what fit and what was open.

    Thanks!!! I'll add this to my cheat sheet!
    Hopefully I won't need this info until next time since it appears to have copied...except my UPS woke me in the middle of the night, power had just gone out from a heavy snow storm, first priority was to run to see if copy completed, it had, new hours 342...just as I go to type what I thought was next:

    tpip -s --swapped /dev/hdb

    the UPS dies all power gone!

    Since I tried to expand and copy, would that still be the next correct command if I boot from PTV again? Is it too late to try tpip?

    I'll probably try to hook it back up to the tivo and see what happened as far as the copy.

    Bad timing for a power outtage!

    Thanks so much!

    ~~~> UPDATE to the power outtage shut down...
    The drive did copy, including all shows, recording capacity variable up to 285 hours.

    Didn't try the tpip command.

    Can't recall how many hours on the 200g drive, so not sure if it has expanded.

    Would this be full use of the 300g hacked DSR708 drive?
     

Share This Page