Can't connect to WiFi... HELP

Discussion in 'TiVo Stream 4K' started by BigC, Jun 1, 2020.

  1. BigC

    BigC New Member

    12
    1
    Apr 27, 2020
    My Tivo Stream 4K lost connect to my WiFi network. My network is hidden. Everything else that connects wirelessly is working fine. I had it connect initially to the network with no problems, but now can't seem to get the connection back. I've even reset the device... It says it Couldn't find the network. Just for fun (yeah, right) I tried to connect to my guest network which has it's SSID transmitted. I get the same "error", Couldn't find the network

    Any help or suggestions would be appreciated.
     
    Last edited: Jun 1, 2020
  2. siratfus

    siratfus Active Member

    366
    29
    Oct 3, 2008
    What about usual troubleshooting such as unplugging router/modem? Let it start up again, then try connecting again.
     
  3. BigC

    BigC New Member

    12
    1
    Apr 27, 2020
    Did that...
     
  4. oscarfish

    oscarfish Member

    229
    23
    Mar 1, 2009
    I setup my TS4K initially and it seemed to be working fine other then not being able to get the volume buttons to work correctly. After about a week I noticed that it was taking longer to connect to Amazon. Then it was having trouble streaming anything. Updating apps took longer. etc .... Eventually, it would just disconnect from my Wi-Fi network, so nothing worked.

    I moved it away from my Roku and then it started working fine, for a day or two.

    Then, I changed my Wi-Fi channel from auto to 11. My access point was selecting channel 10. I forced it to 11. It's been working fine since.

    I should point out that I live in an apartment building and there are lots and lots of Wi-Fi signals. I'm surprised that anything works at all.
     
  5. GBK33

    GBK33 Member

    65
    11
    Sep 21, 2007
    Columbus, OH
    Having similar issue. Says connected to network but no internet. I also tried to use my work hotspot and my phone as a hotpot. Nope, neither worked. Very frustrating
     

Share This Page