Can I UPLOAd to my Tivo?

Discussion in 'TiVo Coffee House - TiVo Discussion' started by JLOB, Sep 2, 2017.

  1. Sep 2, 2017 #1 of 29
    JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut

    Advertisements

    I’d like to be able to upload home videos onto my Tivo Premiere. At the moment, I use KMTTG to download Telenovelas to a thumb drive for my wife to watch on her laptop. Is there any software that would allow me to accomplish this? I thought I had found a solution in "Tivo Desktop Plus", but apparently that program has been withdrawn.

    Thanks.
    JLOB
     
  2. Sep 2, 2017 #2 of 29
    HerronScott

    HerronScott Well-Known Member

    7,592
    1,114
    Jan 1, 2002
    Staunton, VA
    The free version of TiVo Desktop is still available but the formats you can transfer from the PC to the TiVo are limited (works best with either downloaded .TiVo or MPEG2 files). You can get it here.

    http://assets.tivo.com/assets/exe/tivotogo/TiVoDesktop2.8.3.exe

    A better option for you would probably be pyTivo Desktop which you can find here.

    pyTivo Desktop

    Please note that after you install one of these you should be able to scroll to the bottom of your My Shows menu on your TiVo and see your workstation. You can then open it and select the shows that you want to upload to the TiVo.

    Scott
     
    Davisadm and CaseyJ like this.
  3. Sep 2, 2017 #3 of 29
    fcfc2

    fcfc2 Well-Known Member

    2,594
    555
    Feb 19, 2015
    Have a look at Archivo, it has some nice features, commercial skip, and you can compress and convert to several smaller .mp4 files with just a click once you set it up...all very easy.
    Announcing Archivo 1.0: Transfer recordings from TiVo to your computer
     
  4. Sep 2, 2017 #4 of 29
    HerronScott

    HerronScott Well-Known Member

    7,592
    1,114
    Jan 1, 2002
    Staunton, VA
    Good recommendation as an alternative for his kmttg for downloading but he was looking for tools to upload back to his TiVo which Archivo doesn't do (don't want to confuse him).

    Scott
     
    Mikeguy and fcfc2 like this.
  5. Sep 2, 2017 #5 of 29
    fcfc2

    fcfc2 Well-Known Member

    2,594
    555
    Feb 19, 2015

    Advertisements

    Damn, and just when I was beginning to think I was perfect!!:confused::confused: Good catch and thank you for clarifying it for the OP.
     
    Mikeguy likes this.
  6. Sep 2, 2017 #6 of 29
    Sparky1234

    Sparky1234 Well-Known Member

    2,329
    349
    May 8, 2006
    plus 1 on pytivo
     
  7. Sep 5, 2017 #7 of 29
    JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut
    Thanks for all the input. Apparently Tivo Desktop is inferior to pyTivo, so that was my resulting try. I guess I’m either missing something, or installed it incorrectly. I entered my Media Access Key, selected a folder for storage, clicked on “Save”, and I get an “almost” blank screen with “pyTivo Desktop” in the upper RH corner. If I restart, I’m back to re-entering the MAK and folder stuff.

    Kmttg had no problem finding my Tivo’s. Has anyone any thoughts on what I’m doing (or NOT doing) to produce this result?

    Thanks for your help.
    JLOB
     
  8. Sep 5, 2017 #8 of 29
    rchmnd52

    rchmnd52 New Member TCF Club

    18
    1
    Feb 2, 2003
    I had the same problem. I exited pyTivo and then uninstalled. I then reinstalled it from my original download. Make sure when you reinstall it that you fill in the MAK and TiVo default folder during the install process. Next time I clicked in, pyTivo found my TiVo and populated my shows. I did not have to go to the settings screen and re-input my MAK and folder.
     
  9. Sep 5, 2017 #9 of 29
    JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut

    Thanks for the input. That seemed like an elegant solution, and in fact it did preserve my MAK and storage folder but, alas, there were no Tivos found, either on the initial invocation, nor subsequent ones.



    Anyone else have any ideas?



    JLOB
     
  10. jackstoker

    jackstoker Member

    38
    21
    Jul 31, 2017
    I was having what I believe to be your problem in Windows. Then I read some posts in another thread where Dan203 recommended not checking the box to run as a “service” when installing pyTivo Desktop:

    Easier to use pyTivo


    I uninstalled pyTivo Desktop and reinstalled version 1.6.15 using that suggestion, and now pyTivo Desktop sees the TiVo, and the TiVo sees pyTivo Desktop, and recordings are copied in both directions.

    Easier to use pyTivo
     
    Mikeguy likes this.
  11. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,858
    7,164
    Apr 17, 2000
    Nevada
    There seems to be an issue running it as a service. So if you've got it installed as a service try reinstalling without the service option checked and see if that helps.
     
  12. JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut
    I was fairly certain that I had NOT installed pyTivo as a service, but I re-installed it as advised. No joy. Getting message “No Tivos Found”. Since I’m floundering around here in the dark, I thought I’d see what else was running that might affect pyTivo.

    Looking at Task Master, I find….

    Tivo Transport Service
    Tivo Server Service Process
    Tivo Notify Service Process

    pyTivo tivo.exe*
    pyTivo tray.exe*

    *Two instances of each.

    If any of this has any meaning to you, please advise.

    Thanks (again) for everyone’s help.
    JLOB
     
  13. jackstoker

    jackstoker Member

    38
    21
    Jul 31, 2017
    The 3 TiVo processes are for TiVo Desktop. If those processes are running, my pyTivo Desktop does not find the TiVo. To verify on your computer, use Windows Task Manager to "End Task" the 3 TiVo processes, then restart pyTivo Desktop.

    I've uninstalled TiVo Desktop.

    My Task Manager shows the 4 pyTivo processes you've identified.
     
  14. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,858
    7,164
    Apr 17, 2000
    Nevada
    Yes it will conflict with TiVo Desktop. So you need to uninstall that. (or kill it manually)

    There will always be two instances of each pyTivo executable. That's normal and caused by the way I package the python code into an exe. Same applies to the Desktop app. Except it's using javascript/html packages using something called Electron, so you may see that in your task list too.
     
  15. JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut
    Thanks for the input. I first “stopped” the three Tivo Desktop processes. I restarted pyTivo with no joy. Next I uninstalled Tivo Desktop, rebooted the system, uninstalled pyTivo, rebooted again, and re-installed pyTivo. It took a while looking for Tivo, but eventually decided that there were none available. I’m kinda at my wits end.

    JLOB
     
  16. JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut
    PS: KMTTG still has no problem finding my Tivos.
    JLOB
     
  17. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,858
    7,164
    Apr 17, 2000
    Nevada
    Look at your network adapters. Do you have any extra ones installed like for a Virtual Machine? If so try disabling them and see if that helps.
     
  18. JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut
    Dan,

    Strange. I have three Virtual Ethernet Adapters, two VMWare adapters and a Logmein Hamachi adapter. I disabled them and re-tried pyTivo and got an error regarding “pyTivo not running”, instead of the “No Tivo found” error that I had been getting. I uninstalled/re-installed pyTivo and now I’m back to “No Tivo found”. This is true with or without the three virtual adapters disabled,
     
  19. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    53,858
    7,164
    Apr 17, 2000
    Nevada
    Did you accept the firewall prompt when the program first ran?

    One thing you can try is go to Settings and on the network tab set Zeroconf to off. That will force it to use the old style TiVo Beacon instead. Maybe that will work.
     
  20. JLOB

    JLOB New Member

    16
    0
    Sep 20, 2013
    Connecticut

    Curiously, I never saw a firewall prompt when the program first ran. To be certain, I uninstalled and re-installed and there was no prompt. Setting Zeroconf to off didn't change a thing. Sorry.

    Is there a log, or error file, somewhere that I could upload and you might look at?
    Thanks.
    JLOB
     

Share This Page

spam firewall

Advertisements