Cablecards Firmware Updating "Not in operation"

Discussion in 'TiVo Series3 HDTV DVRs' started by laffingleigh, Dec 14, 2006.

  1. laffingleigh

    laffingleigh New Member

    4
    0
    Dec 14, 2006
    New York City

    Advertisements

    Okay. :confused:

    Here's the freakin' deal with my TiVo install. I set the S3 up on my TV all by myself. I'm so proud. So all it needs are the two cablecards. I plan it perfectly so that I end my S2 on Monday and my first available free time is Wed. morning, so I schedule an appointment to come in that day and CableCard me up. Time Warner employees were at my place until 9 PM! And guess who has no service?!

    The one contributing factor that may cause an issue is that I have a low, but acceptable signal, by their standards. It's been an issue for one channel or so in the past, and maybe an internet problem once in a while, but never too bad. Well, I decided after today to get a new wire installed just to make sure it's the wire and not the Tivo.

    Employee number one: Had experience with installing other TiVos, so was quick to move. Tried to install both CCs at once and got the grey "firmware upgrading" screen of death (FUSOD) for over 4 hours! Also, on the "Configure Cablecard Menu" page, the Cablecards are always labeled as "not in operation." After some playing around and checking signal amounts, he leaves and I rule in my head that he had bad cablecards.

    Employee number two: Seemed like more of a novice at installing it in. Didn't read the instructions either and attempted to troubleshoot himself. Also used old CCs and got FUSOD. Boo.

    Employee number three: This guy had some clout, apparently. He moved with confidence and poise and had more intelligent things to say. He brough new CCs with him and tried to install those...but STILL got FUSOD. The thing we NEVER got was the MMI grey screen that describes the card.

    Because of that, #3 feels it is a Tivo error. Tivo, on System information says that firmware is upgrading (which it does FOREVER), and it's true, we never see the grey MMI screen. On the other hand, even with NEW cards, the Configure Cablecard Menu screen always displays that the Cablecard is "not in operation." I do not recall any of the new ones being given the appropriate "40 minutes" to complete it's official "firmware upgrade," but the employees are baffled because everyone else they installed for was up and done in 20 minutes. Why would mine take 40?

    What do y'all think? Is it the Cablecards? Is it the TiVo? I'm leaning toward that the TiVo is fine, because everything besides the MMI screen is showing up and working fine. I have yet to see any TV through my S3. Arg! :thumbsdown:

    Thanks,
    Leigh in New York City :)
     
  2. jdmass

    jdmass Member

    94
    0
    Dec 1, 2002
    Westborough, MA
    With all of those various cards going into firmware update, I'm inclined to think that they actually are doing a firmware update. The firmware update message is not always an SOD. One of my cablecards showed that message when first installed and it took a while (I didn't time it, but I'm guessing 20-30 min.) to get to the MMI screen. Four hours sounds very long, but I don't know what the acceptable time range is.

    Any other cablecard devices around like a TV? If so, then it would be worth having them pop the card into the TV to determine if behavior is the same. I used this tactic to convince the cable company that some of my channel reception problems were not Tivo-related.
     
  3. BruceShultes

    BruceShultes Member

    406
    0
    Oct 2, 2006
    Albany, NY
    The problem with that approach is that the first thing that is done during firmware updating is to erase all the memory in the card. If you remove it from the Tivo before the update is complete, it won't show the card number anymore and just states that your cable provider has not loaded any information onto the card.

    When I had the firmware update problem, TW needed to put in another card and made sure it was the newest the had to avoid the firmware update. It was stamped with a date sometime during April 2006.
     
  4. slimoli

    slimoli New Member

    358
    0
    Jul 29, 2005
    The firmware upgrade on cablecards can be real nightmares. I had 3 cases so far with my Mitsubishi TV and none with the S3. When the msg comes in everything locks up and you can't even change channels. In all 3 cases I waited more than 8 hours and gave up, cablecards replaced by the cableco. I just hope I don't get it with the S3.

    Sergio
     
  5. TerryD

    TerryD New Member

    87
    0
    May 17, 2002
    Bloomington, IN

    Advertisements

    Could it be that the CCs did need to have the firmware updated and the weak signal prevented them from updating properly?

    Just a thought...
     
  6. shaown

    shaown Member

    296
    0
    Jun 30, 2002
    In all my reading, and personal experience, the 3 main problems with CC installs are:

    1) Low Signal Strength (CC's are very vulnerable to this)
    2) Outdated FW (updates fail or CC is destroyed)
    3) Giving the wrong info to the provisioners at the head office
    4) Head office just f'g up the provisioning
    3) Reused Cards (see #2)

    If you are facing 2 of 5, u're dead :)
    Yell at them to bring more cards with em next time they come, My Card #1 was good right away, but Card #2 went through 3 replacements.

    -Shaown
     
  7. jchapman

    jchapman Member

    66
    0
    Mar 29, 2005
    I had a cablecard go into the "Firmware Update Screen of Death" myself a couple of weeks ago for no apparent reason. While the screen claimed ~40 minutes of downtime, I allowed 24 hours before calling my Cable Company and requesting a new card (I actually requested that both be replaced). No firmware update was pushed according to Comcast. Interestingly, the problem with the one card prevented the other card from working; the Series 3 was essentially dead. As part of the troubleshooting procedure, the cable tech had me try the bad card in both slots (the problem followed the card). As the OP described, the card was 'not in proper operation' according to the TiVo cablecard menu. Eventually he left me with two new cards and took the problem card away (along with its functional brother). No cablecard problems since (although I still get partial recordings about once a week).
     
  8. slimoli

    slimoli New Member

    358
    0
    Jul 29, 2005
    when the "firmware upgrade" comes up:

    -It's not the cableco sending the upgrade , it's the cablecard provider, either SA or Motorola. Yes, they have the ability to send upgrades through the cablecos servers. The cableco doesn't know when they do it and their customer service doesn't have a clue on what's going on (as usual).

    -The reason why the S3 or any other device locks during the upgrade is because the cablecard uses the tuners to process the new coding. Some devices are not ready to support the upgrade and some times require it's own upgrade to accept a cablecard upgrade. My Mitsubishi TV doesn't process the upgrade and locks until the cablecard is replaced. My Panasonic plasma can now process the cablecard upgrade because it had a firmware upgrade to support cablecard upgrades.

    Sorry if I made things even more confusing...

    Sergio
     
  9. Roderigo

    Roderigo New Member

    531
    0
    Mar 11, 2002
    Brookdale, CA
    Huh? Where'd you get this information? The upgrade has to come from the headend. So, unless the cable company is giving some amount of remote administration to the card/headend provider, they know when they have an upgrade.

    This is true for SA Cards. Motorola actually uses the OOB tuner to get it's firmware upgrades, which doesn't require annoying the user by grabbing the video's tuner.

    While it's possible there are bugs in any device out there. If a device can't handle a cablecard upgrade, it shouldn't be in the field. Firmware upgrade is one of the tests that any cablecard host needs to pass to gain certification.

    However, it does appear that the SA cards are not very robust when there's some sort of failure (potentially outside of the control of the host device). For example, if a card gets pulled out in the middle of a firmware upgrade (or the power goes out). This can wedge the card, and whenever it's reinserted it will go into firmware upgrade, but never finish. There's a way to unwedge it, but I'm guessing the cable companies don't know how to do that and/or, the installers just take the cards back to the office, and thrown them back into the stock of cards, without unwedging them first. As soon as that cards put into a new host, it will see the same problem.
     
  10. slimoli

    slimoli New Member

    358
    0
    Jul 29, 2005
    The cablecard firmware upgrade was sent by SA through the cableco server. I had a conference call with SA and the chief engineer of Atlantic Broadband for a different reason but according to the SA guy they were sending the upgrade and my cableco didn't know that. When I did a firmware upgrade to my Panasonic plasma this was specifically because of the cablecard firmware upgrade. The latest version of the SA cablecard firmware is the 149 and can be viewed using the cablecard diagnostic screen.

    After reading hundreds of posts here I came to the conclusion that the motorola cards are much more reliable.

    Sergio
     
  11. stevenj68

    stevenj68 New Member

    3
    0
    Jan 4, 2004
    Arlington, VA
    I had this happen to me too with Comcast and SA cards. CC2 got "stuck". I didn't check the tv for a couple of days and missed some recordings.
     
  12. laffingleigh

    laffingleigh New Member

    4
    0
    Dec 14, 2006
    New York City
    Here's an update to my situation:

    Last Wednesday: situation above occurs

    Last Friday: My scheduled rewire so I can address the problem. I SLEEP THROUGH THE GUY BUZZING MY DOOR. Oops! I call to reschedule and the biznitch supervisor explains that since we don't have on record (i.e. in print) in the last 30 days that I have low signal, a rewire cannot be scheduled free of charge. We argue for a good 10 minutes. She wins. I'm pissed.

    Today (Tuesday): Knowing more than I previously did, I literally sat my Cable guy down on the couch and forced him to follow the instructions to the LETTER. Guess what appeared this time? A grey MMI screen!!!! HA! So it WASN'T the TiVo. Idiots.

    I call TiVo while my cable guy is here to make sure I have all bases covered. Looking into the CableCard diagnostics, we find a message that says CP awaiting authorization. TiVo customer service explains that this message implies that it's them, not TiVo. After 5 "hits" from the Cable Company, nothing changed and no channels appeared, so it looks like I'm still TiVoless until Friday, when the rewiring guy comes (again).
     

Share This Page

spam firewall

Advertisements