1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

C125 error for 3 weeks -- no end in sight -- cannot connect to Tivo service

Discussion in 'TiVo Coffee House - TiVo Discussion' started by Greg Russell, Feb 25, 2018.

  1. SusanA

    SusanA New Member

    3
    1
    Mar 4, 2018
    My router is model R6400v2. I just tried connecting after disabling IGMP, but it still doesn't work. Same error. At least I know I can periodically phone-fix it....
     
  2. JoeKustra

    JoeKustra in the other Alabama TCF Club

    12,431
    1,635
    Dec 7, 2012
    Ashland, PA...
    Oops. I meant R8000. Your router is old, but not that old. It should work unless some update broke it. Netgear likes to change software. If you Google "Netgear Routers" there are a lot of scary results.
     
  3. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    988
    134
    Jul 9, 2001
    Central Jersey
    Since all of the relevant troubleshooting information resides in THIS thread (along with 25 out of 26 of your total post history o_O ), I'm going to reply here since IMO you haven't solved anything - yet...
    I've been following this thread on my tablet from my couch due to health problems (need to keep my legs raised) and I was waiting since last Tuesday for you to return. While I'm not professionally IT trained, I do a great deal of reading (retired / disabled) so I have some 'thoughts' for you.

    I spent several hours today reading about Google Wifi, Google Wifi w/ TiVo, and router ports (Open, Closed, Forwarded):
    • AFAICT, Google WiFi is a 'hardware limited / function limited / wifi enhanced' router. You can learn a great deal about it by reading MANY user reviews on either Amazon or Newegg - skip the 'commercial' reviews from CNet or Engadget, etc... ; they don't say anything bad. Look at the top positive and top negative reviews on Amazon and you'll see the problems / limitations with your product. Pay special attention to the comments regarding Wifi printer problems and the forced 192.168.86.x subnet.
      .
    • I found the FAQ for Google WiFi and entered 'TiVo' into the SEARCH box - it works for MANY people, so all this BS you've been getting from TiVo and Google CSRs about closed ports is just that - BS. Unless *YOU* specifically created a rule in your router(s) to block ports 37 and 123, they're open for business. You DO NOT have to Port Forward ports 37 and 123 - that's not how they work. I came across a good write up at "DD-WRT Port Forwarding".
      .
    • Finally, although many regular TCF users have tried to present 'logical' troubleshooting ideas, I personally feel that the details of the Google WiFi setup are being overlooked - i.e. it's NOT like any other router.
    So, while I'm 'off the couch', I'm going to SUBMIT this post and then REPLY individually to a few of the past weeks posts where I have ideas.

    #1 Idea:
    DOUBLE NAT

    Edit: Subnet typo :oops:
     
    Last edited: Mar 8, 2018
  4. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    988
    134
    Jul 9, 2001
    Central Jersey
    Please describe your LAN *BEFORE* you installed the Google WiFi. List make and model of modem, router, switches, etc... What was the 'route', wire wise, between your internet entering your home and your TiVo unit?
    STOP, DO NOT PASS GO, DO NOT COLLECT $200 :cool:

    Until you solve this, all of the other BS is irrelevant. And, since I inadvertently inflicted this problem on myself a few weeks ago (I disabled the Time Service in DD-WRT), I feel confident in stating that you lost access to Port 37 on the one TiVo server that the TiVo Load Balancer server has assigned to you. [Thanks @kdmorse! :thumbsup: ]

    When MANY folks recently had this problem (Fails while attempting to set the clock), the TiVo server was down - nothing you could do but wait. But, since you're the only one with the problem, we can 'assume' the server is up and your router(s) is the problem.
    I my previous post, I recommended the write up at "DD-WRT Port Forwarding". In a nutshell, if an EXTERNAL PC needs to contact let's say a web server running on your LAN, you would Port Forward Port 80 to the local IP of the PC running the web server. But if an INTERNAL PC (or TiVo Unit) on your LAN contacts an EXTERNAL computer and gives it instructions on which port to reply on, Port Forwarding is not required. IT professionals can explain this better but the point I want to make is that you do not Port Forward Ports 37 and /or 123 to a specific IP. If the router firewall is not blocking them, that's good enough.
     
  5. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    988
    134
    Jul 9, 2001
    Central Jersey
    The Google WiFi has 2 gigabit ethernet ports - whether the port is WAN or LAN is decided by the setup app that needs to connect via wifi from a 'phone' (I'll assume a tablet will also work).

    This is my first suspect - if the modem we're talking about here is really a modem/router, then the modem/router may be on one subnet while the Google WiFi is on 192.168.86.x (Hard coded via a reviewer on Amazon).

    From what I read about Google WiFi today, they say to connect the first 'puck' as a router and all subsequent 'pucks' as bridges, IIRC. If the OP's modem is a modem/router, then Double NAT exists with two DHCP servers. If the Google WiFi first 'puck' is connected to a modem, everything is fine. Otherwise, either the modem/router needs to be setup in 'Bridge Mode' or the Google WiFi first 'puck' needs to be setup in 'Access Point' mode (and I haven't researched this).
     
  6. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    988
    134
    Jul 9, 2001
    Central Jersey
    I don't know if the Double NAT would affect this - beyond my IT knowledge. I would think that it would be the same as the "Wifi printer not found" problem w/ Google WiFi so I would GOOGLE that line of questioning for more answers.

    Folks on the Google WiFi FAQ with TiVos have had mixed results in getting minis to see TiVos but I didn't read any complaints about TiVos not able to get their clocks set.
     
  7. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    988
    134
    Jul 9, 2001
    Central Jersey
    Connecting via a computer (using w32tm if on Windows) is not the same process as ntpdate under linux. When I disabled the Time Service (too lazy to check the 'correct' title) via DD-WRT on my router, my Windows PCs and 2 out of 3 Roamios still connected fine. Then one day around two weeks later I noticed that my Roamio OTA 1TB hadn't successfully connected in the same amount of time since when I changed that setting in DD-WRT. It was also the only Roamio of my three that didn't have a Port 37 error. Once I removed the 'block' in DD-WRT, everything went back to normal and the OTA 1TB was immediately able to complete a successful connection (Load Balancer Server - @kdmorse :thumbsup: ). And Port 37 tested successful too.
     
  8. ClearToLand

    ClearToLand Old !*#$% Tinkerer!

    988
    134
    Jul 9, 2001
    Central Jersey
    @GBL,

    Thanks for all of the log 'tips'! :cool:

    @GBL ,

    How do *YOU* specifically open those two ports on your router? :confused: What make and model is it?

    @JoeKustra, thanks for the mark tip! :thumbsup:

    129.6.15.27 is time-d-g.nist.gov but last time we were referencing 204.176.49.10 which is sjr1.tivo.com. I wonder if that's a difference between H1 and H2?

    Edit (totally forgot that TiVo 'temporarily' redirected NTP requests around 2/9/18) :oops::
    As I see it, those 4 IPs are 'peers' and as long as *ONE* is working, TiVo Corp. is not concerned. As was discussed in the aforementioned "Roamio Two Minutes Off" thread, hard coding the IPs is not 'best practice'. I'm curious to know if a Roamio has exactly the same 4 IPs hard coded in it - anyone know? My guess is that the older units are assigned to H1 which has Port 37 open and the newer units are assigned to H2 which has Port 123 open. My newer OTA 1TB was put on H1 because of the S1, S2, S3 units that 'left'.
    When server H1 went down a while back, it stopped EVERYONE who was Load Balanced to it from connecting. When I blocked access to Time in DD-WRT, it stopped my OTA 1TB from connecting. Yes, there is a relationship between Port 37 SUCCESSFUL and which server TiVo has assigned your unit to. ;)
     
    Last edited: Mar 8, 2018
  9. GBL

    GBL covert opiniative

    1,862
    41
    Apr 20, 2000
    Twin Cities, MN
    Thanks! I'm just repeating what I learned here at TCF over the years.

    I don't need to open any ports on my router, they are open by default. I only asked because the OP mentioned that he "opened" them and I was wondering what specifically he did.
     
  10. HerronScott

    HerronScott Well-Known Member

    5,570
    561
    Jan 1, 2002
    Staunton, VA
    I was wondering as well. Did he mistakenly open them inbound since as you indicated, at least on most routers, the ports are already open outbound.

    Scott
     
  11. mattyro7878

    mattyro7878 Active Member

    569
    66
    Nov 27, 2014
    And we wonder why Tivo hasnt gone mainstream. I like to think I have a little tech savvy but this thread is way over my head. I can unplug and replug my router! Is that good? If I started going into router settings there could be some serious casualties.
     
  12. JoeKustra

    JoeKustra in the other Alabama TCF Club

    12,431
    1,635
    Dec 7, 2012
    Ashland, PA...
    I know the date when I stopped having the Port 37 errors. How can I find out what is my TiVo assigned server?

    It was 10/29/17, the day Hydra started its life.
     

Share This Page