Bought New Router, can't connect, N18 Error Msg

Discussion in 'TiVo Help Center' started by eastmeon, Aug 7, 2011.

  1. Aug 7, 2011 #1 of 18
    eastmeon

    eastmeon New Member

    16
    0
    Feb 16, 2010
    Hello - any assistance is greatly appreciated.

    My TIVO Premiere was ethernet connected to my Belkin G Wireless router and worked just fine. I chgd to a Belkin N150 Wireless router BUT still kept the TIVO connected with ethernet, now the TIVO fails to connect to the Belkin to update - N18 is the error msg. I chgd it back to the old G router and of course, the TIVO updated just fine. So my basic knowledge tells me for whatever reason presently, the TIVO & the new N router do not communicate to each other & that something needs to be adjusted on the router.

    I called TIVO - they told me to unplug the TIVO and then plug it back in to try to reset it, that didn't work. I have tried calling Belkin but outsourcing does create communication issues.

    I am a novice with this sort of thing so any help in simple terms to walk me thru a fix is greatly appreciated. Thanks so much in advance.
     
  2. Aug 7, 2011 #2 of 18
    lillevig

    lillevig Cold in East Iowa

    1,778
    1
    Dec 6, 2010
    Marion, Iowa
    If you are doing wireless to the Tivo then you need to make sure that the Tivo is correctly set for the encryption type and password generated by the router. It is also possible that the new router is set to "N-only" instead of "Mixed mode" which would allow either G or N communication. That would be a problem if your wireless receiver connected to the Tivo is a G device.
     
  3. Aug 7, 2011 #3 of 18
    lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    Since you stated that you were connected by Ethernet, I assume that means "wired Ethernet", so there are a few possibilities.

    Is anything else connected to the new router able to access the internet? In that case, the switch port to which the TiVo is connected might be bad.

    Does the new router have a firewall? If so, try disabling it.

    Check the network status on the TiVo.

    Restart the TiVo with the new router in place.
     
  4. Aug 7, 2011 #4 of 18
    eastmeon

    eastmeon New Member

    16
    0
    Feb 16, 2010
    yes, the TIVO is connected by wired ethernet; I do not use wireless for TIVO or ing for that matter in my house even though the router has that capability. That being said, it isn't an encryption issue.

    My laptop & tower all use the same router with wired ethernet and they all work fine. When I used the old G Belkin router with wired ethernet, evertying including TIVO was able to access the internet. Once I switched to the new N Belkin router, all my wired devices work fine with the exception now of the TIVO box. Thats when I now get the N18 message.
     
  5. Aug 7, 2011 #5 of 18
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,688
    920
    Apr 6, 2000
    SF Bay Area
  6. Aug 7, 2011 #6 of 18
    eastmeon

    eastmeon New Member

    16
    0
    Feb 16, 2010
    thank you ThAbtO for your reply; I looked at that section on TIVO but aside from checking the obvious, for me who is not a techie by a long stretch, I did not have any luck with the explanation given.


    I know it works and likes my old G router so it is something with or in the setup of this new N. BTW, the new N router is still set to factory settings, I have not attempted to make any changes to it yet.
     
  7. Aug 7, 2011 #7 of 18
    lillevig

    lillevig Cold in East Iowa

    1,778
    1
    Dec 6, 2010
    Marion, Iowa
    Ok, I misunderstood that this is a wired connection. Something I found when I hooked up my HD unit (wired connection) was that it was not able to get a network address on its own. I went into the connection setup and hardcoded a network address and it has been aces ever since. Most routers have a base address of 192.168.1.1. I set my HD to use 192.168.1.63. It's worth a try.
     
  8. Aug 7, 2011 #8 of 18
    eastmeon

    eastmeon New Member

    16
    0
    Feb 16, 2010
    Thank you lillevig for your suggestion - where do I make that IP address change? somewhere on the router or with the TIVO in messages/settings/etc.

    As I said, I am less than a novice with this sort of stuff and basically needs step by step directions or TIVO for dummies. :confused:
     
  9. Aug 7, 2011 #9 of 18
    ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,688
    920
    Apr 6, 2000
    SF Bay Area
    In your network settings, after you choose to either have DHCP give IP or set your own.

    Under DNS server, i set mine to the address of my router, usually 192.168.1.1. I never have problem after that, not even when I had tried changing my router, although I went back to the old router.
     
  10. eastmeon

    eastmeon New Member

    16
    0
    Feb 16, 2010
    Hi ThAbtO.....just to make sure I am doing this correctly if you don't mind:

    In Tivo Central
    Settings & Messages.....Settings....Network & Phone...Change Network Settings....LET ME SPECIFY A STATIC IP ADDRESS???


    Next screen reads "you'll specify a static IP address. To complete this process you will need to know the following:
    IP Address
    Subnet Mask
    Gateway (router) address
    DNS (name server) address

    press select to continue......Is this where you are saying to go to change the DNS which is the last thing mentioned above?

    For whatever reason when I view the info right now under Network Status it tells me the IP address is 192.168.2.9

    sorry to be so time consuming, but I have no clue as I said with this sort of technical stuff. thank you for your time and input
     
  11. HomeUser

    HomeUser Active Member

    2,452
    13
    Jan 12, 2003
    A2 Michigan
    Changing the settings from Get Automatically to "LET ME SPECIFY A STATIC IP ADDRESS" will require additional information you probably do not know. The current IP address 192.168.2.9 looks valid for the Belkin router with factory settings. What are the other values?

    • Try accessing the TiVos web page using your computers browser http://192/168.2.9
    • Run the network tests in From TiVo Central select "Messages & Settings" -> "Settings" -> "Network & Phone" -> "View network diagnostics".
      • If there is any failure with the DNS resolution test try accessing some web pages from your computer connected where your TiVo is currently.
      • Any port errors then turn off the sPI firewall or other port blocking configurations in your Belkin router. To turn off the firewall bring up the Belkin configuration pages of the router http://192.168.2.1 in you browser. There is no password just select “Submit” (Recommend that you set one later) look through the pages and turn off the sPI firewall (probably in advanced Tools & settings) then save the settings.
    When you are in the routers setup it would be good to do the firmware update I think the N150 has a setting to do that automatically.
     
  12. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,688
    920
    Apr 6, 2000
    SF Bay Area
    It looks like your new router is setting IPs to 192.168.2.xx, so you can choose any number for the 'xx' and set it there.

    255.255.255.0

    Set to your router's IP, looks like its 192.168.2.1. I assume your old router is 192.168.1.1, and that is perhaps why the Tivo will not connect.
     
  13. lillevig

    lillevig Cold in East Iowa

    1,778
    1
    Dec 6, 2010
    Marion, Iowa
    Sounds like you are getting some good advice. You can verify the IP address of your new router by bringing up a browser window and typing in the following address:

    http://192.168.2.1/

    It should bring up a login screen for your router. I strongly recommend that you log into your router and set up wireless encryption even though you won't need this step to get your Tivo working. You do not want your neighbors, etc. being able to access your wireless connection. If your new router didn't come with instructions for doing setup, then an online search should turn up the info you need.
     
  14. lpwcomp

    lpwcomp Well-Known Member

    9,461
    298
    May 6, 2002
    John's...
    Doubtful.

    I recently went the other direction. My Belkin got fried and all I could afford to replace it was a refurbished Linksys. There is nothing to change on the TiVos and all of them work fine.

    Make sure your new router is setup the same way as your old one - DHCP enabled, PPPoE, etc. Verify that something else plugged into the switch slot you are using for the TiVo works for a different device.

    Restart the TiVo.
     
  15. Tony Chick

    Tony Chick Member

    190
    0
    Jun 20, 2002
    Sherman...
    Everything needs to be on the same subnet, which is specified by the subnet mask 255.255.255.0
    That is telling it that the first 3 digit groups in the IP address specifies the subnet, so if the router is on 192.168.2.xx then everything else needs to be too, something with 192.168.1.xx wouldn't even see it. You could theoretically open up the subnet to just 192.168.xx.xx by changing the mask to 255.255.0.0 but I wouldn't recommend it.
     
  16. eastmeon

    eastmeon New Member

    16
    0
    Feb 16, 2010
    thank you all - I think I am ready to call in the Geek Squad or someone like that - I just don't know what IP # goes where on what.

    thanks to all again - appreciate the input.
     
  17. CuriousMark

    CuriousMark Forum Denizen

    2,620
    3
    Jan 13, 2005
    SoCal
    Do you use a DSL connection for your internet connection? If so, go into your router settings and try turning the MTU down to 1492. I bet if this works, that your old router had this number turned down too.
     
  18. HomeUser

    HomeUser Active Member

    2,452
    13
    Jan 12, 2003
    A2 Michigan
    You don't need to know, that is what the "Auto mode" in the setup is for the router tells the TiVo what IP's it needs. Setting it up manually is really for the advanced users.

    To simplify the trouble shooting.
    - Verify the TiVos has a connection to the local (inside your home) network by viewing the TiVo's built in page in a browser HTTP://TiVosIPADDRESS. (it was 192.168.2.9)

    If you can see the TiVo's page then the problem is with the advanced security settings in your new router blocking the TiVo from using the internet.

    If you can not see the TiVo's page there is a problem on the local network possibly a bad port on the new router.

    In any case if you are not comfortable changing the settings it might be a really good idea to have the Geek Squad setup the wireless security in your router.
     

Share This Page