Blank screen when turning tv on

Discussion in 'TiVo Edge' started by rfa5, Dec 2, 2020.

  1. Dec 2, 2020 #1 of 13
    rfa5

    rfa5 New Member

    25
    3
    Jan 1, 2018

    Advertisements

    I just got a new Edge and I'm going crazy trying to figure out what's going on. All hooked up well, cable card activated (needed a little help from FiOS) and 4 Mini VOX all hooked up and working. Often, when I turn on the tv that is attached to the Edge I get a black screen with the message from my tv saying nothing is connected to this input. Unplug and plug in the HDMI and it starts working so I figure must be a bad HDMI connection...even though it was the same cable that was there using my old Bolt. Change the cable and same thing happens...again it's not every time I turn it on, but it does happen quite often. Change the cable to now a third cable...the two different ones I try are brand new, one is mine that I had and the other was the one that came with the Edge. I change the HDMI input on the tv that I'm using figuring that maybe the input is giving me trouble on the tv end, even though the tv (Sony XBR-65A9G) is less than a year old. Rebooted both the Edge and the tv, made sure Edge was not in any type of power saver mode and double checked all the settings...all look good. At this point I'm thinking a bad HDMI connection inside the Edge. The whole while the minis work fine so it's definitely something with the tv/Edge connection. Any ideas? I'm thinking I'll be sending this Edge back to Tivo. Thanks!
     
  2. Dec 2, 2020 #2 of 13
    kpeters59

    kpeters59 Well-Known Member

    3,172
    651
    Jun 19, 2007
    Houston, Texas
    Probably some kind of HDMI HDCP mismatch.

    Are you putting the TiVo in 'Sleep' mode when tuning off the TV? Possibly CEC (Wake With TiVo) is. Turn that off in settings.

    If there's an A/V Receiver involved, try altering the 'turn on' sequence to see if that helps. Give each device enough time to 'fully' turn on before turning on the next device in the 'chain'.

    Also, try setting the Edge to 1080p only.

    Report back.

    -KP
     
  3. Dec 2, 2020 #3 of 13
    rfa5

    rfa5 New Member

    25
    3
    Jan 1, 2018
    No sleep mode nor any power saving functions. All settings are off. CEC is not used and is set to No (off)

    No AV Receiver involved

    It's a 4K tv so I did try setting it in Auto as that's what recommended. Then I did try it in 4K 60 fps (it's listed as recommended in the menu)
     
  4. Dec 2, 2020 #4 of 13
    justen_m

    justen_m Cheesehead TCF Club

    10,438
    855
    Jan 14, 2004
    Boise, ID
    Yeah, doesn't sound like a hardware problem. Maybe firmware, most likely HDMI handshake related. New HDMI cables didn't help. I suspect you'll have the exact same problem with a replacement Edge. A different model/manufacturer of television may help.

    e.g. If I switch my AVR input to my Bolt when my TV is off, then turn on my TV, there is no picture. I have to switch inputs on the AVR to something else, then back to the Bolt, to get the picture through to my TV. This is NOT a problem with my Roamio Plus or Sony Blu-ray player. Just the Bolt. If I turn on the TV before switching the AVR input to the Bolt, everything works fine.

    I know you don't have an AVR involved, but HDMI handshakes can be a PITA sometimes. Instead of unplugging and replugging the HDMI cable from you TV, maybe just try toggling inputs on your TV, like I do with my AVR.
     
  5. Dec 2, 2020 #5 of 13
    rfa5

    rfa5 New Member

    25
    3
    Jan 1, 2018

    Advertisements

    An interesting note is that I never had an issue with my Bolt and this tv. The tv is a newer model, it came out after the Bolt was was introduced, but the Edge is newer than the tv. You would think that the newest Edge would have these compatibility issues resolved. Not expecting much but I'll give Tivo a call and see what they say!
     
  6. Dec 2, 2020 #6 of 13
    dmk1974

    dmk1974 DA BEARS!!!

    730
    76
    Mar 7, 2002
    Cary, IL
    Sounds similar to an issue I have been having the past couple weeks with my Mini Vox. I bet they fubbed up the latest software releases on both TE3 and TE4.

    Weird Mini Vox Sleep/HDMI Issue
     
  7. Dec 2, 2020 #7 of 13
    Edwin Shenk

    Edwin Shenk New Member

    8
    4
    Nov 29, 2019
    This is interesting. I have an Edge and the same Sony TV as you. I am connected with eArc to a Denon receiver for sound. I bought the TV in March 2020 and it worked perfectly for about 3 months. I then got the problem you mention. I bought new HDMI cables that were rated as the best for high frequency transfer. The problem persisted but was less often. When I get the no input message I just click the input button on the remote and cycle back through the inputs until I'm back to HDMI 1 (the Edge connection) and press the OK button. It always gets the connection and the TV works, sometime within a couple of seconds, rarely as long as 40 seconds. Because of the eArc connection I press the OK button when the input is on the eArc input before continuing. I'm not sure if this step does anything but it worked the first time and I haven't changed. I will try skipping this step next time to see if it makes a difference. Lately the problem has become less frequent. I suspect that this might be a result of a firmware upgrade to the Sony TV or the Tivo Edge. After reading your note I think it is related to the Sony A9G.
     
  8. Dec 2, 2020 #8 of 13
    MrDell

    MrDell Active Member

    233
    62
    Jul 8, 2012
    Rhode Island
    I have a Sony Tv (65X950G) also and this happened to me the other day with my Bolt! I was thinking it may be a TiVo software update. What I did is hold down the power button on the Sony remote and it rebooted the Tv and all has been well since. I think something is not quite right with TiVo servers because every so often I get the spinning circle when clicking on to watch a recording. It has not been too bad the last few days thank goodness
     
  9. Dec 3, 2020 #9 of 13
    Steve

    Steve TiVowner since 1999

    1,273
    281
    Apr 23, 2003
    White...
    To everyone having Edge HDMI issues, if you haven't already done so, try turning off "Auto HDR" in the A/V settings. I found that solved some of my issues.

    And according to TiVo tech support, you must use a high speed HDMI cable with HDR and 4k/60p capability. Preferably one with this certification: Premium HDMI® Cable - HDMI
     
    tommage1 and bobzilla like this.
  10. Edwin Shenk

    Edwin Shenk New Member

    8
    4
    Nov 29, 2019
    Thanks MrDell. I tried your suggestion. I've turned the set on several times since the reset. It always worked but there were three different sequences. The first is an immediate picture. The second is a approx. 10 second black screen followed by the picture. The third is the most interesting. I get he black screen followed by the no input message and then the picture. This sequence takes about 3-4 seconds. I've only restarted 10 times so far but this is a big improvement.
     
  11. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008
    Are you running TE4 (Hydra) with pre-roll ads before recording starts? If so, that may be the problem. You might be able to call Tivo and "opt out" of the pre-roll ads.
     
  12. MrDell

    MrDell Active Member

    233
    62
    Jul 8, 2012
    Rhode Island
    Actually I am running Hydra but I called and had those annoying adds disabled. I really don't mind Hydra but I think it may use more resources than TE3 and sometimes may lead to these slow downs.
     
  13. tommage1

    tommage1 Well-Known Member

    1,947
    454
    Nov 5, 2008
    Yes. The Edge creates a pseudo HDR output for non HDR content when this setting is on. The Bolt does not. I've gotten black screen when connected to an HDMI 1.4 input on TV (I did not know it was 1.4, not in manual, TV only has one HDMI 2.0 input). I'd leave auto HDR off with Edge unless going to be playing some actual HDR capable content and are connected to an HDMI 2.0 input with the correct high speed cable also. So much for "recommended" on for the HDR setting.
     

Share This Page

spam firewall

Advertisements