Big files not transferring from Mac to TiVo

Discussion in 'TiVo Home Media Features & TiVoToGo' started by jpaul34, Jun 5, 2009.

  1. Jun 5, 2009 #1 of 61
    jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005

    Advertisements

    Apologies if this was already covered elsewhere... I searched but could not find anything relating to my specific problem.

    I have a Mac Mini OS X 10.5.7, running TiVo Desktop 1.94 (055) and have a TiVo HD. I am having trouble transferring big files (mpeg, 4-5 GB) from the Mac to the TiVo. I'll set it up to transfer and then it will work for a while and then stop -- the file never makes it over to the TiVo.

    I read elsewhere that a hard reset might fix this problem, and I am able to transfer big files after a reset, but I'm wondering if there's a way to solve this problem without unplugging the TiVo every time I want to transfer a file.

    Also, I also tried to transfer "Casino Royal" (10 GB) and it never worked, even after a reset. I had to rip a DVD and watch it that way. Smaller files (< 2 GB) transfer without a hitch.

    Thanks in advance for the help.
     
  2. Jun 5, 2009 #2 of 61
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    This might be an issue with your home network. I certainly haven't had problems transferring large files from a tivo series 3 to a mac..

    One thing to try is to log in to your tivo at
    https://(tivoip)/

    (note the httpS -- the S is important). the username it will want is "tivo" and the password is your media access key. Try transferring from the tivo that way, so you can see what's going on. It may also help you rule out the tivo vs tivo desktop.

    It may be your tivo trying to get a new IP address while the transfer is ongoing.. Make sure your home network always gives it the same IP address.

    If you think it's tivo desktop's fault, try using iTiVo or kmttg instead.
     
  3. Jun 5, 2009 #3 of 61
    jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    Thanks, but just to be clear -- I'm having trouble transferring from the Mac to the TiVo, not the other way around.

    The "Casino Royale" recording transferred from the TiVo to the Mac just fine, but I was unable to get it back onto the TiVo a few months later.

    does (tivoip) represent the TiVo's IP address? when I click on that link it gives me a connection error.
     
  4. Jun 5, 2009 #4 of 61
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    wow.. I must be smoking some GOOD stuff :)
    sorry.. then in that case, DEFINITELY drop tivo desktop and use pyTivoX . tivo desktop for pushing to the mac has been causing no end of headaches for people :)

    and yes tivoip is the IP address of the tivo (but my previous post should be ignored as I totally misunderstood what you were talking about)
     
  5. Jun 5, 2009 #5 of 61
    jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005

    Advertisements

    I am pretty sure I set this up with a static IP, and when I type that in with the "https" I get the following error from Firefox:

    192.168.15.100 uses an invalid security certificate.

    The certificate is not trusted because it is self signed.
    The certificate is only valid for 652-0001-8040-CE7E

    (Error code: sec_error_ca_cert_invalid)

    so I went through the exception process and was able to see the program list on my TiVo. But since I'm trying to transfer big files TO the TiVo, I don't think this helps me.
     
  6. Jun 5, 2009 #6 of 61
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    It does not help you (as I said.. ignore that reply). The latter suggestion (to use pyTivoX) will let you get around tivodesktop's transfer FROM mac TO tivo...
     
  7. Jun 5, 2009 #7 of 61
    jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    Yeah I wrote that response before I saw your last post.

    I installed PyTiVo and everything seems to be working. (I can play .avi's now? Wow -- I've been having to use Visual Hub to convert to mpegs for the last few months.) I will try to transfer a big file over and see how it goes.

    Thanks!
     
  8. Jun 5, 2009 #8 of 61
    jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    Uh-oh...

    I tried to transfer two files -- a 683 MB avi and a 4.22 GB mpeg -- and neither transferred successfully. The 683 MB file stopped at the 32-minute mark (it's one hour long) and the large file stopped at the 3-minute mark. I tried the large file again, and it stopped at the same point.
     
  9. Jun 5, 2009 #9 of 61
    Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    Hmm.. the fact that it's happening at the same point certainly seems interesting (it suggests there's something at the 3 minute mark causing this)... the hard drive on your tivo isn't full is it?
     
  10. jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    No, it's not full.

    I rebooted the TiVo and tried the transfer again and it's looking like it's working. (It's well past the 3-minute mark.) I'll let you know if it stops working since the point of my thread was to avoid having to do that hard reset. Maybe it's something network related, though I don't know what it could be.
     
  11. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    If it does fail again, can you attach the contents of <user>/Logs/pyTivoX/pytivo.log maybe there's something useful in there.

    Also, if it still keeps happening, you may want to try streaming instead (check under Photos/Music/Showcases instead of Now Playing). Note that this will work for most files, but not .tivo files (if you have those).
     
  12. jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    Okay, I tried a 3.35 GB file and both times it stopped transferring near the end, but not at the same point.

    I'd like to attach that log file for you, but I can't find it. My <user> doesn't have a log folder and when I search for that file name, nothing comes up. Is it hidden?

    The only things that come up when I search for pytivo is the application and the original disk image that I downloaded.

    Suggestions?
     
  13. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    I shouldn't be allowed to type when tired..
    it's <user>/Library/Logs/pyTivoX/pytivo.log

    ( note the library that I totally forgot).
     
  14. jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    I saved the .log file to a textedit file and both are 600 kb, too big to attach. what do you recommend? is there a certain section that you're looking for?

    I've attached the excerpt for what I think is the log text for the last two failed transfers...

    look for "unknown.mpg" -- that's the movie I'm trying to transfer.
     

    Attached Files:

  15. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    well I'm fairly certain the following chunk is the cause:
    Code:
    INFO:pyTivo:192.168.15.100 [06/Jun/2009 09:14:40] "GET /TiVoConnect?Command=QueryContainer&Container=&#37;2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.15.100 [06/Jun/2009 09:34:01] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo:192.168.15.100 [06/Jun/2009 09:34:10] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
    INFO:pyTivo.video.transcode:(32, 'Broken pipe')
    DEBUG:pyTivo.video.transcode:Finished outputing video
    INFO:pyTivo:192.168.15.100 [06/Jun/2009 09:44:02] "GET /Recordings/Unknown.mpg HTTP/1.1" 206 -
    
    but all we really know is that for some reason pytivo is trying to write to the tivo and the tivo has abnormally closed the connection. Which I think we already knew :(

    Is there something going on in your home network that might be opening up more connection to the tivo? (perhaps some background downloader or somesuch?). I've never seen this behavior before and not really sure what would cause it.

    Are you maybe using a wireless network which is randomly but rarely losing connection?
     
  16. jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    Nothing should be connecting to the Tivo other than pyTivo. I have TiVo Desktop on the Mac but it's not running, and I was having the same problems with it when I was using it to transfer big files. This usually happens an hour or more into the download. (i.e. more than an hour of the program has already transferred.) Again, it seems to work after a hard reset, but not if the TiVo has been running for a while.

    The TiVo HD is connected to my network via a wired connection. Can you tell from the code whether or not it could be a router problem? I am using a Linksys router from Vonage.
     
  17. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007

    The error message seems to indicate that pytivo thinks the tivo is still there, tries to write to it, and fails, so aborts.

    I *seriously* doubt it's the router since once both machines have an IP address inside your home network, the only thing the router does is switching packets around to deliver them. Unless it's doing some sort of bizarre firewalling inside your network or has some odd bug, it's more likely to be the tivo.

    Is your tivo acting up in any other way too, or is this the only strangeness? Is the tivo updated to the latest software?

    Hoping someone else might have an idea here, but I think for now your best bet is to use streambaby instead (go to photos, music, showcases) and see if you can stream the show to watch it instead of downloading to the tivo.
     
  18. jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    The same problem was happening when I used TiVo Desktop, so you're right, it's probably something to do with the TiVo. Otherwise, it has been running fine. Plus, it will transfer a big file after a hard reset, so something is happening when it runs for a while that is keeping it from working later on.

    The software version is 11.0c-01-2-652, and it's been connecting fine, so I assume it's up to date.

    I will try using streambaby instead and see how that goes. If anyone has any other ideas, let me know.

    Thanks for your help, Yoav. I do like this pyTiVo software, so this was definitely worthwhile.
     
  19. jpaul34

    jpaul34 New Member

    55
    0
    Sep 10, 2005
    I tried streaming The Dark Knight (6.78 GB mpeg) and it wasn't able to stream the media. I then tried to stream Seven Pounds and after it started, I left for a walk with my wife. When we returned, the TiVo was on live TV, so the stream must have failed.

    I attached an excerpt of StreamBaby log in the hopes that you (or someone) could help diagnose the problem -- maybe it's the same problem keeping the transfers from completing. I tried The Dark Knight twice and then tried Seven Pounds and left...I tried it again when we got back, but my wife ended the stream because she wanted to watch TV.
     

    Attached Files:

  20. Yoav

    Yoav New Member

    1,048
    0
    Jan 12, 2007
    Well, this is the error part:
    Code:
    Sun 2009/06/07 12:30:15.824|   |Acceptor|Factory|HME receiver disconnected
    Sun 2009/06/07 12:30:15.825|   |Acceptor|Listener|ctx=HttpRequest /streambaby/ t=java.net.SocketException: Socket closed
    
    It's the same problem as with downloading: For some reason the tivo closes the connection after a while. If you can get your hands on another switch/router so you can for sure rule out the router, then I think there's "something wrong" with your tivo. This is definitely not normal behavior.

    There is no other computer on your home network that is also trying to use the same IP address as the tivo is there?
     

Share This Page

spam firewall

Advertisements