Bad guide data, now its hung?

Discussion in 'TiVo Help Center' started by pppingme, Jan 22, 2020.

  1. pppingme

    pppingme Member

    69
    3
    Apr 21, 2012
    Tivo Roamio (6 tuner cable only version): Several days ago I noticed that guide data was missing, entire gaps, missing a day or more, saying to be announced. I ran guided setup, which took a while, but didn't seem to have any effect.

    Next step, I ran clear guide data & todo list. I started this at around 4pm on Tuesday, by 1am (wed morning) it was still running. Assuming something just got stuck I power cycled, and it went right back into the Clearing Guide data screen (of course promising to only take up to an hour). Now its almost noon, and its still running.

    Am I hosed?

    Except for missing guide data, there haven't been any issues or other symptoms.
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,046
    776
    Apr 6, 2000
    SF Bay Area
    There is 2 weeks of guide data per channel and if you have a ton of channels it would take a long time.
     
  3. TivoJD

    TivoJD Active Member

    349
    64
    Feb 7, 2005
    Polk Co,...
    I have the same issue, two boxes stuck on clearing program info and to do list. Called TiVo and they have no reports of an issue. Please call in if you are experiencing this so they know about it.
     
  4. taronga

    taronga Member

    262
    9
    Nov 15, 2006
    KY
    Ugh, I'm having the same problem here. First gen Bolt (4 tuner) had 2 weeks of slightly wonky guide data, but nothing was scheduled to record during the 2nd week. I've had success in the past clearing data (it tends to develop problems after being accessed via a Mini), but now it's stuck. The maddening thing is I saw this thread earlier and still stupidly cleared the guide info.
     
  5. notmyRovi-epg

    notmyRovi-epg New Member

    3
    0
    Jan 23, 2020
    Anyone check to see if Rovi.corp api is being overwhelmed??? is it a cyberattack?
     
  6. pppingme

    pppingme Member

    69
    3
    Apr 21, 2012
    The "clear guide data" is an offline process, the tivo's nic isn't even active while its happening.
     
  7. JoeKustra

    JoeKustra in the other Alabama TCF Club

    18,495
    3,307
    Dec 7, 2012
    Ashland, PA...
    TE3 or TE4? What's your zipcode and provider? I can run the process on my spare TiVo. I have done a CPI&TDL many times on Roamio and Premiere platforms without issues. Last time was a few weeks ago when they sent my TE3 box a TE4 guide. I could tell by the time when data ran out. But if you would like me to test it, just post the info. I don't have a Bolt.
     
  8. TivoJD

    TivoJD Active Member

    349
    64
    Feb 7, 2005
    Polk Co,...
    I don't want you to hose your TiVo as well. But if you're okay with that possibility, its TE3, 33881, Spectrum Winter Haven standard cable is the selection I use. I've had it happen on a Bolt TCD849500 as well as a basic Roamio 4 tuner TCD846500. But it would have to be when the guide data messes up and you have to be announced on one box when other boxes have guide data filled in (see pictures below). That would be when I would do the CPI&TDL on the box that has the missing data which usually never fills in. If all boxes have to be announced then it usually does fill in.

    See attached, I ran a service connection just now on two different boxes, this was the result, one got garbage and the other filled in. The one with garbage data on 2/5 usually never fills in, so I do the CPI&TDL to get it back so shows will record.
     

    Attached Files:

    Last edited: Jan 24, 2020
  9. taronga

    taronga Member

    262
    9
    Nov 15, 2006
    KY
    I should mention that I'm also running TE3. Damn Tivo is going to force us to 'upgrade' one way or another.
     
  10. TivoJD

    TivoJD Active Member

    349
    64
    Feb 7, 2005
    Polk Co,...
    I've had the bad guide data as described above on TE4 too, its just not a box I use, its just connected so I can see if anything comes up that I might like on TE4, so I really don't care if that one has bad guide data enough to do the clear program info and to do list on it.
     
  11. taronga

    taronga Member

    262
    9
    Nov 15, 2006
    KY
    I just got off the phone with Tivo, and they're sending a replacement box. So I guess there isn't an easy fix.
     
  12. JoeKustra

    JoeKustra in the other Alabama TCF Club

    18,495
    3,307
    Dec 7, 2012
    Ashland, PA...
    I re-ran Guided Setup. No issues. But I went to the channel list and you have a lot of channels. I knew it wasn't going to perform the service connection for about 20 minutes, so I decided to run a channel scan. I have 2 clear QAM channels that can be accessed with a scan. So this added another 400 channels to the scan. I left it alone to do the service connection. When I went back, I could not access the channel list. So I did a repeat of GS and now it's happy and I will check it every day. One very strange thing. My last service connection was 5:20pm. My next scheduled connection is Sunday at 4:00am.
     
  13. NorthAlabama

    NorthAlabama tabasco rules

    10,428
    2,436
    Apr 19, 2012
    sweet home, al
    i've seen this before following a gs and subsequent first connection, it sets the next connection to skip a day - i've always believed it was to give the box time for indexing all the new data following the gs before it looks for more data.
     
  14. pppingme

    pppingme Member

    69
    3
    Apr 21, 2012
    I just put a new hard drive in (mine is probably a bit old, just wanted to verify it wasn't a bad drive), booted up like a new tivo. I'd love to recover the recordings. I may put the drive back in and just let it run its thing for a couple days and see if it comes back. Like I said earlier, the daily call in process was taking forever as well in the loading step. Not sure how or what the clear guide data does (one would think it'd just do a sql drop table, then create, which should take like seconds), but for it to take an hour its probably removing the entries one by one. If I ever get it to boot up on the old one, I may just copy the drive so I have a new drive anyway. I'm grabbing a "dd" copy of the drive before I start.
     
  15. taronga

    taronga Member

    262
    9
    Nov 15, 2006
    KY
    As I expected, my replacement box is TE4 and it's not responding to the rollback process. Damn.
     
  16. TivoJD

    TivoJD Active Member

    349
    64
    Feb 7, 2005
    Polk Co,...
    I was able to get out of the CPI&TDL hang on my Roamio thanks to the folks in the TiVo Upgrade forum with a kickstart code I had never heard of that factory resets and you start over at guided setup (see link below). Lost everything, but at least the box is back working. My Bolt is in the middle of being returned and replaced.

    How to wipe a drive so Roamio will reload software
     
    Last edited: Jan 28, 2020
  17. Mikeguy

    Mikeguy Well-Known Member

    24,700
    7,806
    Jul 28, 2005
    Recommended to keep on trying. The replacement box is not a specifically-denominated Bolt OTA, is it? That model can't be sidegraded to TE3 (nor can the Edge platform).
     
  18. BizzyMarks

    BizzyMarks New Member

    17
    0
    May 21, 2006
    I have a Premiere that did the same thing. Guide data started showing more and more "To Be Announced" entries and manually connecting wouldn't fix it. I ran Clear Guide Data a few times over the past month or 2 and it would temporarily fix it. That is until last week where it was stuck on boot at the "Clearing Guide Data" screen. I cloned the drive and it still got stuck on Clearing Guide Data. It must have been a software issue. I got a clean image and that booted fine. Ran Guided Setup and got 2-3 days of guide data. Manually ran a connection last night, and now each channel has different length of guide data. "Program Information To:" date is 2/14, yet nothing is available after 7pm 2/13 and that's usually a "To Be Announced" which shouldn't be there. I have a few channels that only have guide data till 6pm TODAY.

    I think there is corrupt or unexpected data in the guide data that TiVo isn't able to process and is causing these problems.

    That's bull that they don't have reports. I've reported it for my Premiere. I've seen other users reporting this too.
     
  19. VideoGuyTim

    VideoGuyTim New Member

    6
    1
    May 8, 2019
    I have the same problem with a Roamio OTA (TE3) as of yesterday. Hanging on CPI & TDL. I should have not done this; thought it would prevent future S03 errors if don't connect for a period of time. Was working just fine before the CPI & TDL.
    Looks like I will have to wipe the HDD and start over losing my recordings.
     
  20. JoeKustra

    JoeKustra in the other Alabama TCF Club

    18,495
    3,307
    Dec 7, 2012
    Ashland, PA...
    I was given a KS code that might work to wipe the drive. Look at post 16 in this thread.

    But by pulling the drive I was able to clean the fan and drop my MBT by 2C.
     
    Last edited: Feb 6, 2020

Share This Page