Automatic soft padding running on the TiVo (new version)

Discussion in 'TiVo Series 1 - UK' started by maxwells_daemon, Feb 11, 2006.

  1. Mar 9, 2006 #41 of 394
    PhilG

    PhilG New Member

    905
    0
    Jan 15, 2002

    Advertisements

    Something rather bizarre has happened to my endpad.msg file this week

    It now looks like THIS (according to Tivoweb):

    /var/log/endpad.msg/
    Sunday 16:55:00 : Added 300 seconds end padding to {Stargate SG-1} on SKYONE
    Sunday 18:55:00 : Added 300 seconds end padding to {The Simpsons} on SKYONE
    Monday 12:25:00 : Added 300 seconds end padding to {Judge Judy} on ITV2
    Monday 21:56:09 : Added 300 seconds end padding to {Extraordinary People} on FIVE
    Wednesday 17:55:00 : Added 900 seconds end padding to {World Cup Biathlon} on EURGB
    Thursday 09:25:00 : Added 900 seconds end padding to {World Cup Biathlon} on EURGB
    dded 300 seconds end padding to {Judge Judy} on ITV2
    Wednesday 15:25:00 : Added 300 seconds end padding to {The Mouse on the Moon} on C4
    Thursday 12:25:00 : Added 300 seconds end padding to {Judge Judy} on ITV2

    Notice the partial line that starts "dded 300 seconds ....."
    Also, the entries are NOT in date/time sequence

    Before I stop and restart endpad, could this be a symptom of something more sinister??
     
  2. Mar 9, 2006 #42 of 394
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    Yeah, it made me chuckle too :)

    Having said that, negative padding for the couple of programmes that I use it on seems to be working great.
     
  3. Mar 9, 2006 #43 of 394
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    It would be better if you posted (as an attachment) the actual log file...
     
  4. Mar 9, 2006 #44 of 394
    maxwells_daemon

    maxwells_daemon New Member

    84
    0
    Apr 9, 2005
    Oxford, UK
    That is odd. Can you log into the TiVo and list the file (cat /var/log/endpad.msg)? That would eliminate the possibility of some TiVoWeb problem.

    Did your TiVo crash in the last couple of days? (TiVoWeb info can tell you.)
     
  5. Mar 10, 2006 #45 of 394
    PhilG

    PhilG New Member

    905
    0
    Jan 15, 2002

    Advertisements

    I have FTP'd my log file back up to Windows, and it DOES look like this:

    Sunday 16:55:00 : Added 300 seconds end padding to {Stargate SG-1} on SKYONE
    Sunday 18:55:00 : Added 300 seconds end padding to {The Simpsons} on SKYONE
    Monday 12:25:00 : Added 300 seconds end padding to {Judge Judy} on ITV2
    Monday 21:56:09 : Added 300 seconds end padding to {Extraordinary People} on FIVE
    Wednesday 17:55:00 : Added 900 seconds end padding to {World Cup Biathlon} on EURGB
    Thursday 09:25:00 : Added 900 seconds end padding to {World Cup Biathlon} on EURGB
    dded 300 seconds end padding to {Judge Judy} on ITV2
    Wednesday 15:25:00 : Added 300 seconds end padding to {The Mouse on the Moon} on C4
    Thursday 12:25:00 : Added 300 seconds end padding to {Judge Judy} on ITV2
    Thursday 21:55:00 : Added 300 seconds end padding to ER on E4
    Friday 12:25:00 : Added 300 seconds end padding to {Judge Judy} on ITV2

    Lines not quite in date order, and one line starting "dded ....."

    As it happens, I did have an unexpected reboot on Monday evening if that explains anything

    Phil G
     
  6. Mar 10, 2006 #46 of 394
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    TCL just got itstelf mixed up flushing the file write buffer. Wouldn't stress about it.
     
  7. Mar 10, 2006 #47 of 394
    PhilG

    PhilG New Member

    905
    0
    Jan 15, 2002
    That's what I hoped

    Tivo_stress = low
     
  8. Mar 13, 2006 #48 of 394
    zippy7272

    zippy7272 New Member

    64
    0
    Dec 29, 2004
    I'm still having a bit of trouble

    I hoping to record
    Coronation street from 19:28 to 20:01
    Eastenders from 20:01 to 20:30
    Coronation street from 20:30 to 21:05 (unless the a program on my to do list (not a tivo suggestion))

    Currently I'm using this:

    -s 2 -e 5 sugeq
    -p "Coronation Street" -v Mon/12:00-20:00 -s 2 -n 1 -e 5 sugeq

    and I don't get Eastenders at all (luckily!? it's on again at 10pm)

    Anyone any suggestions
     
  9. Mar 13, 2006 #49 of 394
    tym

    tym New Member

    19
    0
    Sep 28, 2005
    Melbourne,...
    Are these tivo suggestions or real recordings? Suggestions are generally removed to make space for any real recording's padding.

    Can you send the relevant part of the log?

    Tim
     
  10. Mar 14, 2006 #50 of 394
    redav

    redav New Member

    9
    0
    Mar 10, 2004
    Manchester
    I seem to be doing somthing wrong, but for the life of me I can't work it out.

    I copied over the endpad.tcl file and chmod it to 755

    I then started it with /var/hack/endpad.tcl -e 10 -auto >> /dev/null & in my rc.sysinit.author file, but after a few secs I get this error message in my log!

    I do have my recording setting to mode 0 is this whats causing the problem?

    Tuesday 10:38:28 :
    Tuesday 10:38:28 : endpad.tcl 1.5.0 log file, starting up
    Tuesday 10:38:28 : Start padding set to 0 seconds
    Tuesday 10:38:28 : End padding set to 600 seconds
    Tuesday 10:38:28 : Negative start padding set to 0 seconds
    Tuesday 10:38:28 : Force Negative startpadding is 0
    Tuesday 10:38:28 : Suggestions will be padded, even if that means cancelling a subsequent suggestion
    Tuesday 10:38:28 : Detected TiVo software version 2.5.5-01-1-023
    Tuesday 10:38:28 : Suggestion quality change disabled
    Tuesday 10:38:28 : Timezone 00:00
    Tuesday 10:38:28 : Sorted configuration options (last match used):-
    Tuesday 10:38:28 : startpad 0 endpad 10 negpad 0 forceneg 0 maxneg -1 sugeq 1 sugqual -1
    Tuesday 10:38:28 : Woken up
    Tuesday 10:38:28 : Error detected
    Tuesday 10:38:28 : can't read "rectype": no such variable
    while executing
    "if {$rectype == 3} {

    # Recording active
    set isrec 1

    # Get details of currently recording programme
    RetryTransaction ..."
    Tuesday 10:38:28 : Attempting to recover
    Tuesday 10:38:58 : Woken up
    Tuesday 10:38:58 : Error detected
    Tuesday 10:38:58 : can't read "rectype": no such variable
    while executing
    "if {$rectype == 3} {

    # Recording active
    set isrec 1

    # Get details of currently recording programme
    RetryTransaction ..."
    Tuesday 10:38:58 : Attempting to recover
    Tuesday 10:38:58 : Too many errors, stopping

    :(
     
  11. Mar 14, 2006 #51 of 394
    redav

    redav New Member

    9
    0
    Mar 10, 2004
    Manchester
    Hi

    I've just read through the old endpad thread (well some of it anyway) and I've found the answer.

    However is there no way around having to have at least 2 recordings in the TDL?
     
  12. Mar 14, 2006 #52 of 394
    zippy7272

    zippy7272 New Member

    64
    0
    Dec 29, 2004
    All 3 records are 'real' recordings rather than Tivo suggestions
     
  13. Mar 14, 2006 #53 of 394
    maxwells_daemon

    maxwells_daemon New Member

    84
    0
    Apr 9, 2005
    Oxford, UK
    and
    Yeah, this is a bug in the log file display. I have a fix, which I'll upload as version 1.5.1 at the head of this thread.

    This behaviour was due to the fact that, internally, the sugeq flag has a default value of 1, and is set to 0 if you specify -sugeq. That's pretty ugly, but made it easier to interface the new configuration parsing with the reversed flag used elsewhere in the code, while maintaining compatibility with older versions. The new version just prints "sugeq" if the internal value is 0.

    Version 1.5.1 just corrects this confusing log file message. There is no need to upgrade from version 1.5.0 unless such things bother you.

    It is also rather inconsistent that you specify -sugeq as a simple option, but -f (forceneg) as 0 or 1 explicitly. It might be nice to tidy these up eventually (perhaps allowing both forms, for compatibility).

    Tim.
     
  14. Mar 22, 2006 #54 of 394
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    Just had endpad stop on me, see attached log extract.

    Anything to do with endpad or just one of those occassional database screw-ups?

    Thanks.
     

    Attached Files:

  15. Apr 3, 2006 #55 of 394
    Tim Browse

    Tim Browse New Member

    43
    0
    Oct 21, 2000
    I'm just setting up my old Tivo with a new hard disk for someone in my family, and have installed endpad. I tested it by scheduling a few random programs to record.

    As part of the test, two of the programs were adjacent - 'The Royal' was on from 8pm-9pm, and Poirot was on from 9pm-11pm.

    However, no end-padding was added to Poirot - in the log I get entries like:

    So for some reason endpad thinks the gap to the next programme is negative 2 hours - some mistake, surely?

    Anyone got any ideas as to why this would happen?

    Start padding was added ok to 'The Royal', btw, as you would expect.

    The version I'm using was downloaded from this thread last night (v.1.5.1).

    It's a pretty clean Tivo - I have ls/ps/tar/joe installed, and the autospace hack, but that's it. No Tivoweb or anything.

    Tim
     
  16. Apr 3, 2006 #56 of 394
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    What's in the log around the time that Poirot ended?
     
  17. Apr 3, 2006 #57 of 394
    Tim Browse

    Tim Browse New Member

    43
    0
    Oct 21, 2000
    Now that's odd. Well, around the time Poirot ended it's all the same, but I just noticed that endpad thinks the Tivo is still recording Poirot even after it's finished - e.g. the very last log entry mentioning Poirot is:

    So that's at least an hour and a half after it's supposed to be finished (or possibly 2.5 hrs - the times in the log seem to use DST/don't use DST in different places).

    How strange.

    This bit is odd, too:

    I think there was only one episode of Poirot on that evening - the Tivo certainly only recorded one, anyway.

    Tim
     
  18. Apr 3, 2006 #58 of 394
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    That's a completely different showing; the part of the log showing the previous recording is the one I need to see to be able to make a comment (around 2200hrs). The log always uses GMT (1hr behind DST). Perhaps it would be easier if you just posted the whole log file as a .txt attachment?
     
  19. Apr 4, 2006 #59 of 394
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    You can get some odd behaviour with EndPad on an "empty" TiVo as it looks a couple of recordings in advance in normal operation. I don't know how 1.5 handles this, but 1.4 just broke!
     
  20. Apr 6, 2006 #60 of 394
    Tim Browse

    Tim Browse New Member

    43
    0
    Oct 21, 2000
    The reason I showed that is because it kept saying the same thing for hours - so I picked one of the last ones to show that it thought the recording was still going on hours after it had finished.

    Anyway, it seems to be ok now, so perhaps Sanderton's comment about empty Tivos is on the mark - I made sure I had at least 2 items in the To Do list, as recommended before checking to see if endpad was working, but maybe not having any recordings is an issue too.

    I'm afraid the log's been cycled now, so it's gone - sorry.
     

Share This Page

spam firewall

Advertisements