Android Streaming tomorrow??

Discussion in 'TiVo Stream' started by mrsean, Sep 29, 2014.

  1. Oct 1, 2014 #81 of 139
    ZeoTiVo

    ZeoTiVo I can't explain

    25,527
    2
    Jan 2, 2004
    Your reply is a bit confusing but the gist I get is
    If you are connected to your home network, streaming works
    if you have a device on some test network in your house that needs to be routed to see your home network - then streaming does not work for certain shows

    I have TWC and lots of copy protection flags
    I have not tried out of house streaming - but all shows will stream to my tablet while on my home network -

    will try out of home and edit this later


    the way to see the copy protection flags easily if you have another TiVo is to browse the first TiVo and it will show the flags
     
  2. Oct 1, 2014 #82 of 139
    marinrain

    marinrain New Member

    16
    0
    Oct 30, 2001
    Corte...
    Doesn't work on my Samsung Galaxy s5 - AND created error on my SD card - had to reformat!!
     
  3. Oct 1, 2014 #83 of 139
    tatergator1

    tatergator1 Well-Known Member

    2,210
    402
    Mar 27, 2008
    Columbus, Ohio
    Yes, it's only supposed to be restricted when you're outside of your home. There was a lot of debate when iOS first got the feature as to why out-of-home streaming was disabled for shows with the "copy once" CCI-byte. Ultimately, I think it's a CableLabs imposed restriction.
     
  4. Oct 1, 2014 #84 of 139
    Endymion_

    Endymion_ Member

    37
    7
    Sep 9, 2011
    Nonstandard is putting it lightly. You went farther than rooting your device by installing a custom firmware. I wouldn't expect streaming to work even if you could install it for this reason, even if you were to uninstall root or superuser. As for why it won't install, it could be misreporting the device type to the Play store. If you can get ahold of the apk, you can still install it by just getting it on the device, then giving it the right permissions.
     
  5. Oct 1, 2014 #85 of 139
    susandennis

    susandennis Member

    150
    11
    Dec 10, 2001
    Seattle, WA USA

    Nope. I'm getting the exact same results you are. Works great on my MotoX. But, not on the Fire. Sigh.
     
  6. Oct 1, 2014 #86 of 139
    CharlesH

    CharlesH Member

    1,090
    6
    Aug 29, 2002
    Sacramento...
    I am not sure if this is exactly the right place to ask about this, but the update to the Android app that TiVo pushed out the evening of Sept 30 simply does not work for me on my home WiFi. I installed the initial version earlier that day, and set up streaming just fine on my home WiFi, and it worked great. Then I saw that there was an app update, and installed it. This version claims to have added support for the LG G3. Now every time I start the app, after it logs in, it goes into an infinite "Reconnecting" loop. Lots of other reviewers on the Play Store are reporting the same thing, on various phones. I have a Droid Maxx; one reviewer has a Samsung S5. It works just fine on 4G cellular. I have re-installed the app, re-booted my Roamio Plus (which is provides the streaming), and still no success. I haven't seen this discussed yet in TiVoCommunity; maybe I am just not looking in the right sub-forums.
     
  7. Oct 1, 2014 #87 of 139
    caughey

    caughey Member

    323
    23
    May 26, 2007
    Orange County
    Not working on HD 8.9 either, which I think they call 2nd Gen. I suppose any effort to install a newer version would trigger the "root detection" in the app and defeat the purpose.
     
  8. Oct 1, 2014 #88 of 139
    ncfoster

    ncfoster Member

    170
    0
    Jan 22, 2011
    I just updated to a more recent version of the ROM, and I can now install the app. Of course, I still get the "unauthorized modifications" error when I try to stream, which is not surprising.

    Not really sure what specifically was different between the two builds that allowed the install. I know that I went from 4.4.2 to 4.4.4 as far as Android/Kit Kat versions go, but I doubt that was it.
     
  9. Oct 1, 2014 #89 of 139
    ncfoster

    ncfoster Member

    170
    0
    Jan 22, 2011
    As mentioned in my last post, updating to a recent version of SlimKat did solve the problem with installing, but did not get me to streaming.

    I am not complaining or surprised that the streaming doesn't work. I was just surprised that the app does not install, as I have not experienced this with any other app.
     
  10. Oct 2, 2014 #90 of 139
    merleau79

    merleau79 New Member

    16
    0
    Sep 30, 2014
    What I did was use my rooted phone to use the Wi-First tethering so I can connect my tablet to it. And that is when the copy protection flags popped up. If my tablet is connected to the same router as my tablet I can watch all of the shows that my TiVo has recorded, including live TV. If you get it to work please I'M me.
     
  11. Oct 2, 2014 #91 of 139
    merleau79

    merleau79 New Member

    16
    0
    Sep 30, 2014
    So is CableLabs able to detect that a tablet isn't connected to the same router as the Tivo?
     
  12. Oct 2, 2014 #92 of 139
    crxssi

    crxssi Veteran TiVo User

    2,795
    1
    Apr 5, 2010
    No, Cablelabs is a certification/licensing company.
    The TiVo app detects if it is on the same network as the TiVo. Very trivial for it to do.
     
  13. Oct 2, 2014 #93 of 139
    snitm

    snitm Member

    46
    0
    Jul 9, 2006
    the inability to stream on a rooted phone seems to only achieve Tivo pissing off it's more savvy customers. Seriously what is the point? God forbid Tivo customers who want to make full use of the cell phones they pay top-dollar for be able to stream. Tivo is just being complete a-holes with this rooted phone restriction.
     
  14. Oct 2, 2014 #94 of 139
    markp99

    markp99 TakoKichi TCF Club

    12,755
    880
    Mar 21, 2002
    Nashua, NH
    TiVo app is the LAST place I'g go to grab content.
     
  15. Oct 2, 2014 #95 of 139
    TiVoMargret

    TiVoMargret VP Product Dev & Chief Design Officer, TiVo

    364
    113
    Feb 2, 2008
    Silicon Valley
    We're looking for a few volunteers to help us troubleshoot why it is crashing on Kindle Fire.

    If you're willing to help, please email margret@tivo.com with the subject "Kindle Fire".

    Thanks,
    --Margret
     
  16. Oct 2, 2014 #96 of 139
    snitm

    snitm Member

    46
    0
    Jul 9, 2006
    I'd be happy to, except I rooted my Kindle FireHD too. So the rooted restriction basically makes Tivo's streaming efforts useless for people like myself who want to actually make use of devices they paid good money for (FireHD disallows google apps, etc.. only way to have a more feature rich FireHD is to root the device). Companies like Tivo and Amazon need to get over themselves and realize they need to get out of the way of the tech savvy consumers of their devices.

    By rooting my devices I'm able to make use of the device's capabilities -- I'm not doing whatever it is Tivo is paranoid enough to restrict rooted devices over!
     
  17. Oct 2, 2014 #97 of 139
    tomhorsley

    tomhorsley Well-Known Member

    1,663
    213
    Jul 22, 2010
    I'm fairly certain all the paranoia is rooted in Cable Labs and TiVo is merely following their rules.
     
  18. Oct 2, 2014 #98 of 139
    BigJimOutlaw

    BigJimOutlaw Well-Known Member

    3,259
    582
    Mar 21, 2004
    The point is to be able to have a streaming app at all. Everybody knows it's ridiculous, but they still have to play within the rules they're regulated by. They're not in a comfortable industry position where they can ignore rules without repercussions. Tell CableLabs and the cable lobby to grow up. They're the "paranoid" ones, not Tivo.

    Or wait for your rooting software to be updated like everybody else had to.
     
  19. Oct 2, 2014 #99 of 139
    merleau79

    merleau79 New Member

    16
    0
    Sep 30, 2014
    Do you know if there is a way to "trick" the app. Sort of like a VPN on a computer.
     
  20. Oct 2, 2014 #100 of 139
    Dan203

    Dan203 Super Moderator Staff Member TCF Club

    47,114
    4,353
    Apr 17, 2000
    Nevada
    I'm willing to help. Email sent.
     

Share This Page