Amazon Prime missing from menu on Mini; present on main Tivo

Discussion in 'TiVo Mini' started by funchefchick, Feb 4, 2020.

  1. funchefchick

    funchefchick FunChefChick

    21
    0
    Feb 15, 2014

    Advertisements

    I moved to a new area and got issued a new Tivo Series6 and 2 Minis by Wave Broadband (I'm not in a Comcast area for the first time ever).

    Long story short everything is working fine EXCEPT: Amazon Prime does not appear on either of the minis. It appears and works fine on the main Tivo.

    I called Wave support and they had no ideas other than to roll a truck out to have a tech investigate. Since I don't know the Wave folks that well .. . other than asking if there was some magical bit on their end which is preventing Prime from appearing which they could flip, I wasn't sure what to ask them.

    I've unplugged/rebooted the minis multiple times (including unplugging coax at the Wave person's request). Apps all load EXCEPT no Amazon Prime.

    From where does the Mini get its application list? If I had no Prime at all I'd maybe understand, but I'm befuddled about how the main box has it (and it works fine) but neither Mini has it. I didn't see this mentioned in any other posts. It's driving me nuts.
     
  2. JoeKustra

    JoeKustra in the other Alabama TCF Club

    20,125
    3,712
    Dec 7, 2012
    Ashland, PA...
    Amazon Prime was renamed a while back to Amazon Membership. That's probably not your issue. They have to get it onto your Mini boxes. There is also an Amazon Video app, which includes Prime but includes pay-for results when used with Search. I've heard of an app missing on the host, but that is due to a "group" problem (whatever that is). Sorry I couldn't help more.

    You're the third WAVE customer in the last two weeks. They must have just started using TiVo. My cable company now has TiVo, but since it's twice the price of the older stuff, it must not be a big seller. You probably know more about TiVo that they do.
     
  3. funchefchick

    funchefchick FunChefChick

    21
    0
    Feb 15, 2014
    That is probably the case. I just bought a new place and Wave was the least-bad option, and I was thrilled that their 'bundled' DVR of choice was TiVo (don't get me started on the Comcast DVR which I hate with the passion of a thousand suns). Slightly less-thrilled that they only issue one box plus minis because previously I've been a two-TiVo household .. . and they also initially told me that I had to use THEIR TiVo. Since my previous Tivos were all in a box somewhere (it was complicated multi-step move over several months) I figured it was fine.

    Now that I'm getting settled, though … it turns out that my old/existing Tivos ARE supported. I'll just have to pay for Tivo service for them where currently it's included in my cable package. But. I may just go back to my already-owned Tivo boxes because THIS problem is seriously bugging me.
     

Share This Page

spam firewall

Advertisements