Amazon and Netflix apps go to Black Screen

Discussion in 'TiVo Help Center' started by SkyCar, Aug 12, 2018.

  1. SkyCar

    SkyCar New Member

    23
    3
    May 31, 2017

    Advertisements

    Hi, lately, my Amazon and Netflix apps don't work on Tivo Bolt. They just go to a black screen. For a while I just thought they were slow to load, so I've been using my Apple TV to watch those services. But it will stay on that black screen indefinitely -- at least 5 minutes. Hitting the Tivo button returns to the main screen, and the usual Tivo recording and playback functions work fine. YouTube and Hulu apps open up okay. I tried restarting the Tivo, but nothing changed. I have a workaround, so I'm not desparate. But, it should work. I suspect it probably has something to do with friggin' HDCP.
     
  2. anaana

    anaana New Member

    15
    4
    Nov 3, 2008
    I been having the same issues with Netflix and Amazon, but no issue with Hulu. Netflix and Amazon I can login, select the TV show or movie and each will try to play for 2 seconds before I get a black screen. I can go to live tv and everything outside of Amazon and Netflix works. When you call Tivo here are their troubleshooting options. Make sure the HDMI cable Tivo provides goes directly from TV to Tivo box and see if that works. If not, pull the power plug on Tivo box for a minute restart and see if that works. If not, disconnect in my case cable modem and router as well as pull the power plug on Tivo box for a minute. This worked the first time this issue occurred but not the second time I had this problem. When pulling the plug on the Bolt and cable modem did not work, Tivo's solution was to go to Help---> "Reset to Defaults"--->"Clear & Delete Everything". That worked but not sure for how long. I have had the Bolt for a week so there was nothing on there that I could not lose. I told Tivo this is not a solution if this occurs when this box is in full use.

    Here is some info and link I found from Netflix: I'm getting a black screen with no sound..

    Troubleshoot your hardware connection
    Your device may be experiencing an HDCP issue that is preventing Netflix from playing your content. To resolve the issue:

    Ensure that you are using an HDMI cable.

    Bypass any receivers or stereo equipment by connecting your device directly to your TV.

    Try reversing the ends of the HDMI cable.

    Try a new HDMI cable.

    Try another HDMI port on your TV.

    If available, try an HDMI port on another TV.

    If you were able to stream on another TV, there may be an issue with the HDMI port on the original TV. Contact the TV manufacturer for further assistance.
     
  3. V7Goose

    V7Goose OTA ONLY and Loving It!

    1,721
    582
    May 28, 2005
    New Mexico...
    What version of the software are you running? I am seeing this exact problem, as well as other versions of HDMI/HDCP problems on one box where I am testing TE4, but I have never had even a single problem of this type with my boxes running TE3.

    When I see it, generally restarting the box, and usually just putting it in standby briefly, will "fix" the problem until it happens again.
     
  4. Lrovertrevorl

    Lrovertrevorl New Member

    2
    0
    Dec 12, 2019
    Has anyone found the solution to this? I'm about to cancel my TiVo after years because the only thing that resolves this issue ( temporarily) is to remove and reinstall these apps which is such a pain and this happens about once a month for me. I used to think it was worth it to stick with the service for the core TiVo features but now the guide is crappy, always cuts off my shows early and often just decides not to record shows or will mislabel the shows. This is so frustrating....

    By the way, I have contacted TiVo support and the only thing they do is have you remove and reinstall the apps over an hour long phone call. I have no issues with Amazon or Netflix on my phone , laptop or Xbox One.
     
  5. Fugacity

    Fugacity Member

    109
    19
    Oct 1, 2004

    Advertisements

    I'm curious, do you have this attached to an HDR capable TV and does it work normally if HDR is turned off from auto?

    There is an issue with my Edge and my Vizio TV, possibly other Vizio TV owners as the supervisor said others had called in and were told to contact the manufacturer. My problem is different in that it is only Netflix and everything works fine for me unless I have HDR on on the edge for Netflix, then i get similar things to what is posted here. I thought it was a dolby vision issue specifically at first but maybe it isn't. The edge does something different with HDR and this only happens on a Dolby Vision capable TV for me, but if i reboot my edge and wait a minute or so after reboot it will almost always work. So there seem to be a lot of similarities. I can actually get it to work all the time another way but leaving netflix will crash the menues on the Edge and I need to reboot after.

    In my case I check both 4k 60fps and 1080i as options with HDR on. If I go into to netflix the colors will be all off, but chosing and HDR capable show, or maybe any show will work and the colors will be right again. Exiting netflix leaves me with only being able to watch live, trying to pull up the any menu doesn't work, and if its a menue item that makes the tv signal play in the upper right hand corner, that works but where the GUI would be is black.
     
  6. Season Pass

    Season Pass New Member

    18
    3
    Nov 14, 2017
    Same issue with me. live tv is fine, but netflix just hangs black screen nothing reboot and started working no issues before was working fine...
     
  7. Apr 1, 2020 #7 of 18
    sac602

    sac602 New Member

    2
    0
    Sep 24, 2017
    I get this (apps just go to black screen) about 1x/week.

    I have to reboot. This fixes the problem (for a few days). Frustrating.

    Sent from my SM-G986U using Tapatalk
     
  8. Apr 1, 2020 #8 of 18
    Lrovertrevorl

    Lrovertrevorl New Member

    2
    0
    Dec 12, 2019
    Yeah.. It is SUPER annoying. I also have this happen almost every week to both Netflix and Amazon at the same time. So, it can't be an issue with Netflix or Amazon it has to be the Tivo Bolt. I tried to watch a movie with my girlfriend last week on Amazon and reboot didn't help as it sometimes does. I had to uninstall Amazon Prime app to get it to work.

    Does anyone from TIVO monitor these forums? It's crazy that this has been an issue for years.

    And to answer Fugacity
    It seems to have nothing to do with my connected devices / TV. I do not have an HDR TV. I have an old 1080p Plasma which still looks great (enough for me anyway) so I refuse to upgrade until it dies :)
     
  9. Jun 1, 2020 #9 of 18
    Bad_Dog

    Bad_Dog New Member

    5
    0
    Mar 29, 2008
    Ditto. Happens about once a week on my Tivo Bolt.

    Started happening to me only in the past few weeks. Nothing has changed - same TV for the past 9 years, same HDMI cable since I bought the Tivo Bolt.
     
  10. m_jonis

    m_jonis Member

    677
    7
    Jan 3, 2002
    Albany, NY
    I get same thing, although never with Netflix. Only Amazon (it will work once after reboot and 2nd time will lock up Tivo with black screen). Recently Hulu started doing it as well.
     
  11. slowbiscuit

    slowbiscuit FUBAR

    4,699
    634
    Sep 19, 2006
    In the ATL
    *sigh* Get sticks, use sticks. Tivo apps are a waste of time.
     
  12. m_jonis

    m_jonis Member

    677
    7
    Jan 3, 2002
    Albany, NY
    Yeah, the crappy thing is that I have an old receive that doesn't do HDMI switching so I'll either have to have the Tivo route through the surround sound system and the sticks be basic stereo only through the TV, or spend a few hundred bucks to upgrade.
     
  13. Steve Kelso

    Steve Kelso New Member

    5
    0
    Dec 10, 2008
    Running a Tivo Bolt :
    This started happening right after I had called them and DEMANDED they turn off the Pre-Roll they started adding to recorded shows !!!
    CALL THEM and Complain or next you will start see commercials popping up during recorded show playback !!
    (YOU NEVER AGREED TO THIS DON'T ALLOW IT TO CONTINUE CALL THEM )
    But right after they turned that Pre-Roll OFF
    - Every time I try to run an App Netflix- Plex - Amazon any of them the screen goes black and I cant do anything to get back to the main screen ? The only fix is to pull the plug and restart the unit then its good for a day and then the same thing happens ???
    Does anyone have a fix for this ??
     
  14. slowbiscuit

    slowbiscuit FUBAR

    4,699
    634
    Sep 19, 2006
    In the ATL
    See post #11.
     
  15. rfc19061

    rfc19061 New Member

    23
    1
    Mar 5, 2015
    also been getting this recently on the YouTube app...have to restart the Bolt as it locks up. interesting thing is - apps seem to work better on the Mini. Go figure!
     
  16. ManeJon

    ManeJon Active Member

    248
    63
    Apr 14, 2018
    Haven't had that with NetFlix but with Amazon Prime on my Bolt. Actually causes the Bolt to reboot which only takes "forever". Yesterday Prime worked - Who knows. But not counting on it working
    I can run Prime fine directly from my Samsung TV with no problems
     
  17. m_jonis

    m_jonis Member

    677
    7
    Jan 3, 2002
    Albany, NY
    Well slight update. I believe someone had suggested the issue may lie with the HDMI handshake between the Tivo and the TV.

    Since I have a Fire Stick, but an old Receiver, I ended up replacing the receiver with a Yamaha one that has HDMI switching on it. That way I can get the DD 5.1 and all that from Tivo and the Fire Stick (fire stick only lives for Disney+ --haha)

    Anyway, I used the existing HDMI cable from TV (that WAS going to the Tivo) and put that on the HDMI "output" of the Yamaha Receiver.

    Used a new Amazon Basics 6' HDMI cable to go from Tivo to the HDMI input 1 on the Yamaha and just plugged the Firestick directly into the HDMI 2 input on the Yamaha.

    All seemed "ok" (Tivo/Firestick) until day #2, when for some reason I started getting the lovely HDCP 2.2 error (from the receiver end, I believe). Even though I have no 4k content anywhere.

    Even better, when I tried to play Netflix (or anything on the Tivo) I'd get the "having trouble playing this video right now". Same with the Firestick, except it would just give me a black screen.

    I ended up changing the Yamaha to HDMI Passthrough. That seemed to solve the above issue (but not the HDCP 2.2 error).

    I then dug up the manual for the TV (Panasonic 60" plasma, maybe 3 years old--will have to double-check). The HDMI inputs aren't listed as to what spec or HDCP level they are capble of doing. However, HDMI2 is listed as ARC. So I moved the HDMI cable to the HDMI2 on the TV.

    Now the HDCP 2.2 error is gone.

    AND I can reliably play Netflix/Amazon/etc. on the Tivo now as well.
     
  18. blackngold75

    blackngold75 Active Member

    362
    88
    Mar 9, 2010
    Northern...
    The issue I see on my Bolt may be tied to "planned" restarts of the box, such as after service updates. For example, last night Netflix was working with no issues. However, I was getting a playback error on the Hulu app which is usually resolved by a TiVo restart. I performed a restart from the Help menu and that did solve the Hulu playback error, however when we tried Netflix a little later the Bolt froze on the black screen. Rebooted by unplugging, Netflix works. Odd...
     
    Last edited: Aug 28, 2020

Share This Page

spam firewall

Advertisements