All shows copyright protected with Comcast

Discussion in 'TiVo Stream' started by ktheess, Jan 14, 2015.

  1. ktheess

    ktheess New Member

    3
    0
    Jan 14, 2015
    I am posting this as i hope that somebody can help me. Tivo technical service cannot and even as I try to find people with similar problems in the community my case seems special.

    I am using a Stream with a Roamio along with an Apple Airport Extreme router. Until a few months ago all was great - I was able to download every show to my Ipad or stream outside the house. Then all of a sudden the only feature that would still work is the inhouse streaming. Every show, even the stupidest, became grayed out for download as well as out of house streaming. The message is "Download not permitted - Due to copyright restrictions, downloading is not supported through external devices".

    When I bring this up to Tivo they are telling me it's my router, I have verified that NAT-PMP (Apple's UPNP) is (and always was) on; they have me run all kinds of checks for port settings (which all pass), but they are ignoring the fact that my in-home streaming actually still works and that all of this used to work also out of home.
    http://support.tivo.com/app/answers/detail/a_id/402
    http://www.tivocommunity.com/tivo-vb/showthread.php?p=10285551

    On the flip side, I have checked the CCI bytes on the relevant channels and they show 0x00, which suggests that they are not copyright protected.
    http://support.tivo.com/app/answers/detail/a_id/243
    At the same time, I wouldn't put it past Comcast to put these kind of restrictions on Tivo so they can push their inferior X1 product.

    I am really at a loss and despite escalation at Tivo I am unable to find a resolution to this problem. Also searching on the forum and the internet at large has not brought a solution.

    Hope to find somebody out there who can help me.
     
  2. Arcady

    Arcady Stargate Fan

    3,959
    3
    Oct 14, 2004
    Philadelphia...
    If the show has a 0x00 CCI byte, then there should be no reason you can't download to the iOS device. I'm using an AirPort Extreme and AirPort Expresses for my WiFi connection, but I use a Cisco wired router to actually handle the routing (AirPort stuff is all in bridge mode.)

    Have you tried deleting the TiVo app from your iOS device (removing all settings) and re-installing it and then re-activating OOH streaming?

    Is your TiVo and Stream set up with DHCP IP addresses or static IP addresses?
     
  3. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    50,344
    5,799
    Apr 17, 2000
    Nevada
    Try transferring the shows to a PC via TiVoToGo. If that works then the shows are not protected. If it doesn't then they are.
     
  4. ktheess

    ktheess New Member

    3
    0
    Jan 14, 2015
    Thank you both. I have de-and reinstalled the Tivo app, which did not help. As one of the measures I have also assigned a permanent IP address to the Stream vs the previous Auto DHCP - did not help. I will definitely try with my old router to make sure that is not the problem and also look into the Desktop app.

    Arcady - have you ever tried this with your Airport Express not in bridge mode ... did you have a problem and therefore switched to the Cisco wired router?

    Karsten
     
  5. Arcady

    Arcady Stargate Fan

    3,959
    3
    Oct 14, 2004
    Philadelphia...
    I have used it with the AirPort acting as a router, and it worked fine. I recently switched to the Cisco router for other reasons (DynDNS, VPN, etc.)
     
  6. JWhites

    JWhites New Member

    1,366
    0
    May 14, 2013
    I have Comcast in two different locations in two different states and I'm not seeing this copyright protection issue except for the premium channels like HBO, Showtime, Starz, Cinemax, Encore.
     
  7. ktheess

    ktheess New Member

    3
    0
    Jan 14, 2015
    ... just to update on this thread, my streaming and downloading issues have all been resovled. I did ... absolutely nothing. It just started working again all of a sudden.

    It may be related to the Feb 3 Tivo iOS update (version 3.5.1) in which Tivo is commenting "we listened to you and fixed the streaming issues" ... all the time I was talkling to them on the phone it was never their issue, I was this isolated case with my issue.

    Regardless, seems to be reoslved now and I am glad my Tivo stream is no longer a paper weight
     

Share This Page