After reboot, pressing "Live TV" gives "No Channels"

Discussion in 'TiVo Help Center' started by CinciDVR, Sep 9, 2020.

  1. CinciDVR

    CinciDVR Contentious Member

    160
    37
    May 24, 2014
    Cincinnati, OH

    Advertisements

    I have a Roamio (Base model - 4 tuners) that is running Hydra (21.10.1.v8-846-6-846) that uses a tuning adapter subscribed to Spectrum in Southwest Ohio. I have it and the tuning adapter on a timer that power cycles them once a week by shutting them both off, then turning the tuning adapter back on, and then 5 minutes later turning the Roamio back on. I do this because the longer the tuning adapter goes without a reboot, the more likely it will refuse to tune SDV channels which causes lost recordings.

    After writing what happened, I see it is very long, so I'll summarize: After the weekly reboot, the Roamio wouldn't display any channels via normal use. Using "Test Channels" caused one tuner to select a channel and I could watch it but not get the other three tuners to work until I used my minis to select channels. After that the Roamio could access all tuners.

    And now the details:

    This Monday morning the reboot happened like usual, but then things went weird. After the reboot, the Roamio came up in Tivo Central with nothing playing in the video window. When I pressed "Live TV" it presented a pop-up titled "No TV Channels - V425" and text that read "The Tivo box is unable to display any TV channels. This is most likely caused by a delay in loading your Channel List. Please wait a few minutes and try again." So I pressed "Ok" and left for about 20 minutes. When I came back, pressing "Live TV" gave a new dialog box titled "Can't Play Now - V117" with text that read "Please try again later."

    So I rebooted both the Roamio and tuning adapter. Same result when pressing "Live TV". So I tried just rebooting only the Roamio. Same result. So I tried rebooting only the tuning adapter. Got a message saying the connection to the tuning adapter had been lost. I pressed "Ok". Several minutes later got a message saying a connection to the tuning adapter had been made. I pressed "Ok". Then tried "Live TV". Same result as before.

    So I went into the CABLECARD DECODER menu and tried "Test Channels". I got a screen with text at the top saying "Use CHAN UP/DOWN to test CableCARD channels" with the line below reading "No channels available" and the line below reading "Press Clear to exit". I tried both CHAN UP and CHAN DOWN but nothing happened. So I hit "Clear" which took me back to the CABLECARD DECODER screen that has the video window in the upper right and lo and behold video for channel 1 was playing in the video window. I hit "Live TV" and had a full screen of channel 1. Pressing CHAN UP or CHAN DOWN worked as did directly entering a channel number.

    But... when I pressed the left arrow to see what was on the other tuners, I got three blank boxes. I could arrow between them but pressing "OK" did nothing. I tried cycling through tuners by repeatedly pressing "Live TV" but the Roamio just stayed on the current tuner. When I went into the "Diagnostics" screen, I could see that tuner 1 had been tuned, but tuners 0, 2, and 3. had not been tuned.

    So, having two minis, I wondered what would happen if I tried getting a tuner from them. On the first mini when I pressed "Live TV" it displayed the same channel the Roamio was showing, but I don't actually know if it was using a different tuner. So I changed channels so that it was on a different channel than the Roamio and it worked. So now I had the Roamio showing one channel, and the mini showing another. I went to the second mini and pressed "Live TV". It came up on a channel different than the other mini and Roamio. So now I had three tuners working. I started a recording on the second mini and changed the channel to something different from the other mini and Roamio. Now all four tuners were clearly tuned to a channel.

    I went back to the Roamio and pressed the left arrow. I could see that there was a recording in progress on one channel and that the other two minis had claimed the other two tuners. So I put both minis to sleep and stopped the active recording. Now on the Roamio I was able to cycle through all four tuners using the "Live TV" button as well as select different tuners using the left arrow. Since getting access to all four tuners, I haven't tried rebooting the Roamio and tuning adapter. I want to wait until this week's recordings are done before trying that.

    So, if you've read this far... any idea what the frack might be going on? Why couldn't the Roamio tune any channels after a reboot? Why did the "Test Channels" screen say "No channels available" but then upon exiting that screen a channel was tuned on tuner 1? Why were the minis able to get the Roamio to tune channels on the other tuners when the Roamio couldn't do it by itself? Anyone else have this sort of problem? Is it likely a problem with Hydra as opposed to the hardware?
     
  2. kpeters59

    kpeters59 Well-Known Member

    2,944
    606
    Jun 19, 2007
    Houston, Texas
    Try physically removing power from the Roamio for several minutes and see if that doesn't kick-start the Tuner's.

    -KP
     
  3. CinciDVR

    CinciDVR Contentious Member

    160
    37
    May 24, 2014
    Cincinnati, OH
    Thanks for the suggestion. I didn't list everything I did. One of the things I tried was physically removing power from the Roamio, but I only counted to 10 before restoring the power. Once this week's programs are recorded, I'm going to try rebooting the Roamio and tuning adapter. If the same issue happens again, I'll try removing the power from the Roamio for several minutes instead of just counting to 10.
     
  4. CinciDVR

    CinciDVR Contentious Member

    160
    37
    May 24, 2014
    Cincinnati, OH
    This week's automatic reboot happened and...

    still had the issue whereby the Roamio didn't seem to be able to assign a channel to any tuners. I used the "Test Channels" trick to get a channel assigned to one tuner, and then rather than using the Minis, I simply started a recording on the Roamio and hit CHANNEL UP. That worked, so I started a recording and did another CHANNEL UP. Started a third record and did a final CHANNEL UP. All tuner were now assigned a channel.

    Tried @kpeters59 suggestion of removing power for several minutes. In this case, I removed it for 40 minutes. Reapplied power and still had the same problem. Since my Roamio still sports all the same hardware it came with, I figured that I'd return it's configuration to completely standard by unpointing it from my pi-hole domain name server, which blocks mm1.tivoservice.com and prod.adgwy.tivo.com, and repointing it to a google domain server. After doing that, I rebooted the Roamio.

    When it finally completed the reboot (why does it take so long), it had successfully assigned all tuners a channel. So... apparently Tivo has changed something in the last few weeks to make it so that access to mm1.tivoservice.com or prod.adgwy.tivo.com upon bootup is required.

    I have been blocking those connections so that I didn't have to deal with pre-roll ads under Hydra. Looks like I'll be dumping the new UI just as soon as I finish watching unviewed recordings.
     
    kpeters59 likes this.
  5. gantt

    gantt Slightly Worse-For-Wear Member

    27
    6
    Jul 22, 2008

    Advertisements

    I had a somewhat similar issue last night/this morning. Initially I had no live TV. Then live TV resumed but other tuners were blank (UE4) and I was unable to switch tuners - it would generate various errors. Tuners would only get assigned a channel when a scheduled recording began.

    I followed your method here and initiated manual recordings on several different channels and now all tuners have a channel assigned and are accessible.

    FYI this is on a Bolt and I have Comcast with NO tuning adapter.
     

Share This Page

spam firewall

Advertisements