A better /nowplaying/index.html

Discussion in 'TiVo Home Media Features & TiVoToGo' started by gman622, Mar 28, 2005.

  1. Jul 6, 2008 #161 of 168
    DaGhost

    DaGhost New Member

    8
    0
    Dec 24, 2007
    I know this is an old thread but just in case anyone else runs into the problems I had. Maybe someone else besides me searches threads before posting questions!!


    PROBLEM:
    I downloaded this file to my Windows XP desktop then right-clicked and selected Edit from the menu. When I did this it automatically opened the file in MS Word. I then selected View-- HTML Source and was greeted with the HTML code.

    I made the changes to the IP address and MAK settings and then saved my work and exited back to the desktop. When launching the file I received this error.

    XML Parsing Error: not well-formed
    Location: file:///C:/Documents%20and%20Settings/MyName/Desktop/nowPlaying.xhtml
    Line Number 12, Column 18:<meta http-equiv=Content-Type content="text/html; charset=us-ascii">


    CAUSE:
    It would appear that MS Word had added several dozen lines to the code that was fouling this up.

    SOLUTION:
    When I opened the file in Notepad and made my changes there, it worked like a charm.

    DaGhost
     
  2. Jul 6, 2008 #162 of 168
    morac

    morac Cat God TCF Club

    12,452
    1,243
    Mar 14, 2003
    NJ
    I'd avoid MS Word for modifying any HTML files, let alone a XHTML/XML file (which this is) since, like you saw, it tends to add a lot of garbage to the HTML file making it next to unreadable.
     
  3. SJMarty

    SJMarty New Member

    18
    0
    Jul 28, 2007
    Does anyone know what the "total gigabytes used to record shows" value should be for a TiVoHD? Thanks.

    -SJM
     
  4. orourkj

    orourkj New Member

    13
    0
    Nov 16, 2004
    Thanks to this thread and the latest version of the NowPlaying file I can get details on what is on my older Tivo - a 40 hour standard def Tivo that's several years old. However, I cannot get this file to work against our newer HD Tivo. I've tried including it by itself in the file as well as one of two tivos in the same NowPlaying file.

    I don't get any errors, just nothing ever loads. The older Tivo loads up in just a few seconds, but the new Tivo never loads. I scanned this thread and don't see the solution. Both Tivo IPs are listed as exceptions to security certificates in Firefox.

    Any help?
     
  5. morac

    morac Cat God TCF Club

    12,452
    1,243
    Mar 14, 2003
    NJ
    How new is the HD? It can take a day or two to allow inbound connections. You can test if the TiVo is networked correctly by going to its built in web page at:

    http://tivoip/index.html where tivoip is the TiVo's ip address. This should bring up a Congratulations page.

    If that works, then try the same thing except use https instead of http. This requires you to log in. The username is tivo and the password is your MAK number.

    If that works, then check for errors in Firefox's error console since some extensions such as NoScript can cause it to fail.
     
  6. orourkj

    orourkj New Member

    13
    0
    Nov 16, 2004
    Thanks for the response

    Unfortunately I didn't have any luck with your suggestions. I tried the 4 addresses below and got Page Load Errors each time

    http://192.168.0.101/index.html
    http://192.168.0.102/index.html
    https://192.168.0.101/index.html
    https://192.168.0.102/index.html

    Afterwards I tried my nowPlaying file again, and confirmed I can still get at 192.168.0.101 but not 192.168.0.102.

    The HD Tivo we've had for a year or so and its worked fine with no apparent problems.

    I checked the Firefox error console and saw no related entries.

    Help?
     
  7. morac

    morac Cat God TCF Club

    12,452
    1,243
    Mar 14, 2003
    NJ
    The nowPlaying file needs to be able to access the data off the TiVos. If the http://tivoip/ address fails to load then something is wrong with your network connection to the TiVo.
     
  8. orourkj

    orourkj New Member

    13
    0
    Nov 16, 2004
    The NowPlaying file loads successfully off my old tivo and both Tivos successfully connect everyday to the Internet for their updates. They clearly are connected to the network, I'm just not able to connect to them with these tips yet.
     

Share This Page