9.4 Broke My TiVoHD - No Fix after 4 Weeks

Discussion in 'TiVo Series3 HDTV DVRs' started by mtfbwy, Sep 10, 2008.

  1. mtfbwy

    mtfbwy New Member

    8
    0
    Dec 17, 2003

    Advertisements

    The countdown has begun and TiVo has about 4 weeks to fix my TiVo HD before I totally abandon their service. It's really a shame since I own 2 TiVo's and really like the boxes. Unfortunately, the 9.4 update caused major issues with our cable card simply dropping channels soon after a reboot or cable card reinsertion.

    TiVo is aware of the issue but has yet to fix it nor be very responsive to even give me a rough timeframe. According to TiVo, this issue is rampant on Time Warner in our area. No other changes were made except the 9.4 update. In fact, the cable cards still show a March 2008 firmware date.
     
  2. Ziggy86

    Ziggy86 Member

    895
    7
    Jun 22, 2004
    Sorry to hear about your trouble. I have Time warner as well and live in NYC. Where are you located?
     
  3. mtfbwy

    mtfbwy New Member

    8
    0
    Dec 17, 2003
    I live in Cleveland, OH. Apparently, this affected numerous people in my area. At first, TiVo blamed Time Warner but after weeks of going back and forth, they finally owned up that it was their issue. Like the fact that this happened immediately after the 9.4 update wasn't enough to clue them in.

    It's frustrating since we love our TiVo's when they work but I"m not paying the monthly fee for this crap.

     

Share This Page

spam firewall

Advertisements