10TB Bolt?

Discussion in 'TiVo Upgrade Center' started by tommage1, Feb 26, 2019.

  1. Henryr

    Henryr New Member

    10
    0
    Nov 22, 2003
    Franklin, TN
    LOLOL
    Thanks Jim!
    I guess I'll play with a 4Tb and wait.

    Thanks,
    Bob...
     
  2. Henryr

    Henryr New Member

    10
    0
    Nov 22, 2003
    Franklin, TN
    Good day jmBach!
    Hope you had a great weekend. Any chance you got around to looking at adding space (up to 10Tb) on MFSTools?
     
  3. editklink

    editklink New Member

    8
    0
    Apr 25, 2019
    jmbach,

    Will this new version allow me to duplicate (saving all programs) and expand a 1TB TE4 Roamio to an 8TB drive?

    Thanks!
     
  4. jmbach

    jmbach der Neuerer

    2,929
    397
    Jan 1, 2009
    The current version will work for the Roamio. See the Roamio 10 TB thread.
     
  5. editklink

    editklink New Member

    8
    0
    Apr 25, 2019
    Thanks for the quick response jmbach!

    I tried reading through all of these threads but didn't seem to find confirmation that mfsTools 3.3-devel would work on a TE4 Roamio - especially when trying to save programming. Are there any gotchas to look out for to avoid losing everything? If things go bad I'll just throw my 1TB back in, but I don't want to risk it triggering an automatic format (is that only on the Bolts or all systems running TE4)?

    Again, appreciate all of your help and dedication to this thread.
     
  6. jmbach

    jmbach der Neuerer

    2,929
    397
    Jan 1, 2009
    The Bolts store the data for the recordings differently than Roamios so an auto format does not wipe everything out. Consequently just put your old drive back in you are okay. The only issue might be is losing cableCARD paring.
     
  7. editklink

    editklink New Member

    8
    0
    Apr 25, 2019
    Alright, I'll give it a shot and post my results in the 10TB Roamio thread.

    Thanks and have a great weekend.
     
  8. editklink

    editklink New Member

    8
    0
    Apr 25, 2019
    Hi jmbach,

    I'm about 4% through my copy. A few "interrupt took too long" errors but those appear to be harmless?

    I have a question about expanding space... since I'm starting with a 1TB drive and I can only expand 3 (x 2TB) times, does that mean it's impossible to get to the 8TB capacity of the drive (1TB + 6TB = 7TB)?

    7TB is honestly more than enough, just curious if it's possible to use all the available space.

    Thanks!
    David
     
  9. editklink

    editklink New Member

    8
    0
    Apr 25, 2019
    Success (for now) story... Was able to copy all my programs from a 1TB TE4 Roamio Plus factory original drive using MFSTools-3.3 to a new WD 8TB. Drive showed up as 4TB in Roamio Plus after clone. Was then able to run 2 expand commands and am now getting 1200+ HD Hours and the full 8TB.

    Thanks for your help and for creating these tools, jmbach!
     
  10. jmbach

    jmbach der Neuerer

    2,929
    397
    Jan 1, 2009
    Very good. If you are having issues with it not completing a connection with the TiVo servers, try a KS 58 to see if it corrects it. There are reports of some people having that issue after a copy.
     
  11. editklink

    editklink New Member

    8
    0
    Apr 25, 2019
    Ha, did even think to check - but you’re correct. The upgraded Roamio had been failing when loading the data. KS 58 solved the issue.

    Thanks again!
     
  12. ClefCruiser

    ClefCruiser #762 of the Dionysus 1000!

    13
    5
    Apr 24, 2019
    Western KY
    Trying to locate MSFR, or any tool to expand my 8t WD-Red for my Bolt- I got the new Bolt VOX, did the external cable and have the drive hooked up and did the guided setup, now I guess I need to pull it and use MSFR to expand the drive, but can't find a link to the tool, can someone help please?
     
  13. ggieseke

    ggieseke Well-Known Member

    5,616
    674
    May 30, 2008
  14. ClefCruiser

    ClefCruiser #762 of the Dionysus 1000!

    13
    5
    Apr 24, 2019
    Western KY
  15. jmbach

    jmbach der Neuerer

    2,929
    397
    Jan 1, 2009
    So for those interested, the new version of MFSTools that support adding partitions to Bolts has been released.

    This release was made possible with the help of @angra who helped with the modifications and did extensive testing to make sure they worked.
     
    sohkis, Mikeguy and ClearToLand like this.
  16. tommage1

    tommage1 Well-Known Member

    1,258
    286
    Nov 5, 2008
    Where do I download the ISO? Will the commands be the same as they were for the 10TB Roamio upgrade? Right now have a 10TB on TE4 in the Bolt, it is only using 4 of the 10TB. So am hoping can just do the three adds to get it to 10TB? Or will I need to start from scratch?
     
  17. jmbach

    jmbach der Neuerer

    2,929
    397
    Jan 1, 2009
    I updated the post one the MFSTools 3.2 thread with the new ISOs.

    You just follow the instructions in the 10 TB Roamio thread on your current 10 TB drive. No need to redo anything.

    If there any errors or issues don't put the drive back in the Bolt, post back here.

    If everything finishes like it is supposed to and the Bolt green screens, then run a KS 58.
     
  18. tommage1

    tommage1 Well-Known Member

    1,258
    286
    Nov 5, 2008
    Ok found it, MFST 3.32? I gave it a try. On the 10TB drive in the TE4 Bolt which had a current capacity of 4TB. We created it by first making a 4TB drive (check our PMs) then cloning the 4TB to the 10TB. At the time there were numerous partition errors that had to be corrected before we could get the 4TB to work. After cloning the 4 to the 10 ended up with the same number of partitions as the 4, when trying the 10 without creating the 4 first it had one more partition than the 4.

    Anyway current result. I ran 3.32 on the 10TB drive which had 4TB usable. Did a 2TB add, then the mfsaddfix. Put it in the Bolt, seemed to work fine, capacity went up to 1001 HD hours and all recordings/settings seem fine. Also connected to Tivo successfully. So pulled it and ran 3.32 again, two more adds. But when I tried another add I got an error, volsize mismatch, shows 3605052416 expecting 3605052416 (same number). So I tried an mfsaddfix, got some pruning messages and it said expecting 16 partitions but found 14. I'm guessing maybe a problem from the way we had to create the 4TB to begin with, then clone to the 10. Again maybe check our PMs.

    So seems for now am limited to the 6TB usable on the 10. I suppose could start fresh since we had to do so much tweaking to get the original 4TB to work, then clone to the 10, may be causing the problem. Or possibly copy the 10 backwards to the 4 (there are only 700GB of recordings so should work, what would be the command, copy recordings/settings from the current 10 to the fresh/blanked 4?) Then blank the 10 and copy the 4 back to the 10, then try the adds again? Or any other ideas? Starting fresh would not be THAT bad, will just move recordings I want to keep to TE3 Roamios, fairly simple.
     
  19. jmbach

    jmbach der Neuerer

    2,929
    397
    Jan 1, 2009
    If I read your post correctly, you did a total of 3 adds to the drive before you hit a wall. That comes out to adding a total of 6 TB to your 4 TB which is a total of 10 TB.
     
  20. tommage1

    tommage1 Well-Known Member

    1,258
    286
    Nov 5, 2008
    No, I did the one add which worked, then when I tried to do another I got the error. I tested the drive in the Bolt after one add, then put it back in the computer to TRY the other two adds, got the error when trying the 2nd total add. What is the command to copy the 10TB back to the 4TB keeping recordings?
     

Share This Page