TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 03-03-2015, 04:23 PM   #1
vaughajj
Registered User
 
Join Date: Mar 2015
Posts: 6
cTivo error - incorrect media key

I am getting the error "incorrect media key" when trying to connect to my Tivo. I know my MAK is entered correctly, I've verified it several times both using the Tivo menu and on the Tivo.com website. cTivo finds it without a problem over Bonjour. I've also tried connecting manually using the IP address of the Tivo.

My log file is below.

I'm running cTivo version 2.4.0b7 (534) trying to connect to a Roamio 4 tuner. Both the Tivo and Mac are connecting over wifi.

Has anyone had this issue? Thanks for the help!

Connection Failed with error Error Domain=NSURLErrorDomain Code=-1012 "The operation couldn’t be completed. (NSURLErrorDomain error -1012.)" UserInfo=0x7ff79a4470b0 {NSErrorFailingURLStringKey=https://DVR-9AB9.local./TiVoConnect?Command=QueryContainer&Container=%252FNowPlaying &Recurse=Yes&AnchorOffset=0&ItemCount=15, NSErrorFailingURLKey=https://DVR-9AB9.local./TiVoConnect?Command=QueryContainer&Container=%252FNowPlaying &Recurse=Yes&AnchorOffset=0&ItemCount=15}
2015-03-03 16:03:18:250 MTTiVo>connection:didFailWithError:@778>URL Connection Failed with error Error Domain=NSURLErrorDomain Code=-1012 "The operation couldn’t be completed. (NSURLErrorDomain error -1012.)" UserInfo=0x7ff79a509a00 {NSErrorFailingURLStringKey=https://DVR-9AB9.local./TiVoConnect?Command=QueryContainer&Container=%252FNowPlaying &Recurse=Yes&AnchorOffset=0&ItemCount=15, NSErrorFailingURLKey=https://DVR-9AB9.local./TiVoConnect?Command=QueryContainer&Container=%252FNowPlaying &Recurse=Yes&AnchorOffset=0&ItemCount=15}

vaughajj is offline   Reply With Quote
Old 03-03-2015, 06:11 PM   #2
tlp95129
Registered User
 
Join Date: May 2008
Location: California
Posts: 41
I've never used cTivo, but that error looks familiar. It had to do with using the fast transfer mode in TiVo Desktop, which attempts to transfer a transport stream instead of a program stream. Just make sure that fast transfer mode is disabled in TiVo Desktop. Maybe cTivo has a similar setting.

tlp95129 is offline   Reply With Quote
Old 03-04-2015, 12:27 AM   #3
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,521
It says it's failing at the QueryContainer stage, so it's not a transport vs. program stream issue. I don't know what it is, but it's not that, sorry. (It actually reminds me of what happened with pyTivo recently with Python 2.7.9, but that was very Python-specific.)

Here's a result from googling "nsurlerrordomain 1012":

https://discussions.apple.com/docs/DOC-7391

__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wmcbrine; 03-04-2015 at 12:36 AM.
wmcbrine is offline   Reply With Quote
Old 03-04-2015, 10:27 AM   #4
vaughajj
Registered User
 
Join Date: Mar 2015
Posts: 6
I went to https://{Tivo address on your network}/nowplaying/index.html and used tivo as the username and the MAK as the password - it failed. Bingo. I think I found my problem.

I'm new to Tivo but I'm pretty sure I'm putting in the right number. It's a 10 digit number that appears both on Tivo.com and on the Tivo itself when I go to settings.

Screenshot of my number (blurred) at the link below. This is what I should be using - right?

note.io/1zJmILl

vaughajj is offline   Reply With Quote
Old 03-04-2015, 11:34 AM   #5
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,521
Yeah, that's the number.

Is this a brand-new TiVo? It usually takes a few days until everything works right (don't ask me why).

__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 03-04-2015, 11:47 AM   #6
vaughajj
Registered User
 
Join Date: Mar 2015
Posts: 6
It's a new Tivo, ordered off of Tivo.com, but I activated it on 8/13/2014 so I've been using it for some time now.

When I get home I'll try rebooting it.....other than that, I'm at a loss.

vaughajj is offline   Reply With Quote
Old 03-04-2015, 11:54 AM   #7
Arcady
Stargate Fan
 
Arcady's Avatar
 
Join Date: Oct 2004
Location: Philadelphia, PA
Posts: 3,960
Do you have video sharing and downloads turned on in your TiVo.com DVR preferences?

https://www.tivo.com/tivo-mma/dvrpref.do

Arcady is offline   Reply With Quote
Old 03-04-2015, 12:23 PM   #8
vaughajj
Registered User
 
Join Date: Mar 2015
Posts: 6
Yes, both are checked.

vaughajj is offline   Reply With Quote
Old 03-05-2015, 12:28 PM   #9
vaughajj
Registered User
 
Join Date: Mar 2015
Posts: 6
I tried installing cTivo on a different computer and it worked. I could also access the nowplaying tivo webpage on the other computer. So - it's something to do with the specific computer - a Mac Mini running OSX 10.7.5. The computer that worked was a Macbook Pro on OSX 10.9.5. Both computers were attached to the same wifi network. I don't have any fancy routing going on in my router - Buffalo WHR-G54S running Tomato 1.28.

vaughajj is offline   Reply With Quote
Old 03-05-2015, 12:48 PM   #10
vaughajj
Registered User
 
Join Date: Mar 2015
Posts: 6
Completely strange. All of a sudden the Mac Mini let me into the /nowplaying/ website and cTivo now connects. I didn't do anything - but for whatever reason it now works. Thanks everyone for your suggestions - you've got a great community here.

vaughajj is offline   Reply With Quote
Reply
Forum Jump







Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Advertisements





TiVo Community
Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media


(C) 2015 DBNet - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 02:46 AM.
Page generated in 0.07406402 seconds (77.32% PHP - 22.68% MySQL) with 18 queries