TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Series3 HDTV DVRs
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 11-08-2013, 04:17 PM   #1
WO312
Registered User
 
Join Date: Jan 2003
Location: Wilmington, NC
Posts: 1,229
Weird SO3 Behavior

I have had my TA on a timer for 2 years now and it updates about every other day every time I check it, maybe every 2-3 weeks.

I checked it last night (Thurs), and the last GC had been Wed A.M., but the update had failed earlier in the day with an SO3 error. I had never seen that before. I tried a manual update and it got to downloading but once again failed on an SO3. I rebooted and same behavior. I went to bed and checked it this morning. While the GC is still saying Wed, so a little over 2 days now without an update, a program update had completed and an index had occurred. No sign of any SO3 error.

Anybody know what exactly an SO3 error is?? Whatever it is, it fixed itself.
WO312 is offline   Reply With Quote
Old 11-08-2013, 11:44 PM   #2
unitron
Registered User
 
unitron's Avatar
 
Join Date: Apr 2006
Location: semi-coastal NC
Posts: 13,353
Quote:
Originally Posted by WO312 View Post
I have had my TA on a timer for 2 years now and it updates about every other day every time I check it, maybe every 2-3 weeks.

I checked it last night (Thurs), and the last GC had been Wed A.M., but the update had failed earlier in the day with an SO3 error. I had never seen that before. I tried a manual update and it got to downloading but once again failed on an SO3. I rebooted and same behavior. I went to bed and checked it this morning. While the GC is still saying Wed, so a little over 2 days now without an update, a program update had completed and an index had occurred. No sign of any SO3 error.

Anybody know what exactly an SO3 error is?? Whatever it is, it fixed itself.
It's some sort of problem that occurs when there's a problem downloading and indexing program guide data, and putting the timer on the TA is supposed to keep the TA from interfering with Garbage Collection executing properly and completing.

Apparently GC failure is a big cause of S03.

The unofficial fix for S03 that won't go away is to do a Clear Program Information and To Do List (not a C&DE), which saves you having to go through Guided Setup again, where there's a chance of getting stuck on account of an S03 error, although if that happens it's been suggested that you tell it you only have antenna to reduce the amount of guide data that it tries to download, so that you can get through GS and fix the line up later.

I think the CPI&TDL forces it to go back and start the data download from the beginning instead of trying to just grab the changes since last time, or resume an interrupted download where it left off, or something like that.
__________________
(thisismysigfile)


"I am altering the deal. Pray I don't alter it any further."

Darth TiVo, 14 February, 2011
unitron is online now   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 04:14 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |