TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Help Center
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 10-08-2013, 12:39 AM   #1
bhcv
Registered User
 
Join Date: Dec 2005
Posts: 10
Linux newbie needs help with tenet commands

I'm manually upgrading a hacked 240 from 93.2b-01-2-14.0 to 93.2c-01-2-14.0. I can no longer get guide data because of "restart pending" cycle. I'm trying to follow the guide at: http://john-time.com/?p=162 but it doesn't have examples of working commands. I have finished updating and now need to save the hacks. The directions say:
1.) Check what the current TiVO root partition is set to using the command – “bootpage -p /dev/hda”. This will return the full boot string – check what value is contained in the “root=/dev/hda…” parameter of this boot string. Make a temporary directory – mkdir /tmp/tivo<partition number that the TiVO upgrade installed to>
2.) mount /dev/hda<value of root= parameter from command issued above> /tmp/tivo<4 or 7>
I have tried everything I can think of. Examples of actual commands that really work would be so helpful. What am I doing wrong now?

PPV-TiVo# bootpage -p /dev/hda
root=/dev/hda4 dsscon=true console=2,115200 upgradesoftware=false
PPV-TiVo# mkdir /tmp/tivo4
PPV-TiVo# mount /dev/hda/tmp/tivo4
mount: can't find /dev/hda/tmp/tivo4 in /etc/fstab or /var/mtab
PPV-TiVo# mount /dev/hda /tmp/tivo4
mount: you must specify the filesystem type
PPV-TiVo# mount/dev/hda/tmp/tivo4
bash: mount/dev/hda/tmp/tivo4: No such file or directory
PPV-TiVo# mount /dev/hda4/tmp/tivo4
mount: can't find /dev/hda4/tmp/tivo4 in /etc/fstab or /var/mtab
PPV-TiVo# mount /dev/hda4
mount: can't find /dev/hda4 in /etc/fstab or /var/mtab
PPV-TiVo# mount/dev/hda4
bash: mount/dev/hda4: No such file or directory
PPV-TiVo# mount/dev/hda4/tmp/tivo4
bash: mount/dev/hda4/tmp/tivo4: No such file or directory
PPV-TiVo# mount/dev/hda/tmp/tivo4
bash: mount/dev/hda/tmp/tivo4: No such file or directory
PPV-TiVo# mount /dev/hda4
mount: can't find /dev/hda4 in /etc/fstab or /var/mtab
PPV-TiVo#
bhcv is offline   Reply With Quote
Old 10-08-2013, 01:14 AM   #2
kdmorse
Registered User
 
kdmorse's Avatar
 
Join Date: Jan 2001
Location: Germantown, MD
Posts: 4,136
I don't actually see the following (which is I believe what you want) in your many attempts above:

mount /dev/hda4 /tmp/tivo4
__________________
"I disapprove of what you say, but I will defend to the death your right to say it"
"Stop slouching! It's two O'clock in the afternoon, PUT PANTS ON!"
"Statistically speaking, there are two Popes per square kilometer in Vatican City..."
kdmorse is offline   Reply With Quote
Old 10-08-2013, 01:18 AM   #3
bhcv
Registered User
 
Join Date: Dec 2005
Posts: 10
that worked, thanks so much

Quote:
Originally Posted by kdmorse View Post
I don't actually see the following (which is I believe what you want) in your many attempts above:

mount /dev/hda4 /tmp/tivo4

thanks so much,
it worked...
bhcv is offline   Reply With Quote
Old 10-08-2013, 02:57 AM   #4
bhcv
Registered User
 
Join Date: Dec 2005
Posts: 10
well I'm stuck again. The directions say:
[i]2.) Initrd the extracted virgin kernel with the following command:
cd /monte
./replace_initrd.mips <virgin_kernel>.img myinitrd.img(this is what is inserted into the virgin kernel) <tivo_version>.px (this is the kernel file that will be loaded during the monte process)
Screenshot of successful killinitrd on virgin kernel:

I have verified there is a 2.1 mb file in /tmp/tivo4/monte named "932_virgin_kernel.img"
this is what I've tried on my s2 240
PPV-TiVo# cd /tmp/tivo4/monte
PPV-TiVo# ./replace_initrd.mips 932_virgin.img myinitrd.img 932.px
bash: ./replace_initrd.mips: No such file or directory
PPV-TiVo# ./replace_initrd.mips 932.img myinitrd.img 932.px
bash: ./replace_initrd.mips: No such file or directory
PPV-TiVo# ./replace_initrd.mips 932_virgin.img myinitrd.img s2.px
bash: ./replace_initrd.mips: No such file or directory
PPV-TiVo# ./replace_initrd.mips /932_virgin.img /932_initrd.px
bash: ./replace_initrd.mips: No such file or directory
PPV-TiVo# ./replace_initrd.mips/932_virgin.img/932_initrd.px
bash: ./replace_initrd.mips/932_virgin.img/932_initrd.px: No such file or directory
PPV-TiVo# ./replace_initrd.mips /932_virgin.img /932_kernel_initrd.px
bash: ./replace_initrd.mips: No such file or directory
PPV-TiVo# /replace_initrd.mips /932_virgin.img /240.px
bash: /replace_initrd.mips: No such file or directoryPPV-TiVo# ./replace_initrd.mips /932_virgin_kernel.img /240.px
bash: ./replace_initrd.mips: No such file or directory
PPV-TiVo# cd /tmp/tivo4/monte
PPV-TiVo# ./replace_initrd.mips /932_virgin_kernel.img /240.px
bash: ./replace_initrd.mips: No such file or directory

Is this any help?
PPV-TiVo# mfs_dumpobj -r /SwModule
SwModule 3798213/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=3798214
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2c-01-2
Name[16]=GZcore
ServerId[8]=270505630
Version[1]=1
IndexPath[4]=/SwModule/3798213 /Server/270505630
}
SwModule 3798215/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=3798216
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2c-01-2
Name[16]=GZhpk-Series2
ServerId[8]=270505634
Version[1]=1
IndexPath[4]=/SwModule/3798215 /Server/270505634
}
SwModule 3798217/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=3798218
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2c-01-2
Name[16]=GZkernel-Series2
ServerId[8]=270505632
Version[1]=1
IndexPath[4]=/SwModule/3798217 /Server/270505632
}
SwModule 3798326/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=3798327
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2c-01-2
Name[16]=utils
ServerId[8]=270505628
Version[1]=1
IndexPath[4]=/SwModule/3798326 /Server/270505628
}
SwModule 542016/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=542017
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2b-01-2
Name[16]=GZcore
ServerId[8]=146598478
Version[1]=1
IndexPath[4]=/SwModule/542016 /Server/146598478
}
SwModule 542018/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=542019
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2b-01-2
Name[16]=GZhpk-Series2
ServerId[8]=146598502
Version[1]=1
IndexPath[4]=/SwModule/542018 /Server/146598502
}
SwModule 542020/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=542021
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2b-01-2
Name[16]=GZkernel-Series2
ServerId[8]=146598500
Version[1]=1
IndexPath[4]=/SwModule/542020 /Server/146598500
}
SwModule 624430/11 PRIMARY {
ServerVersion[9]=2
ModuleFile[19]=624431
ModuleRelease[18]=1
ModuleVersion[17]=9.3.2b-01-2
Name[16]=utils
ServerId[8]=146598476
Version[1]=1
IndexPath[4]=/SwModule/624430 /Server/146598476
}
PPV-TiVo#

Please, how do I get past this?

Last edited by bhcv : 10-08-2013 at 11:00 AM. Reason: more info
bhcv is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVo® is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 10:01 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |