TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 03-15-2012, 09:03 AM   #1
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
Transfer Problems with PyTivo

Hello All! I have been a faithful PyTivo user for a few years, but I have run into some transfer problems lately. .Avi and .mkv files that I have had for years won't seem to transfer anymore. I can see them from the TiVo menu, but when I try and transfer them, the file never makes it - just a black screen. I just downloaded an updated version of ffmeg, but no luck.

Was there a recent update on the TiVo OS that would prevent file transfers? Right now, it is hit or miss on my files - some will transfer while others won't and I am now sure as to why.

Any suggestions would be greatly appreciated!

Thanks in advance!
Squeege96 is offline   Reply With Quote
Old 03-15-2012, 09:14 AM   #2
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
What does the console output say?
lrhorer is offline   Reply With Quote
Old 03-15-2012, 11:15 AM   #3
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,924
Quote:
Originally Posted by Squeege96 View Post
Was there a recent update on the TiVo OS that would prevent file transfers?
No.

Have you tried rebooting the TiVo?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wmcbrine : 03-15-2012 at 01:05 PM.
wmcbrine is online now   Reply With Quote
Old 03-15-2012, 08:12 PM   #4
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
Quote:
Originally Posted by lrhorer View Post
What does the console output say?
I know that this is a stupid question, but how do I get the console output? Through the command console?
Squeege96 is offline   Reply With Quote
Old 03-15-2012, 08:13 PM   #5
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
Quote:
Originally Posted by wmcbrine View Post
No.

Have you tried rebooting the TiVo?
Yes, i have rebooted. No Luck.
Squeege96 is offline   Reply With Quote
Old 03-16-2012, 08:50 AM   #6
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
Quote:
Originally Posted by Squeege96 View Post
I know that this is a stupid question, but how do I get the console output? Through the command console?
Run pyTivo from the command line.
lrhorer is offline   Reply With Quote
Old 03-30-2012, 03:39 PM   #7
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
Ok - after a Hard Drive Failure, I am back online! Just reinstalled PyTivo, but I am still having an issue. I seem to have a problem with ffmeg - I keep getting an error message that it has stopped responding. Here is a copy of the console output:

INFO:pyTivo.beacon:Announcing shares...
INFO:pyTivo.beacon:Registering: Kid's Drive
INFO:pyTivo.beacon:Registering: Movies (A-M)
INFO:pyTivo.beacon:Registering: Movies (N-Z)
INFO:pyTivo.beacon:Scanning for TiVos...
INFO:pyTivo.beacon:Pablo
INFO:pyTivo.beacon:Bertha
INFO:pyTivo.beacon:BellyButton
INFO:pyTivo:pyTivo is ready.
INFO:pyTivo:10.0.0.4 [30/Mar/2012 16:31:36] "GET /TiVoConnect?Command=QueryConta
iner&Container=%2F HTTP/1.0" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:36] "GET /TiVoConnect?Command=QueryConta
iner&Container=%2F HTTP/1.0" 200 -
INFO:pyTivo:10.0.0.2 [30/Mar/2012 16:31:36] "GET /TiVoConnect?Command=QueryConta
iner&Container=%2F HTTP/1.0" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:42] "GET /TiVoConnect?Command=QueryForma
ts&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:42] "GET /TiVoConnect?Command=QueryConta
iner&Container=Movies%20(A-M)%2FAdventures%20of%20TinTin,%20The%20(2011)%20720p%
2Fmhd-taott.720p&SortOrder=!CaptureDate&ItemCount=8&Filter=x-tivo-container%2Fti
vo-videos,x-tivo-container%2Ffolder,video%2Fx-tivo-mpeg,video%2F* HTTP/1.1" 200
-
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:45] "GET /TiVoConnect?Command=QueryForma
ts&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:45] "GET /TiVoConnect?Command=QueryConta
iner&Container=Movies%20(A-M)%2FAdventures%20of%20TinTin,%20The%20(2011)%20720p%
2Fmhd-taott.720p&SortOrder=!CaptureDate&ItemCount=1&AnchorItem=%2F Movies%2520%25
28A-M%2529%2FAdventures%2520of%2520TinTin%252C%2520The%2520%2528 2011%2529%252072
0p%2Fmhd-taott.720p%2FAdventures%2520of%2520TinTin%252C%2520The%2520% 25282011%25
29%2520720p.mkv&AnchorOffset=-1&Filter=x-tivo-container%2Ftivo-videos,x-tivo-con
tainer%2Ffolder,video%2Fx-tivo-mpeg,video%2F* HTTP/1.1" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:45] "GET /TiVoConnect?Command=TVBusQuery
&Container=Movies%20(A-M)&File=%2FAdventures%20of%20TinTin,%20The%20(2011)%20720
p%2Fmhd-taott.720p%2FAdventures%20of%20TinTin,%20The%20(2011)%20720p .mkv HTTP/1.
1" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:48] "GET /TiVoConnect?Command=QueryForma
ts&SourceFormat=video%2Fx-tivo-mpeg HTTP/1.1" 200 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:48] "GET /TiVoConnect?Command=QueryItem&
Url=http%3A%2F%2Fa%2Fb%3FContainer%3D%2FNowPlaying%26id%3D%2 FMovies%2520%2528A-M
%2529%2FAdventures%2520of%2520TinTin%252C%2520The%2520%25282 011%2529%2520720p%2F
mhd-taott.720p%2FAdventures%2520of%2520TinTin%252C%2520The%2520% 25282011%2529%25
20720p.mkv HTTP/1.1" 404 -
INFO:pyTivo:10.0.0.5 [30/Mar/2012 16:31:55] "GET /Movies%20(A-M)/Adventures%20of
%20TinTin,%20The%20(2011)%20720p/mhd-taott.720p/Adventures%20of%20TinTin,%20The%
20(2011)%20720p.mkv?Format=video%2Fx-tivo-mpeg HTTP/1.1" 206 -
INFO:pyTivo.video.video:[30/Mar/2012 16:31:55] Start sending "J:\Movies\Adventur
es of TinTin, The (2011) 720p\mhd-taott.720p\Adventures of TinTin, The (2011) 72
0p.mkv" to BellyButton
ffmpeg version N-38938-ge01f478 Copyright (c) 2000-2012 the FFmpeg developers
built on Mar 19 2012 23:22:13 with gcc 4.6.2
configuration: --disable-static --enable-shared --enable-gpl --enable-version3
--disable-w32threads --enable-runtime-cpudetect --enable-avisynth --enable-bzli
b --enable-frei0r --enable-libopencore-amrnb --enable-libopencore-amrwb --enable
-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-l
ibrtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-li
bvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-l
ibx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 51. 42.100 / 51. 42.100
libavcodec 54. 12.100 / 54. 12.100
libavformat 54. 2.100 / 54. 2.100
libavdevice 53. 4.100 / 53. 4.100
libavfilter 2. 65.101 / 2. 65.101
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 7.100 / 0. 7.100
libpostproc 52. 0.100 / 52. 0.100
Input #0, matroska,webm, from 'J:\Movies\Adventures of TinTin, The (2011) 720p\m
hd-taott.720p\Adventures of TinTin, The (2011) 720p.mkv':
Duration: 01:46:51.78, start: 0.000000, bitrate: 5846 kb/s
Chapter #0.0: start 0.000000, end 339.297000
Metadata:
title : 00:00:00.000
Chapter #0.1: start 339.297000, end 732.315000
Metadata:
title : 00:05:39.297
Chapter #0.2: start 732.315000, end 1031.364000
Metadata:
title : 00:12:12.315
Chapter #0.3: start 1031.364000, end 1536.869000
Metadata:
title : 00:17:11.364
Chapter #0.4: start 1536.869000, end 1957.581000
Metadata:
title : 00:25:36.869
Chapter #0.5: start 1957.581000, end 2275.315000
Metadata:
title : 00:32:37.581
Chapter #0.6: start 2275.315000, end 2549.839000
Metadata:
title : 00:37:55.315
Chapter #0.7: start 2549.839000, end 3052.508000
Metadata:
title : 00:42:29.839
Chapter #0.8: start 3052.508000, end 3387.217000
Metadata:
title : 00:50:52.508
Chapter #0.9: start 3387.217000, end 3739.611000
Metadata:
title : 00:56:27.217
Chapter #0.10: start 3739.611000, end 4318.981000
Metadata:
title : 01:02:19.611
Chapter #0.11: start 4318.981000, end 4803.966000
Metadata:
title : 01:11:58.981
Chapter #0.12: start 4803.966000, end 5250.996000
Metadata:
title : 01:20:03.966
Chapter #0.13: start 5250.996000, end 5652.814000
Metadata:
title : 01:27:30.996
Chapter #0.14: start 5652.814000, end 6030.483000
Metadata:
title : 01:34:12.814
Chapter #0.15: start 6030.483000, end 6411.780000
Metadata:
title : 01:40:30.483
Stream #0:0(eng): Video: h264 (High), yuv420p, 1280x544 [SAR 1:1 DAR 40:17],
23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1(eng): Audio: dts (DTS), 48000 Hz, 5.1(side), s16, 1536 kb/s (def
ault)
Metadata:
title : English DTS 1509kbps
Stream #0:2(eng): Subtitle: text
Please use -b:a or -b:v, -b is ambiguous
[buffer @ 0000000002448160] w:1280 h:544 pixfmt:yuv420p tb:1/1000000 sar:1/1 sws
_param:
Incompatible sample format 's16' for codec 'ac3', auto-selecting format 'flt'
Output #0, vob, to 'pipe:':
Metadata:
encoder : Lavf54.2.100
Chapter #0.0: start 0.000000, end 339.297000
Metadata:
title : 00:00:00.000
Chapter #0.1: start 339.297000, end 732.315000
Metadata:
title : 00:05:39.297
Chapter #0.2: start 732.315000, end 1031.364000
Metadata:
title : 00:12:12.315
Chapter #0.3: start 1031.364000, end 1536.869000
Metadata:
title : 00:17:11.364
Chapter #0.4: start 1536.869000, end 1957.581000
Metadata:
title : 00:25:36.869
Chapter #0.5: start 1957.581000, end 2275.315000
Metadata:
title : 00:32:37.581
Chapter #0.6: start 2275.315000, end 2549.839000
Metadata:
title : 00:37:55.315
Chapter #0.7: start 2549.839000, end 3052.508000
Metadata:
title : 00:42:29.839
Chapter #0.8: start 3052.508000, end 3387.217000
Metadata:
title : 00:50:52.508
Chapter #0.9: start 3387.217000, end 3739.611000
Metadata:
title : 00:56:27.217
Chapter #0.10: start 3739.611000, end 4318.981000
Metadata:
title : 01:02:19.611
Chapter #0.11: start 4318.981000, end 4803.966000
Metadata:
title : 01:11:58.981
Chapter #0.12: start 4803.966000, end 5250.996000
Metadata:
title : 01:20:03.966
Chapter #0.13: start 5250.996000, end 5652.814000
Metadata:
title : 01:27:30.996
Chapter #0.14: start 5652.814000, end 6030.483000
Metadata:
title : 01:34:12.814
Chapter #0.15: start 6030.483000, end 6411.780000
Metadata:
title : 01:40:30.483
Stream #0:0(eng): Video: mpeg2video, yuv420p, 1280x544 [SAR 1:1 DAR 40:17],
q=2-31, 16384 kb/s, 90k tbn, 23.98 tbc (default)
Stream #0:1(eng): Audio: ac3, 48000 Hz, 5.1(side), flt, 448 kb/s (default)
Metadata:
title : English DTS 1509kbps
Stream mapping:
Stream #0:0 -> #0:0 (h264 -> mpeg2video)
Stream #0:1 -> #0:1 (dca -> ac3)
Press [q] to stop, [?] for help


Any Help would be greatly appreciated!
Squeege96 is offline   Reply With Quote
Old 03-30-2012, 07:30 PM   #8
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,924
Where are you seeing the error message? It's not in the console output.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is online now   Reply With Quote
Old 04-01-2012, 08:08 PM   #9
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
Quote:
Originally Posted by wmcbrine View Post
Where are you seeing the error message? It's not in the console output.
Message: "ffmpeg.exe. has stopped working - A problem caused the program to stop working correctly. Windows will close the program and notfiy you if a solution is available."
Squeege96 is offline   Reply With Quote
Old 04-01-2012, 09:09 PM   #10
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,924
Ah. Interesting. Wonderfully non-specific, isn't it?

I would try a different build of ffmpeg.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is online now   Reply With Quote
Old 04-07-2012, 08:32 PM   #11
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
Quote:
Originally Posted by wmcbrine View Post
Ah. Interesting. Wonderfully non-specific, isn't it?

I would try a different build of ffmpeg.
Still having issues. Is there a particular build of ffmpeg that you would recommend for Win 7 64bit? I have been using Zeranoe FFmpeg builds.

Thanks!
Squeege96 is offline   Reply With Quote
Old 04-08-2012, 12:50 PM   #12
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,924
I don't have specific recommendations, since I'm not a Windows guy. But, do you know your exact processor? When I see an error like that, I'm thinking that it's trying to use instructions that aren't available on your processor.

You could look for a more generic build (not optimized), or even try a 32-bit build.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is online now   Reply With Quote
Old 04-08-2012, 05:57 PM   #13
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by Squeege96 View Post
Still having issues. Is there a particular build of ffmpeg that you would recommend for Win 7 64bit? I have been using Zeranoe FFmpeg builds.

Thanks!
My recommendation is to take a step back from new builds of FFmpeg and test an older one that has been tried and vetted by many pyTivo users. The pyTivo rdian06 v1.02 build of FFmpeg is several years old, and while I would count myself as one who prefers the bleeding edge, this should help out or at least give you an idea if there is something else you should look at.

http://pytivo.sourceforge.net/forum/post3557.html#3557
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X

Last edited by Iluvatar : 04-08-2012 at 06:18 PM.
Iluvatar is offline   Reply With Quote
Old 04-10-2012, 04:41 AM   #14
Squeege96
Registered User
 
Squeege96's Avatar
 
Join Date: May 2006
Location: Richmond, VA
Posts: 171
[quote=wmcbrine;9037950]I don't have specific recommendations, since I'm not a Windows guy. But, do you know your exact processor? When I see an error like that, I'm thinking that it's trying to use instructions that aren't available on your processor.

You could look for a more generic build (not optimized), or even try a 32-bit build.[/QUOTE

My processor is a Intel Core i5-2500 CPU @ 3.30 Ghz. I'll try the suggestion to use an earlier version of ffmpeg.

Thanks!
Squeege96 is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 10:06 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |