TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 02-25-2009, 06:56 PM   #151
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by euckersw View Post
Hrm - I'm certainly no expert at this point, but check the log for text similar to this to see if the file is being transcoded or not:

2009-02-24 18:27:42,707 DEBUG pyTivo.video.transcode: (True, 'TRANSCODE=NO, passing through mp4.'), m:\movies\\movie2.mkv
OK. REALLY DUMB question that I should know better on, but where does pyTivo save the log file?
NA9D is offline   Reply With Quote
Old 02-25-2009, 07:26 PM   #152
euckersw
Registered User
 
Join Date: Jan 2004
Posts: 23
Quote:
Originally Posted by NA9D View Post
OK. REALLY DUMB question that I should know better on, but where does pyTivo save the log file?
No problem - check debug.log in the pyTivo root directory.
euckersw is offline   Reply With Quote
Old 02-25-2009, 08:45 PM   #153
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by euckersw View Post
No problem - check debug.log in the pyTivo root directory.
OK. Maybe I have to start it with some flag or something. No debug.log in the root directory...

Guess I'll go RTFM on that...

Edit: OK. I found out how to turn the log on.

OK...Or so I thought. I set debug to True. But after resetting, I don't see the file in the pyTivo directory.

Now, I am running a startup script that sends console output to /dev/null but that should be an issue should it?

python /mnt/disk1/Media/pyTivo/pyTivo.py > /dev/null 2>&1 &


That's at least according to the script on Armooo's site..

Last edited by NA9D : 02-25-2009 at 09:14 PM.
NA9D is offline   Reply With Quote
Old 02-25-2009, 09:34 PM   #154
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
OK. I ended up directing my output to a file instead of /dev/null and that gets me the same thing basically! Not sure why the debug.txt file isn't being written out. But here's what I get when I try to push a file:

DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/MPEG4-H.264/Battlestar Galactica - (HDTV) 404 - Escape Velocity.mp4

So why is an h.264 file not compatible? I thought it pushed w/o problem..
NA9D is offline   Reply With Quote
Old 02-25-2009, 09:53 PM   #155
burnside
Registered User
 
Join Date: Jan 2009
Posts: 42
Quote:
Originally Posted by moyekj View Post
MediaInfo is pretty nice. You can also use the ffmpeg that comes with pyTivo: "ffmpeg_mp2 -i fileName" to get information in same way pyTivo is doing it.
Damn, one more question. What would be the ffmpeg command to encode an mpeg to an mp4 with ac3 (192kbps)? I'm using winff and see the preset for h264 but it uses aac instead of ac3.
burnside is offline   Reply With Quote
Old 02-25-2009, 10:17 PM   #156
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,054
Quote:
Originally Posted by burnside View Post
Damn, one more question. What would be the ffmpeg command to encode an mpeg to an mp4 with ac3 (192kbps)? I'm using winff and see the preset for h264 but it uses aac instead of ac3.
I created a streambaby Wiki entry on compatible video information which includes a sample ffmpeg recipe to create mp4 with h.264 video and ac3 audio (from mpeg2 source):
http://code.google.com/p/streambaby/..._compatibility
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-25-2009, 10:59 PM   #157
txporter
One sec, almost done
 
Join Date: Sep 2006
Location: Austin, TX
Posts: 666
Quote:
Originally Posted by NA9D View Post
OK. I ended up directing my output to a file instead of /dev/null and that gets me the same thing basically! Not sure why the debug.txt file isn't being written out. But here's what I get when I try to push a file:

DEBUGyTivo.video.transcodeFalse, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/MPEG4-H.264/Battlestar Galactica - (HDTV) 404 - Escape Velocity.mp4

So why is an h.264 file not compatible? I thought it pushed w/o problem..
Are you using wmcbrine's latest pytivo fork from his git?

Jason
__________________
Tivo Premiere 2TB WD20EARS (lifetime)
TivoHD 1TB WD10EACS + 1TB WD10EVCS Antec MX-1 (lifetime)
TivoHD 1TB WD10EACS (lifetime)
Series2 540 400GB Seagate DB35 (lifetime)
txporter is offline   Reply With Quote
Old 02-25-2009, 11:31 PM   #158
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by txporter View Post
Are you using wmcbrine's latest pytivo fork from his git?

Jason
Yeah from earlier today (2/25)...
NA9D is offline   Reply With Quote
Old 02-26-2009, 02:22 AM   #159
txporter
One sec, almost done
 
Join Date: Sep 2006
Location: Austin, TX
Posts: 666
Tried pushing tonight for the first time with wmcbrine's latest git. My mp4 are also getting transcoded like NA9D. I will try to post some logs in the morning, but I created these files using the Constant Quality profile in Handbrake with http optimized checked. I thought I had read this moved the moov atom to the front of the file. Anyone else successfully push a handbrake encode? Or all using something else?

Jason
__________________
Tivo Premiere 2TB WD20EARS (lifetime)
TivoHD 1TB WD10EACS + 1TB WD10EVCS Antec MX-1 (lifetime)
TivoHD 1TB WD10EACS (lifetime)
Series2 540 400GB Seagate DB35 (lifetime)
txporter is offline   Reply With Quote
Old 02-26-2009, 06:14 AM   #160
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
FYI, I think most of my files were done using VisualHub on my Mac. I could try a file that I did using iTivo...Maybe my moov atom is fubar with the VisualHub files.

OK. Nope. A download converted using iTivo doesn't work either...

Last edited by NA9D : 02-26-2009 at 06:31 AM.
NA9D is offline   Reply With Quote
Old 02-26-2009, 07:02 AM   #161
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,010
Quote:
Originally Posted by txporter View Post
Anyone else successfully push a handbrake encode?
Yes, I have. BTW, if you have a version with Keary's qt-faststart patch, it no longer matters if the moov atom is at the start.

debug=True hasn't created a debug.txt file for a long time -- that was outdated documentation. (I've just corrected it.) Instead, it just adds more output, which still goes to the console, unless you redirect it or use the logging options.

It might be that your audio is being reported as libfaad instead of mpeg4aac. I've added that to the pass-through list this morning.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 02-26-2009, 07:22 AM   #162
euckersw
Registered User
 
Join Date: Jan 2004
Posts: 23
So what if we were to use a program like mkv2vob to remux a mkv file with h264 to a mp4 file?:

http://www.videohelp.com/tools/mkv2vob

Would that be able to trick Tivo into accepting the remuxed mkv without transcoding?
euckersw is offline   Reply With Quote
Old 02-26-2009, 07:46 AM   #163
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,010
Sure. I wouldn't call that a trick, either.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 02-26-2009, 08:56 AM   #164
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by wmcbrine View Post
debug=True hasn't created a debug.txt file for a long time -- that was outdated documentation. (I've just corrected it.) Instead, it just adds more output, which still goes to the console, unless you redirect it or use the logging options.

It might be that your audio is being reported as libfaad instead of mpeg4aac. I've added that to the pass-through list this morning.
Thanks for the info. The latest release still isn't working for me. Just VPN'd into home and tried sending a show. Here's what my log file says:
Code:
DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
So I guess I'll have to run MediaInfo or whatever on this and report it back to ya'll because something isn't right...
NA9D is offline   Reply With Quote
Old 02-26-2009, 08:59 AM   #165
txporter
One sec, almost done
 
Join Date: Sep 2006
Location: Austin, TX
Posts: 666
Quote:
Originally Posted by wmcbrine View Post
It might be that your audio is being reported as libfaad instead of mpeg4aac. I've added that to the pass-through list this morning.
Yes, my audio is being reported as libfaad. Will try with your newest version and report back.

Jason

update: push seems to be working now with new build. Thanks! Also, can i queue more than one show to push to Tivo, or do I need to do one at a time as they finish?
__________________
Tivo Premiere 2TB WD20EARS (lifetime)
TivoHD 1TB WD10EACS + 1TB WD10EVCS Antec MX-1 (lifetime)
TivoHD 1TB WD10EACS (lifetime)
Series2 540 400GB Seagate DB35 (lifetime)

Last edited by txporter : 02-26-2009 at 09:09 AM. Reason: update
txporter is offline   Reply With Quote
Old 02-26-2009, 09:24 AM   #166
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
OK. Here is the info on one of my files....Perhaps someone can tell me why it's trying to transcode?

Quote:
General

Complete name : /Volumes/Media-1/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4

Format : MPEG-4

Codec ID : M4V

File size : 293 MiB

Duration : 24mn 57s

Overall bit rate : 1 641 Kbps

Movie name : Darby Goes Woozle Sluethin'; How the Tigger Lost His

Album : My Friends Tigger & Pooh

Performer : My Friends Tigger & Pooh

Genre : Animated, Kids, Educational

Encoded date : 2008

Tagged date : UTC 2009-02-17 14:08:38

stik : 10

tvsh : My Friends Tigger & Pooh

tven : Darby Goes Woozle Sluethin'; How the Tigger Lost His

tves : 201

tvnn : DISNHD



Video

ID : 1

Format : AVC

Format/Info : Advanced Video Codec

Format profile : Baseline@L3.0

Format settings, CABAC : No

Format settings, ReFrames : 1 frame

Codec ID : avc1

Codec ID/Info : Advanced Video Coding

Duration : 24mn 57s

Bit rate mode : Variable

Bit rate : 1 506 Kbps

Width : 640 pixels

Height : 368 pixels

Display aspect ratio : 16/9

Frame rate mode : Constant

Frame rate : 59.940 fps

Resolution : 24 bits

Colorimetry : 4:2:0

Scan type : Progressive

Bits/(Pixel*Frame) : 0.107

Stream size : 269 MiB (92%)

Encoded date : UTC 1970-01-01 00:00:00

Tagged date : UTC 1970-01-01 00:00:00



Audio

ID : 2

Format : AAC

Format/Info : Advanced Audio Codec

Format version : Version 4

Format profile : LC

Format settings, SBR : No

Codec ID : 40

Duration : 24mn 57s

Bit rate mode : Variable

Bit rate : 128 Kbps

Channel(s) : 2 channels

Channel positions : L R

Sampling rate : 48.0 KHz

Resolution : 16 bits

Stream size : 22.9 MiB (8%)

Encoded date : UTC 1970-01-01 00:00:00

Tagged date : UTC 2009-02-17 14:08:38



NA9D is offline   Reply With Quote
Old 02-26-2009, 09:27 AM   #167
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
And here's one more that wouldn't transfer right:

Quote:
General

Complete name : /Volumes/Media-1/Video/MPEG4-H.264/Battlestar Galactica - 405 - The Road Less Traveled.mp4

Format : MPEG-4

Codec ID : M4V

File size : 701 MiB

Duration : 59mn 59s

Overall bit rate : 1 634 Kbps

Encoded date : UTC 2008-06-15 04:48:23

Tagged date : UTC 2008-06-15 13:44:46

Writing library : Apple QuickTime

tvsh : Battlestar Galactica

tven : The Road Less Traveled

tvsn : 4

tves : 5



Video

ID : 1

Format : AVC

Format/Info : Advanced Video Codec

Format profile : Baseline@L3.0

Format settings, CABAC : No

Format settings, ReFrames : 1 frame

Codec ID : avc1

Codec ID/Info : Advanced Video Coding

Duration : 59mn 59s

Bit rate mode : Variable

Bit rate : 1 499 Kbps

Width : 612 pixels

Height : 458 pixels

Display aspect ratio : 4/3

Frame rate mode : Constant

Frame rate : 29.970 fps

Resolution : 24 bits

Colorimetry : 4:2:0

Scan type : Progressive

Bits/(Pixel*Frame) : 0.178

Stream size : 643 MiB (92%)

Encoded date : UTC 2008-06-15 04:48:23

Tagged date : UTC 2008-06-15 04:48:23



Audio

ID : 2

Format : AAC

Format/Info : Advanced Audio Codec

Format version : Version 4

Format profile : LC

Format settings, SBR : No

Codec ID : 40

Duration : 59mn 59s

Bit rate mode : Constant

Bit rate : 125 Kbps

Nominal bit rate : 128 Kbps

Channel(s) : 2 channels

Channel positions : L R

Sampling rate : 48.0 KHz

Resolution : 16 bits

Stream size : 53.7 MiB (8%)

Encoded date : UTC 2008-06-15 04:48:23

Tagged date : UTC 2008-06-15 13:44:46




NA9D is offline   Reply With Quote
Old 02-26-2009, 09:28 AM   #168
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by wmcbrine View Post
It might be that your audio is being reported as libfaad instead of mpeg4aac. I've added that to the pass-through list this morning.
Thanks, I hadn't seen libfaad before, so I just added it to streambaby's list of recognized AAC codecs. Streambaby also has the additional id's listed for AAC audio. (All from various versions/configurations of ffmpeg):

mp4a
aac

I think mp4a is what my stock Ubuntu 8.04 ffmpeg reported (i've since upgraded). The aac came from a user running a recent Mac version of ffmpeg.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 02-26-2009, 09:30 AM   #169
CuriousMark
Forum Denizen
 
CuriousMark's Avatar
 
Join Date: Jan 2005
Location: SoCal
Posts: 2,535
I don't know if this matters or not, but TiVo Desktop allows only one instance to be connected to mind at a time. So if users who are having trouble are also using TiVo Desktop Plus, perhaps the connection of pyTivo is being ignored. Just a thought from out in left field. I can't participate in any of this as a series 2 owner, so feel free to ignore this if it doesn't make sense.
CuriousMark is offline   Reply With Quote
Old 02-26-2009, 09:51 AM   #170
jasonrn
Registered User
 
Join Date: Feb 2007
Posts: 16
Does this work for Series 2?
jasonrn is offline   Reply With Quote
Old 02-26-2009, 10:03 AM   #171
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,054
NA9D, what is really needed is the output of:

ffmpeg -i "/Volumes/Media-1/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4"

ffmpeg -i "/Volumes/Media-1/Video/MPEG4-H.264/Battlestar Galactica - 405 - The Road Less Traveled.mp4"

The MediaInfo information seems to indicate these should work but perhaps the codec names don't match what is currently being checked in pyTivo.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-26-2009, 10:05 AM   #172
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,054
Quote:
Originally Posted by jasonrn View Post
Does this work for Series 2?
S2 machines don't have mpeg4 decoding capabilities so native mpeg4 pushes are not possible.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-26-2009, 10:40 AM   #173
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by moyekj View Post
NA9D, what is really needed is the output of:

ffmpeg -i "/Volumes/Media-1/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4"

ffmpeg -i "/Volumes/Media-1/Video/MPEG4-H.264/Battlestar Galactica - 405 - The Road Less Traveled.mp4"

The MediaInfo information seems to indicate these should work but perhaps the codec names don't match what is currently being checked in pyTivo.
Now you've opened a can of worms! There's something screwy with my FFMPEG install but I don't know what. I was hoping that these pushes wouldn't involve FFMPEG. I'll post some logs and maybe we can figure some of this out...

FYI: I'm running pyTivo in this instance on a Buffalo Linkstation Live. I don't expect it to do well for heavy on the fly transcoding but it serves up MPEG-2s to the Tivo just fine. There is something funky though that I've not been able to figure out as it won't even get to transcoding an MPEG-4 file but errors out. So I'm not even able to get to the point where transcoding starts but the NAS is swamped...
NA9D is offline   Reply With Quote
Old 02-26-2009, 10:44 AM   #174
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Here you go. I just included basically all the output. It goes through this over and over and over again.

I was able to get one show yesterday to appear to push to the Tivo but FFMPEG got hung up and wouldn't transcode. Now it doesn't even get that far. Nothing ever shows up on the Tivo...

Quote:
192.168.1.59 - - [26/Feb/2009 09:00:01] "GET /TiVoConnect?Command=QueryContainer&Container=%2F HTTP/1.0" 200 -
192.168.1.1 - - [26/Feb/2009 10:41:52] "GET /TiVoConnect?Command=QueryContainer&Container=LSL-iTivo/My%20Friends%20Tigger%20%26%20Pooh HTTP/1.1" 200 -
192.168.1.1 - - [26/Feb/2009 10:41:53] "GET /TiVoConnect?Command=XSL&Container=LSL-iTivo/My%20Friends%20Tigger%20%26%20Pooh HTTP/1.1" 200 -
192.168.1.1 - - [26/Feb/2009 10:41:53] "GET /favicon.ico HTTP/1.1" 200 -
DEBUG:root:starting ffmpeg, will wait 30 seconds for it to complete
DEBUG:root:ffmpeg output=FFmpeg version UNKNOWN, Copyright (c) 2000-2008 Fabrice Bellard, et al.
configuration: --enable-cross-compile --cross-prefix=/home/slug/optware/cs05q3armel/toolchain/arm-none-linux-gnueabi/gcc-2005q3-glibc-2.3.6/bin/arm-none-linux-gnueabi- --arch=arm --disable-encoder=snow --disable-decoder=snow --enable-shared --disable-static --enable-gpl --enable-postproc --prefix=/opt
libavutil version: 49.6.0
libavcodec version: 51.54.0
libavformat version: 52.13.0
libavdevice version: 52.0.0
built on Apr 15 2008 22:17:14, gcc: 3.4.4 (release) (CodeSourcery ARM 2005q3-2)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4':
Duration: 00:24:57.6, start: 0.000000, bitrate: 1641 kb/s
Stream #0.0(und): Video: h264, yuv420p, 640x368, 59.94 tb(r)
Stream #0.1(und): Audio: mp4a / 0x6134706D, 48000 Hz, stereo
Must supply at least one output file

DEBUG:pyTivo.video.transcode:failed at aKbps
DEBUG:pyTivo.video.transcode:aFreq=48000; vFps=59.94; kbps=1641; mapAudio=[('0.1', '(und)')]; vWidth=640; vCodec=h264; Supported=True; millisecs=1497600; par=None; aKbps=None; par2=None; par1=None; dar2=None; mapVideo=0.0; vHeight=368; dar1=None; aCodec=mp4a / 0x6134706D
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, aCodec mp4a / 0x6134706D not compatible.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:tsn: 65200018039B973
DEBUG:root:aspect169: True
DEBUG:root:optres: False
DEBUG:pyTivo.video.transcode:File=/mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4 vCodec=h264 vWidth=640 vHeight=368 vFps=59.94 millisecs=1497600 ratio=173 rheight=23 rwidth=40 TIVO_HEIGHT=720 TIVO_WIDTH=1280
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:pyTivo.mind:__login
{'cams_security_domain': 'tivocom', 'cams_login_config': 'http', 'cams_cb_password': 'xxxxxxxx', 'cams_original_url': '/mind/mind7?type=infoGet', 'cams_cb_username': 'jogden@xxxxxxx'}
DEBUG:pyTivo.mind:pcBodySearch
{}

<pcBodyList><isBottom>true</isBottom><isTop>true</isTop><pcBody><bucketNumber>2798</bucketNumber><levelOfDetail>low</levelOfDetail><name>NA9DSERVER</name><pcBodyId>tivo:pc.1000142011</pcBodyId><type>pcBody</type></pcBody></pcBodyList>g
DEBUG:pyTivo.mind:pcBodySearch
{}

<pcBodyList><isBottom>true</isBottom><isTop>true</isTop><pcBody><bucketNumber>2798</bucketNumber><levelOfDetail>low</levelOfDetail><name>NA9DSERVER</name><pcBodyId>tivo:pc.1000142011</pcBodyId><type>pcBody</type></pcBody></pcBodyList>g
DEBUG:pyTivo.mind:bodyOfferModify&bodyId=tsn:65200018039B973
{'subtitle': "Darby Goes Woozle Sluethin'; How the Tigger Lost His", 'description': '', 'title': 'My Friends Tigger & Pooh', 'url': 'http://192.168.1.20:9032/LSL-iTivo/My%20Friends%20Tigger%20%26%20Pooh/My%20Friends%20Tigger%20%26%20Pooh%20-%20Darby%20Goes%20Woozle%20Sluethin%27%3B%20How%20the%20Tigg er%20Lost%20His.mp4', 'pcBodyId': 'tivo:pc.1000142011', 'bodyId': 'tsn:65200018039B973', 'publishDate': '2009-02-26 16:4204', 'source': 'My Friends Tigger & Pooh', 'state': 'complete', 'partnerId': 'tivo:pt.3187', 'duration': 1497, 'encodingType': 'mpeg2ProgramStream', 'size': 3212681760L}

<bodyOffer><bodyId>tsn:65200018039B973</bodyId><bodyOfferId>tivo:bo.15000691</bodyOfferId><createDate>2009-02-26 16:42:06</createDate><description /><duration>1497</duration><encodingType>mpeg2ProgramStream</encodingType><levelOfDetail>high</levelOfDetail><offerId>tivo:of.bs.15000691</offerId><partnerId>tivo:pt.3187</partnerId><pcBodyId>tivo:pc.1000142011</pcBodyId><publishDate>2009-03-01 14:04:00</publishDate><size>3212681760</size><source>My Friends Tigger &amp; Pooh</source><state>complete</state><subtitle>Darby Goes Woozle Sluethin'; How the Tigger Lost His</subtitle><title>My Friends Tigger &amp; Pooh</title><updateDate>2009-02-26 16:42:06</updateDate><url>http://192.168.1.20:9032/LSL-iTivo/My%20Friends%20Tigger%20%26%20Pooh/My%20Friends%20Tigger%20%26%20Pooh%20-%20Darby%20Goes%20Woozle%20Sluethin%27%3B%20How%20the%20Tigg er%20Lost%20His.mp4</url></bodyOffer>g

NA9D is offline   Reply With Quote
Old 02-26-2009, 10:47 AM   #175
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,010
Quote:
Originally Posted by NA9D View Post
I was hoping that these pushes wouldn't involve FFMPEG.
Everything involves ffmpeg. Even when it's not used for transcoding, it's used to find out about the file -- codecs, bitrates, etc. The only exception is for .TiVo files.

Edit: In the log you just posted, the audio track is identified as "mp4a / 0x6134706D". That's why it doesn't want to pass it without transcoding. I just now added "mp4a" to the list of recognized IDs, but it still won't work for that, because of the extra bit at the end.

If you add that full string to the list in tivo_compatible_mp4() in plugins/video/transcode.py, it might work. Or you could upgrade your ffmpeg.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wmcbrine : 02-26-2009 at 10:59 AM.
wmcbrine is offline   Reply With Quote
Old 02-26-2009, 11:19 AM   #176
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by wmcbrine View Post
If you add that full string to the list in tivo_compatible_mp4() in plugins/video/transcode.py, it might work. Or you could upgrade your ffmpeg.
This is what I'd like to do - upgrade my FFMPEG. Problem is, I'm not sure where to get a compiled version from. The version I am using is being supplied through iPKG but it does not seem to work well. So I'm not sure where to get another version compiled for the ARM processor. I'll admit I haven't looked real hard yet either...
NA9D is offline   Reply With Quote
Old 02-26-2009, 11:39 AM   #177
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by wmcbrine View Post
If you add that full string to the list in tivo_compatible_mp4() in plugins/video/transcode.py, it might work. Or you could upgrade your ffmpeg.
OK, looking at transcode.py, I see:

Code:
  if vInfo['vCodec'] != 'h264':
        message = (False, 'TRANSCODE=YES, vCodec %s not compatible.' %
                          vInfo['vCodec'])
    elif vInfo['aCodec'] not in ('mpeg4aac', 'libfaad', 'ac3', 'liba52'):
        message = (False, 'TRANSCODE=YES, aCodec %s not compatible.' %
                          vInfo['aCodec'])
    else:
        message = (True, 'TRANSCODE=NO, passing through mp4.')

    logger.debug('%s, %s' % (message, inFile))
    return message
I've never programmed in Python, but I do know a little and I see something that jumps out at me here - the first line...In English, I translate that to:

If the Video Codec is H.264 then force transcoding because it's not compatible...or am I reading that wrong?

I've got feeling I'm not because I changed the audio format and while that first appeared compatible, I'm still getting:

DEBUG:pyTivo.video.transcode:aFreq=48000; vFps=59.94; kbps=1641; mapAudio=[('0.1', '(und)')]; vWidth=640; vCodec=h264; Supported=True; millisecs=1497600; par=None; aKbps=None; par2=None; par1=None; dar2=None; mapVideo=0.0; vHeight=368; dar1=None; aCodec=mp4a / 0x6134706D
DEBUG:root:CACHE HIT! /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4
DEBUG:pyTivo.video.transcode:(True, 'TRANSCODE=NO, passing through mp4.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4

.....


DEBUG:pyTivo.video.transcode:(False, 'TRANSCODE=YES, vCodec h264 not compatible.'), /mnt/disk1/Media/Video/iTivoDownloads/My Friends Tigger & Pooh/My Friends Tigger & Pooh - Darby Goes Woozle Sluethin'; How the Tigger Lost His.mp4

So it is failing on the H264 codec not compatible thing...
NA9D is offline   Reply With Quote
Old 02-26-2009, 11:41 AM   #178
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by NA9D View Post
This is what I'd like to do - upgrade my FFMPEG. Problem is, I'm not sure where to get a compiled version from. The version I am using is being supplied through iPKG but it does not seem to work well. So I'm not sure where to get another version compiled for the ARM processor. I'll admit I haven't looked real hard yet either...
Edit: I've removed this message because it was completely and utterly incorrect.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 02-26-2009, 11:46 AM   #179
NA9D
Registered User
 
NA9D's Avatar
 
Join Date: May 2008
Location: Algonquin, IL
Posts: 196
Quote:
Originally Posted by kearygriffin View Post
Edit: I've removed this message because it was completely and utterly incorrect.
Damn! I was going to try that.
NA9D is offline   Reply With Quote
Old 02-26-2009, 11:54 AM   #180
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Quote:
Originally Posted by NA9D View Post
If the Video Codec is H.264 then force transcoding because it's not compatible...or am I reading that wrong?
Not gonna comment about the rest, but
'!' is standard (from C) terminology for NOT.

So saying something like
if (A != B) is a test for A NOT equal to B.

So your whole interpretation of the rest is backwards.
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Yoav is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 04:20 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |