TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 08-07-2010, 08:58 AM   #2521
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
Little side note, PS format seems to be downloading at 20Mps while TS format last night maxed out at 11Mps... shouldnt it be the other way around?
wireman121 is offline   Reply With Quote
Old 08-07-2010, 10:44 AM   #2522
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by wireman121 View Post
Little side note, PS format seems to be downloading at 20Mps while TS format last night maxed out at 11Mps... shouldnt it be the other way around?
TS downloads should be higher than 20Mbps. In any case there are plenty of posts about Premiere TS downloads and/or decryption having issues, so should not be used.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-07-2010, 11:04 AM   #2523
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
I was afraid to hear that. Is there a discussion somewhere that is working on getting the TS downloads working properly with kmttg, tivodecode, etc? I'd be interested in participating in getting it to be more stable
wireman121 is offline   Reply With Quote
Old 08-07-2010, 11:35 AM   #2524
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by wireman121 View Post
I was afraid to hear that. Is there a discussion somewhere that is working on getting the TS downloads working properly with kmttg, tivodecode, etc? I'd be interested in participating in getting it to be more stable
The TS download problems are purely a Premiere issue, not curl, kmttg or whatever else you use to download in that format. For tivodecode issues with TS streams the latest source code including TS support is available from kmttg downloads section:
http://kmttg.googlecode.com/files/ti...0.3pre4.tar.gz
It is based on some anonymous poster who posted patches at the sourceforge site (and mentioned there was still a bug present):
http://sourceforge.net/tracker/?atid...16&func=browse

i.e. source code is available if someone wants to take a crack at fixing tivodecode. But that still doesn't help if TS downloads from Premiere units are not reliable - only TiVo can fix that and they have much bigger fish to fry when it comes to the Premiere...
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-07-2010, 12:17 PM   #2525
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
Yea, I made sure I have everything updated to the newest version. I'm not sure why its downloading so slow. I restarted a TS download to see if there would be a difference. It started coming at about 50Mbps for maybe 5 seconds, and has since dropped to an average of 10Mbps. I'm not sure what is causing that - I know the network is fine, and if I initiate a PS download it comes a little faster.

Besides that, I'm going to see if redownloading the TS file works with tivodecode this time, otherwise I'll just be leaving TS off for now until things get fixed...

I have to agree. I'm not that excited about the Tivo Premiere. I thought, if nothing else, it would be faster to navigate through the menus and whatnot, but it definately is slower than my Tivo HD. And theres no menu option to initiate a restart?

Its currently at 14.4 version, and I cant figure out how to get it to update to 14.5, not that I actually expect that to fix any of my problems, but tivo.com says 14.5 is newest...
wireman121 is offline   Reply With Quote
Old 08-07-2010, 12:27 PM   #2526
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by wireman121 View Post
I have to agree. I'm not that excited about the Tivo Premiere. I thought, if nothing else, it would be faster to navigate through the menus and whatnot, but it definately is slower than my Tivo HD. And theres no menu option to initiate a restart?
I know it's off topic, but: If I had a Premiere I would just stick to SD menus. From all accounts that is stable and much faster than THD/S3 units. Also PS downloads are much faster than THD/S3 units as well so I would be content with that as well.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-07-2010, 11:07 PM   #2527
ferror
Registered User
 
Join Date: May 2005
Location: Austin, TX
Posts: 65
@moyekj: I agree on the Premiere HDUI. I wish they would just offer an option to widen the existing SD menus and use a smaller font. It would still run very fast on the new hardware, but skip all that Flash mess until some other time (or not.) They should even back-port that to the S3/THD as well. Seeing as they call that an HD unit, it seems like it should have menus that optionally support that format optimally.

@marbordom and others experiencing the stalled downloads in curl on Windows:

It appears I have found a solution to this issue on my system. I installed the Cygwin version of curl and set kmttg to use that instead of the version that is packaged with it. If you are not familiar, Cygwin is a *NIX-style command shell and tools emulator for Windows. They have ported most of the library code that the *NIX tools require and can compile them to run in Windows, and they actually have done a very good job with most of them. Cygwin is a bit unconventional to most Windows users, so most packages including curl have native Windows distributions that run as standalone apps. I think the advantage in this case is that curl for Cygwin is compiled in a unique way and runs through a different set of APIs compared to the native Windows curl distribution. This looks like it is a fluke that just happens to work in our favor here. Whatever is happening does not seem to effect the Cygwin version. The curl developers will still need to find the root cause of the problem, but this buys us some time by giving us a relatively easy way around the issue for now.

To do it, just run the Cygwin setup program and then be sure to enable the curl package to be installed. Then change the kmttg curl path to point at c:\Cygwin\bin\curl.exe, or wherever it is installed. The Cygwin curl will run fine even if you are not in the Cygwin shell. Now your log entries should show curl running from that new path and with any luck you will also find that your downloads are working right again.

Last edited by ferror : 08-07-2010 at 11:16 PM.
ferror is offline   Reply With Quote
Old 08-08-2010, 01:26 AM   #2528
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Interesting find ferror. NOTE: You don't need a whole cygwin installation to get it to work. I pulled out curl.exe and all the necessary accompanying cygwin .dll files and made a self-contained package that runs without having cygwin installed. Those having this issue can try out this version of curl:
http://kmttg.googlecode.com/files/cygwin_curl.zip
(Rename the kmttg "curl" folder and replace with the one in the above zip file).
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-08-2010, 01:48 AM   #2529
ferror
Registered User
 
Join Date: May 2005
Location: Austin, TX
Posts: 65
Thanks. Yeah, sorry installing Cygwin is a bit extreme, was just a quick way to get the desired result. I was just thinking about looking at what files would be needed to just run curl and then saw your post. Putting this version of curl into the kmttg dist would actually solve the problem completely, at least for the time being. Then the curl developers fixing it in their windows version would just be an interesting bit of news for building the next bundle.

EDIT: I have one thing to add regarding the cygwin curl. If you happen to already have cygwin installed on your machine for any other reason, you should use the cygwin setup program to install/update curl and not use a separate version of curl. The reason is that the .dll files will probably get out of sync.

Last edited by ferror : 08-08-2010 at 02:10 AM.
ferror is offline   Reply With Quote
Old 08-08-2010, 09:32 AM   #2530
marbordom
Registered User
 
Join Date: Sep 2007
Location: Bronx, NY
Posts: 27
curl downloads

Quote:
Originally Posted by ferror View Post
@moyekj: I agree on the Premiere HDUI. I wish they would just offer an option to widen the existing SD menus and use a smaller font. It would still run very fast on the new hardware, but skip all that Flash mess until some other time (or not.) They should even back-port that to the S3/THD as well. Seeing as they call that an HD unit, it seems like it should have menus that optionally support that format optimally.

@marbordom and others experiencing the stalled downloads in curl on Windows:

It appears I have found a solution to this issue on my system. I installed the Cygwin version of curl and set kmttg to use that instead of the version that is packaged with it. If you are not familiar, Cygwin is a *NIX-style command shell and tools emulator for Windows. They have ported most of the library code that the *NIX tools require and can compile them to run in Windows, and they actually have done a very good job with most of them. Cygwin is a bit unconventional to most Windows users, so most packages including curl have native Windows distributions that run as standalone apps. I think the advantage in this case is that curl for Cygwin is compiled in a unique way and runs through a different set of APIs compared to the native Windows curl distribution. This looks like it is a fluke that just happens to work in our favor here. Whatever is happening does not seem to effect the Cygwin version. The curl developers will still need to find the root cause of the problem, but this buys us some time by giving us a relatively easy way around the issue for now.

To do it, just run the Cygwin setup program and then be sure to enable the curl package to be installed. Then change the kmttg curl path to point at c:\Cygwin\bin\curl.exe, or wherever it is installed. The Cygwin curl will run fine even if you are not in the Cygwin shell. Now your log entries should show curl running from that new path and with any luck you will also find that your downloads are working right again.
That find is awesome. Yesterday I ran kmttg under Ubuntu and even there I found the curl problem - I had to restart the Tivo since resetting the web server did not solve that no connection could be made to the tivo's IP. Now I have to fix my Win 7 before I can trye your solution .. after shrinking the Win7 partition I can not boot into this or the recover partition ...
marbordom is offline   Reply With Quote
Old 08-08-2010, 11:11 PM   #2531
marbordom
Registered User
 
Join Date: Sep 2007
Location: Bronx, NY
Posts: 27
Quote:
Originally Posted by moyekj View Post
Interesting find ferror. NOTE: You don't need a whole cygwin installation to get it to work. I pulled out curl.exe and all the necessary accompanying cygwin .dll files and made a self-contained package that runs without having cygwin installed. Those having this issue can try out this version of curl:
http://kmttg.googlecode.com/files/cygwin_curl.zip
(Rename the kmttg "curl" folder and replace with the one in the above zip file).
Hi, when I use the unzipped dir under kmttg the curl.exe can not find cygz.dll. Since I do not know which version this it copying one would just be another trial and error. Other than that I do have cygwin installed and the version installed on my Win7 is not running either (gets stalled)
[xxx@acer]$ /bin/curl --version
curl 7.20.1 (i686-pc-cygwin) libcurl/7.20.1 OpenSSL/0.9.8o zlib/1.2.5 libidn/1.1
8 libssh2/1.2.5
Protocols: dict file ftp ftps http https imap imaps pop3 pop3s rtsp scp sftp smt
p smtps telnet tftp
Features: IDN IPv6 Largefile NTLM SSL libz

Last edited by marbordom : 08-08-2010 at 11:12 PM. Reason: typos galore
marbordom is offline   Reply With Quote
Old 08-08-2010, 11:36 PM   #2532
ferror
Registered User
 
Join Date: May 2005
Location: Austin, TX
Posts: 65
Hmm, sounds like maybe the zip needs another file, but if you are running cygwin now anyway, that should do the trick. You are running the exact same version I am running here. Mine actually did stall again once during the afternoon today, but I've seen that happen before for other reasons. Before I switched to the cygwin curl last night, the stalls were happening on almost every file at least once or twice. It was a very acute issue, not just an annoyance. The -y 60 -Y 100 parameters did help to make it eventually get the files downloaded. When I was testing the cygwin curl, I took those parameters out to see how it handles it without them. When it stalled this afternoon, I decided to go ahead and put them back as an additional measure against the issue. Looks like the stalls can still happen, but in my case the cygwin curl reduced those stalls to such a low amount that it took a day of continuous running before I saw it happen again. Sorry you aren't having as much luck with yours. I am not sure what the variables are in this equation, but I think we are close.
ferror is offline   Reply With Quote
Old 08-09-2010, 01:52 AM   #2533
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by marbordom View Post
Hi, when I use the unzipped dir under kmttg the curl.exe can not find cygz.dll. Since I do not know which version this it copying one would just be another trial and error. Other than that I do have cygwin installed and the version installed on my Win7 is not running either (gets stalled)
[xxx@acer]$ /bin/curl --version
curl 7.20.1 (i686-pc-cygwin) libcurl/7.20.1 OpenSSL/0.9.8o zlib/1.2.5 libidn/1.1
8 libssh2/1.2.5
Protocols: dict file ftp ftps http https imap imaps pop3 pop3s rtsp scp sftp smt
p smtps telnet tftp
Features: IDN IPv6 Largefile NTLM SSL libz
Yeah I guess I missed that dll. I've updated the download to include it and verified that it runs on my Win 7 machine without cygwin installed:
http://kmttg.googlecode.com/files/curl_cygwin.zip

BTW, I've now downloaded over 40 different shows from my S3s to a Win 7 laptop and have not had a single freeze or incomplete download, so I cannot reproduce this issue at all.
Are these curl freezes when downloading from Premiere units only?
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-09-2010, 01:57 AM   #2534
ferror
Registered User
 
Join Date: May 2005
Location: Austin, TX
Posts: 65
For me it happens on either of my TiVo HDs and on my Premiere (which I thought I was getting to replace one the the THDs, but never wound up selling it). It seems to happen more often on the Premiere, than the THDs, but I think this is just because the download speed is faster and so it is that much more likely to fail. Due to the faster transfer speed, it may also increase the likelihood of getting a stall. I have not tried it on anything other than win7 but marbodom said he saw it on Ubuntu as well, which was a big surprise to me. Maybe the issue goes a bit deeper than originally thought.
ferror is offline   Reply With Quote
Old 08-09-2010, 07:55 AM   #2535
lew
Registered User
 
Join Date: Mar 2002
Posts: 3,255
Add me to the list of users who solved issues by uninstalling Java (including every update) then installing the current version.
lew is offline   Reply With Quote
Old 08-09-2010, 08:46 PM   #2536
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Question Metadata seriesId & ProgramId

Is there a reason why seriesId and programId are not appearing in the generated metadata files?

Running kmttg v0p7l and tiveodecode/tdcat v0.3pre4 on Win7-64.

Have .tivo files on the PC and want to decode them to mpg, create metadata files, then delete the .tivo files.

Problem I'm running into is if I tell kmttg to create metadata files, they don't contain seriesId or programId even though that metadata is in the .tivo files.

If I manually run tivodecode or tdcat on the .tivo files it shows both seriesId and programId in chunk2.

Last edited by bwall23 : 08-10-2010 at 03:17 AM. Reason: emphasis on chunk2
bwall23 is offline   Reply With Quote
Old 08-09-2010, 10:03 PM   #2537
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by bwall23 View Post
Is there a reason why seriesId and programId are not appearing in the generated metadata files?

Running kmttg v0p7l and tiveodecode/tdcat v0.3pre4 on Win7-64.

Have .tivo files on the PC and want to decode them to mpg, create metadata files, then delete the .tivo files.

Problem I'm running into is if I tell kmttg to create metadata files, they don't contain seriesId or programId even though that metadata is in the .tivo files.

If I manually run tivodecode or tdcat on the .tivo files it shows both seriesId and programId in chunk2.
seriesId being left out is intentional, see:
http://code.google.com/p/kmttg/issues/detail?id=50
programId is not documented in pyTivo metadata Wiki and thus has never been included.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-10-2010, 01:24 AM   #2538
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Exclamation Metadata seriesId & ProgramId

Quote:
Originally Posted by moyekj View Post
seriesId being left out is intentional, see:
http://code.google.com/p/kmttg/issues/detail?id=50
programId is not documented in pyTivo metadata Wiki and thus has never been included.
Thanks for the quick reply, but whew! Me eyes are too tired too feed all this to my brain right now. And that's a good thing because it couldn't process it all tonight anyway. I'll re-read later when I have time to digest and reply. My first thought was this may have to do with padding recordings (a minute or more early and/or late) and chunk1 vs. chunk2 of metadata where <vActualShowing> vs. <showing> has the data.

Main concern is getting seriesId in there, programId is secondary, but why leave it out just because it's not documented in pyTivo metadata Wiki, does it make something choke on it?.

Last edited by bwall23 : 08-10-2010 at 03:32 AM.
bwall23 is offline   Reply With Quote
Old 08-10-2010, 02:57 AM   #2539
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Exclamation Metadata seriesId & ProgramId

Quote:
Originally Posted by moyekj View Post
seriesId being left out is intentional, see:
http://code.google.com/p/kmttg/issues/detail?id=50
programId is not documented in pyTivo metadata Wiki and thus has never been included.
Quote:
Comment 14 by moy...@yahoo.com, Sep 28, 2009
episodeNumber twice I've fixed. Wrong seriesId I kind of expected. The problem is the
way I'm parsing the xml is very dumb. I don't keep track of what keys I'm currently
inside at more than 1 level deep, so don't know if inside <series> element when
parsing. To do that properly I'd need to replace with a proper full blown xml parser
that keeps track of element hierarchy. I'll see if there's some Java code out there
for xml parsing that I can borrow from. Other than seriesId though I think the rest
seems to work, so perhaps for now just leaving seriesId out is the next best thing
(until a proper xml parser is implemented).
I think I understand now (until a proper xml parser is implemented).

I can send you samples of metadata from recordings where I;

A) don't add anything to the scheduled guide recording time.
B) start recording a minute before the scheduled recording time.
C) stop recording a minute after the sheduled recording time.
D) start recording a minute before and stop recording a minute after the scheduled recording time.

For each instance of A to D above I can include;
1) recursive query to my TiVo's NPL
2) query to my TiVo for video details of the recording
3) output from tivodecode/tcat for that same recording from the .tivo file after transfer to my PC
4) output from kmttg after trying to create metadata from said .tivo file

So, if it would help I could try this and send you all 16 files (A1-4, B1-4, C1-4, D1-4).

i.e.

Code:
A) don't add anything to the scheduled guide recording time.
 1) recursive query to my TiVo's NPL
 2) query to my TiVo for video details of the recording
 3) output from tivodecode/tcat for that same recording from the .tivo file after transfer to my PC
 4) output from kmttg after trying to create metadata from said .tivo file
B) start recording a minute before the scheduled recording time.
 1) recursive query to my TiVo's NPL
 2) query to my TiVo for video details of the recording
 3) output from tivodecode/tcat for that same recording from the .tivo file after transfer to my PC
 4) output from kmttg after trying to create metadata from said .tivo file
C) stop recording a minute after the sheduled recording time.
 1) recursive query to my TiVo's NPL
 2) query to my TiVo for video details of the recording
 3) output from tivodecode/tcat for that same recording from the .tivo file after transfer to my PC
 4) output from kmttg after trying to create metadata from said .tivo file
D) start recording a minute before and stop recording a minute after the scheduled recording time.
 1) recursive query to my TiVo's NPL
 2) query to my TiVo for video details of the recording
 3) output from tivodecode/tcat for that same recording from the .tivo file after transfer to my PC
 4) output from kmttg after trying to create metadata from said .tivo file
Only thing is I can't help you parse XML files and am not interested in getting back into coding (past couple lives of that burnt me out;-)

Last edited by bwall23 : 08-10-2010 at 03:30 AM.
bwall23 is offline   Reply With Quote
Old 08-10-2010, 09:26 AM   #2540
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
To be honest my motivation is pretty low to implement proper xml parser just to address this seriesId issue. There are full xml parsers available out there already but that adds a pretty big bloat of a library to include in kmttg.jar so don't really want to go there. For video transfers to TiVos they end up without programId anyway so not sure what the point is to include that field in metadata file? For seriesId I can understand wanting it in there since it does affect grouping when transferring back to TiVos. I'll look into that more when time permits - right now my real job is taking up most of my time.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-10-2010, 01:38 PM   #2541
Prestond
Registered User
 
Join Date: Feb 2008
Posts: 43
Hi Kevin,

Still using this great program for a couple of years now. I recorded Redeye off ABC the other night and I was able to download the .tivo file, but on 2 different pc's when I try to decode the files I am presented with the following error:

>> DECRYPTING F:\tivo\Red Eye (08_07_2010).TiVo ...
C:\kmttg\tivodecode\tivodecode.exe --mak MAK --out "F:\tivo\Red Eye (08_07_2010).mpg" "F:\tivo\Red Eye (08_07_2010).TiVo"
tivodecode failed (exit code: 10 ) - check command: C:\kmttg\tivodecode\tivodecode.exe --mak MAK --out "F:\tivo\Red Eye (08_07_2010).mpg" "F:\tivo\Red Eye (08_07_2010).TiVo"
processing frame: No error
Encryption by QUALCOMM

Invalid MAK -- aborting


I have no problem with other tivo recordings and all this is the first one I had issue with. Any ideas on what is happening? It errors out if I run straight download and decode and it errors out if I download and then add the file to be decoded..its erroring out during the decode. Its not an invalid MAK, its the same one I use for all my other shows and I have no problem with any other recorded show.

Any ideas here? I tried searching but all I found was where folks actually had bad MAK #'s.

Last edited by Prestond : 08-10-2010 at 04:44 PM.
Prestond is offline   Reply With Quote
Old 08-11-2010, 12:35 AM   #2542
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Metadata seriesId & ProgramId

Quote:
Originally Posted by moyekj View Post
To be honest my motivation is pretty low to implement proper xml parser just to address this seriesId issue. There are full xml parsers available out there already but that adds a pretty big bloat of a library to include in kmttg.jar so don't really want to go there. For video transfers to TiVos they end up without programId anyway so not sure what the point is to include that field in metadata file? For seriesId I can understand wanting it in there since it does affect grouping when transferring back to TiVos. I'll look into that more when time permits - right now my real job is taking up most of my time.
Thanks for the response

I downloaded and am using pyTivoMetaGen, which meets my needs for this purpose. I guess one could always set up a custom script to call it and not check the metadata checkbox in kmttg when using it to transfer .tivo files from the TiVo to PC.
bwall23 is offline   Reply With Quote
Old 08-11-2010, 10:09 AM   #2543
Prestond
Registered User
 
Join Date: Feb 2008
Posts: 43
Hi,

Does anybody know what "tivodecode failed (exit code: 10 )" means?

Thanks!



Quote:
Originally Posted by Prestond View Post
Hi Kevin,

Still using this great program for a couple of years now. I recorded Redeye off ABC the other night and I was able to download the .tivo file, but on 2 different pc's when I try to decode the files I am presented with the following error:

>> DECRYPTING F:\tivo\Red Eye (08_07_2010).TiVo ...
C:\kmttg\tivodecode\tivodecode.exe --mak MAK --out "F:\tivo\Red Eye (08_07_2010).mpg" "F:\tivo\Red Eye (08_07_2010).TiVo"
tivodecode failed (exit code: 10 ) - check command: C:\kmttg\tivodecode\tivodecode.exe --mak MAK --out "F:\tivo\Red Eye (08_07_2010).mpg" "F:\tivo\Red Eye (08_07_2010).TiVo"
processing frame: No error
Encryption by QUALCOMM

Invalid MAK -- aborting


I have no problem with other tivo recordings and all this is the first one I had issue with. Any ideas on what is happening? It errors out if I run straight download and decode and it errors out if I download and then add the file to be decoded..its erroring out during the decode. Its not an invalid MAK, its the same one I use for all my other shows and I have no problem with any other recorded show.

Any ideas here? I tried searching but all I found was where folks actually had bad MAK #'s.

Prestond is offline   Reply With Quote
Old 08-11-2010, 10:18 AM   #2544
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by Prestond View Post
Hi,

Does anybody know what "tivodecode failed (exit code: 10 )" means?

Thanks!
It's probably due to an incomplete download? Have you checked the source .TiVo file with Mediainfo to see if it is a full length recording? Alternatively if you have at least partial TiVo Desktop installed (i.e. TiVo directshow filter installed) make sure it plays all the way through with Windows Media Player. Would also compare the .TiVo file size to the .mpg file size to see how close they are.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-11-2010, 11:02 AM   #2545
marbordom
Registered User
 
Join Date: Sep 2007
Location: Bronx, NY
Posts: 27
stuck curl downloads

Quote:
Originally Posted by moyekj View Post
Yeah I guess I missed that dll. I've updated the download to include it and verified that it runs on my Win 7 machine without cygwin installed:
http://kmttg.googlecode.com/files/curl_cygwin.zip

BTW, I've now downloaded over 40 different shows from my S3s to a Win 7 laptop and have not had a single freeze or incomplete download, so I cannot reproduce this issue at all.
Are these curl freezes when downloading from Premiere units only?
I own a TivO HD on which I experienced this curl problem not a Premiere (so cant speak for that one).
After reinstalling Windows 7 (using gparted I messed up the Windows partition) I am using this combination now:
-- kmttg ---
v0p7l
--- JAVA ---
latest 32 bit version from Sun (since 64 bit wont allow service to start)
--- curl --- (cygwin version)
curl 7.20.1 (i686-pc-cygwin) libcurl/7.20.1 OpenSSL/0.9.8o zlib/1.2.5 libidn/1.18 libssh2/1.2.5
Protocols: dict file ftp ftps http https imap imaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp
Features: IDN IPv6 Largefile NTLM SSL libz

With this combination curl gets going.
So my final thoughts here are that at least two issues were hitting:
1) some version or curl with some dll from windows causes a stall of the Tivo download (not in TS, cant say)
2) due to this stall a curl binary will still be running in taskmgr. This causes the Tivo http server to stay connected. Since there is a limit of one download per Tivo it is required to terminate that stalled curl and either wait or reboot the Tivo. Exiting kmttg does not terminate this curl process. Latter brute force approach ist not always necessary. Sometimes a wait will let the http interface come back to live . Otherwise you get "http server busy" message or "transient error" from curl.

Sure is that the root cause is not clear and there are workarounds which will work for some but not for all - very much what I expect from the Windows world.
marbordom is offline   Reply With Quote
Old 08-12-2010, 12:02 PM   #2546
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by bwall23 View Post
Thanks for the quick reply, but whew! Me eyes are too tired too feed all this to my brain right now. And that's a good thing because it couldn't process it all tonight anyway. I'll re-read later when I have time to digest and reply. My first thought was this may have to do with padding recordings (a minute or more early and/or late) and chunk1 vs. chunk2 of metadata where <vActualShowing> vs. <showing> has the data.

Main concern is getting seriesId in there, programId is secondary, but why leave it out just because it's not documented in pyTivo metadata Wiki, does it make something choke on it?.
FWIW I did find a fairly simple & standard way using DOM for parsing xml files which is part of normal Java distribution which made it easy to parse get seriesId out of .TiVo metadata information. That is already checked in to source tree and will be part of next release. (Note that when starting from downloads instead of .TiVo files seriesId was already taken care of). If desired I can upload a beta kmttg.jar with that change, but since you already are using a different metadata generator perhaps it's a don't care at this point.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-18-2010, 02:57 PM   #2547
rrr22777
Registered User
 
Join Date: Jul 2002
Posts: 529
any idea why my downloads keep failing with error below?


>> DOWNLOADING C:\kmttg\The Colbert Report (08_17_2010).TiVo ...
C:\kmttg\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\cookie2802852220877324220 .tmp --url http://192.168.0.201:80/download/The...ying&id=552718 --output "C:\kmttg\The Colbert Report (08_17_2010).TiVo"
Download failed to file: C:\kmttg\The Colbert Report (08_17_2010).TiVo
Exit code: 7
rrr22777 is offline   Reply With Quote
Old 08-18-2010, 03:33 PM   #2548
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by rrr22777 View Post
any idea why my downloads keep failing with error below?


>> DOWNLOADING C:\kmttg\The Colbert Report (08_17_2010).TiVo ...
C:\kmttg\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\cookie2802852220877324220 .tmp --url http://192.168.0.201:80/download/The...ying&id=552718 --output "C:\kmttg\The Colbert Report (08_17_2010).TiVo"
Download failed to file: C:\kmttg\The Colbert Report (08_17_2010).TiVo
Exit code: 7
Some shows apparently have glitches in them that prevent downloads from completing, and in some cases a reboot might cure problems. I don't run into the issues so far with my S3s but some do. Easy way to check is paste the url from the command above into your browser to do the download (actually if you just click on the link in your post it should work for you). Username is "tivo", password is your 10 digit MAK #. If that still fails (you get an incomplete download) then it's a TiVo issue that you can't really get around - re-recording the show if it airs again is one possibility.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-19-2010, 12:51 AM   #2549
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,062
I've run into periodic download failures from my S3's too. There is no error given - data transfer just simply stops - the relatively new retry logic does not get it going again. I've even tried using curl directly and had the same issue. I haven't yet found if there are any command line options that would make the problem go away.

One further piece of information - I don't know if it's relevant or not, but I wrote a perl version of a kmttg-like program, but it does the download in native perl instead of using curl underneath. I had periodic problems with it where a transfer would simply stop because the socket interface returned EWOULDBLOCK as an error code. I changed the perl module (I didn't like doing this) to tolerate this condition by simply sleeping for a bit and then retrying. Since I made this change, I haven't had a failure.

I've seen something similar on a podcast downloader named juice. Transfers would halt because of EWOULDBLOCK.

Is it possible that this is the underlying problem people are encountering when using curl? I'm not sure, but I though I'd throw that out there.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 08-19-2010, 01:41 AM   #2550
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Exit code 7 from curl is "COULD NOT CONNECT".

I virtually never have any issues with downloads from both my S3s and I have literally done thousands of downloads by now. Once or twice I remember a condition where no downloads would start at all and a reboot was in order, but I've never had partial download issues. Also for recent posts about troubles with Win7 downloads and curl hangups I could not reproduce on Win7 laptop, so apparently I'm not a good test subject for debugging these problems.
However I've seen enough posts indicating that downloading with other methods typically have same/similar problems as with curl, so I would more likely suspect TiVo server side problems than the client side pulling shows.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 07:48 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |