TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 02-22-2009, 09:28 AM   #511
citivolus
Registered User
 
Join Date: Jul 2002
Posts: 93
Quote:
Originally Posted by moyekj View Post
Then it could just be a matter of the particular ffmpeg version being used. Note that you can configure path to ffmpeg in kmttg so you can grab the ffmpeg.exe used by Videora. It could also be the particular encoding arguments which make a difference. If you can find out the particular ffmpeg recipe used by Videora that's working for you then it would be trivial to create a .enc file for kmttg that does the same.
if anyone does have a profile or ffmpeg version # that keeps the video in sync when using comskip + VideoReDo, please do post it as I can't avoid the sync issues in my setup.
citivolus is offline   Reply With Quote
Old 02-22-2009, 12:26 PM   #512
jadekitten
Registered User
 
Join Date: Feb 2009
Posts: 4
vrd qsfix error

can you hep? it really doesn't say what's wrong

>> Running VRD qsfix on C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg ...
"C:\WINDOWS\system32\cscript.exe" //nologo "C:\Program Files\VideoReDoTVSuite\vp.vbs" "C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg" "C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg.qsfix" /t1 /d /q /na
C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg.qsfix size=0.00 MB elapsed=00:00:09 (0.00 Mbps)
*ERROR* qsfix failed (exit code: 0) - check above qsfix command
jadekitten is offline   Reply With Quote
Old 02-22-2009, 05:17 PM   #513
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Quote:
Originally Posted by jadekitten View Post
can you hep? it really doesn't say what's wrong

>> Running VRD qsfix on C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg ...
"C:\WINDOWS\system32\cscript.exe" //nologo "C:\Program Files\VideoReDoTVSuite\vp.vbs" "C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg" "C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg.qsfix" /t1 /d /q /na
C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg.qsfix size=0.00 MB elapsed=00:00:09 (0.00 Mbps)
*ERROR* qsfix failed (exit code: 0) - check above qsfix command
Well the command is running for 9/10 of a second and generating a 0 size file. Check that:
1. C:\kmttg\kmttg\Josh and S.A.M._Tue_Feb_10.mpg looks proper (not zero size)
2. Paste the entire cscript call above into a run.bat file and execute the run.bat file from a cmd window to see if there are any errors reported.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-22-2009, 06:02 PM   #514
doormat
Registered User
 
Join Date: Sep 2004
Location: Vegas
Posts: 146
OK I setup kmttg, however the resulting files I'm getting from Decrypt+Comskip+Comcut aren't working at all. I copied out the TiVo and the Decrypt files and they look OK. Its the comskip and cut that seems to be an issue. Is there config stuff that I need to change to get it to work right? The source file is an epsiode of Big Bang theory in HD.
__________________
S2 540040 - 40GB+120GB (RIP - dead and I couldn't bring it back to life)
TiVoHD - 400GB
doormat is offline   Reply With Quote
Old 02-25-2009, 12:26 PM   #515
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
There is an issue with file name keyword parsing in kmttg 0.5i (latest release) where in some cases characters are incorrectly being treated as keywords and being replaced. Example:
'Terminator: The Sarah Connor Chronicles'
The "min" in Terminator is replaced with # minutes.
I will issue a fix for this issue probably later tonight.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-26-2009, 02:02 AM   #516
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
v0p5j release

------------------
v0.5j (02/25/2009)
------------------
FIXES
* With prior version in some cases characters were incorrectly being treated
as keywords and being replaced. Example:
'Terminator: The Sarah Connor Chronicles'
The "min" in Terminator was being replaced with # minutes.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-27-2009, 10:05 AM   #517
fyodor
Registered User
 
Join Date: Sep 2006
Posts: 438
Thanks for all of your work on this. Are there any plans to integrate some sort of auto-push back to the Tivo, now that there's MP4 support-I am wistful for my SageTV days when I had autocompression.

F



Quote:
Originally Posted by moyekj View Post
------------------
v0.5j (02/25/2009)
------------------
FIXES
* With prior version in some cases characters were incorrectly being treated
as keywords and being replaced. Example:
'Terminator: The Sarah Connor Chronicles'
The "min" in Terminator was being replaced with # minutes.

fyodor is offline   Reply With Quote
Old 02-27-2009, 10:58 AM   #518
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Quote:
Originally Posted by fyodor View Post
Thanks for all of your work on this. Are there any plans to integrate some sort of auto-push back to the Tivo, now that there's MP4 support-I am wistful for my SageTV days when I had autocompression.

F
Haven't really considered it, especially as pyTivo can do native mp4 pushes now. Any reason to not use pyTivo? I know that currently pyTivo pushes are a manual process, but it wouldn't take much effort by pyTivo authors to make them automated like in Tivo Desktop +.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-27-2009, 11:17 AM   #519
fyodor
Registered User
 
Join Date: Sep 2006
Posts: 438
I guess that there's appeal to having it be automated. Does KMTTG wait until the transcoding is complete before putting it in the destination directory?

Quote:
Originally Posted by moyekj View Post
Haven't really considered it, especially as pyTivo can do native mp4 pushes now. Any reason to not use pyTivo? I know that currently pyTivo pushes are a manual process, but it wouldn't take much effort by pyTivo authors to make them automated like in Tivo Desktop +.

fyodor is offline   Reply With Quote
Old 02-27-2009, 11:51 AM   #520
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Quote:
Originally Posted by fyodor View Post
I guess that there's appeal to having it be automated. Does KMTTG wait until the transcoding is complete before putting it in the destination directory?
Currently it transcodes directly into destination directory, but I could change that behavior.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 03-13-2009, 09:17 AM   #521
chazas
Registered User
 
Join Date: Jan 2007
Posts: 144
I was having problems with 2.7, so I decided to try KMTTG.

I can't get beyond the conversion stage. Every time ffmpeg.exe crashes. I have this vague recollection that I tried another conversion program at one point that relied on the ffmpeg.exe and it didn't work either.

Any suggestions?
chazas is offline   Reply With Quote
Old 03-13-2009, 09:26 AM   #522
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Quote:
Originally Posted by chazas View Post
I was having problems with 2.7, so I decided to try KMTTG.

I can't get beyond the conversion stage. Every time ffmpeg.exe crashes. I have this vague recollection that I tried another conversion program at one point that relied on the ffmpeg.exe and it didn't work either.

Any suggestions?
The pre-defined encoding profiles in kmttg all do use ffmpeg but it's possible to create a custom encoding profile using a different encoder if you wish. That being said the fact that both TD and ffmpeg encoders are having trouble with your source file suggests there may be an issue with it. Have you verified that source file plays fine all the way through on your computer? If .TiVo file plays fine when you decrypt it to .mpg does it still play fine on your computer? Once it's decrypted to .mpg you can also try any number of encoders, for example Handbrake.

If you have VideoRedo I suggest running through QuickStream Fix before encoding to see if that helps (you can do that via kmttg if you wish).
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 03-13-2009, 10:00 AM   #523
chazas
Registered User
 
Join Date: Jan 2007
Posts: 144
Thanks. This particular file wasn't necessarily a problem with TD (I don't know, I never tried to convert it). I picked it as a test for KMTTG because it was a small file.

Last year due to earlier frustrations with TD I tried using VideoReDo (trial) to strip the .tivo wrapper and then Handbrake to convert. That worked fine for every file I tried, even ones that TD messed up, though I found having to use 3 programs/steps completely frustrating, and at that time wasn't willing to pay for VRD. I never got around to trying the VRD autoprocessor program, plus it intimidated me.

I'm not at home now, but I can try playing the .tivo file when I get home. I'll also try another show or two and see what happens. I guess the thing do to from there would be to see if I can get another trial run at VRD for the QuickStream fix and see if that makes everything work.
chazas is offline   Reply With Quote
Old 03-14-2009, 06:11 PM   #524
MikeAndrews
Registered abuser
 
MikeAndrews's Avatar
 
Join Date: Jan 2002
Location: Northern Illinois (Dn Nr WI)
Posts: 11,891
ARRGH!!!

Why do I have to suffer CHRONIC problems with truncated downloads.

I have to download repeatedly and the if show is long it's impossible to get teh full file. (I have one HD movie now that's 11GB. I've only tried 6 times to get the whole thing transferred. I have some successful 11Gb files on the server. )

Many shows stop downloading at exactly 4,194,300 KB!

I get the curl error with hundred of lines of com;lalint and "Failed writing body 1275 != 116384"

I have the Tivo and the Windows PC on the same 100mb switch with CAT 6 cables!

I'll admit I have the same problem with TiVo Desktop.

Is there any way to fix that?
__________________
1) Series 4 Premiere - Lifetime
2) Series 3 OLED - Lifetime.
2) Series 2 DT 500GB
Mac Mini NAS with 9 7 x 2TB drives.
UVerse and OTA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MikeAndrews is offline   Reply With Quote
Old 03-14-2009, 06:32 PM   #525
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
netringer, that error means curl is unable to write to the destination drive.
A few things to check:
* anti-virus software running that is imposing a 4GB limit on files - Kaspersky for example is infamous for doing this
* Enough disk space remaining in your download folder
* The destination drive is using NTFS and not fat32
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 03-14-2009, 06:49 PM   #526
MikeAndrews
Registered abuser
 
MikeAndrews's Avatar
 
Join Date: Jan 2002
Location: Northern Illinois (Dn Nr WI)
Posts: 11,891
Quote:
Originally Posted by moyekj View Post
netringer, that error means curl is unable to write to the destination drive.
A few things to check:
* anti-virus software running that is imposing a 4GB limit on files - Kaspersky for example is infamous for doing this
* Enough disk space remaining in your download folder
* The destination drive is using NTFS and not fat32
Hmmm. The drive is on a 1TB Time Capsule mounted over the LAN. It's formatted OS X HSFS, AFAIK, but serves over SMB, sop there's no isse with FAT or NTFS.

I'll have to work on having enough local disk space for curl to use and then copying the file afterwards in a seperate operation.
__________________
1) Series 4 Premiere - Lifetime
2) Series 3 OLED - Lifetime.
2) Series 2 DT 500GB
Mac Mini NAS with 9 7 x 2TB drives.
UVerse and OTA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MikeAndrews is offline   Reply With Quote
Old 03-14-2009, 07:02 PM   #527
MikeAndrews
Registered abuser
 
MikeAndrews's Avatar
 
Join Date: Jan 2002
Location: Northern Illinois (Dn Nr WI)
Posts: 11,891
Quote:
Originally Posted by moyekj View Post
netringer, that error means curl is unable to write to the destination drive.
A few things to check:
* anti-virus software running that is imposing a 4GB limit on files - Kaspersky for example is infamous for doing this
* Enough disk space remaining in your download folder
* The destination drive is using NTFS and not fat32
It just did it again. Exactly 4,194,300 KB.

I was thinking it goes to local C:\TEMP first but the drive is NTFS and has 15GB free.

I'll go back to trying to get kmttg working on my Macbook. No luck there.
__________________
1) Series 4 Premiere - Lifetime
2) Series 3 OLED - Lifetime.
2) Series 2 DT 500GB
Mac Mini NAS with 9 7 x 2TB drives.
UVerse and OTA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MikeAndrews is offline   Reply With Quote
Old 03-14-2009, 07:12 PM   #528
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Quote:
Originally Posted by netringer View Post
It just did it again. Exactly 4,194,300 KB.

I was thinking it goes to local C:\TEMP first but the drive is NTFS and has 15GB free.

I'll go back to trying to get kmttg working on my Macbook. No luck there.
If you're having trouble getting kmttg to work on your mac, try iTivo. It should just install and run.

However, I'm not clear on what's causing the truncation. It really sounds like there's some tool on your computer (like a virus checker) that is killing the write at 4G.
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Yoav is offline   Reply With Quote
Old 03-15-2009, 03:39 PM   #529
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
New release

------------------
v0.5k (03/15/2009)
------------------
ENHANCEMENTS
* Added new encoding profiles for popular Handbrake encoder. Handbrake command
line executable now included in win32 zip file. Several of the main
Handbrake profiles were added but it's easy to add your own as well if
desired.

* Handbrake profiles start with hb_ prefix and ffmpeg profiles were renamed
to use ff_ prefix to make it easy to distinguish between them.

* New configuration option to specify location of HandBrakeCLI added.

*IMPORTANT*: Because the encoding profile names change if you have auto transfers
that use encoding profiles you have to update them. You can do this as follows:
1. Auto Transfers -> Configure...
2. Select a title in the list
3. Update the encode cyclic profile name
4. Click on the UPDATE button
5. Repeat above steps as needed for each title
6. OK the form
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 03-18-2009, 03:13 AM   #530
spocko
TiVo HD
 
Join Date: Feb 2009
Posts: 409
Quote:
Originally Posted by chazas View Post
I can't get beyond the conversion stage. Every time ffmpeg.exe crashes.
I had the same issue, ffmpeg would get part way through the encode and then crash. This happened when using the SVN-r15216 version of ffmpeg that is included in the win32 tools package. I believe this is a ffmpeg problem. Today I tried the latest 0.5 version of ffmpeg and it appears to have fixed the crashes. The .enc encoding profiles for ffmpeg have to be modified to use "-me_method" instead of the deprecated "-me" option, but otherwise they seem to work as is.

Here is where I found a win32 build of ffmpeg ver 0.5:
http://fb2k.net/ffmpeg-0.5.zip
I don't know if this is a "good" build or not, but it's the only one I could find.

Another potential solution is to use a Handbrake encoding profile instead of ffmpeg, since the latest 0.5k version of kmttg adds Handbrake support.

Suggestions to Moyekj:
- Update the version of ffmpeg included in the win32 tools package
- Add some mpeg4 ASP encoding profiles, since h.264 is too CPU intensive for some people

Last edited by spocko : 03-18-2009 at 12:18 PM.
spocko is offline   Reply With Quote
Old 03-24-2009, 09:58 PM   #531
qtip96
Registered User
 
Join Date: Jan 2009
Posts: 24
Auto Transfers do not work

I can't get Auto Transfers to work with kmttg running on WHS. If I run a transfer manually, everything works fine.

Here is what I notice in the log:

Sun 3/22/2009 09:43 PM *ERROR* Output Dir does not exist: W:\Tivo\temp
Sun 3/22/2009 09:43 PM *ERROR* Mpeg Dir does not exist: W:\Tivo\temp
Sun 3/22/2009 09:43 PM *ERROR* Mpeg Cut Dir does not exist: W:\Tivo\temp
Sun 3/22/2009 09:43 PM *ERROR* Encode Dir does not exist: W:\Tivo
Sun 3/22/2009 09:43 PM Stopping kmttg service
Sun 3/22/2009 09:43 PM *ERROR* Failed to stop kmttg service (state=Running)

Yes, the path exists and it works just fine running it manually. Anyone have suggestions?
qtip96 is offline   Reply With Quote
Old 03-25-2009, 12:15 AM   #532
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Is W: a network share by any chance? I saw posted in another thread recently that Windows services cannot access network shares without special configuration.

Not sure what WHS is exactly but for Vista some special configuration of the service is needed as detailed in documentation:

SETTING UP KMTTG AS A SERVICE IN WINDOWS VISTA

Vista with it’s extra security takes more work to get kmttg running as a service. I was able to get it up and running as follows:

* Run kmttg as “Run As Administrator”
* Auto Transfers->Service->Enable to create the registry entries
* Close kmttg
* Control Panel->Administrative Tools->Services
* Scroll down and find kmttg entry
* Right click on kmttg and stop service if it is running
* Right click on kmttg and select Properties
* Choose Log On tab and select “Local System account”
* OK the form
* Right click on kmttg and start the service
* It should now be running as expected (inspect auto.log file in the same folder as kmttg.pl to check)

NOTE: I don't personally run kmttg as a service and don't do any testing of it in that mode unfortunately but hopefully others that do run as a service can chime in.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 03-25-2009 at 12:23 AM.
moyekj is offline   Reply With Quote
Old 03-25-2009, 01:55 AM   #533
Devx
Registered User
 
Join Date: Jun 2006
Location: Atlanta, GA
Posts: 269
Not to go too far OT here but in general services running under Windows cannot access network shares because the share is not setup under that login account and that account typically does not have proper permissions to access the share. However it's possible to configure a service such that it logs in using credentials of an actual user on the system. In that case the service will have access to all of the shares that the user can access. It's easiest to setup an account with administrator privileges to do this but almost any account will work as long as the proper privileges are setup. This applies to all NT 5.0+ client and server based versions of Windows and should apply to Windows Home Server (WHS) as well although the steps might be different.
__________________
Roamio Pro
Roamio Plus (3TB)
Premiere Elite/XL4
THD 2TB x 2
Humax S2 300GB (retired)
Devx is offline   Reply With Quote
Old 03-25-2009, 05:54 AM   #534
qtip96
Registered User
 
Join Date: Jan 2009
Posts: 24
Quote:
Originally Posted by moyekj View Post
Is W: a network share by any chance? I saw posted in another thread recently that Windows services cannot access network shares without special configuration.

Not sure what WHS is exactly but for Vista some special configuration of the service is needed as detailed in documentation:

SETTING UP KMTTG AS A SERVICE IN WINDOWS VISTA

Vista with it’s extra security takes more work to get kmttg running as a service. I was able to get it up and running as follows:

* Run kmttg as “Run As Administrator”
* Auto Transfers->Service->Enable to create the registry entries
* Close kmttg
* Control Panel->Administrative Tools->Services
* Scroll down and find kmttg entry
* Right click on kmttg and stop service if it is running
* Right click on kmttg and select Properties
* Choose Log On tab and select “Local System account”
* OK the form
* Right click on kmttg and start the service
* It should now be running as expected (inspect auto.log file in the same folder as kmttg.pl to check)

NOTE: I don't personally run kmttg as a service and don't do any testing of it in that mode unfortunately but hopefully others that do run as a service can chime in.
Yep, W: is a network share. WHS = Windows Home Server (aka Windows 2003 Server).
qtip96 is offline   Reply With Quote
Old 03-25-2009, 05:59 AM   #535
qtip96
Registered User
 
Join Date: Jan 2009
Posts: 24
Quote:
Originally Posted by Devx View Post
Not to go too far OT here but in general services running under Windows cannot access network shares because the share is not setup under that login account and that account typically does not have proper permissions to access the share. However it's possible to configure a service such that it logs in using credentials of an actual user on the system. In that case the service will have access to all of the shares that the user can access. It's easiest to setup an account with administrator privileges to do this but almost any account will work as long as the proper privileges are setup. This applies to all NT 5.0+ client and server based versions of Windows and should apply to Windows Home Server (WHS) as well although the steps might be different.
Hrm -- this makes perfect sense. So I should I just change the kttms service account to a user with access to those shares?
qtip96 is offline   Reply With Quote
Old 03-25-2009, 09:40 AM   #536
Devx
Registered User
 
Join Date: Jun 2006
Location: Atlanta, GA
Posts: 269
Quote:
Originally Posted by qtip96 View Post
Hrm -- this makes perfect sense. So I should I just change the kttms service account to a user with access to those shares?
You can but remember to login to that account and make sure the shares are setup and accessible before con figuring that account as a service account.
__________________
Roamio Pro
Roamio Plus (3TB)
Premiere Elite/XL4
THD 2TB x 2
Humax S2 300GB (retired)
Devx is offline   Reply With Quote
Old 03-26-2009, 07:43 AM   #537
qtip96
Registered User
 
Join Date: Jan 2009
Posts: 24
Quote:
Originally Posted by Devx View Post
You can but remember to login to that account and make sure the shares are setup and accessible before con figuring that account as a service account.
Hey thanks for the help -- everything is being downloaded, decoded, and run through VideoRedo with no problems. The only thing left is the encoding and its running into an error:

Thu 3/26/2009 08:31 AM *ERROR* Encoding command not found/executable:


I created a new ffmpeg encoding profile and it works fine from the GUI. I've quit and started kmttg up again with the same results. Any thoughts?
qtip96 is offline   Reply With Quote
Old 03-27-2009, 09:29 AM   #538
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Quote:
Originally Posted by qtip96 View Post
Hey thanks for the help -- everything is being downloaded, decoded, and run through VideoRedo with no problems. The only thing left is the encoding and its running into an error:

Thu 3/26/2009 08:31 AM *ERROR* Encoding command not found/executable:


I created a new ffmpeg encoding profile and it works fine from the GUI. I've quit and started kmttg up again with the same results. Any thoughts?
I'll have to check when I get a chance (been very busy with paying job lately) but it's possibly a bug in kmttg in service mode.
Interesting though that you mention you actually got VideoRedo running in service mode? I and others haven't been able to do that.

EDIT: Didn't see anything obviously wrong in the code and I just confirmed running as a service including encoding worked fine. When you execute Auto Transfers->Run in GUI does the encoding part work?
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 03-27-2009 at 06:45 PM.
moyekj is offline   Reply With Quote
Old 03-27-2009, 06:34 PM   #539
chazas
Registered User
 
Join Date: Jan 2007
Posts: 144
Quote:
Originally Posted by spocko View Post
I had the same issue, ffmpeg would get part way through the encode and then crash. This happened when using the SVN-r15216 version of ffmpeg that is included in the win32 tools package. I believe this is a ffmpeg problem. Today I tried the latest 0.5 version of ffmpeg and it appears to have fixed the crashes. The .enc encoding profiles for ffmpeg have to be modified to use "-me_method" instead of the deprecated "-me" option, but otherwise they seem to work as is.

Here is where I found a win32 build of ffmpeg ver 0.5:
http://fb2k.net/ffmpeg-0.5.zip
I don't know if this is a "good" build or not, but it's the only one I could find.

Another potential solution is to use a Handbrake encoding profile instead of ffmpeg, since the latest 0.5k version of kmttg adds Handbrake support.

Suggestions to Moyekj:
- Update the version of ffmpeg included in the win32 tools package
- Add some mpeg4 ASP encoding profiles, since h.264 is too CPU intensive for some people
Thanks. I've tried Handbrake in the new(ish) version and also paid for VideoReDo so I could do QSF. The same several files still don't convert properly - they skip and the audio and video are out of synch. Arrgh.

Moyekj: Agreed, if you could add some mpeg4 profiles that would be great, h.264 takes longer in my experience and is unnecessary for my Zune. Maybe I'll try the Zune profile instead....
chazas is offline   Reply With Quote
Old 03-27-2009, 06:50 PM   #540
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,987
Note that there are 5 non H.264 profiles already so it would be pretty easy to copy one of these and create your own custom one(s) if you don't like one of these existing ones:
ff_ipod_high_res.enc:mpeg4 container, 640x480 xvid video, aac audio
ff_ipod_low_res.enc:mpeg4 container, 320x240 xvid video, aac audio
ff_psp.enc:mpeg4 container, 320x240 mpeg4 video, aac audio
ff_zen.enc:Creative Zen: avi container, 320x240 xvid video, mp3 audio
ff_zune.enc:Zune: asf container, 320x240 wmv video, wma audio
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVo® is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 02:05 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |