TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 09-23-2012, 02:16 PM   #4321
janry
Registered User
 
Join Date: Jan 2003
Location: Nashville, TN
Posts: 17,688
Quote:
Originally Posted by moyekj View Post
Just tried and it works. My guess is you are setting kmttg.jar as the Program/script which won't work. You need to set it up as:
Program/script = full path to javaw.exe
Arguments = -jar "full path to kmttg.jar" -b
Example:
Program = "C:\Program Files (x86)\Java\jre6\bin\javaw.exe"
Arguments = -jar "C:\home\kmttg java testing\kmttg.jar" -b

For testing purposes you may want to leave off the -b just to see if kmttg GUI pops up as expected, and one you have that working add the -b back in.
BINGO! That seems to be doing the trick. I had a feeling it had something to do with the kmttg.jar script not be the right right thing to call initally but I don't understand all that technical stuff.

Thanks so much for your help. I can't wait to see in the morning if everything new tonight has transferreed.

Edit: I awoke this morning to find the two recordings from last evening transferred fine and the computer was back in sleep mode. In other words, everything ran as I hoped for.

Last edited by janry : 09-24-2012 at 10:14 AM.
janry is offline   Reply With Quote
Old 09-28-2012, 01:59 PM   #4322
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 169
Had a great thought.

I often have several things going on in my computer and lets say I am copying a dvd which uses lots of processor but know it will be done in 30 minutes and then would like kmttg to resume running its commands. Right now for instance, it will not qsfix and decode at the same time because of the way I have the process set up in kmttg ( I know I can have it do more processes but not less.)

Anyway, it would be great, if either thru a custom command or thru kmttg itself I could set a timer to pause all processing except downloading until that timer runs out.

Say I have a bunch of cuts I want to make but I need it to wait 20 minutes to run so that the dvd that is burning will finish and kmttg can have the processor all to itself. That would be awesome for my day to day.

So, anybody know a custom command string I could make, or could this be added to kmttg as a command? That would help alot.
sanjonny is offline   Reply With Quote
Old 09-28-2012, 02:05 PM   #4323
kpeters59
Registered User
 
Join Date: Jun 2007
Posts: 26
How about just stop the 'service' for a while? You could probably write a small 'batch file' that would do that pretty simply...
kpeters59 is offline   Reply With Quote
Old 09-28-2012, 03:39 PM   #4324
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,686
Wish list: I would like an automatic feature where Kmttg sends the reset command to the Tivo when the transfer speed drops below a preset level, like <1mbps, with a preset interval, ie: 30 or 60 sec.
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 09-28-2012, 06:23 PM   #4325
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 169
Quote:
Originally Posted by ThAbtO View Post
Wish list: I would like an automatic feature where Kmttg sends the reset command to the Tivo when the transfer speed drops below a preset level, like <1mbps, with a preset interval, ie: 30 or 60 sec.
I didnt know you could reset the tivo remotely. Is that possible on the s3/hd or only on premiere?
sanjonny is offline   Reply With Quote
Old 09-28-2012, 06:28 PM   #4326
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 169
Quote:
Originally Posted by kpeters59 View Post
How about just stop the 'service' for a while? You could probably write a small 'batch file' that would do that pretty simply...
I think that would cause a crash or lose some of the active processes. That being said, i dont usually run kmttg as a service.

I basically need a countdown timer i could insert between or before certain jobs within kmttg.

For example, qsfix then adscan then pause for 10 minutes while another external process finishes, then resume the next queued entry or whatever.

Kmttg already has builtin delays between say qsfix and adscan in the interface (i think i have mine set to 10 seconds) so i am imagining just a box or whatever where you could make a delay as a task and set the time it would take to delay. That way you could run it wherever you needed it.
sanjonny is offline   Reply With Quote
Old 09-28-2012, 06:45 PM   #4327
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,686
Quote:
Originally Posted by sanjonny View Post
I didnt know you could reset the tivo remotely. Is that possible on the s3/hd or only on premiere?
It only resets the server side of the Tivo, not the entire box.
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 09-29-2012, 12:56 AM   #4328
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 169
Quote:
Originally Posted by ThAbtO View Post
It only resets the server side of the Tivo, not the entire box.
That never resolves the issues i have, i have to reboot reset. I have one hacked box, i imagine there is some hack command i can use but dont know what it is.
sanjonny is offline   Reply With Quote
Old 09-29-2012, 02:56 AM   #4329
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,867
Ahem. Try `reboot`.
lrhorer is offline   Reply With Quote
Old 09-29-2012, 12:01 PM   #4330
lew
Registered User
 
Join Date: Mar 2002
Posts: 3,262
Trying to run kmttg in auto transfer mode. I've tried everything including changing uac setting to never notify.

kmttg is v0p8u
VRD TVSuite is 4.20.7.641 Aug24, 2012

Any suggestions?




2012_09_29_09:27:50 ---DONE--- job=javadownload output=C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).TiVo
2012_09_29_09:27:52 NOTE: VideoRedo video dimensions filter is enabled
2012_09_29_09:27:53 NOTE: VideoRedo video dimensions filter set to: x=1920, y=1080
2012_09_29_09:27:53 >> Running qsfix on C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).TiVo ...
2012_09_29_09:27:53 C:\Windows\system32\cscript.exe //nologo C:\kmttg\VRDscripts\qsfix.vbs "C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).TiVo" "C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).mpg.qsfix" /l:C:\kmttg\VRDLock3179841919186552071.tmp /m /x:1920 /y:1080
2012_09_29_09:27:55 ERROR: qsfix failed (exit code: 0 ) - check command: C:\Windows\system32\cscript.exe //nologo C:\kmttg\VRDscripts\qsfix.vbs "C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).TiVo" "C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).mpg.qsfix" /l:C:\kmttg\VRDLock3179841919186552071.tmp /m /x:1920 /y:1080
2012_09_29_09:27:55 ERROR: C:\kmttg\VRDscripts\qsfix.vbs(40, 4) WScript.CreateObject: Could not create object named "VideoReDo.Application".
2012_09_29_09:27:57 ERROR: mpeg file not found: C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).mpg
2012_09_29_09:27:59 ERROR: vprj file not found: C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).VPrj
2012_09_29_09:27:59 ERROR: mpeg file not found: C:\kmttg\My Name Is Earl - Camdenites, Part 2 (09_29_2012).mpg
lew is offline   Reply With Quote
Old 09-29-2012, 12:20 PM   #4331
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
Problem is this:
"2012_09_29_09:27:55 ERROR: C:\kmttg\VRDscripts\qsfix.vbs(40, 4) WScript.CreateObject: Could not create object named "VideoReDo.Application".

Window Wscript is not finding VideoReDo.Application means it is not registered in registry. Make sure that:
a/ You bring up VideoRedo GUI at least once using Admin account (i.e. Run as Administrator)
b/ qsfix works with kmttg in GUI mode
c/ service is setup to use same account as you run GUI (assuming running through GUI works). By default services are setup using different Windows account.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 09-30-2012, 12:45 AM   #4332
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 169
Quote:
Originally Posted by lrhorer View Post
Ahem. Try `reboot`.
OMG, the simple solutions are always the best, though I have been on planes trains auto shuttles and subways for two days straight sooooo my brain isn't working and my memory is shot. can I send that command thru a custom command I can make in kmttg, or do I have to telnet or ssh or whatever into the cranky Tivo to run. I truly just need a memory bump. and some sleep and food.
sanjonny is offline   Reply With Quote
Old 10-01-2012, 10:44 PM   #4333
lew
Registered User
 
Join Date: Mar 2002
Posts: 3,262
Quote:
Originally Posted by moyekj View Post
Problem is this:
"2012_09_29_09:27:55 ERROR: C:\kmttg\VRDscripts\qsfix.vbs(40, 4) WScript.CreateObject: Could not create object named "VideoReDo.Application".

Window Wscript is not finding VideoReDo.Application means it is not registered in registry. Make sure that:
a/ You bring up VideoRedo GUI at least once using Admin account (i.e. Run as Administrator)
b/ qsfix works with kmttg in GUI mode
c/ service is setup to use same account as you run GUI (assuming running through GUI works). By default services are setup using different Windows account.
Also needed to run javaw as administrator. Had already done a b and c.

I got this message. I removed this show from the auto transfer list and problem solved. Not a big deal but I'd like to know how to avoid this problem in the future.
Title keyword match: 'once upon a time' found in 'once upon a time'
START PROCESSING OF ENTRY: Once Upon a Time - Broken
java.lang.NullPointerException

at java.util.Hashtable.put(Unknown Source)

at com.tivo.kmttg.main.auto.keywordMatchJobInit(auto.java:505)

at com.tivo.kmttg.main.auto.keywordSearch(auto.java:175)

at com.tivo.kmttg.task.javaNowPlaying.parseNPL(javaNowPlaying.j ava:245)

at com.tivo.kmttg.task.javaNowPlaying.check(javaNowPlaying.java :197)

at com.tivo.kmttg.main.jobData.check(jobData.java:195)

at com.tivo.kmttg.main.jobMonitor.monitor(jobMonitor.java:123)

at com.tivo.kmttg.main.kmttg$3.actionPerformed(kmttg.java:91)

at javax.swing.Timer.fireActionPerformed(Unknown Source)

at javax.swing.Timer$DoPostEvent.run(Unknown Source)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEventImpl(Unknown Source)

at java.awt.EventQueue.access$400(Unknown Source)

at java.awt.EventQueue$2.run(Unknown Source)

at java.awt.EventQueue$2.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.security.AccessControlContext$1.doIntersectionPrivilege (Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)
lew is offline   Reply With Quote
Old 10-02-2012, 12:43 AM   #4334
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
Quote:
Originally Posted by lew View Post
I got this message. I removed this show from the auto transfer list and problem solved. Not a big deal but I'd like to know how to avoid this problem in the future.
Title keyword match: 'once upon a time' found in 'once upon a time'
START PROCESSING OF ENTRY: Once Upon a Time - Broken
java.lang.NullPointerException
at java.util.Hashtable.put(Unknown Source)
at com.tivo.kmttg.main.auto.keywordMatchJobInit(auto.java:505)
Looks like maybe in that auto transfer setup you setup a 2nd encoding name but without specifying a file suffix. (BTW that code is from someone else that really wanted double encoding capability, so I'm not too familiar with it).
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-02-2012, 05:40 AM   #4335
lew
Registered User
 
Join Date: Mar 2002
Posts: 3,262
Quote:
Originally Posted by moyekj View Post
Looks like maybe in that auto transfer setup you setup a 2nd encoding name but without specifying a file suffix. (BTW that code is from someone else that really wanted double encoding capability, so I'm not too familiar with it).
bingo--I missed the part about needed to specify an extension.

Thanks.
lew is offline   Reply With Quote
Old 10-02-2012, 09:07 AM   #4336
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
Quote:
Originally Posted by lew View Post
bingo--I missed the part about needed to specify an extension.

Thanks.
I updated the code to skip the 2nd encoding if extension is missing so null point exception will no longer happen.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-12-2012, 09:29 AM   #4337
Beven
Registered User
 
Join Date: Sep 2011
Posts: 10
So I have transferred a whole slew of programs via Tivo Desktop, and would like to use this great program to do a mass-encode. Unfortunately I'm getting the following - any help would be greatly appreciated!

Recorded Thu 10/11/2012 10:00 PM on 867=TLCHD, Duration=60 mins, EpisodeNumber=101
Thelma begins to search for her 10 new trainees; once the girls are chosen, chaos ensues and Thelma must act fast before it all falls apart.
>> ENCODING WITH PROFILE 'hb_ipod' TO FILE D:\tivo_encoded\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).m4v ...
C:\kmttg\handbrake\HandBrakeCLI.exe -i "D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg" -t 1 -c 1 -f mp4 -I -X 320 -e x264 -b 700 -a 1 -E faac -B 160 -R 48 -6 dpl2 -D 0.0 -x level=30:bframes=0:cabac=0:ref=2:vbv-maxrate=768:vbv-bufsize=2000:analyse=all:me=umh:no-fast-pskip=1:subq=6:8x8dct=0:trellis=0:weightb=0:mixed-refs=0 -v 1 -o "D:\tivo_encoded\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).m4v"
encoding failed (exit code: 0 ) - check command: C:\kmttg\handbrake\HandBrakeCLI.exe -i "D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg" -t 1 -c 1 -f mp4 -I -X 320 -e x264 -b 700 -a 1 -E faac -B 160 -R 48 -6 dpl2 -D 0.0 -x level=30:bframes=0:cabac=0:ref=2:vbv-maxrate=768:vbv-bufsize=2000:analyse=all:me=umh:no-fast-pskip=1:subq=6:8x8dct=0:trellis=0:weightb=0:mixed-refs=0 -v 1 -o "D:\tivo_encoded\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).m4v"
[10:23:07] hb_init: checking cpu count
[10:23:07] hb_init: starting libhb thread
HandBrake 0.9.5 (2011010300) - MinGW i386 -
2 CPUs detected
Opening D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg...
[10:23:07] hb_scan: path=D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg, title_index=1
libbluray/bdnav/index_parse.c:157: indx_parse(): error opening D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg/BDMV/index.bdmv
libbluray/bluray.c:960: nav_get_title_list(D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg) failed (0x19d2ca0)
[10:23:07] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnavVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnavVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[10:23:07] dvd: not a dvd - trying as a stream/file instead
[mp3 @ 0x19ebbf0] Header missing
[mp3 @ 0x19ebbf0] Header missing
[10:23:07] hb_stream_open: open D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg failed
[10:23:07] scan: unrecognized file type
[10:23:07] libhb: scan thread found 0 valid title(s)
No title found.
HandBrake has exited.
Beven is offline   Reply With Quote
Old 10-12-2012, 01:33 PM   #4338
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
@Beven, looks like Handbrake can't determine the video codecs in the mpg file. I would do 2 things:
1. Try an ffmpeg profile instead to see if ffmpeg can recognize video
2. Examine mpg video using mediainfo (and post info here if you can't solve the problem)
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-13-2012, 01:33 PM   #4339
Beven
Registered User
 
Join Date: Sep 2011
Posts: 10
Thanks for helping!

Unfortunately an ffmpeg didn't work either - resulting in:
==============
>> ENCODING WITH PROFILE 'ff_droid' TO FILE D:\tivo_encoded\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mp4 ...
C:\kmttg\ffmpeg\ffmpeg.exe -y -i "D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg" -threads 2 -vcodec libx264 -acodec aac -ac 2 -s 854x480 -coder 0 -level 41 -sameq -subq 6 -me_range 16 -qmin 10 -qmax 50 -g 300 -bufsize 14745k -b 2000k -maxrate 16000k -bug +autodetect+ms -me_method epzs -trellis 2 -mbd 1 -f mp4 "D:\tivo_encoded\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mp4"
encoding failed (exit code: 1 ) - check command: C:\kmttg\ffmpeg\ffmpeg.exe -y -i "D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg" -threads 2 -vcodec libx264 -acodec aac -ac 2 -s 854x480 -coder 0 -level 41 -sameq -subq 6 -me_range 16 -qmin 10 -qmax 50 -g 300 -bufsize 14745k -b 2000k -maxrate 16000k -bug +autodetect+ms -me_method epzs -trellis 2 -mbd 1 -f mp4 "D:\tivo_encoded\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mp4"
FFmpeg version SVN-r21085, Copyright (c) 2000-2010 Fabrice Bellard, et al.
built on Jan 8 2010 06:05:02 with gcc 4.2.4
configuration: --enable-memalign-hack --prefix=/mingw --cross-prefix=i686-mingw32- --cc=ccache-i686-mingw32-gcc --target-os=mingw32 --arch=i686 --cpu=i686 --enable-avisynth --enable-gpl --enable-version3 --enable-zlib --enable-bzlib --enable-libgsm --enable-libfaad --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libmp3lame --enable-libopenjpeg --enable-libxvid --enable-libschroedinger --enable-libx264 --enable-libopencore_amrwb --enable-libopencore_amrnb
libavutil 50. 7. 0 / 50. 7. 0
libavcodec 52.45. 0 / 52.45. 0
libavformat 52.46. 0 / 52.46. 0
libavdevice 52. 2. 0 / 52. 2. 0
libswscale 0. 8. 0 / 0. 8. 0
[NULL @ 0x25f2f00]Format detected only with low score of 1, misdetection possible!
[mp1 @ 0x32f3e0]Header missing
Last message repeated 1 times
[mp3 @ 0x25f2f00]Could not find codec parameters (Audio: mp1, 0 channels, s16)
[mp3 @ 0x25f2f00]Estimating duration from bitrate, this may be inaccurate
D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).mpg: could not find codec parameters
===============

And here is the media info of the file:
====================
General
ID : 1 (0x1)
Complete name : D:\from_tivo\2 Broke Girls - ''And the Hidden Stash'' (Recorded Sep 24, 2012, WBZDT).TiVo
Format : MPEG-TS
File size : 3.84 GiB
Duration : 29mn 59s
Overall bit rate mode : Variable
Overall bit rate : 18.3 Mbps

Video
ID : 2048 (0x800)
Menu ID : 1 (0x1)
Format : MPEG Video
Format version : Version 2
Format profile : Main@High
Format settings, BVOP : Yes
Format settings, Matrix : Custom
Codec ID : 2
Duration : 29mn 59s
Maximum bit rate : 17.5 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 29.970 fps
Standard : Component
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Top Field First
Compression mode : Lossy
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

Audio
ID : 2049 (0x801)
Menu ID : 1 (0x1)
Format : AC-3
Format/Info : Audio Coding 3
Codec ID : 129
Compression mode : Lossy
Encryption : Encrypted

Text #1
ID : 2048 (0x800)-CC1
Menu ID : 1 (0x1)
Format : EIA-608
Muxing mode : A/53 / DTVCC Transport
Muxing mode, more info : Muxed in Video #1
Duration : 29mn 59s
Bit rate mode : Constant
Stream size : 0.00 Byte (0%)

Text #2
ID : 2048 (0x800)-1
Menu ID : 1 (0x1)
Format : EIA-708
Muxing mode : A/53 / DTVCC Transport
Muxing mode, more info : Muxed in Video #1
Duration : 29mn 59s
Bit rate mode : Constant
Stream size : 0.00 Byte (0%)

Text #3
ID : 2048 (0x800)-2
Menu ID : 1 (0x1)
Format : EIA-708
Muxing mode : A/53 / DTVCC Transport
Muxing mode, more info : Muxed in Video #1
Duration : 29mn 59s
Bit rate mode : Constant
Stream size : 0.00 Byte (0%)



Quote:
Originally Posted by moyekj View Post
@Beven, looks like Handbrake can't determine the video codecs in the mpg file. I would do 2 things:
1. Try an ffmpeg profile instead to see if ffmpeg can recognize video
2. Examine mpg video using (and post info here if you can't solve the problem)

Beven is offline   Reply With Quote
Old 10-13-2012, 01:54 PM   #4340
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
Looks to me like the problem is you have a bunch of .TiVo files that were downloaded in "fast transfer mode" and are thus in Transport Stream container. tivodecode step to decrypt the .TiVo file must be failing (I think you omitted that part in your post) resulting in a bogus .mpg file. Note that tivodecode cannot decrypt TS .TiVo files properly so most likely that is your issue. The only way to decrypt TS .TiVo files is using VideoRedo if you have it - and you can configure kmttg to use VideoRedo to decrypt instead of tivodecode.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-13-2012, 07:24 PM   #4341
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,686
Moyekj,

With KMTTG, if I wanted to push video to multiple TiVos, I would have to go to the Configure menu to change the PyTivo push destination. Its also easier to forget where the pushes would go and it would end on the wrong Tivo.

Can you change/add a Push destination to a checkbox on the Tivo tabs (only one checked box can be applied at any time).
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 10-13-2012, 09:04 PM   #4342
Beven
Registered User
 
Join Date: Sep 2011
Posts: 10
Quote:
Originally Posted by moyekj View Post
Looks to me like the problem is you have a bunch of .TiVo files that were downloaded in "fast transfer mode" and are thus in Transport Stream container. tivodecode step to decrypt the .TiVo file must be failing (I think you omitted that part in your post) resulting in a bogus .mpg file. Note that tivodecode cannot decrypt TS .TiVo files properly so most likely that is your issue. The only way to decrypt TS .TiVo files is using VideoRedo if you have it - and you can configure kmttg to use VideoRedo to decrypt instead of tivodecode.
Thanks -- it's sounding like that's what the issue is. I just happened across that option the other day within tivo desktop - I saw that it was enabled, and I just disabled it. Since then, I can transfer and encode. Looks like I'll have to play with videoredo.

Thanks again!
Beven is offline   Reply With Quote
Old 10-13-2012, 09:54 PM   #4343
Soapm
Registered User
 
Soapm's Avatar
 
Join Date: May 2007
Location: So close, yet too far away
Posts: 1,475
I guess I didn't read the post...

Last edited by Soapm : 10-13-2012 at 10:06 PM. Reason: Stupidity on my part
Soapm is offline   Reply With Quote
Old 10-15-2012, 03:26 PM   #4344
Jimbob_Seattle
Registered User
 
Join Date: Oct 2012
Posts: 2
custom commands on mac

Hi all,
Long time viewer, first time poster.....

I have a quick question about the custom command option in kmttg (kmttg_v0p8u on Mac OSX 10.8). I have a (very) quick and dirty shell script that I would like to run after encoding has taken place, and so in the custom command space I entered:
"~/Desktop/customtest.csh [encodeFile]" (without the quotes)

Clicking OK then generates this error message:

custom command setting does not start with a valid file: '~/Desktop/customtest.csh [encodeFile]'

Could some kind soul/kmttg guru show me the error of my ways please?

Thanks in advance!

Jimbob
Jimbob_Seattle is offline   Reply With Quote
Old 10-15-2012, 04:01 PM   #4345
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
Replace '~' with full path to your home dir. (~ is a shell shortcut, kmttg needs the real full path to the command).
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-15-2012, 04:45 PM   #4346
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,867
Quote:
Originally Posted by sanjonny View Post
OMG, the simple solutions are always the best, though I have been on planes trains auto shuttles and subways for two days straight sooooo my brain isn't working and my memory is shot. can I send that command thru a custom command I can make in kmttg, or do I have to telnet or ssh or whatever into the cranky Tivo to run. I truly just need a memory bump. and some sleep and food.
If you want to do it manually, just telnet into the TiVo and issue the command. If you want to automate it, you need to use something like Expect to spawn a telnet session and issue the command.

If you want more details, take it over to the Linux discussion stickied in this forum. Expect isn't strictly a Linux interpreter, but few people use Expect outside of *nix, so I think it would be OK.
lrhorer is offline   Reply With Quote
Old 10-15-2012, 06:26 PM   #4347
Jimbob_Seattle
Registered User
 
Join Date: Oct 2012
Posts: 2
custom commands on mac

Quote:
Originally Posted by moyekj View Post
Replace '~' with full path to your home dir. (~ is a shell shortcut, kmttg needs the real full path to the command).
Awesome! Thank you very much - both for the answer, and kmttg!
Jimbob_Seattle is offline   Reply With Quote
Old 10-17-2012, 11:10 PM   #4348
mattack
Registered User
 
Join Date: Apr 2001
Location: sunnyvale
Posts: 16,933
Quote:
Originally Posted by moyekj View Post
Looks to me like the problem is you have a bunch of .TiVo files that were downloaded in "fast transfer mode" and are thus in Transport Stream container. tivodecode step to decrypt the .TiVo file must be failing (I think you omitted that part in your post) resulting in a bogus .mpg file. Note that tivodecode cannot decrypt TS .TiVo files properly so most likely that is your issue. The only way to decrypt TS .TiVo files is using VideoRedo if you have it - and you can configure kmttg to use VideoRedo to decrypt instead of tivodecode.
Is anybody working on this? Does anybody (besides the VideoReDo people) know the exact details about why tivodecode doesn't work on them?

I now have a Premiere 4, and would like to have faster downloads!
mattack is offline   Reply With Quote
Old 10-18-2012, 12:29 AM   #4349
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,067
Quote:
Originally Posted by mattack View Post
Is anybody working on this? Does anybody (besides the VideoReDo people) know the exact details about why tivodecode doesn't work on them?
VideoReDo simply uses the DirectShow filter from TiVo Desktop so no need to know the details. If you have Windows you can actually leverage the same filter to decrypt videos without VideoRedo using GraphEdit and removing everything after de-muxer and inserting a muxer followed by a File Writer in the graph to save to a file. (Before tivodecode days that is what the various 3rd party decrypt tools were doing).
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-18-2012, 09:23 PM   #4350
mattack
Registered User
 
Join Date: Apr 2001
Location: sunnyvale
Posts: 16,933
Sorry, I guess I wasn’t clear. I *don’t* have Windows.. I want to do it on a Mac, and heck, having the info out there for Linux people would be good too.

Since I’m already posting, this is possibly a FAQ, but I have my Premiere set up (and it knows it has lifetime subscription), and kmttg can get the metadata file, but ends up barfing when it tries to download. Obviously I will post more specific info (exact error) the next time I try when I’m home.. But IIRC, it seems to basically not be getting data back, and complains about a 'chunk' error.

My two Tivos (Premiere 4 and Tivo HD) DO see each other, though I haven’t yet tried downloading between them directly.

I’m likely going to go home for a few mins before I go out, but probably won’t have time to get more info until tomorrow.
mattack is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 11:13 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |